Transient Analysis Is Not Converging for Your Model


Integrator convergence problems detected during transient analysis of this model.


  • Try slowing down the rate of profile functions used on motors or actuators in your model by changing time values or magnitudes.
  • Try switching the Model Units from MKS to something else via File > Preferences > Inspire > Units.
  • Try increasing the Output rate in the Run Motion Analysis settings so you can better see what is happening right before the error occurs.
  • Enable (or disable) the controller for the motor or actuator to see whether or not it has an effect.
  • Try to simplify what is happening in your model by locking motors or actuators, or using rigid groups or grounding to temporarily prevent some parts of the model from moving.
  • Try changing the controller parameters (e.g. PID Gains) for the motor or actuator.
  • Try starting from an equilibrium position when running transient analysis.
  • Joint behavior may be too stiff, or not stiff enough. Try changing the magnitude of Motion Rates for flexible joint behavior.
  • Change the Solver settings on the Run Motion Analysis window (e.g. Maximum step size, Integrator tolerance).