Allowable Deformation in Joint Has Been Exceeded


The deformation exceeded the value defined in the Run Motion Analysis window.


  • Increase the Deformation Allowed setting in the Run Motion Analysis window under Advanced > Model Checking.
  • Set the joint's Behavior property to Rigid in the Property Editor. Alternatively, set it to Flexible and increase the Stiffness (K) and/or Torsional Stiffness (KT).
  • Observe what happens when gravity is turned off in the Run Motion Analysis window.
  • Enable the controller option for motors and actuators.
  • Change the profile function, time, or duration parameters for motors and actuators, so that the motion is applied more gradually.
  • Try re-enabling the Auto calculate rates option under the Advanced section of the Run Motion Analysis window.
  • Check to see if you have any motor or actuator profile functions that are of Type=Solver Expression, and then verify that your current Model Units are set properly to correspond to the expression you have written. (Model Units can be changed via File > Preferences > Inspire > Units.)