OS-T: 6030 Seam Weld Fatigue using S-N Method

Before you begin, copy the file(s) used in this tutorial to your working directory.

The method is a hot-spot stress approach applicable to thin metal sheets. Hot-spot stress is calculated from grid point forces at the weld line. The method showed a good agreement with laboratory test results for sheet thickness between 1.0 mm and 3.0 mm. The method typically requires two SN curves. One is a bending SN curve which is dominated by bending stress, and the other is a membrane SN curve which dominated by membrane stress.

In this tutorial, a frame is experiencing frontal and rear torsional loads in addition to vertical bending. Seam Welds are modeled between the sections forming the frame. This exercise is performed to calculate the damage that occurs at the seam (fillet) weld locations.


Figure 1. Automotive Frame

Launch HyperMesh and Set the OptiStruct User Profile

The model being used for this exercise is that of an automotive frame (OS-T: 6030 Seam Weld Fatigue using S-N Method). The input file consists of 3 static loadsteps to which the frame is subjected to – Frontal torsion, Rear torsion and the Vertical bending.

  1. Launch HyperMesh.
    The User Profile dialog opens.
  2. Select OptiStruct and click OK.
    This loads the user profile. It includes the appropriate template, macro menu, and import reader, paring down the functionality of HyperMesh to what is relevant for generating models for OptiStruct.
  3. Click Tools > Fatigue Process > Create New.
  4. For New Session, enter a name in your working directory folder.
  5. Click Create.
    This creates a new file to save the instance of the currently loaded fatigue process template.

Import the Model

  1. Click File > Import > Solver Deck.
    An Import tab is added to your tab menu.
  2. For the File type, select OptiStruct.
  3. Select the Files icon files_panel.
    A Select OptiStruct file browser opens.
  4. Select the SeamWeld_frame.fem file you saved to your working directory.
  5. Click Open.
  6. Click Import, then click Close to close the Import tab.
    The outline of the Fatigue Analysis setup to be achieved in the following steps.


    Figure 2. Fatigue Setup - Fillet Seam Welds

Set Up the Model

Define TABFAT Load Collector

The first step in defining the loading sequence is to define the TABFAT curves. This represents the loading history.
  1. Make sure the Utility menu is selected in the View menu. Click View > Browsers > HyperMesh > Utility.
  2. Click on the Utility menu beside the Model tab in the browser. In the Tools section, click on TABLE Create.
  3. Set Options to Import table.
  4. Set Tables to TABFAT.
  5. Click Next.
  6. Browse for the loading file.
  7. In the Open the XY Data File dialog box, set the Files of type filter to CSV (*.csv).
  8. Open the load1.csv file you saved to your working directory.
  9. Create New Table with Name LH1.
  10. Click Apply to save the table.
    The curve LH1 with TABFAT card image is created.
  11. Browse for a second loading file load2.csv.
  12. Create New Table with Name LH2.
  13. Click Apply to save the table.
    The load collector table2 with TABFAT card image is created.
  14. Tables LH1 and LH2 can be edited/reviewed from Utility tab > TABLE Create > Create/Edit Table > TABFAT > Edit Existing Table.
  15. Exit from the Import TABFAT window.
    Tables appear under Load Collector in the Model Browser.
    Note: A file in DAC format can very easily be imported in HyperGraph and converted to CSV format to be read in HyperMesh.

Define FATLOAD Load Collector

Create a fatload each for the loadcases present.

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter Fatload_Front.
  3. For Card Image, select FATLOAD.
  4. For TID(table ID), select LH1 from the list of curves.
  5. For LCID (load case ID), select Front Torsional Stiffness from the list of load steps.
  6. Set LDM (load magnitude) to 0.1.
  7. Set Scale to 0.6.
  8. Repeat the process to create 2 additional load collectors with FATLOAD cards named:

    Fatload_Rear with LCID as Rear Torsional Stiffness and TID as LH2

    Fatload_Vertical with LCID as Vertical Bending Stiffness and TID as LH2

  9. Set LDM to 0.1 and Scale to 0.6.

Define FATEVNT Load Collector

Create an event to assign the fatloads created.

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter Event1.
  3. For Card Image, select FATEVNT.
  4. For FATEVNT_NUM_FLOAD, enter 1.
  5. Set the FLOAD load collector to FATLOAD_Front.


    Figure 3. Event Card Containing the 3 Fatloads
  6. Similarly create Event2 by setting FATEVNT_NUM_FLOAD to 2 with the remaining FATLOADS, Fatload_Rear and Fatload_Vertical.


    Figure 4. Event Card Containing the 3 Fatloads

Define FATSEQ Load Collector

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter FATSEQ.
  3. For Card Image, select FATSEQ.
  4. For FATSEQ_NUM enter 2, as 2 FATEVENTs have been created.
  5. For FID (Fatigue Event Definition), select Event1 and Event2 .
    Defining the sequence of events for the fatigue analysis is completed. The Fatigue parameters are defined next.

Define Fatigue Parameters

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter fatparam.
  3. For Card Image, select FATPARM.
  4. Verify TYPE is set to SN.
  5. Set STRESS COMBINE to SGVON (Signed von Mises).
  6. Set STRESS CORRECTION to GERBER.
  7. Set STRESSU to MPA (Stress Units).
  8. Set RAINFLOW RTYPE to LOAD.
  9. Set GATEREL to 0.0.
  10. Set CERTNTY SURVCERT to 0.5.
  11. Check the box beside SMWLD and select the following options:

    METHOD = VOLVO

    Mean Stress Connection = FKM

    SURVCERT = 1e-9

    THCKCORR = YES

  12. Click Apply.
    This saves the current definitions and guides you to the next task Elements and Materials of the Fatigue Analysis tree. For details, refer to the Altair HyperWorks 2023.1 help.

Define Fatigue Material Properties

The material curve for the fatigue analysis can be defined on the MAT1 card.

  1. In the Model Browser, click on the Steel material.
    The Entity Editor opens.
  2. In the Entity Editor, check the box besides MATFAT.
  3. Set UNIT as MPA from the list.
  4. Set UTS (ultimate tensile stress) to 600.
  5. Check the box besides SMWLD and set STRUCTURAL SN CURVE as User Defined.
  6. For the SN-based Seam Weld Fatigue properites, set:
    SRI1_SM1
    1203.0
    B1_SM1
    -0.133
    NC1_SM1
    1e6
    B2_SM1
    -0.108
    SE_SM1
    1
    SRI1_SM2
    803.0
    B1_SM2
    -0.15
    NC1_SM2
    1e6
    B2_SM2
    -0.11
    SE_SM2
    2.0

    2-point slope curves are added for both the bending SN and the membrane SN (Here 1 = bending, membrane), 1-point slope can also be added.

Define PFATSMW Property

BRATIO helps understand if the Bending Moments or if the Membrane Forces dominates the maximum stresses based on which the interpolated SN curve is created.

Similarly, TREF and TREF_N help in accounting for thickness correction

  1. In the Model Browser, right-click and select Create > Property.
  2. For Name, enter PFATSMW_7.
  3. For Card Image, select PFATSMW.
  4. Set BRATIO to 0.6.
  5. Set TREF to 1.1.
  6. Set TREF_N to 0.1.
  7. Click Close.

Define FATSEAM Load Collector

FATSEAM helps to select the seam weld type.

In this case it is the fillet weld.

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter FATSEAM.
  3. For Card Image, select FATSEAM.
  4. Set WTYPE to FILLET.
  5. Set NUM_FATSEAM_PSHELL_PIDS to 1.
  6. Click <Unspecified> field next to PID and select property1 for PID.
    property1 is the property ID of the seam weld component.


    Figure 5.
  7. Click Close.
    This saves the current definitions and guides you to the next task Load-Time History of the Fatigue Analysis tree.

Define FATDEF Load Collector

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter FATDEF1.
  3. Set the Card Image to FATDEF.
  4. Activate FATSEAM in the PTYPE Entity Editor.
  5. For FATDEF_FATSEAM_NUMIDS, enter 1.
  6. Select FatSeam for FATSEAMID and PFATSMW_7 for PFATSMWID.
  7. Click Close.

Define the Fatigue Load Step

  1. In the Model Browser, right-click and select Create > Load Step.
  2. For Name, enter Fatigue_3LCs_SeamWeld.
  3. Set the Analysis type to fatigue.
  4. For FATDEF, select fatdef.
  5. For FATPARM, select fatparam.
  6. For FATSEQ, select fatseq.

Submit the Job

  1. From the Analysis page, enter the OptiStruct panel.
  2. Click save as following the input file field.
    The Save As dialog opens.
  3. For File name, enter the name Automotive-Frame-SeamWeld-fillet.fem.
  4. Click Save.
  5. Click OptiStruct to submit the analysis.

Review the Results

  1. From the OptiStruct panel, click HyperView.
    HyperView is launched and the results are loaded. A message window appears to inform of the successful model and result files loading into HyperView.
  2. Go to the Results tab.
  3. In the Results tab, select Subcase 4 (Fatigue_3LCs_SeamWeld) from the subcase field.
  4. On the Results toolbar, click resultsContour-16 to open the Contour panel.
  5. Set Result type to Damage and click on Apply to contour the elements.
  6. Set Result type to Toe/Root/Throat(s) and sub Result Type to Toe.
  7. Click Apply.

    The contoured elements are Toe elements for the respective Seam Elements.

  8. Similarly, toggle between Toe and Root, to highlight the corresponding elements.

    Toe and Root are the evaluation locations considered for the fillet welds.