OS-T: 8020 Divergence Analysis of an Aircraft

This tutorial demonstrates the divergence analysis of an aircraft.

Before you begin, copy the file(s) used in this tutorial to your working directory.

Preprocessing is done using Altair HyperWorks in the OptiStruct user profile. A model with existing structural and aeroelastic data is used as a base model and this tutorial demonstrates the creation of entities specific to divergence analysis.

Divergence occurs in aeroelasticity when the deflection of lifting surfaces of an aircraft leads to additional lift that, in turn, leads to further deflection in the same direction. A divergence analysis determines divergence dynamic pressures which are square of eigenvalues from a direct complex eigenvalue analysis. The lowest eigenvalue correlates with the critical divergence dynamic pressure. Using the divergence dynamic pressures, the critical velocities are computed. Once determined, you can aim to avoid your system nearing this critical velocity and beyond.

The following exercises are included in this tutorial:
  • Create DIVERG entry
  • Define complex eigenvalue related entries
  • Submit the job
  • View the results

Launch Altair HyperWorks and Import the Model

Refer to Access the Model Files for more details about obtaining the tutorial model file. The model file required for this tutorial is aeroelasticity_diverg.fem

  1. Copy the model file to your directory.
  2. Launch Altair HyperWorks.
    A New Session dialog opens.
  3. Select the HyperMesh radio button and set Profile to OptiStruct and click the Create Session button.
  4. From the menu bar, click File > Import > Solver Deck.
  5. Select the model file and click Open.
  6. In the Solver Import Options dialog, for Reader select OptiStruct.
    The OptiStruct user profile loads. The functionality of HyperMesh is paired down to the appropriate template, macro menu, and import reader to create models in OptiStruct.


    Figure 1. OptiStruct User Profile in HyperMesh
  7. Click Import.
    The base model is loaded into HyperMesh.


    Figure 2. Base Model of Aircraft

Open the Aeroelasticity Browser

The Aeroelasticity Browser is useful for upcoming tasks in this tutorial.

  1. In the menu bar, click View > Ribbons > Aeroelasticity.
    The Aeroelasticity ribbon appears on the menu bar.
  2. On the Aeroelasticity ribbon, hover over any tool group and click the satellite icon that appears.
    The Aeroelasticity Browser opens.


    Figure 3. Access the Aeroelasticity Browser

Set Up the Model

Create DIVERG Entry

  1. In the Aeroelasticity Browser, expand AeroModule.
  2. Right-click on Aero Loads and select Create > DIVERG.
    A collector for DIVERG is created in the Aero Loads folder.
  3. Enter a name of your choice for the collector.
    In this tutorial, the collector is called DIVERG.
  4. For Number of dynamic pressures (NROOT), enter 20.
  5. For Num Factors, enter 1.
  6. For Mach number (Mi), enter 0.4.


    Figure 4. Definition of the DIVERG Entry

Create EIGC Entry

Divergence analysis determines the divergence dynamic pressures, which are the eigenvalues from a complex eigenvalue analysis. Hence, the EIGC Bulk Data Entry will be defined.

  1. In the Aeroelasticity Browser, expand StructureModule.
  2. Right-click on Eigenvalues and select Create > EIGC.
    A collector for EIGC is created under Eigenvalues.
  3. Enter a name of your choice for the collector.
    In this tutorial, the collector is called EIGC.
  4. For ND0_OPTIONS, select User Defined from the drop-down menu.
  5. For the number of desired roots (ND0), enter 20.


    Figure 5. Definition of EIGC Entry

Create Constraints

  1. In the Solver browser, expand General-Collectors.
  2. Right-click on LoadCollector and select Create.
  3. Name the new load collector SPC.
  4. Select the Analyze ribbon.
  5. In the Structural tool group, select BCs > Constraints.
    Figure 6. Access Contraints Tool
  6. On the panel, verify the selection method is set to nodes.
  7. Select the grid at the bottom of the aircraft.
    The grid number is 10593.
  8. Constrain all degrees of freedom.


    Figure 7. Creation of SPC at Bottom of Aircraft
  9. Select Create.
  10. After the SPC is created, select Return.

Create Divergence Analysis Subcase

In this step, the previously created Bulk Data Entries will be referenced in the divergence analysis subcase.

  1. In the Aeroelasticity Browser, expand SolutionJobSetup.
  2. Right-click on Case Controls and select Create > Subcases.
    A collector for the subcase is created in the Case Controls folder.
  3. Enter a name of your choice for the collector.
    In this tutorial, the collector is called DIVERG.
  4. For Analysis type, select Aeroelastic Divergence from the drop-down menu.
  5. Reference the previously created Bulk Data Entries as shown in Figure 8.


    Figure 8. Subcase Definition for Static Aeroelastic Divergence Analysis

Export the Input File

In this step, the input file is exported to the working directory. This file is later solved using OptiStruct as the solver.

  1. From the menu bar, click File > Export > Solver Deck.
  2. Enter a name for the file.
  3. Click Save.
    The Solver Export Options dialog opens.
  4. In the dialog, accept the default options.
  5. Click Export.
    The file is now available in your working directory.

Submit the Job

  1. In the Windows Start menu, select Start > Altair 2023.1 > Compute Console.
  2. For Input file, use to browse your working directory for the desired file.
  3. Click Open.
  4. For Options, click .
    1. In the Select Solver Options dialog, click the -nt check box.
    2. Enter 8 for the argument.
    3. Click OK.
    4. Click the -out check box.
  5. Click Apply Selected.
  6. Click Close.
  7. Click Run.


    Figure 9. Altair Compute Console

    If the job is successful, the new results files should be in the working directory. If any errors are present, look in the aeroelasticity_diverg.out file for error messages that could help debug the input deck.

View the Results

View the Mode Shapes

  1. After you receive the analysis completion message, click Results.
    HyperView is launched and the results are loaded.
  2. In HyperView, click the Contour panel button .
  3. For Result type, select Eigen Mode (v) (c) from the first drop-down menu.
  4. Click Apply.


    Figure 10. Results for Mode 3

Review the Divergence Dynamic Pressures

The divergence dynamic pressures can be viewed from the aeroelasticity_diverg.out file.

By definition, divergence occurs when the roots of the Direct Complex Eigenvalue analysis have purely imaginary components.

  1. Check the .out file for modes where divergence occurs.
    These modes are highlighted in Figure 11.


    Figure 11. Roots with Only Imaginary Components
  2. Identify the critical mode at which divergence begins to occur.
    The divergence dynamic pressures are squares of eigenvalues. The first mode in the divergence summary corresponds to the critical mode.


    Figure 12.
  3. Based on these values, compute the critical velocities.