OS-T: 8000 Trim Analysis using the Stick Model of an Aircraft Wing

This tutorial demonstrates trim analysis using the stick model of a simple aircraft wing.

Before you begin, copy the file(s) used in this tutorial to your working directory.

Stick models are generally used to simplify the representation of an aircraft for aeroelastic analysis.

Preprocessing is done using Altair HyperWorks in the OptiStruct user profile. A structural stick model with existing data is used as a base model and this tutorial demonstrates the creation of entities in the Aeroelasticity domain.

The following exercises are included:
  • Create Panels (CAERO1)
  • Create interpolation splines (SPLINE2)
  • Create rigid body motions for aeroelastic TRIM variables (AESTAT)
  • Define TRIM variables
  • Submit the job
  • View the results

Launch Altair HyperWorks and Import the Model

  1. Launch Altair HyperWorks.
    A New Session dialog opens.
  2. Select the HyperMesh radio button and set Profile to OptiStruct and click the Create Session button.
  3. From the menu bar, click File > Import > Solver Deck.
  4. Select the aeroelasticity_trim_wing_stick.bdf file you copied to your working directory.
  5. Click Open.
  6. In the Solver Import Options dialog, for Reader select OptiStruct.
    The OptiStruct user profile loads. The functionality of HyperMesh is paired down to the appropriate template, macro menu, and import reader to create models in OptiStruct.
    Figure 1. Import Base Model in HyperMesh
  7. Click Import.
    The base structural stick model is loaded into HyperMesh. The model is comprised of CBAR elements.
    Figure 2. Base Structural Model of an Aircraft Wing Stick Model


Open the Aeroelasticity Browser

The Aeroelasticity Browser is useful for upcoming tasks in this tutorial.

  1. In the menu bar, click View > Ribbons > Aeroelasticity.
    The Aeroelasticity ribbon appears on the menu bar.
  2. On the Aeroelasticity ribbon, hover over any tool group and click the satellite icon that appears.
    The Aeroelasticity Browser opens.
    Figure 3. Access the Aeroelasticity Browser


Set Up the Model

Create AEROS Entry

In this step, basic/reference parameters for the simulation are defined through AEROS.

  1. In the Aeroelasticity Browser, expand AeroModule.
  2. Right-click on the Controls folder and select Create > AEROS.
    A collector for AEROS is created in the Controls folder.
  3. Click on the AEROS collector.
  4. For REFC (Reference chord length), enter 0.1.
  5. For REFB (Reference span), enter 0.55.
  6. For REFS (Reference wing area), enter 0.055.
    Figure 4. AEROS Definition


Create Grid Points around the Stick Model

Since the base structural model is a stick representation, grid points are created around the stick model as corner points of the panel mesh.

  1. On the Geometry ribbon, Points tool group, click the Create Points and Nodes tool.
    Figure 5.


  2. Left click anywhere in the modeling window.
    The grid coordinate window opens.
  3. In the X, Y, and Z grid coordinate fields, enter 0.0. Press Enter to confirm.
    Figure 6. Create Grid Points


  4. Create more grid points using the coordinates listed in the table below.
    Table 1. Coordinates of Grid Points
    Grid Point X Y Z
    2 0.1 0.0 0.0
    3 0.1 0.55 0.0
    4 0.0 0.55 0.0
  5. Right click and exit the tool.
    Figure 7. Grid Points around Stick Model


Create Aeroelasticity Panels

The CAERO1 entry is used to create aeroelasticity panel mesh in the base structural model.

  1. On the Aeroelasticity ribbon, Aero Meshing tool group, click the Panel Mesh tool.
    Figure 8.


  2. Select the Transparent check box.
    The points surrounding the structural model are displayed.
    Figure 9. Open Panel Mesh Tool


  3. Select the end points of the CAERO1 panel mesh so that node 1 and node 4 are along the span direction and node 1 and 2 are along the chord direction. For more information, refer to CAERO1.
    Figure 10 shows the correct selection order.
    Figure 10. Grid Point Selection for CAERO1 Definition


  4. In the microdialog that appears, for Span enter 10. Hit Enter to confirm.
  5. For Chord, enter 5. Hit Enter to confirm.
  6. Click .
    Figure 11. Specify Span and Chord Values in CAERO1 Definition


    The panel mesh is created.
    Figure 12. Aeroelastic Panel Mesh for the Problem


Create Interpolation SPLINES

In this step, a SPLINE2 entry is created for interpolating motion and/or forces between the aeroelastic and structural domain. The SPLINE2 entry refers to the panels (aeroelastic domain), a node-set (structural domain) and the corresponding CAERO1 entry. The node-set for the structural domain is already available in the base model.

  1. On the Aeroelasticity ribbon, click the Spline tool.
    Figure 13.


    The SPLINE2 creation tool opens.
  2. Click the icon.
  3. For Spline type, select Linear_Spline_2 from the drop-down menu.
    Figure 14. Selection of Linear Spline (SPLINE2)


  4. Reference the aero panels.
    1. In the Aero drop-down menu, select Elements.
      Figure 15. Element Based Selection in Aero Domain


    2. On the model, select the aero panels.
      Figure 16. Selection of Aero Panels on Model


  5. Reference the node-set.
    1. In the Structure drop-down menu, select Sets.
      Figure 17. Set Based Selection in Structural Domain


    2. Click .
    3. In the Advanced selection dialog, select SET1.
      Figure 18. Selection of Structural Node Set


    4. Click OK.
  6. Reference the CAERO1.
    1. Next to Component, click .
    2. In the dialog, select the CAERO1 previously created.
      Figure 19. Selection of CAERO1 Entry


    3. Click OK.
  7. In the microdialog that appears, enter a name of your choice. In this tutorial the name is SPLINE2.
    Figure 20. Name SPLINE2 Entry


  8. Click .
    The spline is shown under the Splines section on the Aeroelasticity browser.
  9. Reference the existing coordinate system.
    1. For CID, click and select .
    2. In the dialog, select the existing coordinate system.
  10. Specify other parameters as shown in Figure 21.
    Figure 21. SPLINE2 Definition


Create AESTAT Entry

The AESTAT entry specifies rigid body motions which are used as trim variables in the aeroelastic analysis. This is later referenced in the TRIM Bulk Data Entry.

  1. In the Aeroelasticity Browser, right-click on Controls and select Create > AESTAT.
    The AESTAT collector is created.
  2. For Name, enter ANGLEA_AESTAT.
  3. For Label, select ANGLEA from the drop-down list.
    A Degree of Freedom (DoF) for Angle of Attack is created.

Define TRIM Entry

In this step, the Mach number, Dynamic pressure, and constraint values for the aerodynamic trim variables are defined.

  1. In the Aeroelasticity Browser, right-click on Aero Loads and select Create > TRIM.
  2. For Name, enter TRIM ANGLEA 0.1 RAD1.
  3. For Q (Dynamic pressure), enter 1500.0.
  4. For NUM_LABEL, enter 1.
  5. Reference AESTAT.
    1. Under TRIM1, for LABEL, click and select .
    2. In the Advanced Selection dialog, choose ANGLEA_AESTAT.
      Figure 22. Reference AESTAT in the TRIM Entry


    3. Click Click OK.
    4. For UX, enter 0.1.
      The angle of attack is constrained to 0.1 radians.

Reference the TRIM Entry in the Subcase

In this step, the TRIM entry is referenced in the subcase.

  1. In the Aeroelasticity Browser, expand SolutionJobSetup > Case Controls > Subcases and click the TRIM_ANALYSIS subcase.
  2. Reference the TRIM entry.
    1. Under Subcase Definition, for Analysis type select Static Aeroelastic Response from the drop-down menu.
    2. For TRIM, click and select .
    3. In the Advanced Selection dialog, choose TRIM ANGLEA 0.1 RAD1.
      Figure 23.


    4. Click OK.
  3. Under SUBCASE OPTIONS, for Analysis TYPE, select SAERO from the drop-down menu.

Export the Input File

In this step, the input file is exported to the working directory. This file is later solved using OptiStruct as the solver.

  1. From the menu bar, click File > Export > Solver Deck.
  2. Enter a name for the file.
  3. Click Save.
    The Solver Export Options dialog opens.
  4. In the dialog, accept the default options.
  5. Click Export.
    The file is now available in your working directory.

Submit the Job

The Altair Compute Console (ACC) is used to submit the job.

  1. In the Windows Start menu, select Start > Altair 2024 > Compute Console.
  2. For Input file, use to browse your working directory for the desired file.
  3. Click Open.
  4. For Options, click .
    1. In the Select Solver Options dialog, click the -nt check box.
    2. Enter 4 for the argument.
    3. Click OK.
    4. Click the -out check box.
  5. Click Apply Selected.
  6. Click Close.
  7. Click Run.
    Figure 24. Altair Compute Console

    If the job is successful, the new results files should be in the working directory. If any errors are present, look in the aeroelasticity_trim_wing_stick.out file for error messages that could help debug the input deck.

View the Contour Plot

The following steps describe how to review the results in HyperView.

HyperView is a complete post-processing and visualization environment for finite element analysis (FEA), multi-body system simulation, video, and engineering data.

  1. After you receive the analysis completion message, click Results.
  2. In HyperView, click the Contour panel button .
  3. For Result type, select Displacement (v) from the first drop-down menu.
  4. Select Mag from the second drop-down menu.
  5. Click Apply.
    The resulting contour represents the displacement field for the aeroelastic trim analysis.
    Figure 25. Displacement Contour Plot of Wing Stick Model