Open Database Dialog

Monarch Classic provides an Open Database dialog that you can use to import data from an external database or delimited text file.

Once open, you can select the fields to import into Monarch Classic using the External Lookup window. Data that you import from an external database can be used just like data extracted from a report. You can apply filters to drill down the data, hide and rename fields, sort the data, create new calculated fields, create summary reports, print and copy data, and export data to any file format that Monarch Classic supports.

To access the Open Database dialog, do one of the following:

  • Select File tab, then Open, then Database. Note: This menu option is unavailable if a report file is open.

  • Select External Lookups from the Table Design ribbon, select Click to add a new External Lookup, and then Database from the drop-down..

Options

Field

Description

Data Source

The Data Source combo box displays the name of the data source you select:

  • For a local or network file, this box displays the path and filename for the selected file.

  • For a Web file, this box displays the Web Server and folder.

  • For an ODBC connection, this box displays the ODBC DSN definition along with information specific to the data source.

  • For an OLEDB connection, this box displays the OLEDB Provider and security information..

The combo box also includes a drop-down list that holds the most recently used data sources that you imported or joined data from. You may select a data source from this list, or use the Browse button to select a new data source.

Browse Data Source

When you click the Browse button, select one of the following from the drop-down list:

  • Local or network file:  Select this option if your data resides in a file on your local drive or on a network drive that is accessible to you. Use the Select File dialog that displays to select a file of the desired type. Monarch Classic can access the following file types:

    • Microsoft Excel (*.xls;*xlsx;*.xlsm)

    • Microsoft Access (*.accdb;*.mdb)

    • Delimited Text files (*.csv;*.tab;*.asc)

    • dBASE file (*.dbf)

  • Web File: Select this option if your lookup file is located in folder on a Web Server. You will be asked to provide the web server, folder, and security settings.

  • ODBC connection:  Select this option if your data resides in a SQL database or other database system that you have access to via ODBC. The Select an ODBC Data Source dialog displays. Monarch Classic can draw data from ODBC data sources for which you have established an ODBC connection, called a Data Source Name definition, or simply a DSN. Any existing DSNs will be displayed. Select the desired DSN from those listed.

  • OLEDB connection: If you select this option, choose one of the following from the drop-down menu:

    • Data Link Wizard: Select this option to specify, via the Data Link Properties dialog, the appropriate OLE DB provider for the type of data you want to access.

    • Data Link File: Select this option to choose, via the Select Data Link File dialog, the udl (universal data link) file (*.udl) that describes the data source you want to connect to.

Source Type

Displays the currently-selected Source Type.

Table

If you are defining the database for the first time, select a table using the Select Table button. Otherwise, this displays the currently-selected table.

Select Table

Click this button to display the Select Table dialog. You can then select from  a list of available table in the data source.

Model

This is the name of the model you want to apply to a selected data source. If you previously imported data from the same data source and then saved a model file for that Monarch Classic session, the model file will include parameters that indicate which fields were imported along with the Monarch Classic field names that were assigned to those fields.

Browse Model

Use this button to select a model file to use.

Include Password

If you are importing from a password-protected data source, select this and enter the required password in the adjacent field.

 

 

 

© 2024 Altair Engineering Inc. All Rights Reserved.

Intellectual Property Rights Notice | Technical Support