Export Design Window

The Export Design Window allows you to view or edit existing exports.

To access this window select Export Design on the Export View ribbon. Note that different panels and tabs displays depending on the source view and output file type.

Table View

This panel displays if you select an export that uses a table as its source..

Field

Description

Description

Displays a description of the current export (e.g., "Export the table data").

Select Filter

Selects the filter you want to apply to the table or summary. Select the All Filters option to apply all of the available filters or the No Filter option to apply none of them.

If you choose the All Filters option, specify the desired Automatic Naming setting:

  • by Files: produces a file for each filter

  • by Tables: produces a table for each filter

Sort Order

Applies a sort order to the data you are exporting.

 

Summary View

This panel displays if you select an export that uses a table as its source.

Field

Description

Summary drop-down list

Selects the summary that you want to export. Select the "All summaries" option to export all of the available summaries.

Automatic Naming options

 

Specifies how you want Monarch Complete to name the export:

  • By files: Specifies that, when exporting multiple summaries, a file is exported for each summary, and the files are named according to the summary names

  • By tables: Specifies that, when exporting multiple summaries, a table is produced in the export file for each summary.

Drill State options

 

Specifies the desired drill state:

  • Most detailed: Select to export the summary in the most detailed (i.e., drilled down) drill state.

  • Current: Select to export the summary in the current drill state.

Measure options

Specifies either one of the following options:

  • Active measure or measure grouping: Select to export only the current measure or measure grouping.

  • All measures as separate exports: Select to export all of the measures as separate exports. If you choose this option, specify the desired Automatic Naming setting, either "by files" or "by tables".

Split:

Check Each distinct value of the first key makes a separate file or table to split the summary export according to each value change in the first key (i.e., the leftmost one). If you choose this option, specify the desired Automatic Naming setting, either "by files" to have each distinct value of the first key make a separate file, or "by tables" to have each change of it make a separate table.

Select Filter

 

Applies filters to the summary. Select the "All filters" option to apply all of the available filters or the "No filter" option to apply none of them. If you choose the "All filters" option, specify the desired Automatic Naming setting, either "by files" or "by tables".  

Sort Order

Applies a sort to the summary.

 

Excel Output

The Excel Output panel displays if your export outputs to an Excel file.

Excel Output

Field

Description

File Name

Allows you to browse for a location to save the file and also to select the file type.

Table Name

Displays the current name of the table. You can assign a new table name here.

Existing Tables

Displays the names of the tables in the file when exporting to a file that already exists.

When output files exist options

Provides options for when a file of the specified name and type already exists in the export location. Select one of the following options:

  • Overwrite file: Overwrites the data of the existing output file with the data in the current export file.

  • Add data to file: Adds the export file data to the end of the specified file.

  • Skip file: Used for Monarch Complete project exports, this allows you to create a project export which will skip the export operation if a file of the same name already exists. This is useful for automated operations, where you may not want to overwrite a file that already exists.

 

EXCEL ADVANCED PROPERTIES

Field

Description

Digital Signature

This option is available for Table and Summary exports and allows you to embed the currently selected digital signature to the exported Excel file (XLSX/XLSM). By adding a digital signature, you establish the authenticity, integrity, and non repudiation of the export output.

Certificate...

Select this button to display a Select Certificate dialog. Options will allow you to digitally sign with a valid X.509 Certificate (an existing Certificate selected from the Current User's Certificate Store or from a Certificate file).

Filter: Add AutoFilter drop down lists to column labels in the Table

This option enables the Excel AutoFilter feature, ready and active when you open the exported Excel file.

Note: Monarch Complete does not apply an AutoFilter when it adds data to an existing worksheet. Overwriting an existing sheet falls into this category. In this case it preserves the worksheet (since there may well be hidden data, macros, etc, associated with the worksheet) and overwrites the old named range data with new named range data. Since two AutoFilters cannot exist on the same worksheet, Monarch Complete makes no assumptions regarding an existing AutoFilter and does not apply one.

Include Pivot Table sheet

This option is available for Table exports to Excel 2007 (XLSX) files.

Fields Tab

Use this tab to select the desired pivot field(s)

Options

Use this tab to select the pivot options (see Pivot Table Tab Options below)

 

Pivot Table

Use this tab to specify pivot table options when performing a table export to an Excel 2007 (xlsx, xlsm) file.

Field

Description

Name

By default, the Pivot Table is named “PivotTable”. You can assign a new name to it by entering it here..

Weight

This refers to the Pivot Table style weight that will be applied when the Pivot Table is rendered in Excel. There are 3 options: Light, Medium and Dark. The weight is used in conjunction with the style index.

Index

This is the number of the table format style that will be applied when the Pivot Table is rendered in Excel. Excel has 28 styles available in 3 weights. This style can be viewed in Excel by selecting the “Format as Table” menu item when viewing a Pivot Table.

Apply to row headers

Applies the style settings to the row headers of the Pivot Table.

Apply to column headers

Applies the style settings to the column headers of the Pivot Table.

Banded rows

Applies alternate color shading to the rows in the Pivot Table.

Banded columns

Applies alternate color shading to the columns in the Pivot Table.

Show grand totals for rows

Displays grand totals for each row of the Pivot Table.

Show grand totals for columns

Displays grand totals for each column of the Pivot Table.

 

PDF Output

The PDF Output panel displays if your export outputs to a PDF  file.

Field

Description

Description

Displays a description of what the export will do when run, as well as the name and path of the export file.

Open Password

Password-protects the PDF file.

Apply

Allows you to password protect the PDF file. Select this option and  then click the adjacent Change Open Password button.

Change Open Password

Displays the Change Password dialog. Use this dialog to specify the password that must be supplied to open the PDF file.

Permissions options

Allows you to restrict the permissions available to users of the PDF file. Note: If you choose not to specify PDF file permissions, users will have full access to it.

Apply

Specifies permissions for the PDF file.

Printing allowed

Allows the PDF file to be printed.

Content extraction allowed

Allows copying (e.g., cut and paste) of the PDF file's content.

Editing allowed

Allows editing of the PDF file.

Annotation (comments) allowed

Allows comments to be added to the PDF file.

Change Permission Password

Displays the Change Password dialog. Use this dialog to specify the password that must be supplied to change the PDF file permissions.

Encryption

Encrypts the file through either of the following options. One (or both) of the passwords must be applied to enable encryption.

  • RC4 (128-bit): Encrypts the PDF file with RC4 encryption.

    WARNING: This option is not recommended for extremely confidential data. Use the AES option instead.

  • AES: Encrypts the PDF file with the Advanced Encryption Standard. If you choose this encryption method, Adobe Acrobat 7 or higher must be used to open the PDF file, as earlier versions of Acrobat do not support AES encryption.

ANSI Locale

Select the appropriate locale for ANSI Encoding. You can select to use:

  • Current system locale

  • Western locale

  • Japanese locale

 

 

Table Output

The Table Output panel displays if your export outputs to a database table.

Field

Description

Table Name

Displays the current name of the table. You can assign a new table name by entering it here.

Existing Tables

Displays the names of the tables in the file when exporting to a file that already exists.

When output tables exist options

Tells Monarch Complete what to do if the output table already exists. These options are only accessible if you select a table from the Existing Tables list.

  • Overwrite existing table: Overwrites the data in an existing table with the data in the export table.

  • Append data to existing table: Adds the export table data to the end of the specified table.

  • Skip (no output): Used for Monarch Complete project exports, this allows you to create a project export which will skip the export operation if a table of the same name already exists. This is useful for automated operations, where you may not want to overwrite a table that already exists.

 

 

 

 

 

 

© 2024 Altair Engineering Inc. All Rights Reserved.

Intellectual Property Rights Notice | Technical Support