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 Supported CAD 

Windows Linux 

• MCAD 

o Parasolid (V37.1.153) 

o STEP 

o CATIA (Up to CATIA V5-6R2024) 

o Creo (Up to 11.0) 

o JT 

o NX (Up to NX 2412 series) 

o SOLIDWORKS (Up to 2024) 

o Inventor (Up to 2025) 

o ACIS (Up to 2024) 

o AutoCAD (Up to 2025) 

• ECAD 

o Altium (Up to PCAD 2006 and from Designer 18.0) 

o IPC-2581 (Revision A and B) 

o Siemens PADS (from 9.0) 

o Zuken CR-8000/CR-5000  

o Siemens Xpedition 

o Cadence Allegro (from 16.3) 

o GDSII 

o ODB++  

• MCAD 

o Parasolid (V37.1.153) 

o STEP 

o CATIA (Up to CATIA V5-6R2024) 

o JT 

o AutoCAD (Up to 2025) 

• ECAD 

o ODB++ 

 Supported Results Reader 

• Abaqus: Up to V2025 

• ANSYS: Up to 2025 R1 

• ADVC: Up to V2.3 

 Solvers 

  Altair Solvers bundled with SimLab 

• OptiStruct: 2026 

• AcuSolve: 2026 

• Radioss: 2026 

• Flux: 2026 

• ElectroFlo: 2026 

• nanoFluidX: 2026 

• EDEM: 2026 

• Feko: 2026  
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 System   

File > Extension > Physics AI (BETA) 

• Altair PhysicsAI is fully integrated into SimLab 2026, bringing physics-agnostic, AI-powered design insights from 

historical datasets into your Multiphysics workflow—delivering full-field and KPI predictions directly from CAD/mesh up 

to 1000× faster than traditional solver runs, helping teams accelerate design decisions. 

• Key Features: 

o Native CAE File Support: The solver-agnostic PhysicsAI modeling environment lets you work directly with native 

CAE models, including historical simulation data models. 

o Geometric Deep Learning: PhysicsAI models are trained with groundbreaking geometric deep learning that 

operates directly on meshes and CAD models. This technology eliminates the time-consuming handcrafting of 

parameters needed with other training methods. 

o Confidence Score Metric: PhysicsAI offers a confidence score that helps identify novel shapes in your data. By 

scoring geometric similarity, PhysicsAI prevents questionable predictions and ensures reliable results. 

o End-to-End Workflow: Complete workflow in SimLab: curate datasets from historical data → train models → 

validate accuracy → deploy for real-time predictions across a broad range of physics solutions including 

computational fluid dynamics (CFD), structural, and electronics. 

 

File > Compare Database  

• The Compare Database and Duplicate Database options are now available directly in the File menu for quicker 

access. 

• A new “Exit Compare Mode” option has been added to the right-click menu, allowing users to exit compare mode 

seamlessly. 

• The Compare Database option is also included in the Database tab’s right-click menu to improve overall usability. 

• When closing a database in Compare Database mode, a new empty database will be created in the same location. 

Define Plane 

• Added an option to define the XY, YZ, or XZ plane based on the local coordinate system. All other plane definition 

options can be used with global coordinates only. 

File > Preferences > Applications > General > Theme 

• “Automatic” theme option is supported to match the application theme with the system theme light or dark. 
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File > Preferences > Applications > Options  

• The option to retain model grouping when merging models is now supported for CAD models, by converting each 

model into a sub model and retaining all its bodies. 

File > Preferences > Geometry > Options  

• A new preference option “Exclude open faces from scribing” is added to exclude open faces from the scribing process 

when importing Parasolid CAD models. 

File > Preferences > Graphics > Auto-hide small bodies 

• New option added to automatically hide bodies in the graphics area based on a specified tolerance when zooming out, 

to enhance performance when handling large models.  

 

 Import 

 Database 

  PollEx 

• The PollEx database import performance has been improved by ~95%. 

 CAD 

  STEP 

• Introduced an option in “Convert to Parasolid” to choose between the Parasolid translator and an external translator for 

STEP import.  

• Simplified the dialog by removing Save geometry in database, Assembly Structure, and Imprint Solid Bodies and 

making them as default values. 

 

 Graphics and Visualization 

 Enhancements 

Ribbons 

• Enhanced the UI with a visual indicator for the secondary ribbon to improve usability. 

• Removed the Measure and Move tools from the Solution ribbon to accommodate more solutions in main ribbon.  
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Home > Move Object  

• Enhanced the process of moving the bodies/move tool to capture every move in the script and it can be 

parameterized. Previously, script was recorded only with start and end center point position. 

Note: Moving bodies using the Local/Body Coordinate System and Align axis options is not supported for script 

recording with this new approach. 

 

Home > Move > Transform   

• The copy option associated with the Transform tool has been enhanced to address significant performance issues 

when hundreds or thousands of bodies are copied. 

View Tool Bar > Model View Options > More Options > Back side in Darker shade 

• The “Back side in Darker shade” option has been moved from “File > Preferences > Applications > Colors” to “View 

Toolbar > Model View Options > More Options” for easier accessibility. 

View Tool Bar > Display Thickness > Shell Thickness 

• Visualization of shell thickness properties is supported for various offset parameters defined in the material properties 

of the sheet body. It works with both CAD and FEM bodies. 

• Shell thickness can now be displayed in Transparency Mode for better clarity. 

  Assembly Browser > Model > Update Model  

• The Update Topology operation has been refined to deliver significantly faster performance on large and complex 

models.  

• A model with ~1600 faces and ~140000 edges now complete the topology update in ~2 seconds, down from ~26 

seconds in the previous build.  
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  Group Browser > Update / Delete Groups 

• Enhanced support to automatically update the entities in group-based mesh controls and boundary conditions, when 

group entities are modified or deleted. Previously, users had to manually open the respective mesh controls or 

boundary conditions to refresh the updated entities.  

• A warning message will be posted to alert the user that the solution result will be removed when the group associated 

with the solution is updated or deleted.  

Property Browser > Tables > Create Table  

• Introduced an option to generate table data through a Python script.  

Inspect > Section Properties 

• The Section Properties tool has been enhanced to support rectangular local coordinate-based calculations and 

multiple body inputs. 

• When a section plane intersects multiple faces, the tool now calculates and displays the combined inertia for that 

plane.  

 

 Sketch 

 New Feature 

Sketch > Create > Image Plane   

• Added new tool “Image Plane” to import reference images and trace over them easily to create new sketches. 

 Enhancements 

Sketch > New Sketch   

• Added support for creating the sketch plane using the Plane Defining dialog and the translation marker. 

Assembly Browser > Sketch > New Sketch   

• Sketch model right click options are now restricted during “Edit mode”. Right click options will be displayed only after 

exiting sketch edit mode.  

Automation > Parameters    

• Enhanced support for editing sketch parameters with expressions directly in the Parameter Manager for improved 

usability and workflow efficiency.  
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 Geometry  

 Enhancements  

Edge > Edit > Split Edge  

• Extended support for splitting a wire-body edge using either a face or a body as input. 

Face > Create > Cylinder  

• Added support for creating cylindrical faces using the Quad8 element type. 

Face > Edit > Merge Faces 

• Rearranged the options in the Merge Faces dialog to prioritize options based on usage patterns. 

Face > Drop Down > Transfer Face 

• "Make Shared Face” option is added to make the transferred face as shared faces between the bodies. 

Body > Create > Primitives > Cylinder 

• Enhanced the tool to define the cylinder using the local coordinate system axis. 

• Added support for creating cylinders and hollow cylinders using Quad8, Wedge15 and Hex20 element types. 

Body > Create > Primitives > Sphere 

• Added an option to define the output sphere body name.   

Body > Feature > Remove Fillet 

• Improved the robustness of removing fillets from complex regions.   

Body > Connect > Boolean  

• The Boolean dialog has been updated to set CAD (Parasolid) as the default option and reposition it above Mesh. 

Additionally, the Create Connected Body and Merge Redundant Entities options have been moved below Combine, 

and Merge Boundary Edges has been renamed to Merge Redundant Entities for better clarity and consistency.   
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Body > Connect > Fuse  

• Improved the generation of elements in the fusing region by ensuring that the junctions follow the input geometry. 

Additionally, the newly generated elements in the fusing region are now seamlessly integrated with the existing bodies.   

Body > Drop Down > Intersecting Bodies 

• Added an option “Intersecting bodies” to identify all intersecting/penetrating bodies and group them in body groups 

based on their intersection. With tolerance, this option will identify nearby bodies too.   

Note: This enhancement requires the environment variable SL_GRP_INTERSECTINGBODIES = TRUE.   

  

 Mesh  

 Enhancements  

Mesh Controls: Symmetry Mesh 

• Added an option “Preserve Face Topology” to retain all edges on a face during the meshing process. When activated, 

even small or narrow edges are preserved, preventing the face vertices from collapsing or being simplified. This is 

especially useful when fine geometric details are essential for accurate simulation results. 

Surface Mesh 

• Material transfer is now supported for both surface and volume mesh generation when using the “Create the mesh in 

new model” option. 

• Enhancement added to retain body-based mesh controls on the input CAD bodies when the “Create Matching Mesh” 

option is used in meshing (Surface mesh, Tet mesh and CFD mesh). 

o Previously, body-based mesh controls were automatically converted to face-based controls due to body merging 

during mesh generation. This enhancement ensures that user-defined body-based controls are preserved, 

maintaining consistency in the meshing workflow and reducing the need for manual redefinition of mesh controls. 

Auto Extrude  

• Robustness of the Auto Extrude Single option has been improved for generating Hex mesh on complex geometry. 

Screw Mesh 

• The following options are added for screw mesh, 

o User defined shank diameter - to specify the user defined shank diameter. 

o Create section face – Pretension section can be created during screw mesh generation. 
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 Solutions   

Solutions > Applications > Battery > Battery Designer (BETA) 

• Battery Designer is a platform for early-stage battery design in the pre-CAD stage of battery development. Equipped 

with various tools for this purpose, Battery Designer provides users with a streamlined workflow to generate battery 

designs from parameters and perform multi-physics simulations to quickly validate the design. 

• Key Features: 

o Cell Catalog: Cell Catalog contains and shows the cell details like name, geometry and Equivalent circuit 

parameters that are used for building battery modules. 

o Parameter Fitting: Provides an interface to fit ECM models up to third order using transient current and voltage 

data from pulse-discharge/charge experiments, such as Galvanostatic Intermittent Titration Technique (GITT) or 

Hybrid Pulse Power Characterization (HPPC). 

o Create Cell: Provides the ability to include customized or user-defined cell templates to the Cell Catalog. 

o Battery Module: Builds simulation ready battery modules from the user given parameters. Busbars and cooling 

channel creation are supported for default library cells. 

o 1D Battery Pack: Effortlessly create 1D battery pack system models in Twin Activate using the ‘Energy Storage 

Library’ extension, directly from the 3D bodies prepared in SimLab. 

 

 Solution Browser  

Solution Right Click > Export Solution Template  

• Added support for exporting a solution template for any selected solution. This enables exporting all related data, such 

as solution settings, boundary conditions, mesh controls, properties, materials, field tables, groups, parameters, and 

companion folder details, into a reusable template format. 

• The exported template can be reused across different models by importing it through Solution Browser > Right-click on 

Solutions Header > Import Solution Template. If the imported template includes body or group data and the current 

model contains matching bodies or group names, a message will appear asking the user to automatically assign the 

corresponding entities. 

• Enhanced to prompt the user to select the mesh model when multiple mesh models are present during solution 

template import.   

 

 

 

. 
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DOE (Using Script) Solution > Result > DOE Result Table   

• Supported Plotting scalar and Time-Dependent Response from DOE Results.  

• An option is added to the DOE table to plot scalar and vector responses by selecting rows from the DOE table. 

 

• Added an option to export selected DOE/Results columns to JSON, including optional time-dependent responses. One 

JSON file is generated per run. Users can select multiple columns and right-click to export as JSON file. 

 Assembly Browser  

Structural / Thermal / Drop Impact Solution > Model > Link Mesh by Matching location  

• Added new options to check for thickness changes and centroid shifts between CAD and mesh• This feature is 

supported only for 2.5D bodies. 
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 Solver Interface  

 OptiStruct     

  Solutions > Application > Electronics > Tumble Test 

• Tumble test solution setup is now supported, providing a quick way to setup the solution to simulate the repeated 

impact and drop scenarios that electronic devices (e.g., smartphones, tablets, and other portable electronics) are likely 

to encounter during typical use. It provides the in-built standard rotating barrels and quick setup including preloading of 

the test components. 

  Solutions > Structural > Dynamic Stress > Normal Mode Solution > Simplified Normal Mode Analysis 

• Introduced a streamlined user interface with only the key inputs for faster solution setup with fewer steps. Advanced 

users still have full control when required. 

  Model Frequency Response Solution Loadcase > Analysis > Request > Modal Participation 

• Modal frequency response solution is supported with the Modal Participation computation tool, which identifies the 

vibration modes contributing most to the response at a given frequency. 

 

  Vibration Fatigue Solution > Analysis > Loads > Component Parameters 

• Added support for importing and exporting vibration fatigue setup data, including component parameters and loading 

data. 
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  Vibration Fatigue Solution > Result > Display Table > Table Sorting 

• Added support to sort the columns of the vibration fatigue results table in ascending or descending order. 

  Vibration Fatigue Solution > Result > Display 

• Vibration fatigue solution results can be visualized using result contours generated from the values in the .csv file after 

solving. Additionally, body-based query results are supported for this result.  

  Modal Transient / Direct Frequency Response / Modal Frequency Response Solution > Settings > Result Request 

• Added support to enable contact result output using the CONTF card. 

Non Linear Static Solution > Settings > Result Request 

• Added support to request and visualize the Neuber Stress result. 

Modal Transient Solution > Settings > Solver Settings 

• Modal effective mass output is now supported for OptiStruct modal transient solutions under solver settings. The 

Modal effective mass can be checked from .out files. 

Modal Transient Solution > Results > Response 

• Response support is extended for modal transient solution.  

  Nonlinear Static / Nonlinear Transient / Explicit Dynamic Solutions > Settings > Solver Settings 

• Added support for Follower Force (both force and moment). This follower effect can be enabled by setting PARAM > 

FLLWER in the solver settings This setting applies the follower effect to all the existing point forces on the node. 

Solutions > Applications > Battery > Battery Thermo-Electric 

• Multi-module definition is supported for OptiStruct battery solution. Existing battery LBCs are grouped under “Battery”. 

Battery Thermo-Electric Solution > Analysis > Loads and Constraints > Current 

• Option to apply constant current in all cells is supported. This enhancement helps replicate battery with working BMS 

which balances cell current. 

E-Motor Acoustic Solution > Analysis > Loads and Constraints > Spatial Harmonic Orders Excitations (1/2) 

• Users can now automatically create excitations corresponding to selected spatial harmonic orders. These excitations 

can be used directly in eMotor acoustic simulations. 

• This enables resonance analysis between spatial orders and structural modes. 

Note: Skewed motors are not yet supported and will be addressed in future releases.  

Normal Mode Solution > Results/Result Panel > Modal Result Table  

• This option displays the mode numbers and their corresponding frequencies in a table for OptiStruct normal mode 

analysis. Selecting a specific row updates the graphical display to show the results for the selected frequency. This 

feature is also accessible from the Results Panel icon. An Export option is provided to export the table data in CSV 

format.  
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  Solutions > Contact > Review 

• OptiStruct data check process is updated to stop after *.cpr file creation. This helps to reduce the time required for 

computing contact status in SimLab.    

Free Shape Optimization Solution > Analysis > Response 

• Support added to define Neuber Correction as a response component for free shape optimization.  

  Topology Optimization Solutions > Analysis > Design Space > Level Set  

• New access is provided to the alternative LevelSet optimization method of OptiStruct solver. 

• Access to advanced parameters (LevelSet initial hole size & layout).  

Analysis > Create Materials 

• A new Hyper Visco-Elastic material model BBOYCE has been added under the Rubber class in the Create Material 

tool.  

Analysis > Constraints > Enforced Acceleration & Enforced Velocity 

• Added support to define Enforced Acceleration & Enforced Velocity based on local coordinate system.  

 AcuSolve  

Solutions > Optimization > Thermal Topology Optimization  

• Support added for thermal topology optimization. 

• Added support for four new responses for thermal optimization as listed below. 

o Mass-averaged temperature difference between inlet and outlet 

o Average temperature in the design domain 

o Average temperature in the solid part 

o Thermal compliance 

• Support added to set maximization of thermal optimization related responses as objective function. 

• The following solver settings are supported to control the optimization of thermal problems. 

o Constraints strength. 

o Constraints factor. 

o Amount of fluid penetrating the solid domain. 
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Flow solution > Results > Response  

• Added support to compute surface integrated force and moment components as responses. 

Battery Thermo-Electric Solution > Analysis > Loads and Constraints > Heat Source  

• Added heat source under analysis ribbon for transient heat transfer load case. 

Battery Thermo-Electric Solution > Analysis > Loads and Constraints > Gas Venting 

• Added support for a new Forchheimer Flow type gas velocity formulation to model gas venting. In SimLab 2025.1, the 

Isentropic Nozzle Flow model was the default model. 

• Support added for new vapor pressure models as listed below. 

o Ethylene Carbonate. 

o Dimethyl and Ethylene Mixture. 

 EDEM 

Multiphysics Post > Particles  

• Support added to render non-spherical particle shapes such as cubes, cylinders, sphero-cylinder, etc. in EDEM 

results. 
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• Support added to request flow results in h3d format. Additionally, extended support for displaying coupled results using 

flow results in h3d format along with EDEM results. 

• Graphics performance for post-processing of EDEM particle results has been enhanced to handle large volumes of 

data with less RAM usage. 

  Particle & Flow with Particle Solution > Results > Stop after current time step 

• Support added to stop the simulation after the completion of the current time step. The option is enabled for both Flow 

with Particle and Particle solutions. 

  Flow with Particle Solution > Analysis > Particle BCs > Assign Equipment Material 

• This tool is used to specify the equipment materials for the flow body surfaces, and these are then transferred to 

EDEM as separate geometry. 

  EDEM Model Performance 

• Significantly improved rendering performance for particle-based EDEM models, with support for up to 10 billion 

particles. 

• Added efficient rendering for multiple particle shapes, including spheres, cubes, prisms, pyramids, and 

spherocylinders. Enhanced interaction responsiveness, delivering smoother rotation, zooming, and panning even with 

massive datasets. 

  Result Import 

• Added support for spherocylinder particles, enabling both results visualization and on-screen drawing. Previewing 

spherocylinder particles is also supported in Analysis > Particles tool. 

• Support added to read Heat Flow Rate and Temperature results component when Heat conduction model is used in 

the simulation. 

 Radioss 

File > Import > Solver Input File  

• Import of Visco-elastic foam material (LAW70) is supported. 

 Flux 

  Solutions > Physics > Electro magnetics > Solution Type Conversion 

• Added the following Flux solution conversions for CAD-based or FEM-based, 2D/Axisymmetric/3D solutions: 

o Magnetostatic               →          Transient Magnetic 

o AC Magnetic                 →          Transient Magnetic 

o Magnetostatic   →          AC Magnetic       

o Magnetostatic 3D          →          Magnetostatic Integral 

o Transient Magnetic 2D  →          RMM 
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  Solutions > Applications > E-Motor > Axial Flux Motor 

• Enhancement added to automate the Back EMF and Constant Speed Solution for AFM. 

• This allows users to automatically compute the induced voltage waveform in motor windings for quick and accurate 

performance evaluation and to run fully automated simulations to evaluate electromagnetic fields and torque at steady 

speeds. 

 

  Solutions > E-Motor > FluxMotor  

• New Inner Salient Pole type part enables accurate geometry adjustments of a Wound Field Synchronous Machine in 

FluxMotor for performance testing and parametric studies. 

o Number of bars 

o Bar shape 

o Pole shape 

• Provides easy drawing in SimLab & robust coupling with FluxMotor.  
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  Export eMotor from FluxMotor to Simlab 

• New Export functionality added in FluxMotor to export eMotors directly to Simlab. 

  

• Users can now directly open the eMotors created in FluxMotor inside Simlab and continue with advanced modelling 

and Multiphysics. 

  Electromagnetics Solution > Analysis > Materials > Material Calibration 

• The Material Calibration tool is used to derive material parameters and coefficients directly from measured data, 

making it easier to define materials for electromagnetic simulations.  

• It supports two types of B(H) magnetic-property models: a soft analytical model (with saturation and knee adjustment 

options) and a hard nonlinear model specified by Br, HcB and HcJ. 

 

• In addition, a refined Modified Bertotti iron-losses model calibration module is included so the user can match a 

material’s loss behaviour from experimental data. 

Advanced > Electromagnetic > Create SMPM 

• The Create SMPM tool lets users quickly build a permanent-magnet synchronous machine geometry by selecting rotor 

and stator parts and setting structural dimensions.   

• Once configured, it automatically generates parameterized sketches (rotor, stator, and basic sector), including the air-

gap midpoint for critical analysis. These sketches are fully driven by user-editable parameters via the Variable 

Manager. All parts are automatically realized into separate bodies, ready for meshing and further electromagnetic 

study. 
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• The functionality supports both Transient Magnetic and Magnetostatic simulation solutions. 

• Supported to regenerate the CAD model created from SMPM tool. 

 

  Reduced Motor Model Solution > Settings > Solver Settings 

• RMM solutions allows users to export reduced order models toward PSIM, Activate and Simcenter Amesim. 

  Solutions > Advanced > Optimization > EM / Mechanical Topology Optimization 

• New optimization capabilities allow optimization of Electromagnetics solutions while considering constraints from 

Structural solutions. 

• Supported EM solutions: 2D Magnetostatic2D & 2D Magnetic Transient. 

• Supported Structural solutions: 2D Linear & Nonlinear Static Stress, 2D Dynamic Normal Mode. 

• Added the following validations, 

o Design Space consistency (materials, physics) 

o Optimization Objective, Constraints consistency 

o EM/Structural Solutions definition & compatibility 

o Electromagnetic Motion LBC consistency with respect to Optimization 

  EM / Mechanical Topology Optimization Solutions > Analysis > Response > Dependent > Electromagnetic Torque > Response 

• New optimization response dedicated to Electromagnetic/Topology Optimization solutions. 

• Maximize or constrain the average torque of a 2D Electromagnetic (Static or Transient) Solution. 
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  EM / Mechanical Topology Optimization Solutions > Analysis > Topology Design Space  

• Topology Design Space LBC can now support bodies with Plane Strain & Plane Stress Properties. 

 

  Solutions > Physics > Electromagnetics > Parasitics Extraction, AC Supplied Conductors, MagnetoStatic Integral  

• Linux compatibility for the Mipse solver has been successfully implemented. It is Supported on RedHat 9 version and 

above.  

  Advanced > Electromagnetics > Import Flux Project 

• Flux projects can now be imported directly into SimLab with the new tool Import Flux Project. 

o No need to export it from Flux beforehand. Just select the .FLU directory. 

o Draging and droping the .FLU directory onto SimLab is also supported. 

  MagnetoStatic Integral Solution > Analysis > Loads > Non-Meshed Co > Magnetic AC solution – 2D 

• Added composed non-meshed coils into MSIM solution. 
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  MagnetoStatic Integral Solution > Analysis > Loads > Motion 

• Added motion for composed non-meshed coils into MSIM. 

 

• Remove the limitation for rotation motion in Magnetostatic Integral solution. 

  Solutions > Electromagnetics > MT2D / MS2D / MAC2D / ES3D > EM Mesh for 2D 

• In the mesh settings for the 2D CAD based workflow, surface mesh has been replaced by EM mesh. 

• Now creates significantly improved mesh to capture small details and grading. 

  Solutions > Physics > Electromagnetics > AC Supplied Conductors > Motion Parameters 

• Motion LBC added to the SCAC solution, enabling the execution of multiple movement sequences with various 

frequency inputs. 

  MT2D / MTAxi / MTSkew / RMM / MT3D / AFM Solutions > Magnet losses computation 

• Improved the workflow to enable magnet losses computation. 

o New workflow: In the Magnet LBC, enable the new “Magnet losses” checkbox to consider the eddy currents and 

compute the magnet losses. There is no longer any need to create a Passive Solid Conductor LBC. 

o Managed backward compatibility with models created in older SimLab versions. 

o Checks are added to verify that the magnet bodies have consistent physical definitions.   

  MT3D / MAC3D / MS3D Solution > Magnetic Field 

• Added a new “Magnetic Field” LBC in EM3D solutions to define the boundary conditions with magnetic field direction 

(tangential / normal). 

• The LBC can be used instead of the Infinite Box LBC by creating an air bounding box around the device under study 

and assigning the external faces to the Magnetic Field LBC with tangential or normal magnetic field direction as a 

boundary condition. 

  MT2D / MAC2D / MS2D / RMM / MT3D / MAC3D / MS3D / AFM Solutions > Settings > Solver Settings 

• Solving mode, initialization, coefficient of circuit-connected coil, and complete cut options are moved from Format and 

Execute Options to Solver Settings. 
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  Solutions > Settings > Format and Execute Options > Mesh Relative Epsilon 

• Based on the mesh transmitted to Flux, the mesh relative epsilon is automatically computed. 

• Mesh Relative Epsilon mode is set to auto-computation by default. User mode is also available. 

• This feature is available for 2D, 3D and Skew EM solutions. 

  Mesh > Verify > More Tools / EM Solution > Mesh Right Click > Validate Mesh 

• The Flux mesh validation process has been enhanced with a new volume overlap check that detects overlapping 

elements within and across solid bodies. 

• The 3D quality computation has been updated from the traditional negative volume method to ABAQUS-based error 

checks, improving accuracy and robustness, with Pyramid and Hex27 elements retaining the existing approach. 

  Solutions > Physics > Electro magnetics > Transient Magnetic > New Interval Definition 

• New multi-interval definition for Transient Magnetic solutions is controlled by Time or Position. Multiple contiguous 

intervals can be enabled.  

  Transient magnetic 2D solution > Analysis > Transient magnetic load > Motion 

• Enhanced Motion LBC in Flux Transient Magnetic 2D solution by adding the Mechanical Characteristics, consistent 

with the Transient Magnetic 3D solution. 

  Solutions > Physics > Electromagnetics > Parasitics Extraction > Motion Parameters 

• Motion BC is added to the PE solution, enabling the execution of multiple movement sequences with various 

frequency inputs. 

  AC Supplied Conductors / Magnetostatic Integral Solution > Settings > Result Request 

• For AC Supplied Conductors and Magnetostatic Integral solution, option is added in the Results Request to export the 

H3D result files. 

  Magnetostatic Integral Solution > Settings > Result Request 

• In the Magnetostatic Integral solution, added the Inductance computation in the Result Request. In SimLab 2025.1 

version, Inductances were computed by default. 

  AC Supplied Conductors / Parasitics Extraction Solution > Results > Plot  

• In 2DPlot results added the real and image part for complex values. 

o PE: Impedance and S-Parameters. 

o SCAC: Current and voltage for active and passive components.  

  Solution > Application > Electromagnetic > Transient Magnetic > Control Parameter  

• Added the ability to define multiple intervals for the control parameter in transient magnetic solution settings 

(MT2D/MT3D).  Multiple interval types are supported: by step value by number of steps (linear or logarithmic) and by 

step list. 

http://altair.com/


Release Notes / Altair SimLab 2026    

 

 

  © Altair Engineering, Inc. All Rights Reserved.  /  altair.com  /   Nasdaq: ALTR   / Contact Us 

 

 

23 

  MT2D / MS2D / MAC2D / ES3D Solution > Circuit Designer Shortcuts 

• Supported keyboard shortcuts for,  

o Copy (Ctrl+C) 

o Paste (Ctrl+V) 

o Rotate (Ctrl+R) 

  MT2D / MS2D / MAC2D / ES3D Solution > Loads and Constraints > Import Circuit 

• Provided support for importing the same SCM (Circuit file) multiple times within the same database, as well as across 
different databases in a single SimLab session. 

  MT3D Solution > Analysis > Circuit > Circuit Catalogs For 3D 

• A new feature has been introduced in the eMag Solution for MT support 3D Circuit Catalogs. This enhancement 

enables users to seamlessly access and integrate 3D circuit components within the 3D domain, improving modeling 

flexibility and accuracy. 

• In addition, the Circuit Catalog folder structure has been reorganized to provide a clearer distinction between 2D and 

3D circuits.  

• Key benefits are listed below: 

o Dedicated support for 3D circuit elements in electromagnetic simulations. 

o Enhanced workflow consistency between 2D and 3D domains. 

 ElectroFlo 

  Summary: 

• New body-based convection BC. 

• Detailed PCB: vias as 1D links. 

• Reduced solver memory footprint. 

• New linear CFD solver for large models. 

Electronics Thermal Solution > Analysis > Smart Object > Liquid cooling: 

• Removed requirement of inlet/outlet to be at the domain boundary. 

• Automatic CFD solution freeze after convergence if there is no multiplier. 

• CFD equations are solved at least for 10 iterations. 

Electronics Thermal Solution > Analysis > Smart Object > PCB > Detailed PCB: 

• Added option to consider vias as 1D links in Solver Settings > Advanced Options > Write vias as links. 

• Added support for hollow vias & FR4 filled vias, only for vias as 1D links option. 
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Electronics Thermal Solution > Analysis > Smart Object > Filter: 

• Improved UI by adding units into dP/Q ratio. 

Other new features: 

• CFD solver: 

o Advanced option item for selecting matrix solver (Hyper vs PETSc). 

o Improved robustness by making default value for velocity relaxation factor to 0.9. 

o Improved robustness of pressure solver. 

• Solver: 

o Treat air as solid automatically in Flow simulations without fan. 

o Reduction of 8% in maximum solver memory footprint. 

o Reduction of 70% in solver memory footprint before postprocessing. 

• Coupled Solution > Electronics Thermal - Electromagnetics: 

o Report Joule heating, total Joule heating, voltage, and current density. 

• Log file: 

• Added report that vias as links option has been activated. 

• Added report that treat air as solid toggle has been enabled. 

• Report Joule heating value at each iteration. 

• Report total number of elements in all simulation types. 

• Added Joule heating value at each iteration in Coupled Solution (Electronics Thermal – Electromagnetics). 

 nanoFluidX 

Analysis > Boundary Conditions > Initial Condition 

• Supported multiple cuboid regions to set fluid domain for creating fluid particles using the “Particles” tool in Drivetrain 

Oiling and Tank Sloshing solutions. 

o The particles located within and on the defined cuboids in the fluid region will be created as “Fluid_1” body.  

o In a multiphase flow, particles in the fluid region that lie outside the defined cuboids will be created as the 

“Fluid_2” body.  

o For overlapping cuboids, duplicate fluid particles will not be created.  

• By % of “Fluid1” in total volume and by “Fluid1” volume in liters, the gravity direction is defined using the “Define 

Vector for filling direction” option in Drivetrain Oiling and Tank Sloshing solutions.  
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 Feko 

Solution > Application > RF Electromagnetics > Radio Coverage / Connectivity Analysis (BETA) 

• Added polarimetric support for Radio Coverage solutions. This extension allows users to switch between Standard and 

Full analysis methods. 

• A new Site feature is available that groups transmit antennas, making it easier to manage larger networks.  

  Solution > Application > RF Electromagnetics > Network Planning Solution (BETA). 

• Multiple-input and multiple-output (MIMO) technology can now be either disabled or enabled using two to eight parallel 

streams.   

• This solution now supports importing wire standards from .wst files, improving integration with external datasets.  

Solution > Application > RF Electromagnetics > Connectivity Analysis (BETA) 

• Prediction planes now support relative height settings when topography is included, allowing for more accurate 

analysis in varied landscapes. 

View Tool Bar > Display Thickness > Heigh > Topography Display 

• Automatic height display is enabled when importing WinProp outdoor database (.oda) and the sheet bodies are 

displayed with the height details extracted from imported .oda file.  

 

Radio Coverage Solution > View Tool Bar > Visibility > Display Ground Plane 

• Ground plane is rendered as a grid with coordinates.  

Radio Coverage Solution > Result GUI Right Click > Query Results 

• Query results on nodes or elements now correctly reference only the results mapped over the prediction plane, 

avoiding interference from underlying geometry. 

Results > Create Scene 

• Supported added for creating scenes for all RF Electromagnetics solution results. 

Results GUI Right Click > Display Results in Transparent 

• Supported to display the 3D results far field request in transparent mode. 
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 Coupled 

  Solutions > Physics > Coupled Solution > Electromagnetics + Flow 

• Added bidirectional coupling between Electromagnetics and Thermal solutions using Mipse and AcuSolve.   

 

  Solutions > Physics > Coupled Solution > Electronics Thermal + Circuit (External) 

• The circuit schematic PSIM database created in PSIM 2026 is not supported in SimLab 2026; it is compatible only with 

the PSIM 2025.1 database.   

 StarCCM+ 

Flow Solutions > Export Solver Input File  

• Support has been added to export volume mesh to StarCCM+ in CGNS format. 

• Mesh generated in SimLab can be used for STAR-CCM+ simulations. 

• Interfaces between bodies are automatically created for internal shared surfaces.  
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Flow Solutions > Export Bodies as STL  

• Support has been added to export surface mesh to StarCCM+. 

• Body and surface names are preserved.  

 Abaqus 

Analysis > Tool > Sets  

• Support added for exporting node and element sets to respective include files when the option “First level of sum 

models” is selected in the Format and Execute Options > Include file structure.  

 Permas 

Solution > Export Solver Input file 

• The thread pretension IDs will stay unchanged during the export of the solver input file, even if new LBCs or bodies 

are added to the solution.  

 Ansys 

Analysis > Solve > Export Solver Input file 

• PYRAMID 13 elements can be exported to both the ANSYS “.cdb” and “.ans” (input deck) file formats.  

File > Import > Solver Input File > Ansys 

• Enhanced support to read and import PYRAMID 13 (Solid 92/Solid 187 equivalent) elements from ANSYS “.cdb” and 

“.ans” decks.  

 

 Results 

 Enhancements   

Create Notes 

• The notes functionality is now enhanced to provide complete visibility and consistency by supporting the display of 

values for all averaging methods (Maximum, Minimum, Advanced, Difference, and Volume Averaged), all defined 

coordinate systems and all derived results, including signed Von Mises stresses etc. 

• When an existing Note is double-clicked in the Solution Browser or in the graphical area, the Note dialog opens in 

Modify Mode, allowing: 

o Selection of a new entity (node or element). 

o Immediate update of the Note to reference the new location. 

• This is particularly useful when the model has been modified, and local extrema (e.g., stress peaks) have shifted. 

• When creating a new Note, both component and sub-component names are now displayed by default. This 

improvement ensures greater clarity on which physical quantity the Note refers to. 
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• When exporting a solution using “Export Solution Template”, all Notes attached to that solution are now automatically 

included in the template. 

• Upon importing this template, Notes are restored and appear in the solution browser, under their respective solutions. 

• Notes can then be updated and attached to new entities (nodes or elements) as needed. 

Results GUI > Result Panel   

• Extending the uniform sampling of vector for 3D results. 

• This feature displays vectors at uniformly distributed points in the X, Y, and Z dimensions. 

Results GUI > Animation   

• Linear Animation Now uses frame-based rendering, updating the animation at defined time steps for smoother 
playback and reduced processing load. Previously, linear animation refreshed continuously, causing constant screen 
updates. 

• Enhancement made to increase the performance for Linear, Transient, and Modal Animations that include the below, 

o Pause/Resume on Mouse Events, Animation pauses while you click and hold. Resumes automatically when the 
mouse is released. 

o Rotation Center Updates Disabled During Playback, reduces processing overhead, resulting in faster animation 
performance. 

o Entity Highlighting Disabled During Playback, highlight effects (Bounding box) turned off while animation runs. 

Results GUI Right Click > Query Results   

• Support added for querying result values at arbitrary points selected on the surface of the model.  
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 Electronics 

 New Features  

Tools > Chip > Create QFN 

• This tool can generate a mesh for quad flat no-lead (QFN) components along with solder, using either user-defined 

models or SimLab templates. 

 

 Enhancements  

File > Import > ECAD 

• Added an option to skip polygon merging during ECAD model import, significantly speeding up the process of reading 

large ECAD models with complex trace data. 

• Introduced support for importing data from ECAD files as wire bodies, significantly improving the import speed for large 

and complex ECAD models. Import time is reduced by approximately 80%. 

• Added an option to group vias based on the via diameter during ECAD model import. 

  Material Mapping 

• The material mapping concept is extended to interconnect structures as well. Instead of explicitly meshing individual 

bumps or microbumps for all simulation scenarios, their effects can be represented on a simplified reference mesh 

through mapping. This approach further accelerates simulations while preserving result accuracy.  

• Interconnect material mapping can be performed based on MCAD bodies or a CSV-file. 

• Added support to perform material mapping based on ECAD data imported as wire bodies. 

• Added support to perform interconnect material mapping based on MCAD data. 

  ECAD Detailed Modeling 

• The following improvements have been added to this tool to enhance overall robustness and usability. 

o Preserve-shape mesh control is now automatically applied to all side faces during sub-model (SM) generation. 

o The intermediate database is now written to the temporary folder before SM generation. If Tet meshing fails, the 

intermediate database is automatically loaded to allow users to continue without losing progress. Preserve-shape 

mesh controls are retained in the intermediate database and restored correctly when the file is loaded. 
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o Mesh-control display is reset to improve visualization. 

o Model view automatically fits to screen to bring the cut-section model into focus. 

  Create BGA 

• Create BGA tool has been updated to support four new mesh patterns. These patterns expand the available meshing 

options and provide greater flexibility when generating BGAs with improved coverage for varying seed counts and 

mesh distribution needs. 

 

• Several enhancements are made for BGA locations (select spherical bodies) option, 

o The corresponding bodies are now merged automatically in the output for cleaner and more consistent geometry. 

o Nodes between solder balls and the top/bottom copper pads are now automatically equivalenced. 

o Added support for generating copper pillar BGAs when the input solder bodies are cylindrical. 

o Materials assigned to CAD bodies are now transferred to the corresponding solder bodies in the output. 

o The assembly structure is now maintained in the output model, improving organization. 

  Advanced BGA 

• Advanced BGA tool has been enhanced with support creating CAD BGAs directly from CAD geometry.  

Note: This capability can be enabled using the environment variable SIMLAB_ADVANCED_BGA_CREATE_CAD. 

• Users must use “Multiple types” option to create the BGAs. 

• No package or board geometry is created. 

• Supports both box and cylindrical CAD shapes for defining the bumps. 
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 Advanced       

 Weld 

Without Heat Zone > Create Seam Weld 

• Seam weld tool now supports creating and selecting the property for the weld body. 

 

 Automation 

 New Features  

  UI Customization > UI Designer 

• GUI with predefined objects from the UI Designer toolkit is supported to design the dialogs for getting the inputs from 
the user and perform SimLab automation.  

• The UI Designer offers an intuitive drag-and-drop interface for designing dialogs without the need for manual coding. 
Dialog designs can be exported in the following formats, 

o *.ui: Saves the dialog design, allowing it to be reopened and modified later in the UI Designer.  

o *.py: Saves the dialog as a Python script for integration with SimLab operations. 

 

Note: Importing an exported .py file is not supported. Currently, only the .ui file can be imported for further changes in 
dialog design, after which new .py file must be exported, requiring all modifications to be reapplied manually once 
again. 
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 Enhancements   

  UI Customization  

• Moved UI Customization and Remote Solve options under Automation menu. 

  Parameter Manager  

• Supported below inbuilt function, 

o TAND(x) - returns the tangent of an angle x, where the angle is interpreted in degrees. 

o SIND(x) - returns the sine of an angle x, where the angle is interpreted in degrees. 

o COSD(x) - returns the cosine of an angle x, where the angle is interpreted in degrees. 

o ASIN(x) - returns the inverse sine (arcsine) of x, giving the angle in radians whose sine is x. 

o ACOS(x) - returns the inverse cosine (arccosine) of x, giving the angle in radians whose cosine is x. 

o ASIND(x) - returns the inverse sine (arcsine) of x, giving the angle in degrees whose sine is x. 

o ACOSD(x) - returns the inverse cosine (arccosine) of x, giving the angle in degrees whose cosine is x. 

o ATAN2(y, x) - returns the angle (in radians) whose tangent is y/x, considering the signs of both x and y to 
determine the correct quadrant. 

o ATAN2D(y, x) - returns the angle (in degrees) whose tangent is y/x, considering the signs of both x and y to 
determine the correct quadrant. 

o VALID(x,x1,x2) - allows creating square wave signals. 

o MODULO(X,X1 ) - allows to create periodic signals. 

o TRAPEZ(X,X1,X2,X3) - allows creating signals of a trapezoidal shape. 

o TRAPEZPER(X,X1,X2,X3,X4,X5,X6,X7) - allows creating periodic trapezoidal signals. 
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