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3 

 

 Supported CAD 

• MCAD 

o Parasolid (35.1.219) 

o STEP 

o CATIA (Up to CATIA V5-6R2022) 

o Creo (Up to 9.0) 

o JT 

o NX (Up to NX 2306 series) 

o SOLIDWORKS (Up to 2022) 

o Inventor (Up to 2022) 

o ACIS (Up to 2022) 

o AutoCAD (Up to 2022) 

• ECAD 

o Altium (Up to PCAD 2006 and Designer 16.0) 

o IPC-2581 (Revision A and B) 

o MentorGraphics PADS (from 5.0) 

o Zuken CR-8000/CR-5000 (7.0) 

o MentorGraphics Xpedition 

o Cadence Allegro Expansion (from 16.3 to 22.1) 

o GDSII 

o ODB++  

 Supported Results Reader 

• Abaqus 

o Reader 1: Up to V2024 

o Reader 2: Up to V2018 

• ANSYS: Up to V2023 R1 

• ADVC: Up to V2.3 

 Solvers 

  Altair Solvers bundled with SimLab 

• OptiStruct: 2024 

• AcuSolve: 2024 

• Radioss: 2024 

• Flux: 2024 

• Altair Manufacturing: 2024 

• ElectroFlo: 2024 
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• nanoFluidX: 2024 

• EDEM: 2024  

 System 

 Enhancements   

File > Save / Save As  

• Enhanced the structure of storing the results and spec files related to database solution, while saving the database. 

Note:  

o Due to this change, the old script that has process of saving database with results and trying to access the result 

/ spec files from database folder in old folder structure, will fail.  

o Users need to update the script with the new file path. 

 

File > Catalog  

• Added the option Catalog in File Menu. 

• Supported to preserve user added catalog across different SimLab databases / sessions using catalog settings file. 

File > Preferences > Geometry > Options   

• Support added to export Parasolid based on version. 
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Dialog: Line Edits 

• Added preview balloon which displays the value of the parameter used in the Line edit when user hovers it. 

 

Unit  

• Supported the following unit physical quantities, 

o “Friction coefficient proportional to speed square” for Flux MT2D 

o “Electric conductance per unit area” for OptiStruct Electrical contact 

o “Flow resistivity” for poro elastic material 

Unit Converter   

• Supported a new physical quantity “Temperature gradient” in the Unit converter dialog. 

 

 

 

 

 

 

 

 

http://altair.com/


Release Notes / Altair SimLab 2024    

 

 

  © Altair Engineering, Inc. All Rights Reserved.  /  altair.com  /   Nasdaq: ALTR   / Contact Us 

 

 

6 

 Import 

 CAD   

  Parasolid  

• Tessellation of Parasolid wire bodies made finer to improve its visualization. 

  Creo  

• Creo 9 version CAD files are now supported to import. 

  ECAD  

• Added support to import an array of boards in ECAD models. 

 

• Added support to import GDSII file format. 

• Added support to import only the board from the ECAD file. By selecting the “Compute and export the layer data” 

option, the layer information data is computed from the ECAD file and then exported as a CSV file. 

• The database memory size is optimized while importing ECAD files with BGA’s.  

o Usually, the BGA’s are many in number, performance improvement and size of the database is optimized in 2024 

compared to 2023.1. 

• Support added to import Cadence Allegro files in SimLab (*.brd and *.mcm) 

Note: User needs to have access to Cadence Allegro and it needs to be configured while installing SimLab. 

  AutoCAD  

• Support added to convert the DXF to Sheet. 

• Redesigned the AutoCAD import options to import Sheet and Sketch bodies. 
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 Graphics and Visualization 

 Enhancements 

View Toolbar > Capture Views 

• Relocated a few options to get better visibility and for easy access. 

• Enhanced the option to capture the view with entities transparency and display it back once it is activated.  

• Added script support for Rename, Delete All and Activate views options.  

View Toolbar > Views > Lock Rotation 

• Lock Rotation option was hidden under environment variable in 2023.1 version. In 2024 version, enabled it by default 

and relocated it from View menu > Views to View Tool Bar > Views. 

View Toolbar > Enable Cutting Plane  

• Increment and Decrement options are supported in the Move Cutting Plane micro-dialog to adjust the cutting plane’s 

position to a predefined delta value. 

View Toolbar > Render Mode > Edge display > Topological: Free Edge and Non-manifold Edge 

• Support added to display the total number of Topological Free Edges and Non-manifold Edges present in a model 

along with their respective body names in the Output window. 

Note: Supported for both CAD and FEM Inputs. 

Assembly Browser > Model/Sub Model Right Click > Export / Import Browser Column 

• Support added to export the browser parameters for the selected bodies. 

• Importing browser columns now supports Mesh control assignment in addition to drop test parameters. Mesh control 

template should be imported prior to this operation. If the mesh control name specified in the .csv file is available, it will 

be assigned to the body while importing the browser column data. 

• Script support is added for export & import browser columns.  

Body / Face Right Click > Select / Inspect > Faces > Faces by Region 

• Enhanced the show Faces by Plane option to show the faces based on cylinder, sphere, and box regions too. Also 

changed the option name to Faces by Region. 

Inspect > Bodies > Validate CAD Parasolid 

• Added support for finding the invalid Parasolid bodies and “Invalid_bodies” group can be created for them. 
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 Geometry  

 Enhancements  

Edge > Create Curve 

• Added support to create a Parasolid wire body from nodes/vertices. 

Face > Create Rectangle Face 

• Extended support for creating rectangle face using the below options for both CAD(Parasolid) and FEM bodies, 

o Rectangle Selection 

o Planar Face 

o 3 Nodes / 3 Vertices 

Face > Create Cylinder Face  

• Extended support for creating Cylinder face using the below options for both CAD(Parasolid) and Mesh body types. 

o Centre and Point 

o Dimensions 

o Bounding Body 

o Selected Faces 

o Straight / Arc Edge / Group 

o Cylinder face / Group 

o 2 Nodes 

o 3 Nodes 

o 2 Vertices 

• Supported Mesh size and Model selection option. Allowed user to specify the body name. 

Body > Create Cylinder  

• Support added to define cylinder using “Center and point” option for creating both solid and sheet cylindrical bodies. 

Body > Create Sphere  

• Extended support for creating sphere using the below options for both CAD(Parasolid) and FEM bodies, 

o Bounding Body 

o Straight / Arc edge 

o Spherical face 
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o 2Nodes 

o 2 Vertices 

Body > Create > Sweep   

• Extended the Helical Gear tool support to CAD bodies. 

 

Body > More Tools > Unmerge / Connected Body > GUI > Right Click > Unmerge 

• Added support to unmerge connected bodies (General Bodies) that were not created within SimLab. 

Body > More Tools > Simplify Bodies 

• Improved the performance by ~70% for simplifying each body option if there are large number of bodies in the model. 

Body > More Tools > Simplify Fasteners 

• The Simplify Fasteners tool has been enhanced with the following features, 

o Option to Delete or Suppress input bodies. 

o “SimplifyFasteners_FailedBodies” body group will be created for the failed fasteners. 

Body > Connect > Boolean: CAD (Parasolid) 

• Extended support to select connected body as input for Subtract option tool bodies.   
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 Mesh  

 Enhancements  

Mesh Control 

• Supported to display the Parameters name in the line edit for the mesh control dialog in the modify mode. 

• For the group input, the group name will be listed in the selection list in the modify mode. In the previous version, 

entities will be listed. 

 

Mesh Control: Symmetry Mesh Control 

• Support added to specify the tolerance to select the coplanar faces. In SimLab 2023.1, the coplanar faces will be 

identified based on the default tolerance.   

Free and Non - Manifold Edges 

• Extended the support to verify free and non-manifold edges for CAD bodies. 

Tet Mesh 

• Added support to create a group for the Cavity bodies when the user generates TET mesh with the “Fill cavity inside 
volume” option turned ON. 
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  Hex Secondary Ribbon  

• Re-organized the ribbon layout for ease of use.  

 

  Auto Extrude 

• “Auto extrude – single” option is enhanced to create pattern mesh for disc faces. 

• Edge mesh control can also be assigned for the disc faces/edges to get the required number of seeds. Pattern mesh 

will be created only if the seed count is multiple of four.  

 

  Connect Hex Bodies 

• Performance improved by ~95% for Top face connection with preserve body option. 
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 Solutions 

 Analysis 

Create Coordinate System 

• Added support for center point and rotation angle-based coordinate system for solutions. 

 

Property  

• Supported the visualization for the following Beam Sections: C, I, T, Plus and L sections when bar property is applied. 

Connectors  

• Enhanced the LBC Markers for the following connectors,  

o Bush,  

o Spring Damper,  

o Spring,  

o Gap, and  

o Rigid Bar. 

 Solution Browser  

Solution Right Click > Sort 

• Added “Sort” option to sort the LBC objects by its name. 

 Property Browser  

Material Right Click > Duplicate 

• Extended support to duplicate Materials in property browser. 
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 Solver Interface  

 OptiStruct   

  Solutions > Applications > Electronics > Snap Fit 

• Added support to automate the solution setup for snap fit analysis. Solution type can be either non-linear static, non-

linear transient and explicit dynamic analysis. This tool is supported only for OptiStruct solver.  

Structural Solution > Static Stress Analysis > Linear Buckling 

• Added support for linear buckling analysis type.   

Non Linear Static & Transient Solution > Setting > Result Request 

• Added support to request results at the user-defined time steps. It is supported for non-linear static and transient 

solution types.  

Non Linear Static Solution > Setting > Format and Execute Options 

• Added support to improve the solution convergence of non-linear setups. By enabling this option, OptiStruct 

automatically converts the NLPARM entry in the input file into an equivalent NLCTRL entry which can improve 

convergence.  

Normal Mode Solution > Results > Fatigue > Vibration Fatigue 

• Enhanced the Vibration Fatigue Life calculator tool to support overall GRMS value inputs.  

Solder Fatigue Solution > Setting > Result Request 

• Support added to request the results only at the required points based on the input thermal profile to reduce the size of 

the result files.  

Explicit Dynamic Solution > Setting > Solver Settings 

• Added support to activate adaptive dynamic relaxation for Explicit Dynamics analysis type.  

Thermal Solution > Results Right Click > Response   

• Added support to create heat flux response for thermal solutions. It is supported only for OptiStruct and Abaqus 

solvers.  

Electric Conduction Solution > Results Right Click > Response   

• Joule loss density and current density responses are supported for steady-state and multi-steady-state electric 

conduction OS solutions. 

• The responses can be used as design variables for DOE runs. 

E - Motor Acoustic Solution > LoadCase Right Click > Display / Hide Excitations 

• Supported to display the Order value next to the Frequency value in the Results panel while displaying the Excitation 

loads as vectors.  
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E - Motor Acoustic / Modal Frequency Response Solution > Analysis > Loads and Constraints > Reflective Surface 

• Supported to define reflective surface to define amount of sound reflected to the source. 

• By placing the selected ISO microphones over the reflective surface, we can measure the sound pressure received at 

that point. 

• It is supported only for OptiStruct solver with the Adaptive Perfectly Matched Layer (APML) method. 

E - Motor Acoustic / Modal / Direct Frequency Response Solution > Analysis > Tools > Sound Receiver 

• Acoustic analysis can now be performed based on ISO 3745 / ISO 3744 standards. The tool supports the creation of 

microphones around the sound source based on the above ISO standards. 

Modal Frequency Response Solution > Analysis > Force Computation 

• The Force Computation tool automatically creates a normal mode loadcase. 

• In this loadcase, eigenvalue extraction for fluid is only requested when the solution contains a fluid domain. Previously, 

eigenvalue extraction for both structure and fluid were always requested. 

Electric Conduction Solution > Analysis > Loads and Constraints > Contacts 

• Unit supported for contact electric conductance.  

Analysis > Property > Material 

• Temperature dependant electrical resistivity is supported. It can be used for coupling electrical analysis with thermal 

analysis.  

• Added support for poro-elastic material. Also, added support for flow resistivity unit in SimLab which is used by poro-

elastic material properties. 

• Supported the definition of rate dependent plastic material. Both types of strain rates are supported: “Total strain rate” 

and “Plastic strain rate”. Tables are exported as TABLEMD card in the solver input deck.  

Analysis > Loads and constraints > Contact 

• Added support for augmented lagrange multiplier method-based contact definition for OptiStruct solutions. It is 

supported only for USE_CONTACT_PARAMS contact type. 

Solutions > Advanced > Optimization > Topology 

• Added support to include Beam and Bar element in topology design space.  

Optimization Solutions > Results Right Click > Response  

• Below Optimization responses are supported for steady-state electric conduction solutions, 

o Nodal electric potential 

o Global electric compliance 

o This support enables users to setup electrical and steady-state electro-thermal optimization problems.  
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 AcuSolve  

Flow Solutions > Boundary conditions > Mapping Nodal BC – Velocity & Pressure 

• Added support to map results from one Flow solution to another. 

• Results (Pressure, Velocity) on the outlet face can be mapped on the inlet face of the second solution.  

• This is written as Nodal Boundary Condition to AcuSolve input file. 

 

Solutions > Physics > Flow > Particle Flow  

• Geometric models that need equipment material to be defined, for EDEM setup, can be created as separate shell 

bodies using the Geometry > Body > From Faces tool. Support added to include these shell bodies to the current 

Particle Flow solution automatically upon creation. 

• Added support to assign EDEM equipment material to these shell bodies. 

• Support to save particles material definition in SimLab database is added. 

• Support added to save EDEM results files along with Flow results when SimLab database is saved. 

Particle Flow Solution > Particle Flow Enhancements 

• Support added to assign multiple equipment materials to different shell bodies. 

• Support added to save EDEM results file (*.dem) along with slb. 

• Supported to save EDEM material definitions along with slb. 

  Particle Flow Solution > Analysis > Boundary Conditions > Particle Factory 

• Particle Inlet dialog is renamed to Particle Factory.  

• Support added to define Static and Dynamic type particle factories.  

• Added support for “Fill Section” type particle generation using Static Particle Factory.  

• Advanced section in Particle Inlet dialog is modified into a separate dialog called Particle Parameter.  
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• Support added to input Temperature and Heat Flux of the particles. 

  Particle Flow Solution > Analysis > Boundary Conditions > Volume Packing 

• Support added to define volume packing used to fill a geometry with particles.  

Analysis > Components > Porosity 

• Support added to auto compute the Darcy and Forchheimer coefficients for the porosity model based on the input 

velocity versus pressure drop data. 

Analysis > Property > Material 

• For fluid materials, support is added to input viscosity as a piecewise linear function of strain-rate. 

• Added support for Levelset redistancing method for multiphase immiscible flow simulations. 

• For Flow solutions, support is added to input anisotropic thermal conductivities for solid materials. 

o Support extended to define using local rectangular and cylindrical coordinate system and include temperature 

dependency. 

 Coupled OptiStruct + EDEM 

Solutions > Advanced > Coupled Solution OptiStruct + EDEM Solvers (Beta version) 

• Support added to perform 2-way coupled simulation with structural and particle physics using OptiStruct and EDEM 

solver.  

  

 Radioss 

Solutions > Applications > Drop Test  

• Support added to select CAD bodies as input for Radioss drop test solution. 

Note: Currently, the mesh bodies should be added manually to the solution. 
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 Flux 

Solutions > Physics > Electromagnetic > Magnetic AC 3D 

• New Magnetic AC solution 3D is supported. 

• The Magnetic AC 3D solution allows the study of devices in the harmonic state (sinusoidal steady state) for a given 

frequency. 

• This solution considers the currents induced in the conducting regions (eddy currents). It also considers the skin 

effects which can be significant in 3D modelling and the proximity effects in the conducting regions. 

• Main use cases for Magnetic AC 3D solutions are : 

o Induction heating 

o Induction motor 

 

Solutions > Physics > Electromagnetic > Supplied Conductors AC 

• New solution dedicated to AC electromagnetic simulations for power electronics type geometries (power modules, 

bus-bars…) 

• A circuit can be defined and connected to geometry through “N Solid Conductor” components. 

 

http://altair.com/


Release Notes / Altair SimLab 2024    

 

 

  © Altair Engineering, Inc. All Rights Reserved.  /  altair.com  /   Nasdaq: ALTR   / Contact Us 

 

 

18 

• Joule Losses, Current density (complex) and Electrical potential (complex) are displayed after solving. 

• For multi-frequency simulation, animation can be shown. 

Supplied Conductors AC Solution > SC Workflow > 2D Plot  

• In 2DPlot, circuit and body quantities can be plotted, 

o Joule losses in bodies  

o Current/voltage in components (Sources and R, L, C) 

Mesh > Mesh Control: Skin Effect Mesh Control & 3D Mesh > Skin Effect Mesh 

• Taking into account the skin effect phenomena: the AC electric currents are not uniformly distributed in the conductor 

cross-section but are concentrated in the external layers close to the conductor surface, This happens when the value 

of either the frequency (f), or the permeability (µ), or those of the electric conductivity (σ) are high. 

• There are currently 2 tools for the skin effect mesh: 

o Skin Effect Mesh: The tool allows to create a skin effect volume mesh defined by skin depth, number of layers, 

etc. 

o Skin Effect Mesh Control: It assigns skin effect mesh settings to the selected bodies. It allows to assign different 

skin effect settings to the solution bodies (especially different skin depth values). The bodies with the skin effect 

mesh control must be meshed with Skin effect mesh tool (not Tet mesh or any other mesher). For bodies 

selected in the skin effect mesh dialog, if skin effect mesh controls are assigned on these bodies, the mesh 

controls inputs have higher priority. 

 

Note: Those 2 tools are available in the following solutions, 

o Magnetic AC 3D 

o Magnetic Transient 3D 

o Parasitics Extraction 

o Supplied Conductors AC 
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  Electromagnetic Solutions > Analysis > Loads and Constraints > Coordinate > Create Coordinate System 

• Added support for center point and rotation angle-based coordinate system for solutions. 

  Electromagnetic Solutions > MT2D/MT3D/MS2D/MS3D > Create SMPM 

• Update the new tool to quickly create parameterized sketches of a permanent magnet synchronous motor. Now after 

clicking the tool, the sketches won’t be automatically created until users select the rotor and stator shape from the 

catalog. 

  MT3D & MT2D Solution > Settings > Result Request 

• Units are now supported in Result Request dialog for Min and Max Computation steps. 

  MT3D & MT2D Solution > Circuit designer 

• Added a new circuit designer component brush, useful for DC motors. 

  MT2D Solution > Settings > Result Request 

• Result requests related to sensors in Flux are now available for computation. 

• Below result requests are now available for skewed motors also, 

o Flux for coil conductors, 

o Joule losses coil conductors 

o Energy coil conductors 

o Lorentz force coil conductors 

  Electrostatic 3D Solution > Results > Tools > Streamer Criterion 

• The breakdown voltage value computed with Streamer Criterion is listed now under “Results” in the solution browser. 

Earlier, it was listed under Parameters browser. 

  Electromagnetics Solution > MT2D/MS2D > Analysis > Periodicity 

• Automatic computation of offset angle and number of sectors for rotational periodicity.  

  MT2D/Mtaxis/MS2D Solution > Analysis > Magnet > Magnet Orientation 

• Added a new option to define magnet orientation depending on straight edge/ arc. 

  Mesh > Verify > More Tools > Quality Check (New) - Flux  

• Added the following criteria to the Flux mesh Quality specification: 

o Pyramid: interior angle minimum 

o Tet: Flux JY Talon 

o Quad: Flux ratio of area to square of perimeter 
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• Now the Quality check covers all the mesh checks that are performed by Flux solver. 

  OS / AcuSolve Solution > Boundary conditions Right Click > Direct Coupling (Flux - AcuSolve / OS – Heat Loss) 

• Automatic heat source mapping from a MT2D solution to a thermal / flow solution. 

 

  MT3D / SCAC / MAC3D Solution > Circuit Designer > Coil Conductor, Solid Conductor and N Solid Conductor 

• Added the possibility to select face groups in Coil conductor, Solid conductor, and N solid conductors in 3D to define 

the Input and Output terminals. 

  MT2D Solution > Circuit Designer > Auto Circuit Creation 

• Enhanced the tool to create the circuit components for periodic models and double layer hairpin windings. 

  Magnetic AC3D Solution > Circuit Designer > Solid Conductor and N Solid Conductor 

• Updated Solid Conductor and N Solid Conductor circuit components by adding a new option “Eddy currents with 

strong skin effect described by surface impedance” to simulate precisely strong skin effects (small skin depth). 

  Magnetic AC3D Solution > Results GUI > Complex Quantities 

• Supported complex quantities graphical display for Flux solver: Contour and Vectors display on Modal animation, with 

or without Motion. 

  Magnetic AC3D Solution > Results > Response  

• Added EM Response for Magnetic AC3D solution, with or without Motion. 

  Magnetic Transient2D solution > Analysis > Motion  

• Added all the friction coefficients units in the line edits. 

• Corrected one input for Translation Motion: “Mass” instead of “Moment of Inertia”. 

  Results > Spatial Plot 

• For single speed MT2D solution, the speed is automatically selected in the spatial plot dialog. 
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 ElectroFlo 

Assembly Browser > Model Right Click > Import/Export Browser Columns: 

• Model setup is reduced by exporting material properties and heat sources to a csv file or importing these from an 

existing file. 

• Heat sources can be created by right-clicking on any component that has a heat source, and then selecting “Create 

Heat Source”. 

Solutions > Applications > Electronics > Electronics Thermal  

• Renamed the simulation types, 

o Non-CFD → Thermal 

o Full-CFD → Thermal & Flow 

o Non-CFD with Air → Thermal & Frozen Flow 

• Added new simulation type, 

o Flow → This will simulate only flow (no thermal). 

Electronics Thermal Solution > Smart objects Right Click > Review 2R Components 

• Support added to review the defined 2R components. If the solution is solved, user can review the Junction, Case and 

Board temperatures. 

Electronics Thermal Solution > Results > Response 

• Support added to create temperature response for CAD face / face group / body. 

  Analysis > Model Discretization > Key Planes 

• The “Minimum distance between keyplanes” is renamed as “Merge keyplanes if closer than”. 

Analysis > Model Discretization > Geometry Discretization 

• For Thermal & Flow and Thermal & Frozen Flow simulations, user now has an option to create the air body in the 

discretized geometry.   

o By default, the “Create air body” check box is OFF, and the air body will not be created. 

o While creating Analysis mesh/Discretized Geometry, based on the “Create air body” check box ON/OFF, the air 

element count is specified as Air/VirtualAir in the output window.  

• For Thermal simulation: Existing behaviour is retained. (i.e. No air body will be created and the “Display discretized air 

region” check box will be hidden in its dialog). 

GUI Right Click > Display in Color > LBC 

• Improved the large model performance with the LBC color mode.   
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Other new features: 

• Improved analysis meshing: reduced element count and improved mesh smoothness. 

• Remote solve on Linux solvers. 

• Thermal solver: 

o More robust patch creation for Network Radiation. 

• Post-processing: 

o Improved quantitative reports. 

• Log file: 

o Added average value of each variable. 

o Added warning message if fluid material has non-physical properties. 

o Added runtime error information in case simulation fails. 

 nanoFluidX  

Solutions > Applications > SPH Flow > Vehicle Wading 

• Supported the Time vs Velocity table as input for the Vehicle Velocity in the Vehicle Wading solution. 

• It is supported only in the “Moving Vehicle Static Road” simulation type. 

SPH Flow Solution > Vehicle Wading > Analysis > Probes 

• Extended the support to create probe particles for custom surfaces in Vehicle Wading solution. 

SPH Flow Solution > Vehicle Wading > Analysis > Porous Media 

• Modified the Porous Region in the Impose Porous for all the SPH solutions. 

• Damping time has been removed. 

Vehicle Wading / Water Management Solution > Analysis > Particles drop down > 1 Click SPH Creation 

• Extended the support to create Inlet/Probe particles in the 1 Click SPH Creation tool.  

• Inlet/Probe particles will be created automatically for the defined custom Inlet/Probe surfaces. 

• This is supported in both Vehicle Wading and Water Management solutions similar to the Drivetrain Oiling solution. 

SPH Flow Solution > Analysis > Particles drop down > 1 Click SPH Creation 

• The custom probe surface was treated as a wall, and it was blocking the fluid particle creation. 

• Now they are ignored in Particles, 1 Click SPH Creation and Baffle tools for particle creation. 

• It is supported in all the SPH solutions.  
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 Abaqus 

Drop Impact Solution > Body Right click > Contact > Define / Modify Contact  

• Abaqus Tie creation for drop analysis can be done through script. Currently recording script is not supported. But user 

can add the following line to the script to create ties. 

 

• Limitations, 

o If the given bodies already have any defined contacts, those bodies are skipped from processing. Always create 

new contact pairs only. 

o Currently scripting is supported only by body-based Ties. 

o Contact creation through script does not consider already excluded pairs. 

Drop Impact Solution > Body Right Click > Drop Test Mesh 

• Mesh size settings for drop test mesh can be defined with a combination of Mesh controls and Drop Test Parameters. 

In SimLab 2023.1, Drop Test Parameter definition is mandatory even if both Mesh controls and Drop Test parameters 

are defined, smallest of the two sizes was used to mesh the part. 

• When drop test parameters are defined for a body which has body mesh control or vice versa, a warning message will 

be posted. 

Solution Right Click > Review > Review Contact – Based on submodel 

• Added support to review the contacts based on sub model structure. 
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 Results 

 Enhancements   

Home > Measure 

• Support added to measure the distance on the deformed model while displaying the results. 

Results > Plot 

• A new curve type “XYZ vs Result Component” has been added for all solutions. 

• Added a minimize button in the plot button to help selecting entities in the UI. 

• Added chevron to hide and show the “X/Y” and “statistics” tabs in the bottom part of the plot window.  

• Added support to plot the results of the vector with respect to time/frequency. 

Entity Selection  

• Entity Selection is supported for the below result types, 

o Derived results 

o Modal animation 

• This enables users to query results and plot curves by picking the entities. 

Results GUI 

• Supported visualization of results for the spring element. 

• Extended support to visualize Rigid body SPC Forces. 

• Linear Buckling Loadcase: Modes are sorted based on frequency values. Default behaviour for other solution type is 
sort based on mode number. Since buckling analysis can have negative eigen values, this sorting helps post 
processing. 

Results > Fatigue Life > Steinberg’s Life Calculator 

• Enhanced to support multiple loading types and overall GRMS for Steinberg equation-based life calculation to 
compute life of the electronic components in a PCB assembly, based on the normal mode results. 

Animation Toolbar > Settings > Animate Contour  

• Extended support for animating the contour of the vector plot for both linear and modal animation for the below 
solutions. 

o OptiStruct 

o Abaqus (Supported only for Reader 1) 

o Flux 
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Results GUI > Node Right Click > Plot Curve   

• Added support to plot the results of the vector with respect to time/frequency using 2D Plot. 

 Resolved Issues 

File > Import > Results > Abaqus  

• Fixed the issue where a few of the result components were missing, and supported layers for the scalar result 
component. 

Results GUI 

• Fixed the issue with contour display when the center node of an RBE element alone has a result value. 

NVH > Frequency Response 

• Fixed interpolation issues for start and end frequency points specified in frequency options for modal damping-based 
vibration. 

 

 Electronics 

 New Feature  

Tools > BGA > Refine BGA 

• Added a new tool to refine the solder mesh on specific locations. 

• Mesh will be updated on the components connected to the solder. 

 

Tools > Chip > 3D IC 

• Added a new tool to stack chiplets, where each chiplet contains one or more blocks or modules. 
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 Enhancement  

Electronics Ribbon    

• Re-organized the ribbon layout for ease of use. 

 

  Chip Underfill Weld   

• Improvements made in Chip Underfill Weld tool to avoid large aspect ratio hex elements. 

• Enhanced the tool to accept multiple body as input and generate underfill in concave corners without intersections. 

 

  Layer Definition 

• Added support to import the layer data of a PCB as a CSV file in the layer definition tool. 

  Component Definition 

• Added support to download detailed component models from Ultra Librarian’s component library and automatically 

position it on the PCB based on their footprint data. 
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  Fill Chip Gap 

• When multiple dies are close to each other, a gap between them needs to be filled to create underfill around the dies. 

Fill Chip Gap tool helps to fill the gap easily. 

• Gaps can be filled completely or for user given height. 

 

 Advanced  

 Electromagnetics  

Simplify Stator  

• Added a tool “Simplify Stator” to simplify the insulator bodies in the stator slots.    

 Weld 

Verity Weld Sets 

• Added a new tool to create weld node and solid element sets for verity solver. 

• Weld definitions for all the welds will be written in a *.def file. 

 

 Automation 

 New Features  

Batch Mode 

• Added an argument to specify the user-defined path to write the script log file. In SimLab 2023.1, the script log file will 
be written in the script folder. 

Batch mode syntax: 

[simlab location] –auto [python script] –scriptlogdir [log file directory] 

 Enhancement  

Sub Model Tag 

• All the Sub Models in the Model will be considered for the operation, if the <SubModel> tag does not have any value in 
the DOM node. 
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