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 Supported CAD 

• ACIS (Up to 2022) 

• Altium (Up to PCAD 2006 and Designer 16.0) 

• AutoCAD (Up to 2022) 

• Cadence Allegro Expansion (from 16.3 to 22.1) 

• CATIA (Up to CATIA V5-6R2022) 

• Creo (Up to 8.0) 

• Inventor (Up to 2022) 

• IPC-2581 (Revision A and B) 

• JT 

• MentorGraphics PADS (from 5.0) 

• MentorGraphics Xpedition 

• NX (Up to NX 2306 series) 

• ODB++  

• Parasolid (35.1.219) 

• SOLIDWORKS (Up to 2022) 

• STEP 

• Zuken CR-8000/CR-5000 (7.0) 

 

 Supported Results Reader 

• Abaqus 

o Reader 1: Up to V2023 

o Reader 2: Up to V2018 

• ANSYS: Up to 2022 R2 

• ADVC: Up to 2019 R2.3 

 

 Solvers 

  Altair Solvers bundled with SimLab 

• OptiStruct: 2023.1 

• AcuSolve: 2023.1 

• Radioss: 2023.1 

• Flux: 2023.1 

• Altair Manufacturing: 2023 

• ElectroFlo: 2023.1 

• nanoFluidX: 2023.1 

• EDEM: 2023.1  
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 System 

 Enhancements   

Licensing: Student Edition 

• Removed the node count limitation for saving and opening the database in Student Edition SimLab version. 

o Previously, the database that has less than 2,00,000 nodes can be opened or saved in Student Edition version.  

• Database that saved in normal SimLab version can be opened in Student Edition SimLab version. Previously, it was 

restricted. 

• User can setup ElectroFlo solution with Student Edition license. Previously it was restricted.  

Preferences: Applications > General > Keyboard shortcuts 

• Added a support to set the user defined shortcut keys for the selection filter. 

 

 Import 

 CAD   

  ECAD  

• Added support to create matching tessellation across the bodies, while using Mesh > 2D Mesh > More Tools > Extract 

Facets. 

 

• Supported the following file types in ECAD import, 

o MentorGraphics PADS 

o Zuken CR-8000/CR-5000 

o MentorGraphics Xpedition 

o Cadence Allegro Expansion 
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• Support added to create the Dielectric board without vias while importing the ECAD model if the “Create Dielectric 

overlapping traces and vias” toggle is turned ON. Only mount holes will be present on the Dielectric board. 

 

 Graphics and Visualization 

 New Feature  

Assembly Browser > Model Right Click > Set Random Color 

• Added an option "Set Random Color" which will update the color of all the bodies in a model. 

 Enhancements 

View Toolbar > Capture Views 

• Redesigned the view creation options and moved it to View Tool Bar from View menu to easy access of options.  

• Enhanced the tool to capture the model orientation and displayed entities details as an image and store it for future 

reference.  

• Also supported to write the *.ppt report for all the saved views and export the view as image.  

Note: Captured views will not be stored in database. As a workaround, record a script while capturing the views and 

execute it back after opening the database again. 

 

Body > Right Click > Unmerge 

• Unmerge operation is now supported for Parasolid sheet bodies. 

Body > Right Click > Edit Associate > Color 

• Support added to edit the color of the selected body from UI right-click. 

• Added script support for changing the body color using this right option.   

Face > Right Click > Edit Associate > Loads and Constraints  

• Added support to edit the excitation load of the faces associated with the enforced constraint. 
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Face > Right Click > Select Adjacent Layers 

• Added “Ignore shared faces” toggle which when enabled skips the shared faces / internal faces, while fetching the 

adjacent faces. 

Note: “Ignore shared faces” toggle is also available in Add/Remove Layers Option. 

Node > Right Click > Select Associated Entities 

• Added support to select the associated Solid/Shell bodies, RBE Bodies and Bar bodies for node input. 

Inspect > Node > By Region > Show Nodes 

• Multiple plane support added for selecting nodes in the specific region.  

 Resolved Issues  

Entities > Right Click > Edit Associate > Loads and Constraints 

• Unable to find the spring attached to the selected nodes and bar pretension load attached to the selected face edges. 
This issue is fixed now. 

   

 Geometry  

 Enhancements  

Chain Edges  

• Support added for defining multiple planes to create topology edges. 

Sweep 

• Added support to create spiral and conical sweep CAD (Parasolid) bodies using Python script. 

Show Instances & Replace Instances  

• Added “Consider identical bodies as instances” option to consider both instances and identical bodies or only instance 

bodies. 
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Boolean > CAD (Parasolid) 

• Merge boundary edges option is supported for CAD Parasolid models imported with "Save geometry in database" 

option.  

 

Simplify Bodies  

• Performance improved significantly for “Simplify bodies identical to input bodies” option for large models.  

  

 Mesh  

 Enhancements  

Mesh Control: Imprint Circle 

• Supported creation of face and edge groups for Imprint circle mesh control on CAD bodies in Surface Mesh.  

Note: These groups will be created only when “Create group from mesh controls when meshing” toggle is turned ON 

in File > Preference > Mesh > Surface Mesh. 

  Quality Check 

• Support added to calculate the angle between element faces (Dihedral Angle) of the Tet element.  

  Quality Check(New) 

• Mesh quality check has been added for the Flux solver. 

• This is especially useful for large models to check mesh compatibility for the solver.  

  Change Mesh Pattern 

• Performance Improvement has been done when Mesh Pattern is modified from Iso Mesh to Union Jack and for Flip 

Orientations in Iso mesh for large models with shared faces between them.  
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  Hex Mesh 

• Added support to consider washer mesh control in below Hex meshing tools.  

o Mesh > 3D Mesh > 2.5D Hex Mesh 

o Mesh > 3D Mesh > Auto Hex for 2.5D Bodies 

o Mesh > 2D Mesh > Mid Mesh 

  Auto Extrude 

• Create ring around circle and slot option is supported. 

• Offset distance will be determined such that outer edge length should be less than or equal to 1.5 times the edge 

length of the circle and slot.  

• The maximum number of layers on the ring will be 2 and it will depend on the edge length of the circle and slot.  

  Auto Sweep 

• Robustness improved to create Hex mesh for more complex models. 

  Cartesian Hex Mesh 

• Previously in SimLab 2023, the user must manually define the key planes before generating Cartesian Hex mesh. Now 

in SimLab 2023.1, key planes need not be created. 

• With the specified value of “Collapse grid lines lesser than” and selected combination of “Preserve faces parallel to” 

check box the planar faces parallel to global XY YZ ZX planes in the input body will be retained in the output mesh. 

  Acoustic Mesh 

• Support to add variable thickness mesh for foam layer and metal layer in acoustic mesh. 

  CFD Mesh 

• Enhanced CFD Mesh tool to generate boundary layers with input CAD bodies.  

Note: Mesh controls applied on the input CAD bodies will not be considered in CFD meshing. 
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 Solutions 

Configure Solution  

• Added a tool to configure the solution. This tool can be used to tailor the solutions displayed in the solution ribbon 

based on customer requirements. 

• If the selected solution is < 10 then the selected solutions will be displayed in the main ribbon and if the selected 

solutions is more than 10 then the solutions will be grouped and listed. 

 

 Analysis 

Create Coordinate System 

• Added support to create feature-based coordinate system for solutions. 

• This coordinate will update its position when the input geometry changes its position. 

 

Manual RBE 

• Added an option to ignore the mid side nodes while creating manual RBEs using faces and edges. 

• RBE created using the “Manual RBE” option will be automatically added to the current solution. 

http://altair.com/


Release Notes / Altair SimLab 2023.1    

 

 

  © Altair Engineering, Inc. All Rights Reserved.  /  altair.com  /   Nasdaq: ALTR   /  Contact Us 

 

 

10 

 Solution Browser  

Solution Boundary Conditions Display 

• Support added to automatically compress all the available BCs if the BC count under the Load case exceeds 100. 

• The user can manually expand the BCs by clicking on the “Compressed BC right-click > Expand All” option. 

Export Solution Specification File  

• Support added to export Solution Specification File using a new approach for Flow and Electronics Thermal solution. 

• This new approach is used only when exporting individual solutions through Solution Right-click > Export Specification 

File. 

 

 Solver Interface  

 OptiStruct   

Modal Frequency Response / Acoustic Solution > Results Right click > Response 

• Supported Acoustic pressure response for Acoustic Solution and Modal Frequency Response solution.  

Modal Transient Solution > Analysis > Loads and Constraints > Load > Pressure 

• The load definition for the modal transient solution is supported as a time function. This improves the solution setup 

workflow.  

Non Linear Transient Solution > Analysis > Loads and Constraints > Initial Condition 

• Initial velocity support is added for non-linear transient solution. Initial velocity is written out in the input file using the 

TIC card.  

Non Linear Transient Solution > Analysis > Loads and Constraints > Pretension  

• Added support to create pretension loads.  

Model Reduction Solution > LoadCase Right Click > LoadCase Settings  

• Supported loadcase definition of model reduction analysis for SIMPACK and motion solve.  

• This can be used to include prestress/preload effects in the super element creation.  

E - Motor Acoustic Solution > MFR LoadCase Right Click > Display / Hide Excitations 

• Added an option to visualize and animate the excitation loads as vectors before running the job. 

• This option is also supported for Modal Frequency Response solution without loadcases.  
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Modal Frequency Response / E - Motor Acoustic Solution > Analysis > Force Computation 

• Support for force computation using MTSkew solutions or FluxSkew projects (.FLU). 

 

Analysis > Loads and Constraints > Constraints > Enforced Acceleration 

• Supported to define enforced acceleration boundary condition for Dynamic Analysis.  

File > Import > Solver Input File  

• Added support to import the below cards in Free Format. 

o Node Card - GRID 

o Element Cards – Tri (CTRIA), Quad (CQUAD), Tet (CTETRA), and Hex (CHEXA). 

o Properties Cards – Shell (PSHELL) and Solid (PSOLID). 

o Material Cards – Structural materials (MAT1), Thermal materials (MAT4), Fluid material (MAT10).  

 AcuSolve  

Solutions > Physics > Flow  

• Two new DES turbulence models namely, Spalart-Allmaras DES and Shear Stress Transport DES are supported for 

transient flow solution.  

• Added support for turbulence transition models for Spalart-Allmaras, Shear Stress Transport, Spalart-Allmaras DES, 

and Shear Stress Transport DES turbulence models. 

Analysis > Boundary conditions > Material 

• Added support for Isentropic density model in fluid materials. 

Analysis > Boundary conditions > Wall 

• Support added to apply convection and applied heat flux boundary condition together. 
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Analysis > Boundary conditions > Advanced > Advanced BC 

• Added support for Mesh X, Y, Z displacement variables. 

• Added support for Mesh Motion when variable is set to Mesh displacement (X, Y, Z). 

• These options enable setting up of advance mesh motion simulations. 

 Battery 

Battery Thermo Electric Solution > Analysis > Battery Pack 

• Support added to set time vs power curve data in the Battery pack definition for Battery Thermo Electric and Thermal 

Runaway solutions.  

Thermal Runaway Solution > Analysis > Thermal Runaway 

• Added mass input type which specifies total mass and volume specific. For volume-specific, it refers to the mass of the 

anode (or cathode, electrolyte, etc.) divided by the jellyroll volume.  

 Flux 

  Electromagnetic Solutions > MT2D solution-based Ribbons 

• When an electromagnetic solution is created, SimLab user interface is customized to that solution. 

• Geometry, mesh, analysis, and results ribbons will be adapted along with some tools like mesh controls. 

• This has been done to streamline workflows and for better user experience. 

  Parasitics Extraction Solution > Settings > Solver settings 

• Added a new option in the solver settings to be able to solve using model order reduction. This option saves a lot of 

calculation time, and a high number of frequency steps can be defined for better interpolation of results within a 

frequency range. 

• Added a new option in Result Request, to compute RLC in case of Impedance computation. This option allows to 

deduce Resistance (R), Inductance (L), and Capacitance (C) values from impedance (Z) value. In case of a frequency 

(f) sweep, the according RLC values are frequency dependent curves and can be seen in the 2DPlot. The computation 

is done as following: 

       
 

Note:  

o When the option “Include Parasitic Capacitance effects” in Solver Settings is not selected, the C values will not 

be computed. 

o Please note that the RLC values computed reflect the user-defined ports configuration. It is essential for the user 

to have a clear understanding of what he/she is going to compute according to the geometric connections of the 

ports. For example, if the user calculates capacitance values for a closed loop of electrical current, the resulting 

values may be inaccurate. Inversely, a computation of inductance values on an open loop can lead to its 

inaccuracy. 
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  Parasitics Extraction Solution (Impedance computation) > Settings > Result Request 

• Added a new result request to compute RLC value from the impedance values (Z) values. 

  MT2D Solution > Skewed Motor 

• MT2D solution dialog has new “domain parameters” to define a skewed motor in the axial direction. 

• Note that using this option will automatically change the solver from Flux2D to FluxSkew. 

o FluxSkew is a 2.5D solver specifically used for skewed eMotors. 

• The solution definition is same as the MT2D solution, but user has access to 3D results. 

• Skew types supported, 

o Step and continuous, 

o Fixed and rotating parts, 

o Continuous or layer by layer definition. 
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  Magnetic Transient 3D Solution > Circuit Designer > Solid Conductor 

• Added a new circuit component to simulate a circuit connected conductor by considering the eddy currents, the 

proximity effect, and the skin effect. 

 

  Magnetic Transient 2D & 3D Solution > Circuit Designer > Solid Conductor 

• Improved the usability by hiding the unsuitable bodies at the selection. 

• In MT3D, added the possibility to select more than one body (already the case in MT2D). 

• In MT3D, added consistency checks between bodies and faces selection.  

  MT2D / MTaxis Solution > CAD based workflow > Mesh Settings 

• In the mesh settings option, for the CAD based workflow, an option has been added to mesh using first order (tri3) or 

second order (tri6) elements. 

• This same option has been added to the general motor mesh tool also. 

  MT2D / MTaxis Solution > Material Transfer  

• For CAD based workflow using mesh settings, material applied on the CAD will now be reflected on the mesh bodies 

also. 

  MT2D Solution > Circuit designer > Auto Circuit Creation  

• Added a new tool that automatically generates the circuit for the given hairpin windings. 
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  Electro magnetics > MT3D & MS3D Workflows > Analysis > Non-Meshed Coils 

• Display coil dimensions in graphics view when editing a non-meshed coil. 

• Display points and their index in graphics view when editing a composed non-meshed coil. 

 

  MT3D Solution > Circuit Designer > N Solid Conductor 

• Added a new Solid Conductor component with N ports. As for the existing Solid Conductor (with 2 ports), it considers 

the eddy currents, the proximity effect, and the skin effect. 

 

  MT3D Solution > MT3D Workflow > Analysis > Cut 

• The Cuts are "artificial" cuts created in 3D on a group of bodies sharing the same physical definition and having 

hole(s). In fact, if hole(s) exist, there is a connectivity issue which cannot be handled correctly during the solving when 

using specific formulations model because of its mathematical constraints. In fact, the results may be wrong. The 

formulations model currently used in Flux3D is the scalar model that uses various magnetic scalar potentials ϕ and the 

electric vector potential T. This formulations model requires the cuts when having connectivity issue. 
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• Added a check to verify if the magnetic circuit or the electric loop contains holes and needs to be cut. The check is 

done through “Check cuts” button and also at solving. 

• Added a new LBC button “Cut” containing the two cut types of buttons to cut the magnetic circuit or the electric loop 

containing holes by selecting manually internal faces. Example of magnetic circuit cut: 

 

  MT3D Solution > Analysis > Motion 

• Added the possibility to define Minimal and Maximal Mechanical Stops. 

  MT2D / MT3D Solution > Settings > Result Request 

• The result request on Switch Square and Diode components are now displayed in 2D plot. 
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  Analysis > Property > Material 

• Temperature dependency is now supported for, 

o Electrical properties 

o Magnetic properties of linear hard magnets & non-linear soft magnets. 

  Results > Plot 

• Added categorization for the result .CSV file from Flux. 

 

• Added the curves of translation or rotation Motion parameters in the 2D plot. 
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  Results > Spatial Plot 

• Added categorization for the result .CSV file from Flux. 

• Support for the spatial plot of a MT2D solution or of a FLU project. 

 

 ElectroFlo 

Solutions > Applications > Electronics > Pressure Drop Analysis 

• Added support for flow pressure drop analysis for electronics as a beta solution. 

Note: Set the Environmental Variable SL_PRESSURE_DROP_ANALYSIS = TRUE, to enable the solution. 

 

Analysis > Smart Objects > PCB 

• Combine multiple MCAD. 

• Advanced merging of ECAD-MCAD. 

• PCB trace mapping as smart object. 

• Via support in trace mapping. 

• Via connectivity. 
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Analysis > Smart Objects > Liquid Cooling 

• Added support for multiple liquid cooling entities. 

• Added outlet temperature in liquid cooling report. 

Analysis > Smart Objects > Thermo Electric Cooler 

• Added support for multiple TEC entities. 

Other new features: 

• Improved geometry discretization: reduced discretization time by half. 

• Improved analysis meshing: reduced element count and improved mesh smoothness. 

• MPI scalability improved: increased maximum number of CPUs from 4 to 16. 

• Remote solve on Linux solvers. 

• Automated report for all variable BCs. 

• CFD solver: 

o Fractional first time-step. 

o Faster solver and turbulence modeling. 

o Independent handling of air and liquid regions. 

o Improved CFD convergence and larger time steps (up to 100 times for long transient simulations). 

o Better handling of models with large BCs. 

• Post-processing: 

o Streamline support. 

• Improved quantitative reports (8 new parameters, more accurate integration). 

Solution Browser > Results > Response 

• Added support to create temperature response for ElectroFlo results. 

 nanoFluidX  

Solutions > Settings > Format and Execute Options 

• Supported the export of particle file type as binary format. 

• nanoFluidX will automatically detect the file type and read the content accordingly. 
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 Abaqus 

Drop Impact Solution > Assembly Browser > Model Right Click > Link Mesh by  

• If the CAD and mesh model has the same sub model name with a different hierarchy, then the link creates sub-models 

with unique names for each body. Now, the mesh sub-model name is maintained. 

Drop Impact Solution > Assembly Browser > Model / Sub Model Right Click > Link Mesh by > Matching Location 

• New Option “Retain Existing Mesh” added to choose where existing FE body to be retained or meshed from new CAD. 

• Sorting supported based on absolute values of the volume difference. 

Drop Impact Solution > Assembly Browser > Model Right Click > Select Linked Bodies to Remesh 

• An option “Select Linked Bodies to Remesh” is added to select bodies that are linked but “Retain Existing Mesh” toggle 

was turned OFF while establishing link. 

Drop Impact Solution > Assembly Browser > Model Right Click > Review Linked Bodies 

• New Option “Review Linked Bodies” is added to review and update the linked body pairs.  

  Drop Impact Solution > Assembly Browser > Model Right Click > Select Bodies with No Attributes > Link   

• Link option is added under Select Bodies with No Attributes selection. 

• This option helps to select the bodies which are not linked, and user can either manually link with existing FE body or 

set drop test parameters to mesh them.  

Analysis > Loads and Constraints > Constraints > Enforced Acceleration 

• Supported to define enforced acceleration boundary condition for Dynamic Analysis.  

  Analysis > Tools > Sets 

• Membrane section will be grouped along with the solid and shell sections for sets defined using bodies while exporting 

Abaqus solver input file. 

 OpenFOAM 

Solution > Physics > Flow  

• Added OpenFOAM solver support for setting up Flow solutions. 

• Steady state and transient solutions are supported. 

• Spalart-Allmaras turbulence model is supported. 

Solution Settings   

• Essential OpenFOAM Solver Settings, Result Request, and Format and Execute Options are supported. 
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Analysis > Boundary Conditions  

• Inlet, Outlet, Wall, Slip and Symmetry type boundary conditions, and material definitions are supported for OpenFOAM 

Flow solutions. 

• Mass Flow Rate, Average Velocity and Volumetric Flow Rate Type Inlet boundary conditions. 

Post  

• Support added to postprocess OpenFOAM simulation results in VTK format. 

• OpenFOAM results files can now be loaded in 2 different ways: 

o In a new session, using File > Import, 

o Attach Results to the existing solution. 

• Only supported in the Flow Post-processing mode. 

 

 Results 

 New Feature  

  Results GUI > Right Click > Notes  

• Added support to create notes for solutions with *.h3d and *.log results. 
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 Enhancements   

Results > Plot 

• Redesigned the Plot tool to enhance the usability. 

• By default, it will open a new empty plot window. Clicking on + icon will open the Create Curve dialog to create new 

curves to the plot. 

 

• Curves tab is supported to list and to show / hide the created curves in the plot.  
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• Double click on curves will open the Modify Curve dialog to modify the selected curve. 

 

• Right click support is available to export and delete the curves. 

 

• “X / Y Data” and “Statistics” tables supported for complex plots. 

• Data and statistics are given for both magnitude and phase curves. 
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NVH > Order Response 

• Loadcases used to plot the waterfall diagram must be selected with the “Loadcase Identification” tool. 

• This tool lists all Modal / Direct Frequency response loadcases contained in the displayed solution. 

• For each loadcase “RPM” and “Group” information need to be specified. 

 

• Loadcases extracted from the Flux solver using the “Force Computation” tool are automatically identified by the 
“Loadcase Identification tool”. “RPM” and “Groups” do not need to be specified by the user. 

 

• All modifications done by the user can be reset by clicking the “Reset” button. 

• All modifications done by the user are retained when the “Loadcase Identification” tool is closed. 

• However, all modifications are lost when the “Order Response” window is closed. 

http://altair.com/


Release Notes / Altair SimLab 2023.1    

 

 

  © Altair Engineering, Inc. All Rights Reserved.  /  altair.com  /   Nasdaq: ALTR   /  Contact Us 

 

 

25 

Solution Browser > Display Settings > Right Click > Modify   

• Added support to modify the saved displays. 

Solution Browser > Display Settings & Scenes   

• Added support to preserve “Display Settings” and “Scenes” upon result updation. 

  Results Browser > Flow Post-processing mode  

• Export the state file as a script containing the operations performed in the post-processing window. 

• Import the saved state file for post-processing automatically for different results. 

  File > Preferences > Plot Settings   

• Added script support for Plot setting options in Preferences. 

  File > Preferences > Results > Display > Vector Display  

• Provided various options under preferences to visualize the vectors in post processing. 

• This option allows for 3D visualization of the vectors. 

  Results Import 

• Added support to import the Super Elements.  

 Resolved Issues  

Solution > Results > Scenes 

• Fixed the issue on enabling the scenes title and legend on opening database with scenes. 

 

 Electronics 

 New Feature  

  Tools > Chip Underfill Weld   

• Added new tool to create underfill extension(weld) between PCB and die bodies. 

 Enhancement  

  Layer Definition 

• Added a support to compute the density of the equivalent homogeneous material based on the user-defined target 

mass. 
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  Advanced BGA  

• Enhancements are made to the Advanced BGA tool to support creating different types of BGAs on user-defined solder 

locations along with the package and the board.  

• The database file should contain the reference mesh for the different BGA types, and the CSV file should contain the 

solder location and the corresponding BGA type. 

 

  Import Custom BGA  

• This tool imports BGAs generated using Surface Evolver program. Users can input *. output or *.stl files.  

• Turning on the ‘Auto Hex Mesh’ toggle will hex mesh the imported BGA models. 

 

 

 Advanced  

 IC Meshing  

Volume Decompose  

• Volume Decompose is supported to create output as Parasolid bodies for CAD Parasolid models imported with the 

"Save geometry in database" option.   
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 Trials 

Create Battery Module  

• Automatic busbar creation is supported for rectangular layout type. 

• Properties for busbar is also created with the given thickness and copper as material.  

• Default materials and properties will be auto assigned to all the components of the battery module. 

 

 Electromagnetics  

Simplify Rotor  

• Added a tool to extract the air region within the rotor parts by simplifying the magnets and shaft region.   
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Create Stator and Rotor Air  

• Added a new tool to extract the fixed and rotating air regions between the stator and rotor bodies. Also, it supports 

the generation of the sliding bodies at the rotor ends.  

 

 

 DOE 

 Enhancements  

DOE Solutions > Results > Right Click > Display > DOE Result: DOE 

• Added support to open multiple databases from the DOE table.  

  Solutions > Advanced > DOE > Using Script 

• Added support to create DOE solutions in the same database. Previously, DOE solution will be created in a new 
database. 

  Solutions > Advanced > DOE > Using Solution  

• Added superimpose plotting support for Electromagnetics solution DOE, which allows the users to visualize the 
behavior of the transient variables over time and how a particular design variable is affecting the transient behavior. 

 

 Automation 

 New Features  

  Utility function 

• Added a utility function ‘stopExecutionOnError’ to halt the script execution before it reaches its end when any 
command fails in between. 

Python syntax: 

simlab.stopExecutionOnError() 
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