OS-T:4040 シュレッダーの寸法最適化

本チュートリアルでは、シェル要素とバー要素から成るモデルについて、寸法最適化を行います。バー要素の特性を解析するためにPBARL特性を更新し、それを設計変数にリンクします。結果の設計は、より高い振動数と更新された要素特性を有するものになります。

開始する前に、このチュートリアルで使用するファイルを作業ディレクトリにコピーします。

寸法最適化は、1次元要素または2次元要素の特性変更を含みます。これらの特性には、面積、1次元要素の慣性モーメント、および2次元要素の板厚が含まれます。寸法最適化は、材料の削除、ビードの生成または構造物の形状変更が必要ない場合に行います。

寸法最適化では、必要とされる目的に見合うよう要素の断面特性を変更します。特性は、DVPRELカードを用いて設計変数(DESVAR)にリンクされます。

本チュートリアルは、OptiStructユーザープロファイル下のOptiStructマクロを使った最適化問題の設定を示します。
1. シュレッダーの有限要素モデル

4040_fe_model_shredder
最適化問題の設定は次の通りです:
目標
全体質量の最小化
制約条件
横モードは6 Hz以上
設計変数
ビーム幅、ビーム板厚、ビームの深さ、およびシェル厚

HyperMeshの起動とOptiStructユーザープロファイルの設定

  1. HyperMeshを起動します。
    User Profilesダイアログが現れます。
  2. OptiStructを選択し、OKをクリックします。
    これで、ユーザープロファイルが読み込まれます。ユーザープロファイルには、適切なテンプレート、マクロメニュー、インポートリーダーが含まれており、OptiStructモデルの生成に関連したもののみにHyperMeshの機能を絞っています。

モデルの読み込み

  1. File > Import > Solver Deckをクリックします。
    Importタブがタブメニューに追加されます。
  2. File typeにOptiStructを選択します。
  3. Filesアイコンfiles_panelを選択します。
    Select OptiStruct Fileブラウザが開きます。
  4. 自身の作業ディレクトリに保存したshredder.femファイルを選択します。
  5. Openをクリックします。
  6. Import、続いてCloseをクリックし、Importタブを閉じます。

有限要素解析の実行と結果のチェック

ジョブのサブミット

  1. AnalysisページからOptiStructパネルをクリックします。
    2. OptiStructパネルへのアクセス

    OS_1000_13_17
  2. save asをクリックします。
  3. Save Asダイアログで、OptiStructモデルファイルを書き出す場所を指定し、ファイル名としてshredder_analysisと入力します。
    OptiStruct入力ファイルには、拡張子 .femが推奨されます。
  4. Saveをクリックします。
    入力ファイル欄には、Save Asダイアログで指定されたファイル名と場所が表示されます。
  5. export optionsのトグルをallにセットします。
  6. run optionsのトグルをanalysisにセットします。
  7. memory optionsのトグルはmemory defaultにセットします。
  8. OptiStructをクリックし、OptiStructジョブを開始します。
ジョブが成功した場合、shredder_analysis.femが書き出されたディレクトリに新しい結果ファイルがあるはずです。何らかのエラーがある場合、shredder_analysis.outファイルはデバッグを手助けするエラーメッセージを探すのに良い場所です。

固有モードの表示

  1. OptiStructパネルから、HyperViewをクリックします。
    HyperViewHyperMesh Desktop内で起動し、新しいページとセッションファイルshredder_analysis.mvwが読み込まれます。このファイルは、モデルと結果を含むshredder_analysis.h3dファイルとリンクされています。
  2. Animationツールバーで、アニメーションタイプをanimationModal-24(Modal)に設定します。
  3. ResultsツールバーでresultsDeformed-24をクリックし、Deformedパネルを開きます。
  4. 変形形状設定を定義します。
    1. Result typeをEigen Mode(v)に設定します。
    2. ScaleをModel Unitsにセットします。
    3. TypeをUniformにセットします。
    4. Value欄に1000と入力します。

    これは最大変位がモデルの1000単位となることを意味し、他の変位はそれに比例します。

    1.0より大きいスケールファクターを使用すると変形は拡大し、1.0より小さい場合は縮小します。この場合、すべての方向の変位を強調させます。

  5. 変形形状設定を定義します。
    1. ShowをEdgesに設定します。
    2. ColorをMeshに設定します。
  6. Applyをクリックします。
  7. Results Browserでシミュレーションのリストから、Mode 1を選択します。
    3.

    os_4040_mode1
  8. ResultsツールバーでresultsContour-24をクリックし、Contour panelを開きます。
  9. Applyをクリックします。
    Eigen Modeコンターが表示されます。
  10. Page Controlsツールバーで、ページレイアウトをpageLayout4-24に設定します。
    4.

    os_4040_4windows
  11. 1つ目のウィンドウをクリックし、menu barからEdit > Copy > Windowをクリックします。
  12. 2つ目のウィンドウをクリックし、続いてmenu barからEdit > Paste > Windowをクリックします。
  13. 1つ目のウィンドウを3つ目と4つ目のウィンドウにコピーします。
    5. 全ウィンドウ上の最初のモードのコンター

    os_404_4windows2
  14. ウィンドウをクリックしてアクティブにし、Results Browserでモードを選択することによって、ウィンドウに割り当てられているモードを変更します。
    • 2つ目のウィンドウをMode 2にセットします。
    • 3つ目のウィンドウをMode 3にセットします。
    • 4つ目のウィンドウをMode 4にセットします。
    6.

    os_4040_assign_entities
    7. 最初の4つの固有モードのコンタープロット

    os_4040_modes
  15. AnimationツールバーでanimationStart-24をクリックし、アニメーションを開始します。再度クリックし、アニメーションを停止します。
    3次および4次モード(~ 3.9および~ 4.8 Hz)は、加振された際にシュレッダーのパフォーマンスを落とし得る横形を有しています。目的は、7Hz以上で最小の質量を得ることです。
  16. menu barFile > Save As > Report Templateをクリックします。
  17. Save Report Asダイアログで作業ディレクトリに移動し、ファイルをreport.tplとして保存します。
    8.

    4040_save_session_file
  18. アプリケーションの上部右側でpagePrevious-24pageNext-24をクリックし、最初のページ上のHyperMeshクライアントに戻ります。

最適化のセットアップ

設計変数の定義

本演習における設計変数はカバーの板厚、バーの幅、板厚と深さです。1つ目の設計変数をSizeパネルを使って定義します。
  1. Analysisページからパネルoptimizationをクリックします。
  2. sizeパネルをクリックします。
  3. desvarサブパネルを選択します。
  4. 設計変数coverthckを作成します。
    1. desvar=欄にcoverthckと入力します。
    2. initial value =欄に3.0と入力します。
    3. lower bound欄に1.0と入力します。
    4. upper bound欄に6.0と入力します。
    5. move limitのトグルはmove limit defaultにセットします。
    6. 離散設計変数(ddval)のトグルをno ddvalにセットします。
    7. createをクリックします。
  5. さらに4つの設計変数を作成します。
    設計変数 Initial Value Lower Bound Upper Bound
    Beamwide 50 30 90
    Beamhigh 100 80 125
    Beamthck1 10 5 15
    Beamthck2 20 15 30
  6. generic relationshipサブパネルを選択します。
  7. 設計変数とプロパティの関係coverthckを作成します。
    1. name =欄にcoverthckと入力します。
    2. C0欄に0.0と入力します。
    3. プロパティセレクターを使って、coverを選択します。
    4. プロパティセレクターの下で、Thickness Tを選択します。
    5. designvarsをクリックし、coverthckを選択し、returnをクリックします。
    6. createをクリックします。
次の手順では、ビーム寸法についてプロパティの関連付けを定義Cビームの各寸法が設計変数として定義されます。
9.

4040_type_chan
1. 初期設計の特性値
名称 Represents
DIMs(1) Beam Width 50
DIMs(2) Beam High 100
DIMs(3) Beam Thck1 10
DIMs(4) Beam Thck2 20
  1. 設計変数とプロパティの関係DIM1を作成します。
    1. name =欄にDIM1と入力します。
    2. C0欄に0.0と入力します。
    3. プロパティセレクターを使って、frame2を選択します。
    4. プロパティセレクターの下で、Dimension 1を選択します。
    5. designvarsをクリックし、Beamwideを選択し、returnをクリックします。
    6. createをクリックします。
  2. 設計変数とプロパティの関係DIM2を作成します。
    1. name =欄にDIM2と入力します。
    2. C0欄に0.0と入力します。
    3. プロパティセレクターを使って、frame2を選択します。
    4. プロパティセレクターの下で、Dimension 2を選択します。
    5. designvarsをクリックし、Beamhighを選択し、returnをクリックします。
    6. createをクリックします。
  3. 設計変数とプロパティの関係DIM3を作成します。
    1. name =欄にDIM3と入力します。
    2. C0欄に0.0と入力します。
    3. プロパティセレクターを使って、frame2を選択します。
    4. プロパティセレクターの下で、Dimension 3を選択します。
    5. designvarsをクリックし、Beamthck1を選択し、returnをクリックします。
    6. createをクリックします。
  4. 設計変数とプロパティの関係DIM4を作成します。
    1. name =欄にDIM4と入力します。
    2. C0欄に0.0と入力します。
    3. プロパティセレクターを使って、frame2を選択します。
    4. プロパティセレクターの下で、Dimension 4を選択します。
    5. designvarsをクリックし、Beamthck2を選択し、returnをクリックします。
    6. createをクリックします。
  5. returnをクリックし、Optimization panelに戻ります。

Create Optimization Responses

  1. From the Analysis page, click optimization.
  2. Click Responses.
  3. Create the mass response, which is defined for the total volume of the model.
    1. In the responses= field, enter mass.
    2. Below response type, select mass.
    3. Set regional selection to total and no regionid.
    4. Click create.
  4. Create the frequency response.
    1. In the responses= field, enter f3.
    2. Below response type, select frequency.
    3. For Mode Number, enter 3.
    4. Click create.
    A response, f3, is defined for the frequency of the third mode extracted.
  5. Create another frequency response, named f4, for mode 4.
  6. Click return to go back to the Optimization panel.

拘束の定義

  1. dconstraintsパネルをクリックします。
  2. 制約条件c_f3を作成します。
    1. constraints=欄にc_f3と入力します。
    2. lower boundの横のボックスにチェックマークを入れ、6.0と入力します。
    3. response =をクリックしf3を選択します。
    4. 荷重ステップセレクターを使って、を選択します。
    5. createをクリックします。
  3. 制約条件c_f4を作成します。
    1. constraints=欄にc_f4と入力します。
    2. lower boundの横のボックスにチェックマークを入れ、6.0と入力します。
    3. response =をクリックしf4を選択します。
    4. 荷重ステップセレクターを使って、を選択します。
    5. createをクリックします。
  4. returnをクリックしてパネルを終了します。

Define the Objective Function

  1. Click the objective panel.
  2. Verify that min is selected.
  3. Click response and select mass.
  4. Click create.
  5. Click return twice to exit the Optimization panel.

データベースの保存

  1. menu barFile > Save As > Modelをクリックします。
  2. Save Asダイアログでファイル名欄にshredder_optimization.hmと入力し、自身の作業ディレクトリに保存します。

Run the Optimization

  1. From the Analysis page, click OptiStruct.
  2. Click save as.
  3. In the Save As dialog, specify location to write the OptiStruct model file and enter shredder_optimization for filename.
    For OptiStruct input decks, .fem is the recommended extension.
  4. Click Save.
    The input file field displays the filename and location specified in the Save As dialog.
  5. Set the export options toggle to all.
  6. Set the run options toggle to optimization.
  7. Set the memory options toggle to memory default.
  8. Click OptiStruct to run the optimization.
    The following message appears in the window at the completion of the job:
    OPTIMIZATION HAS CONVERGED.
    FEASIBLE DESIGN (ALL CONSTRAINTS SATISFIED).
    OptiStruct also reports error messages if any exist. The file shredder_optimization.out can be opened in a text editor to find details regarding any errors. This file is written to the same directory as the .fem file.
  9. Click Close.

結果の表示

  1. OptiStructパネルから、HyperViewをクリックします。
    HyperMesh DesktopでHyperViewが起動され、結果が読み込まれます。
  2. アプリケーションの上部右側でpagePrevious-24pageNext-24をクリックし、Design Historyページに進みます。
  3. Results Browserから、最終反復計算を選択します。
    10.

    os4040_iteration
  4. ResultsツールバーでresultsContour-24をクリックし、Contour panelを開きます。
  5. Result typeをElement Thicknesses (s)およびThicknessに設定します。
  6. Applyをクリックします。
    結果の色は、適用されている荷重および境界条件から得られた変位の状態を示しています。カバーコンポーネントの最終の最適板厚は1.0です。
  7. 任意のテキストエディタでshredder_optimization.propファイルを開き、最終の最適PBAR特性を確認します。
    11.

    4040_pbarl
    最終的な寸法は次のとおり(小数点以下切捨て):
    Beam Wide (DIM1):
    70.10
    Beam High (DIM2)
    125
    Beam Thck (DIM3)
    5
    Beam wide (DIM4)
    15
    この.propファイルは、上書きモードでHyperMeshに読み込むことができ、PBARLカードは更新されます。