OS-T:6030 シーム溶接疲労解析、S-N法

開始する前に、このチュートリアルで使用するファイルを作業ディレクトリにコピーします。

この手法は、薄いメタルシートに適用可能なホットスポット応力アプローチです。ホットスポット応力は溶接線における節点力から計算されます。この方式は、1.0~3.0mmのシート厚に対し、ラボでのテスト結果と十分な一致を示しています。通常、この方式では、2つのS-N曲線が必要です。1つは曲げ応力による曲げS-N曲線で、もう1つは面内応力による面内S-N曲線です。

本チュートリアルでフレームには、縦方向の曲げに加え、前方および後方ねじり荷重がかかっています。シーム溶接は、フレームを形成するセクション間にモデル化されています。本演習は、シーム(フィレット)溶接位置で生じる損傷を計算するために行われます。
1. 自動車のフレーム


HyperMeshの起動とOptiStructユーザープロファイルの設定

本演習に使用されるモデルは、OS-T:6030 シーム溶接疲労解析、S-N法に示すような自動車のフレームのモデルです。入力ファイルには、フレームが受ける3つの静的荷重ステップFrontal torsion、Rear torsionおよびVertical bendingです。

  1. HyperMeshを起動します。
    User Profilesダイアログが現れます。
  2. OptiStructを選択し、OKをクリックします。
    これで、ユーザープロファイルが読み込まれます。ユーザープロファイルには、適切なテンプレート、マクロメニュー、インポートリーダーが含まれており、OptiStructモデルの生成に関連したもののみにHyperMeshの機能を絞っています。
  3. Tools > Fatigue Process > Create Newをクリックします。
  4. New Sessionで、作業ディレクトリフォルダーに名称を入力します。
  5. Createをクリックします。
    これで、現在ロードされている疲労プロセステンプレートの内容を保存するための新しいファイルが生成されます。

モデルの読み込み

  1. File > Import > Solver Deckをクリックします。
    Importタブがタブメニューに追加されます。
  2. File typeにOptiStructを選択します。
  3. Filesアイコンfiles_panelを選択します。
    Select OptiStruct Fileブラウザが開きます。
  4. 自身の作業ディレクトリに保存したSeamWeld_frame.femファイルを選択します。
  5. Openをクリックします。
  6. Import、続いてCloseをクリックし、Importタブを閉じます。
    疲労解析のセットアップの大筋は、以下のステップで得られます。
    2. 疲労のセットアップ - フィレットシーム溶接


モデルのセットアップ

Define TABFAT Load Collector

The first step in defining the loading sequence is to define the TABFAT curves. This represents the loading history.
  1. Make sure the Utility menu is selected in the View menu. Click View > Browsers > HyperMesh > Utility.
  2. Click on the Utility menu beside the Model tab in the browser. In the Tools section, click on TABLE Create.
  3. Set Options to Import table.
  4. Set Tables to TABFAT.
  5. Click Next.
  6. Browse for the loading file.
  7. In the Open the XY Data File dialog box, set the Files of type filter to CSV (*.csv).
  8. Open the load1.csv file you saved to your working directory.
  9. Create New Table with Name LH1.
  10. Click Apply to save the table.
    The curve LH1 with TABFAT card image is created.
  11. Browse for a second loading file load2.csv.
  12. Create New Table with Name LH2.
  13. Click Apply to save the table.
    The load collector table2 with TABFAT card image is created.
  14. Tables LH1 and LH2 can be edited/reviewed from Utility tab > TABLE Create > Create/Edit Table > TABFAT > Edit Existing Table.
  15. Exit from the Import TABFAT window.
    Tables appear under Load Collector in the Model Browser.
    注: A file in DAC format can very easily be imported in HyperGraph and converted to CSV format to be read in HyperMesh.

Define FATLOAD Load Collector

Create a fatload each for the loadcases present.

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter Fatload_Front.
  3. For Card Image, select FATLOAD.
  4. For TID(table ID), select LH1 from the list of curves.
  5. For LCID (load case ID), select Front Torsional Stiffness from the list of load steps.
  6. Set LDM (load magnitude) to 0.1.
  7. Set Scale to 0.6.
  8. Repeat the process to create 2 additional load collectors with FATLOAD cards named:

    Fatload_Rear with LCID as Rear Torsional Stiffness and TID as LH2

    Fatload_Vertical with LCID as Vertical Bending Stiffness and TID as LH2

  9. Set LDM to 0.1 and Scale to 0.6.

Define FATEVNT Load Collector

Create an event to assign the fatloads created.

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter Event1.
  3. For Card Image, select FATEVNT.
  4. For FATEVNT_NUM_FLOAD, enter 1.
  5. Set the FLOAD load collector to FATLOAD_Front.
    3. Event Card Containing the 3 Fatloads


  6. Similarly create Event2 by setting FATEVNT_NUM_FLOAD to 2 with the remaining FATLOADS, Fatload_Rear and Fatload_Vertical.
    4. Event Card Containing the 3 Fatloads


Define FATSEQ Load Collector

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter FATSEQ.
  3. For Card Image, select FATSEQ.
  4. For FATSEQ_NUM enter 2, as 2 FATEVENTs have been created.
  5. For FID (Fatigue Event Definition), select Event1 and Event2 .
    Defining the sequence of events for the fatigue analysis is completed. The Fatigue parameters are defined next.

Define Fatigue Parameters

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter fatparam.
  3. For Card Image, select FATPARM.
  4. Verify TYPE is set to SN.
  5. Set STRESS COMBINE to SGVON (Signed von Mises).
  6. Set STRESS CORRECTION to GERBER.
  7. Set STRESSU to MPA (Stress Units).
  8. Set RAINFLOW RTYPE to LOAD.
  9. Set GATEREL to 0.0.
  10. Set CERTNTY SURVCERT to 0.5.
  11. Check the box beside SMWLD and select the following options:

    METHOD = VOLVO

    Mean Stress Connection = FKM

    SURVCERT = 1e-9

    THCKCORR = YES

  12. Click Apply.
    This saves the current definitions and guides you to the next task Elements and Materials of the Fatigue Analysis tree. For details, refer to the Altair HyperWorks 2024 help.

Define Fatigue Material Properties

The material curve for the fatigue analysis can be defined on the MAT1 card.

  1. In the Model Browser, click on the Steel material.
    The Entity Editor opens.
  2. In the Entity Editor, check the box besides MATFAT.
  3. Set UNIT as MPA from the list.
  4. Set UTS (ultimate tensile stress) to 600.
  5. Check the box besides SMWLD and set STRUCTURAL SN CURVE as User Defined.
  6. For the SN-based Seam Weld Fatigue properites, set:
    SRI1_SM1
    1203.0
    B1_SM1
    -0.133
    NC1_SM1
    1e6
    B2_SM1
    -0.108
    SE_SM1
    1
    SRI1_SM2
    803.0
    B1_SM2
    -0.15
    NC1_SM2
    1e6
    B2_SM2
    -0.11
    SE_SM2
    2.0

    2-point slope curves are added for both the bending SN and the membrane SN (Here 1 = bending, membrane), 1-point slope can also be added.

Define PFATSMW Property

BRATIO helps understand if the Bending Moments or if the Membrane Forces dominates the maximum stresses based on which the interpolated SN curve is created.

Similarly, TREF and TREF_N help in accounting for thickness correction

  1. In the Model Browser, right-click and select Create > Property.
  2. For Name, enter PFATSMW_7.
  3. For Card Image, select PFATSMW.
  4. Set BRATIO to 0.6.
  5. Set TREF to 1.1.
  6. Set TREF_N to 0.1.
  7. Click Close.

Define FATSEAM Load Collector

FATSEAM helps to select the seam weld type.

In this case it is the fillet weld.

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter FATSEAM.
  3. For Card Image, select FATSEAM.
  4. Set WTYPE to FILLET.
  5. Set NUM_FATSEAM_PSHELL_PIDS to 1.
  6. Click <Unspecified> field next to PID and select property1 for PID.
    property1 is the property ID of the seam weld component.
    5.


  7. Click Close.
    This saves the current definitions and guides you to the next task Load-Time History of the Fatigue Analysis tree.

Define FATDEF Load Collector

  1. In the Model Browser, right-click and select Create > Load Collector.
  2. For Name, enter FATDEF1.
  3. Set the Card Image to FATDEF.
  4. Activate FATSEAM in the PTYPE Entity Editor.
  5. For FATDEF_FATSEAM_NUMIDS, enter 1.
  6. Select FatSeam for FATSEAMID and PFATSMW_7 for PFATSMWID.
  7. Click Close.

Define the Fatigue Load Step

  1. In the Model Browser, right-click and select Create > Load Step.
  2. For Name, enter Fatigue_3LCs_SeamWeld.
  3. Set the Analysis type to fatigue.
  4. For FATDEF, select fatdef.
  5. For FATPARM, select fatparam.
  6. For FATSEQ, select fatseq.

ジョブのサブミット

  1. Analysisページからパネルに入ります。
  2. input file欄に続くsave asをクリックします。
    Save Asダイアログが開きます。
  3. File nameに名称Automotive-Frame-SeamWeld-fillet.femを入力します。
  4. Saveをクリックします。
  5. OptiStructをクリックし、解析をサブミットします。

結果の確認

  1. OptiStructパネルから、HyperViewをクリックします。
    HyperViewが起動され、結果が読み込まれます。HyperViewにモデルと結果が正しく読み込まれたことを示すメッセージウィンドウが現われます。
  2. Resultsタブに移動します。
  3. Resultsタブで、サブケースフィールドから を選択します。
  4. ResultsツールバーでresultsContour-16をクリックし、Contour panelを開きます。
  5. Result typeをにセットし、Applyをクリックして要素コンターを表示させます。
  6. Result typeにToe/Root/Throat(s)を、サブのResult TypeにToeをセットします。
  7. Applyをクリックします。

    コンター表示された要素は、対応するSeam要素についてのToe要素です。

  8. 同様にToeRootの間で切り替え、対応する要素群をハイライト表示させます。

    ToeとRootは、フィレット溶接について考慮される評価位置です。