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Technical Support
Altair's support resources include engaging learning materials, vibrant community forums, intuitive
online help resources, how-to guides, and a user-friendly support portal.

Visit Customer Support to learn more about our support offerings.

https://altair.com/customer-support
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Creating a Rectangular Horn 1

1 Creating a Rectangular Horn

The example is intended for users with no or little experience with CADFEKO. It makes use of a
completed rectangular horn model to familiarise yourself with model creation in CADFEKO and viewing
the simulated results in POSTFEKO.

This chapter covers the following:

• 1.1 Example Overview  (p. 14)

• 1.2 Topics Discussed in this Example  (p. 15)

• 1.3 Example Prerequisites  (p. 16)

• 1.4 Feko Components and Workflow  (p. 17)

• 1.5 Introduction to CADFEKO  (p. 18)

• 1.6 Introduction to POSTFEKO  (p. 33)
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1.1 Example Overview
This example shows a completed rectangular horn model to familiarise yourself with the Feko
components and workflow. The main elements and terminology in the CADFEKO and POSTFEKO
graphical user interface are discussed.

Figure 1: Illustration of the horn antenna.

Tip:  Watch the demo video before working through this example. The model in the demo
video is similar to the horn model used in this example.

Find the short demo video in the Altair installation directory, for example:

Altair/2025.1/help/feko/videos/DemoExample.mp4 for Windows and

Altair/2025.1/help/feko/videos/DemoExample.html for Linux.
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1.2 Topics Discussed in this Example
Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

• View the Feko general workflow.

• Launch CADFEKO.

• View the CADFEKO layout.

• View the POSTFEKO layout.

• View the far field results and near field results in POSTFEKO.

Note:  Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the application macro library[3]:

GS 1: Rectangular Horn Antenna

3. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.
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1.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1 or later should be installed.

• It is recommended that you watch the demo video before attempting this example.

• This example should not take longer than 30 minutes to complete.

Note:  When using CADFEKO over a remote desktop connection, you may need to enable 3D

support for remote desktop[4] for the host's graphics card should a crash occur when clicking
New Project in CADFEKO.

4. See the Troubleshooting section in the Appendix of the Feko User Guide for more details.
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1.4 Feko Components and Workflow
View the typical workflow when working with the Feko components.

Create new

Add / view results

Post-processing of
results / scripng

Export results /
generate report

Set soluon sengs

Use CADFEKO Use POSTFEKO

graph / display

Run Feko Solver
or add component

from
component library

Create / modify
geometry

sources and requests
Define frequency,

CADFEKO
Create or modify the geometry (or model mesh) in CADFEKO, import geometry or mesh, or use a
component from the component library. Apply solution settings, define the frequency, specify the
required sources and request calculations.

When the frequency is specified or local mesh settings are applied, the automatic mesh algorithm
calculates and creates the mesh to obtain a discretised representation of the geometry or model mesh.

View the status of the model in the Notification centre[5]. If any warnings or errors are given, correct
the model before running the Solver.

Solver
Run the Solver to calculate the specified output requests.

POSTFEKO
Create a new graph or 3D view and add results of the requested calculations on a graph or 3D view.
Results from graphs can be exported to data files or images for reporting or external post-processing.
Reports can be created that export all the images to a single document or a custom report can be
created by configuring a report template.

After viewing the results, it is often required to modify the model again in CADFEKO and then repeat the
process until the design is complete.

5. Notification centre is the panel to the right of the 3D view under Model Status.
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1.5 Introduction to CADFEKO
Use CADFEKO to configure a solver-ready input file for Solver simulations.

CADFEKO is the Feko component that allows you to create complex CAD geometry using primitive
structures (for example, cuboids and polygons) and to perform Boolean operations (for example,
union and subtract) on the geometry. Complex geometry models and mesh models can be imported or
exported in a wide range of industry standard formats. Reduce development time by using a component
from the list of antennas and platforms in the component library.

In CADFEKO, you can request multiple solution configurations, specify calculation requests as well as
specify the solution settings for the model. If an optimisation search is required, you can specify the
optimisation parameters and goals.
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1.5.1 Launching CADFEKO (Windows)
There are several options available to launch CADFEKO in Microsoft Windows.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

Figure 2: The Launcher utility.

• Open CADFEKO by double-clicking on a .cfx[6] file.

• Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

Note:  If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

1.5.2 Launching CADFEKO (Linux)
There are several options available to launch CADFEKO in Linux.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

• Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:

/home/user/2025.1/altair/feko/bin/cadfeko

• Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

. /home/user/2025.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

6. A .cfx file is created by CADFEKO and contains the meshed and/or unmeshed CADFEKO model as
well as the calculation requests.
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Note:  Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.

1.5.3 Start Page
The Feko start page is displayed when starting a new instance (no models are loaded) of CADFEKO,
EDITFEKO or POSTFEKO.

The start page provides quick access to Create a New Project, Open an Existing Project, and a list
of Recent models.

Links to the documentation (in PDF format), introduction videos and website resources are available on

the start page. Click the  icon to launch the Feko help.

Figure 3: The CADFEKO start page.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
1 Creating a Rectangular Horn p.21

1.5.4 User Interface Layout
View the main elements and terminology in the CADFEKO graphical user interface (GUI).

1. Quick access toolbar
The quick access toolbar is a small toolbar that gives quick access to actions that are
performed often. The actions available on the quick access toolbar are also available via the
ribbon. The quick access toolbar includes: New, Open, Save, Undo and Redo.

2. Ribbon
The ribbon is a command bar that groups similar actions in a series of tabs. The ribbon
consists of the application menu, core tabs and contextual tab sets.

3. Configuration list
The configuration list is a panel that displays all defined configurations in the model. A new
model starts by default with a single standard configuration. The following configuration
types are supported: Standard configuration, Multiport S-parameter configuration and
Characteristic modes configuration.
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Tip:  Multiple configurations allow you to perform efficient simulations using
different configurations (different loads, sources, frequencies or power scaling) in
a single model.

4. Model tree

The model tree is a panel that organises the model-creation hierarchy and configuration-
specific items of the model into two separate tabs at the top of the panel. A right-click
context menu is available for all items in the model tree. Double-click on an item to open its
properties.

Predefined variables, named points, media, workplanes, field/current data, worksurfaces
and cables are listed in both the Construction tab and the Configuration tab to provide
quick access.

a. Construction tab
The Construction tab lists the model-creation hierarchy in a tree format.

Note:  Select a geometry or mesh part on the Construction tab
and in the details tree (5), modify its wire / edge / face / region
properties, solution settings and custom mesh settings.

b. Configuration tab
The Configuration tab lists the configuration-specific items in a tree format.

Note:  Select a configuration in the configuration list (3) and view its
configuration-specific items in the Configuration tab.

5. Details tree
The details tree is a panel that displays the relevant wires, edges, faces and regions for the
geometry or mesh part selected in the Construction tab (4). From the right-click context
menu specify the properties for its wire, edge, face or region properties in the details tree.
You can modify the selected item's local mesh size, material definition or coating or solution
properties that are specific to the selection.

6. Status bar
The status bar is a small toolbar that gives quick access to macro recording, general display
settings, tools, selection method and type, snap settings and the model unit.

7. Model Status icon
The Model Status icon shows the current status of the model in the Notification centre. The
Notification centre can be hidden but the Model Status icon in the status bar will still indicate
the current status of the model.
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8. Notes view
The notes view is a window where you can document model details. Add additional
comments or information for future reference.

Tip:  The notes view is hidden by default, but can be enabled.

On the Home tab, in the Create view group, click the  Notes icon.

9. Notification centre
The Notification centre performs computational electromagnetic model (CEM) validation and
shows the status of the model. When problems in the model are detected, it is highlighted in
the Notification centre with hyperlinks to the problematic entities.

10. 3D view
The 3D view window displays the geometry and mesh as well as solution requests (for
example, a far field request).

Tip:

• Select the Construction tab (4.a) to view only CAD in the 3D view.

• Select the Configuration tab (4.b) to view both CAD and solution requests
in the 3D view.

11. Help
The Help icon gives quick access to the Feko manuals.

Tip:  Press F1 to access context-sensitive help.

12. Search bar
The search bar is a single-line textbox that allows you to enter a keyword and search for
relevant information in the GUI. Entering a keyword in the search bar will populate a drop-
down list of actions as well as the location of the particular action on the ribbon or context
menu. Clicking on an item in the list will execute the action.

13. Application launcher
The application launcher toolbar is a small toolbar that gives quick access to other Feko
components.
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1.5.5 Ribbon
The ribbon is a command bar that groups similar actions in a series of tabs.

Figure 4: The ribbon in CADFEKO.

1. File menu
The File menu is the first item on the ribbon. The menu allows saving and loading of models,
import and export options as well as giving access to application-wide settings and a recent file
list.

2. Core tabs
A tab that is always displayed on the ribbon, for example, the Home tab and Construct tab.

The Home tab is the first tab on the ribbon and contains the most frequently used commands for
quick access.

3. Contextual tab sets
A tab that is only displayed in a specific context.

For example, the Schematic contextual tab set contains the Network Schematic contextual
tab. Contextual tabs appear and disappear as the selected items such as a view or item on a view,
change.

4. Ribbon group
A ribbon tab consists of groups that contain similar actions or commands.

5. Dialog launcher
Click the dialog launcher to launch a dialog with additional and advanced settings that relate to
that group. Most groups don't have dialog launcher buttons.

Keytips
A keytip is the keyboard shortcut for a button or tab that allows navigating the ribbon using a
keyboard (without using a mouse). Press F10 to display the keytips. Type the indicated keytip to
open the tab or perform the selected action.
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Figure 5: An example of keytips.
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1.5.6 Construction Tab
The Construction tab contains the geometry and mesh representation of the current model in a tree
structure. It also lists ports and the optimisation configuration.

The tree contains a Definitions branch, Model branch and Optimisation branch.

Figure 6: The Construction tab in the model tree.

Definitions Branch
The Definitions branch contains by default the predefined variables, named points, media, mesh
settings, workplanes, field/current data, worksurfaces and cables.

Model Branch

The Model branch is mainly a visualisation of the geometry and mesh creation hierarchy. Where
geometry or mesh objects are derived from existing ones, the original (parent) objects are
removed from the top level of the model and listed as sub-levels (children) under the new object.

Note:  The highest-level items in the model are referred to as “parts”.

For example, Cone1 and Cuboid1 (parent objects) were unioned and the result is that they have
become children of the new object Union1. Union1 is the highest-level item and referred to as a
part.
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Figure 7: The Construction tab in the model tree showing the part, Union1.

The Model branch also contain the ports, meshing rules, cutplanes and solution settings.

Optimisation Branch
The Optimisation branch contains the optimisation searches, associated masks, parameters and
goal functions defined for the model.

Note:  The Optimisation branch is only displayed if the model contains an
optimisation search or mask.
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1.5.7 Configuration Tab
The Configuration tab contains the global and configuration-specific model settings and requests of the
current model in tree form.

The tree contains a Definitions branch, Global branch and Configuration specific branch.

Figure 8: The Configuration tab in the model tree.

Definitions Branch
The Definitions branch contains by default the predefined variables, named points, media, mesh
settings, workplanes, field/current data, work surfaces and cables.

Global Branch
The Global branch contains the global specific model settings. From the right-click context menu
define solver settings, specify the global frequency, sources, loads, networks and power.

Configuration specific Branch
The Configuration specific branch contains configuration specific settings. From the right-
click context menu define requests per configuration, frequency per configuration, sources per
configuration, loads per configuration and power per configuration.
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1.5.8 Notification Centre
The Notification centre performs computational electromagnetic model (CEM) validation and shows the
status of the model and notifications.

The Notification centre lets you stay informed of the model status at all times. When problems in
the model are detected, it is highlighted in the Notification centre with hyperlinks to the problematic
entities.

The Notification centre can be hidden but the Model Status icon in the status bar will still indicate the
current status of the model.

Figure 9: The Notification centre in CADFEKO. Note the Model Status icon at the bottom that shows the current
status of the model.

Show or hide the Notification centre using one of the following workflows:

• Click the Model Status icon in the status bar.

• Drag the splitter from the right edge of the application to open the pane. To close, drag the splitter
all the way to the right.

• On the Home, in the Validate group, click the  Model Status icon.

• Click the  icon in the Notification centre to hide the panel. Click the  icon to show the panel

again.
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1.5.9 Dialog Error Feedback
CADFEKO provides error feedback for dialogs by showing a soft message bubble when validation fails on
a dialog.

Click the  icon to show or hide the message bubble or click elsewhere in CADFEKO to hide the

message bubble. The error feedback is also shown per tab when the validation fails on a multi-tab
dialog.

Figure 10: The soft message bubble indicating that an undefined variable was used on the Geometry tab of the
Create Rectangle dialog.
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1.5.10 Custom Keyboard Shortcut Settings
CADFEKO provides default keyboard shortcuts. To better fit your workflow and work style, you can
reassign keyboard shortcuts to different commands.

To reassign keyboard shortcuts, click File > Settings > Keyboard Shortcut Settings.

Figure 11: The Keyboard Shortcut Settings dialog.

For example, to change the shortcut key for the undo command, on the Keyboard Shortcut Settings
dialog, click in the CurrentKeySequence column and enter the shortcut key that suits your work style.
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1.5.11 Custom Mouse Bindings
CADFEKO provides default commands for all the mouse buttons. To better fit your workflow and work
style, you can reassign mouse buttons to different commands.

To reassign mouse buttons, click File > Settings > Mouse Binding Settings.

Figure 12: The Mouse Binding Settings dialog.

For example, to reverse the mouse wheel direction to better suit your workflow, on the Mouse
Bindings dialog, click Click to Configure. On the Zoom dialog, select the Invert check box.

Figure 13: The Zoom dialog.
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1.6 Introduction to POSTFEKO
Use POSTFEKO to validate meshed geometry and analyse and post-process results.

POSTFEKO is the component that allows you to verify that your model is constructed and configured
correctly before starting a simulation and analyse the results after the simulation completes. The
POSTFEKO component is particularly useful to verify models created using EDITFEKO, but it is just as
relevant for CADFEKO model verification.

Result post-processing and analysis is the primary function of POSTFEKO. Once a model has been
simulated, POSTFEKO can be used to display and review the results. It is easy to load multiple models
in a single session and compare them on 3D views, Cartesian graphs, Smith charts, polar graphs
and surface graphs. Various measurement and other data formats are supported for comparison to
the simulated results. A powerful scripting interface makes it easy to post-process results, automate
repetitive tasks and create plug-in extensions that customise the interface and experience.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
1 Creating a Rectangular Horn p.34

1.6.1 Reviewing POSTFEKO and Launching OPTFEKO
Open POSTFEKO from within CADFEKO.

Use one of the following workflows to launch POSTFEKO:

• On the Solve/Run tab, in the Run/Launch group, click the  POSTFEKO icon.

• On the application launcher toolbar, click the POSTFEKO icon in the  group.

• Press Alt+3 to use the keyboard shortcut.

POSTFEKO opens by default with a single 3D view containing the model geometry.
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1.6.2 User Interface Layout
View the main elements and terminology in the POSTFEKO graphical user interface (GUI).

1. Quick access toolbar
The quick access toolbar is a small toolbar that gives quick access to actions that are
performed often. The actions available on the quick access toolbar are also available via the
ribbon. The quick access toolbar includes: New project, Open project, Save project,
Undo and Redo.

2. Ribbon
The ribbon is a command bar that groups similar actions in a series of tabs. The ribbon
consists of the application menu, core tabs and contextual tab sets.

3. Project browser
The project browser is a panel that lists the models loaded in the current project, imported
data, stored data and scripted data.
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Tip:  Collapse the project browser to expand the 3D view.

On the View tab, in the Show group, click the  Project icon.

4. Model browser
The model browser is a panel that organises the model information of the selected model in
the project browser (3), into two separate tabs.

Model tab
The Model tab lists the model information and results for the selected model.

Results tab
The Results tab lists the results and solution information.

5. Details browser
The details browser is a panel that shows in-depth detail for the selected item in the model
browser (4).

Tip:  View the solution information for the selected model.

On the model browser (Results tab), click Solution information to view:

• start and end time

• memory per process

• total CPU-time

6. Status bar
The status bar is a small toolbar that gives quick access to general display settings, tools,
and graph cursor settings.

7. 3D view/2D graphs

3D view
The 3D view displays the geometry, mesh, solution settings as well as 3D results.

2D graphs
The 2D graphs display the 2D results on either a Cartesian graph, polar graph, Smith
chart or Cartesian surface graph.

Tip:

• Re-order the window tabs by simply dragging the tab to the desired location.

• Rename the window tab by using the right-click context menu and selecting
Rename.
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8. Result palette
The result palette is a panel that gives access to options that control the data in the 3D view
or 2D graph for the relevant result type. For example, 3D far field data allows the phi cut
plot type and gain in dB to be specified.

9. Help
The Help icon gives quick access to the Feko manuals.

Tip:  Press F1 to access context-sensitive help.

10. Search bar
The search bar is a single-line textbox that allows you to enter a keyword and search for
relevant information in the GUI. Entering a keyword in the search bar will populate a drop-
down list of actions as well as the location of the particular action on the ribbon or context
menu. Clicking on an item in the list will execute the action.

11. Application launcher
The application launcher toolbar is a small toolbar that gives quick access to other Feko
components.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
1 Creating a Rectangular Horn p.38

1.6.3 Validating the Model in POSTFEKO
View the model using visualisation tools in POSTFEKO to confirm the model was created as intended.

Confirm the horn model is open in the 3D view.

1. Enable the mesh edges of the model.

a) On the 3D View contextual tabs set, on the Mesh tab, in the Visibility group, click the

 Metal icon. From the drop-down list, select the Edges check box.

2. Zoom to extents of the 3D view using one of the following workflows:

• On the View tab, in the Zoom group, click the  Zoom to extents icon.

• Press F5 to use the keyboard shortcut.

3. Enable tick marks on the axes.

a) On the 3D View contextual tabs set, on the Display tab, in the Axes group, click the

 Tick Marks icon.

4. Use the distance measurement tool to validate the dimensions of the horn.

a) On the 3D View contextual tabs set, on the Mesh tab, in the Tools group, click the

 Measure Distance icon.

b) On the Measure Distance dialog, ensure that the Point1 field is active.

c) In the 3D view, press Ctrl+Shift+left click on the first point.

d) Repeat Step 4.c for the second point.

Figure 14: The Measure distance dialog showing the distance between two points.

e) Click Close the close the dialog.
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1.6.4 Viewing the Near Field Results (3D)
View the near field results in the 3D view and add a legend and contours.

1. Add the near field data to the 3D view.

a) On the Home tab, in the Add results group, click the  Near Fields icon. From the drop-

down list, select NearField1.

Figure 15: Section of the ribbon showing the Add results group.

2. View the magnitude of the Ey component of the field.

a) On the result palette, in the Quantity, clear the X check box and the Z check box.

Figure 16: The Quantity panel in the result palette.

3. View the electric field in dB.

a) On the result palette, in the Quantity panel, select the dB check box.

4. Add a legend to the 3D view (top left).

a) On the 3D View contextual tabs set, on the Display tab, in the Legends group, click the

 Top left icon. From the drop-down list select NearFields.

5. Add contours to the near field result.

a) On the 3D View contextual tabs set, on the Result tab, on the Contours group, click the

 Show contours icon.

6. Specify the number of contours for the near field.

a) On the 3D View contextual tabs set, on the Result tab, in the Contours group, click the

 Position icon. Click Number of contours and set its value to 11.
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Figure 17: The Contour positions dialog.

b) Click OK to close the dialog.

Figure 18: The near field results with contours.
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1.6.5 Viewing the Near Field Results (2D)
Create a new Cartesian graph. Create two near field traces and compare the Ey and Ex components of
the near field along the X direction.

1. Create a new Cartesian graph.

a) On the Home tab, in the Create new display group, click the  Cartesian icon.

2. Add the near field result to the Cartesian graph.

a) On the Home tab, in the Add results group, click the  Near Fields icon. From the drop-

down list, select NearField1.

3. View the near field along the X direction.

a) On the result palette, in the Slice panel, make the following changes:

• From the Independent axis (Horizontal) list, select X position.

• From the Frequency list, select 1.645 GHz.

• From the Y position list, select 100 mm.

• From the Z position list, select 460 mm.

Figure 19: The Slice panel in the result palette.

4. View the magnitude of the Ey component of the field.

a) On the result palette, in the Quantity panel, clear the X check box and the Z check box.

Figure 20: The Slice and part of the Quantity panels in the result palette.

5. Add a second trace to the Cartesian graph by duplicating the NearField1 trace.

a) On the Trace tab, in the Manage group, click the  Duplicate trace icon.

A second trace, NearField1_1, is created.
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6. View the magnitude of the Ex component of the field.

a) On the result palette, select the NearField1_1 trace.

b) On the result palette, in the Quantity panel, select the X check box and clear the Y check
box.

7. Set the vertical axis to dB.

a) In the result palette, select both traces (NearField1 and NearField1_1).

b) In the Quantity panel, select the dB check box.

8. Modify the minimum and maximum values for the vertical axis.

a) On the Cartesian context tab, on the Display tab, on the Axes group, click the  Axis

settings icon.

b) On the Axis settings (Cartesian graph) dialog, select the Vertical tab.

c) Clear the Automatically determine the grid ranges check box.

d) In the Maximum value field, enter a value of 40.

e) In the Minimum value field, enter a value of -20.

Figure 21: The Axis settings (Cartesian graph) dialog.

f) Click OK to close the dialog.
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Figure 22: The Ey and Ex components of the near field along the X direction.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
1 Creating a Rectangular Horn p.44

1.6.6 Viewing the Far Field Results (3D)
View the far field results in the 3D view.

1. Select the 3D view window.

2. Add the far field result to the 3D view.

a) On the Home tab, in the Add results group, click the  Far field icon. From the drop-

down list, select FarField1.

3. Hide the near field result still displayed in the 3D view.

a) In the result palette, on the Traces panel, click the  “eye” icon next to NearField1.

Figure 23: An open  “eye” icon indicates that the trace is shown.

Figure 24: A closed  “eye” icon indicates that the trace is hidden.

4. Add an annotation to the far field.

a) Add an annotation to the desired location by pressing Ctrl+Shift+left click.

5. View the fields in dB.

a) On the result palette, in the Quantity panel, select the dB check box.

6. Change the size of the far field compared to the geometry.

a) On the 3D View contextual tabs set, on the Result tab, in the Rendering group, click the

 Size icon. From the drop-down list, select Custom.

b) On the Specify dialog, set the size as 70%.

Figure 25: The 3D far field result.

c) Click OK to specify the size of the far field and to close the dialog.
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1.6.7 Viewing the Far Field Results (2D)
View the far field results on a polar graph.

Note:  Since a full 3D set of data was requested for this example, 2D cuts can be extracted.

1. Create a new polar graph.

a) On the Home tab, in the Create new display group, click the  Polar icon.

2. Add the far field result to the polar graph.

a) On the Home tab, in the Add results group, click the  Far field icon. From the drop-

down list, select FarField1.

3. View the far field gain plotted in the YZ plane.

a) On the result palette, in the Slice panel, make the following changes:

• From the Independent axis (Angular) drop-down list, select Theta (wrapped).

• From the Frequency drop-down list, select 1.645 GHz.

• From the Phi drop-down list, select 90 deg (wrapped).

4. On the result palette, in quantity panel panel, select the dB check box.

Figure 26: The far field results on a polar graph.
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2 Creating CADFEKO Models

The example is intended for users with no or little experience with CADFEKO. This example is not an
example intended for simulation, but rather to familiarise yourself with model creation in CADFEKO.

This chapter covers the following:

• 2.1 Example Overview  (p. 47)

• 2.2 Topics Discussed in this Example  (p. 48)

• 2.3 Example Prerequisites  (p. 49)

• 2.4 Creating the Model in CADFEKO  (p. 50)

• 2.5 Final Remarks  (p. 78)
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2.1 Example Overview
Create a simple model using basic geometry and transformations to familiarise yourself with model
creation in CADFEKO.

Figure 27: Illustration of the geometry created in this example.

Note:

• The example does not use the fastest or most effective way to create geometry, but
instead it highlights a subset of tools available in CADFEKO to create complicated
geometrical structures.

Note:

• This example is not intended for running the Solver. No electromagnetic solution is
performed and no results are presented.
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2.2 Topics Discussed in this Example
Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

• CADFEKO

◦ Launch CADFEKO.

◦ Define variables to create a parametric model.

◦ Add a custom workplane.

◦ Create a rectangle.

◦ Create a line.

◦ Create a cuboid by sweeping the rectangle along the line.

◦ Create a flare.

◦ Union the flare and cuboid to ensure the parts are electrically connected.

◦ Remove a redundant face in the flare to create a horn.

◦ Add a feed pin to the line.

◦ Use automatic selection in the 3D view.

◦ Create an ellipse and subtract the shape from the cuboid face to create a hole.

Note:  Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the application macro library[7]:

GS 2: Model Construction

7. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
2 Creating CADFEKO Models p.49

2.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1 or later should be installed.

• It is recommended that you watch the demo video before attempting this example.

• This example should not take longer than 40 minutes to complete.

Note:  When using CADFEKO over a remote desktop connection, you may need to enable 3D

support for remote desktop[8] for the host's graphics card should a crash occur when clicking
New Project in CADFEKO.

8. See the Troubleshooting section in the Appendix of the Feko User Guide for more details.
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2.4 Creating the Model in CADFEKO
Create the model geometry using the CAD component, CADFEKO.
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2.4.1 Launching CADFEKO (Windows)
There are several options available to launch CADFEKO in Microsoft Windows.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

Figure 28: The Launcher utility.

• Open CADFEKO by double-clicking on a .cfx[9] file.

• Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

Note:  If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

2.4.2 Launching CADFEKO (Linux)
There are several options available to launch CADFEKO in Linux.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

• Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:

/home/user/2025.1/altair/feko/bin/cadfeko

• Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

. /home/user/2025.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

9. A .cfx file is created by CADFEKO and contains the meshed and/or unmeshed CADFEKO model as
well as the calculation requests.
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Note:  Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.
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2.4.3 Building a Horn
Learn to create variables, workplanes and primitive shapes. Continue by combining these basic entities
and modifying their properties.

Note:  To demonstrate the path sweep tool, the cuboid in this example is constructed using
a rectangle and the path sweep tool.
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Adding Variables
Define variables to create a parametric model.

A model is parametric when it is created using variable expressions. When a variable expression is
modified, any items dependent on that variable are re-evaluated and automatically updated. It is the
recommended construction method when creating a model, but not compulsory.

Defined variables are stored as part of the model in the .cfx file.

1. Open the Create Variable dialog using one of the following workflows:

• On the Construct tab, in the Define group, click the  Add Variable icon.

• On the model tree, a right-click context menu is available on Variables. From the list, select
Add Variable.

Figure 29: The model tree (Construction tab).

• On the model tree, click the  icon. From the drop-down list, select Add Variable.
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Figure 30: The  drop-down list available in the model tree.

• Press # to use the keyboard shortcut.

2. Create the following variables:

Name Expression Comment [Optional]

Width 1 Width of rectangle.

Length 1 Length of rectangle.

BottomDepth 1 Bottom depth of flare.

BottomWidth 1 Bottom width of flare.

FlareLength 1 Length of flare.

TopWidth 2 Top width of flare.

TopDepth 2 Top depth of flare.

Figure 31: The Create Variable dialog.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
2 Creating CADFEKO Models p.56

Tip:

• Click Add to keep the Create Variable dialog open and add more variables.

• Click Create to add a variable and close the Create Variable dialog.
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Defining a Workplane
Define a workplane to create an oblique plane. Workplanes simplify the process of creating geometry on
oblique planes in comparison to using transforms.

The use of workplanes during construction is not compulsory, but is a more efficient method for creating
geometry. For this example you will create a custom workplane and set as the default workplane.

Note:  A workplane can be defined relative to another workplane.

1. Open the Create Workplane dialog using one of the following workflows:

• On the Construct tab, in the Define group, click the  Add Workplane icon.

• On the model tree, a right-click context menu is available on the Workplanes group. Select
Add Workplane from the drop-down list.

Figure 32: The Add Workplane group is available on both the Construct and Configuration tabs in
the model tree.

• On the model tree, click the  icon. From the drop-down list, select Add Workplane.

• Press F9 to use the keyboard shortcut.

2. On the Create Workplane dialog, from the drop-down list, select Global YZ.

3. Use the default workplane label, Workplane1.
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Figure 33: The Create Workplane dialog.

4. Click Create to create the workplane and to close the dialog.

The default workplane is used when creating new geometry primitives. For this example, set the new
workplane as the default workplane.

5. In the model tree, select Workplane1.

a) From the right-click context menu, select Set as default.

Figure 34: The right-click context menu options for workplanes.
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Note:  The current default workplane is indicated by the text, [Default].
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Creating a Rectangle
Create a rectangle to be used in the construction of the horn.

1. On the Construct tab, in the Create Surface group, click the  Rectangle icon.

Figure 35: The Create Rectangle dialog.

Note:  Default values are used on geometry creation dialogs to allow a preview in the
3D view. You may change the values as required.

Tip:  An active field allowing point-entry is indicated by a yellow outline.

Point-entry allows a variable or named points to be entered by pressing
Ctrl+Shift+left click on a variable or named point in the model tree.

2. Create a rectangle using the Base centre, width, depth definition method.

a) Use the following dimensions:

• Base centre (C): (0, 0, 0)

• Width (W): 1

• Depth (D): 1

3. Click Create to create the rectangle and to close the dialog.
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Figure 36: The rectangle created using Workplane1.
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Creating a Line
Create a line to be used in the construction of the horn. This line will be used to create a cuboid by
sweeping the rectangle along the line.

1. On the Construct tab, in the Create Curve group, click the  Line icon.

2. On the Create Line dialog, enter the start point and end point for the line.

• Start point: (0, 0, 0)

• End point: (0, 0, 1)

Figure 37: The Create Line dialog.

3. Click Create to create the line and to close the dialog.

Figure 38: The rectangle and line created using Workplane1.
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Creating a Cuboid by Sweeping a Rectangle along a Line
Create a cuboid by sweeping the rectangle along a line (path).

Tip:  For demonstrative purposes, a rectangle is swept along a path to create a cuboid.

The preferred method to create a cuboid is to make use of the cuboid tool.

1. In the model tree, select Rectangle1.

Note:  Selecting Rectangle1 in the model tree enables Path Sweep on the ribbon.

2. On the Construct tab, in the Extend group, click the  Path Sweep icon.

Figure 39: The Path Sweep dialog.

3. In the model tree, click Line1 to use as path.

4. On the Path Sweep dialog, use the default values.

5. Click Create to create the path sweep and to close the dialog.

Figure 40: The rectangle swept along a path (line) to create a cuboid.
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Creating a Flare
Create a flare primitive to be used in the construction of the horn.

1. On the Construct tab, in the Create Solid group, click the  Flare icon.

2. Create the flare using the Base centre, width, depth, height, top width, top depth method.

3. Specify the flare dimensions using one of the following workflows:

• Add the defined variables manually.

• Select a field on the Create Flare dialog and use point-entry to enter the values.

Note:  An active field allowing point-entry is indicated by a yellow outline.

Point-entry allows a variable or named points to be entered by pressing
Ctrl+Shift+left click on a variable or named point in the model tree.

Use the following dimensions:

Figure 41: The Create Flare dialog.

• Base centre (C): (0, 0, 0)

• Bottom width (Wb): BottomWidth

• Bottom depth (Db): BottomDepth

• Height (H): -FlareLength
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• Top width (Wt): TopWidth

• Top depth (Dt): TopDepth

Tip:  Parametric models are the preferred construction method. A parametric model
updates automatically when updating a defined variable.

Alternatively, use values instead of defined variables.

4. View the preview of the flare in the 3D view. Confirm that the model looks correct.

Figure 42: The preview of the flare is indicated in green.

5. Click Create to create the flare and to close the dialog.
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Creating a Union of the Flare and Cuboid
Union the flare and cuboid to create the horn.

Note:  The union operation is used to define connectivity between parts.

Parts that touch, but are not unioned, are not considered to be physically connected and will
result in an incorrect mesh.

1. In the model tree, select the flare and the cuboid (PathSweep1).

Figure 43: The Construction tab in the model tree showing the selected Flare1 and PathSweep1.

2. Union using one of the following workflows:

• On the Construct tab, in the Modify group, click the  Union icon.

• Press U to use the keyboard shortcut.

Figure 44: The Construction tab in the model tree showing the unioned part, Union1.
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Removing Redundant Geometry Faces
Delete the redundant faces in the geometry to create a horn.

1. In the model tree, select Union1.

2. In the details tree, under Faces, go through the list of faces. For each face, click on  to hide the

face until only the two redundant faces remain.

Figure 45: For illustration, a side face is hidden to show the two redundant faces highlighted in yellow with a
blue outline.

3. Select the two faces that remain.

4. From the right-click context menu, click Delete.

Note:  Deleting one of a regions's enclosing faces, removes the PEC region.

5. Select any of the remaining faces and from the right-click context menu, click Visibility > Show
All in Model.

Figure 46: The redundant faces were deleted.
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2.4.4 Adding a Feed Pin to the Horn
Add a wire feed to the model. As this example is only for demonstration purposes, this example does
not cover the adding of a port or source to the wire feed.
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Creating the Feed Wire
Create a wire feed for the model.

1. On the Construct tab, in the Create Curve group, click the  Line icon.

2. On the Create Line dialog, click the Workplane tab.

a) On the Workplane tab, select Custom workplane.

b) Under Origin, click on X field to make point-entry active (indicated by a yellow outline).

3. Press Ctrl+Shift while moving the mouse cursor over the bottom face centre of the cuboid.

Note:  The circles with a black outline indicate special snapping points. The red outline
indicates the position of the mouse cursor.

Use snapping points to snap the workplane to an object. Although only special
snapping points are indicated, you can snap to any point in the 3D view.

4. Press Ctrl+Shift+left click to snap the workplane to the bottom face centre of the cuboid.

5. On the Create Line dialog, click the Geometry tab.

a) Create a line.

• Start point: (0, 0, 0)

• End point: (0, 0, 0.25)

• Label: Feed
6. Click Create to create the line and to close the dialog.

Figure 47: The feed wire is selected (highlighted in blue).
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Unioning the Feed Wire and Horn
Union the feed wire and horn to ensure mesh connectivity and a correct mesh.

1. In the model tree, expand Union1.

2. In the model tree, select Feed and drag it to below  Union1.

3. From the right-click context menu, select Move in.

4. View the model tree and confirm that it is correct.

Figure 48: Union by dragging as item into a union in the model tree.
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2.4.5 Using Selection in the 3D View
Use the selection type tool to highlight an element in the 3D view.

The following steps are not required for constructing the model, but it illustrates how selection works in
CADFEKO.

1. Move the mouse cursor to one of the faces on the inside of the flare.

2. Click on a face.

Figure 49: The part is selected and highlighted in yellow.

3. Click again on the face.

Figure 50: The face is selected and highlighted in yellow with a blue outline.

Note:

The default selection method (Auto) cycles through the applicable selection types
when repeatedly clicking on the model.

The first click selected the part. The second click selected the face.

4. Change the selection type using one of the following workflows:
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• On the Tools tab, in the Selection group, click the  Selection Type icon.

• On the status bar, click  Selection Type icon. Select the required selection type from the

list. 
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2.4.6 Creating an Aperture in a Face
Create an aperture (hole) in a face or region by using the subtract tool. Create the geometry to be
removed and subtract it from the target part. The target is the part that is reduced by cutting away a
section of the part.
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Creating and Placing the Ellipse
Create an ellipse to subtract from the horn. The ellipse is placed on the face of the horn.

1. On the Construct tab, in the Create Surface group, click the  Ellipse icon.

2. On the Create Ellipse dialog (Geometry tab), create an ellipse using the following dimensions:

• Centre point (C): (0, 0, 0)

• Radius (Ru): 0.3

• Radius (Rv): 0.2

3. On the Create Ellipse dialog, click the Workplane tab.

a) On the Workplane tab, select Custom workplane.

b) Under Origin, click on X field to make point-entry active (indicated by a yellow outline).

c) Move the mouse cursor over the flare while holding down Ctrl+Shift until the local workplane
is orientated as displayed in the image.

Figure 51: The placement of the ellipse on the horn.

Note:  The history of from where the mouse cursor was moved to the face
centre, affects the orientation of the workplane.

4. Click Create to create the ellipse and to close the dialog.
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Subtracting the Ellipse from the Horn
The ellipse is subtracted from the horn to create a hole.

1. In the model tree, select Ellipse1.

2. Subtract using one of the following workflows:

• On the Construct tab, in the Modify group, click the  Subtract From icon.

• On the model tree, a right-click context menu is available on the primitive. From the list
select Apply > Subtract From.

Figure 52: The ellipse was subtracted from the horn.

3. In the model tree, select Union1.

Note:  The T in the model tree indicates the target (object that was subtracted from).

4. Click Create to subtract the ellipse and to close the dialog.
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2.4.7 Setting the Simulation Frequency
Specify the frequency range of interest. For this example, a single frequency point is used.

1. On the Source/Load tab, in the Settings group, click the  Frequency icon.

2. In the Frequency (Hz) field, enter 1e9.

Figure 53: The Solution Frequency dialog.

3. Click OK to set the frequency and to close the dialog.
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2.4.8 Saving the Model
Save the model to a CADFEKO.cfx file.

1. Save the model using one of the following workflows:

• On the Home tab, in the File group, click the  Save icon.

• Press Ctrl+S to use the keyboard shortcut.

2. Save the model as Model_creation.cfx.

3. Click Save to close the dialog.
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2.5 Final Remarks
This example showed aspects of model creation in CADFEKO.

Important:  This example is not an example intended for simulation, but rather an
introductory example that illustrates the power of CADFEKO when creating complex models.
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3 GPS Patch Antenna

The example considers a left-handed circular polarised GPS patch antenna on a finite substrate.

This chapter covers the following:

• 3.1 Example Overview  (p. 80)

• 3.2 Topics Discussed in Example  (p. 81)

• 3.3 Example Prerequisites  (p. 82)

• 3.4 Creating the Model in CADFEKO  (p. 83)

• 3.5 Launching the Solver  (p. 117)

• 3.6 Viewing the Results in POSTFEKO  (p. 118)

• 3.7 Final Remarks  (p. 124)
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3.1 Example Overview
Calculate the input reflection coefficient and circular components of a left-handed circular polarised GPS
patch antenna on a finite substrate close to 1.57 GHz.

Figure 54: The chamfered GPS patch antenna on a finite substrate.
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3.2 Topics Discussed in Example
Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

• CADFEKO

◦ Activate macro recording of a model.

◦ Changing the model unit.

◦ Create and group variables.

◦ Create a dielectric.

◦ Create geometry (polygon, cuboid and line).

◦ Set the region of a cuboid to dielectric.

◦ Set the faces of a dielectric cuboid to PEC[10].

◦ Add a voltage source to a wire segment.

◦ Modify the auto-generated mesh.

◦ Add a far field request.

◦ Deactivate macro recording and run the resulting Feko Lua script.

◦ Run the Solver.

• POSTFEKO

◦ View the input reflection coefficient on a Cartesian graph.

◦ View the left-hand and right-hand circular components of the far field on a Cartesian graph.

Note:  Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the application macro library[11]:

GS 3: GPS Patch Antenna

10. perfect electric conductor

11. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.
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3.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1 or later should be installed.

• It is recommended that you watch the demo video before attempting this example.

• This example should not take longer than 40 minutes to complete.

Note:  When using CADFEKO over a remote desktop connection, you may need to enable

3D support for remote desktop[12] for the host's graphics card should a crash occur when
clicking New Project in CADFEKO.

12. See the Troubleshooting section in the Appendix of the Feko User Guide for more details.
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3.4 Creating the Model in CADFEKO
Create the model geometry using the CAD component, CADFEKO.
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3.4.1 Launching CADFEKO (Windows)
There are several options available to launch CADFEKO in Microsoft Windows.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

Figure 55: The Launcher utility.

• Open CADFEKO by double-clicking on a .cfx[13] file.

• Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

Note:  If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

3.4.2 Launching CADFEKO (Linux)
There are several options available to launch CADFEKO in Linux.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

• Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:

/home/user/2025.1/altair/feko/bin/cadfeko

• Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

. /home/user/2025.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

13. A .cfx file is created by CADFEKO and contains the meshed and/or unmeshed CADFEKO model as
well as the calculation requests.
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Note:  Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
3 GPS Patch Antenna p.86

3.4.3 Activating Macro Recording of Model
Use macro recording to record actions in a script. Play the script back to automate the process or view
the script to learn the Lua-based scripting language by example. Macro recording allows you to perform
repetitive actions faster and with less effort.

Note:  This step is optional when creating a model in CADFEKO but it is included in this
example to highlight the functionality.

Activate macro recording using one of the following workflows:

• On the Home tab, in the Scripting group, click the  Record Macro icon.

• Click the  icon in the status bar.
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3.4.4 Setting the Model Unit
Set the model unit to millimeters.

The default unit length in CADFEKO is metres. Since the structure that you will build is small, the model
unit is set to millimetres. All dimensions entered will be in the new model unit.

1. Set the model unit to millimetres using one of the following workflows:

• On the Construct tab, in the Define group, click the  Model unit icon.

• On the status bar, click .

2. On the Model Unit dialog, select Millimetres (mm).

3. Click OK to change the model unit to millimetres and to close the dialog.

Figure 56: The Model Unit dialog.
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3.4.5 Adding Variables
Define variables to create a parametric model.

A model is parametric when it is created using variable expressions. When a variable expression is
modified, any items dependent on that variable are re-evaluated and automatically updated. It is the
recommended construction method when creating a model, but not compulsory.

Defined variables are stored as part of the model in the .cfx file.

1. Open the Create Variable dialog using one of the following workflows:

• On the Construct tab, in the Define group, click the  Add Variable icon.

• On the model tree, a right-click context menu is available on Variables. From the list, select
Add Variable.

Figure 57: The model tree (Construction tab).

• On the model tree, click the  icon. From the drop-down list, select Add Variable.
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Figure 58: The  drop-down list available in the model tree.

• Press # to use the keyboard shortcut.

2. Create the following variables:

Name Expression Unit

patch_size 18.8 mm

chamfer_d 4.3 mm

feed_pos -6.4 mm

substrate_w 45 mm

substrate_d 45 mm

substrate_h 5 mm

ceramic_epsR 5.6

ceramic_tanD 0.0041

Figure 59: The Create Variable dialog.
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Tip:

• Click Add to keep the Create Variable dialog open and add more variables.

• Click Create to add a variable and close the Create Variable dialog.

3. [Optional] Group the variables related to the patch.

a) In the model tree, under Variables, select patch_size and chamfer_d.

Tip:  To select multiple objects, press and hold Ctrl while you click the items.

b) From the right-click context menu, select Group > Create.

c) Select Group1 and from the right-click context menu, click Rename.

d) Rename the group to Patch.

4. [Optional] Group the variables related to the substrate.

a) In the model tree, select substrate_w, substrate_d and substrate_h.

b) From the right-click context menu, select Group > Create.

c) Select Group2 and from the right-click context menu, click Rename.

Tip:  Press F2 to use the keyboard shortcut to rename a selected item.

d) Rename the group to Substrate.
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3.4.6 Defining a Dielectric Medium
Define a lossy frequency-independent dielectric with a relative permittivity ( ) = 5.6 and a dielectric
loss tangent ( ) = 0.0041 to be used as the patch substrate.

1. Open the Create Dielectric Medium dialog using one of the following workflows:

• On the Construct tab, in the Define group, click the  Media icon. From the drop-down

list, click the  Dielectric icon.

• On the model tree, a right-click context menu is available on Media. From the list, click
Dielectric.

Two variables (ceramic_epsR and ceramic_tanD) were added to the model to define the dielectric.

2. Set the Relative permittivity ( ) to ceramic_epsR.

3. Set the Dielectric loss tangent  ( ) to ceramic_tanD.

Figure 60: The Create Dielectric Medium dialog.

4. Set the Label to Ceramic.

5. Click Create to create the dielectric and to close the dialog.

Note:  In the model tree, the defined dielectric is displayed under Dielectric. CADFEKO
assigns a colour to each medium randomly but the colour may be changed by using the
Change Display Colour right-click context menu option.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
3 GPS Patch Antenna p.92

3.4.7 Creating the Patch
Create the chamfered[14] patch using a polygon.

1. On the Construct tab, in the Create Surface group, click the  Polygon icon.

Figure 61: The Create Polygon dialog showing the default values. Active fields are outlined in yellow.

Note:  Default values are used on geometry creation dialogs to allow a preview in the
3D view. You may change the values as required.

Tip:  An active field allowing point-entry is indicated by a yellow outline.

Point-entry allows a variable or named points to be entered by pressing
Ctrl+Shift+left click on a variable or named point in the model tree.

2. Under Corner 1, add the following coordinates:

• Corner 1:

◦ U: Patch.patch_size

◦ V: Patch.patch_size

◦ N: Substrate.substrate_h

14. An edge created at 45° between two adjoining right-angled edges.
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3. In the table, click on the second row to make Corner 2 active. Add the following coordinates:

• Corner 2:

◦ U: -Patch.patch_size + Patch.chamfer_d

◦ V: Patch.patch_size

◦ N: Substrate.substrate_h

4. Click on the third row to make Corner 3 active. Add the following coordinates:

• Corner 3:

◦ U: -Patch.patch_size

◦ V: Patch.patch_size - Patch.chamfer_d

◦ N: Substrate.substrate_h

5. Click Add row for Corner 4. Add the following coordinates:

• Corner 4:

◦ U: -Patch.patch_size

◦ V: -Patch.patch_size

◦ N: Substrate.substrate_h

6. Repeat Step 5 twice to add Corner 5 and Corner 6 using the following coordinates:

• Corner 5:

◦ U: Patch.patch_size - Patch.chamfer_d

◦ V: -Patch.patch_size

◦ N: Substrate.substrate_h

• Corner 6:

◦ U: Patch.patch_size

◦ V: -Patch.patch_size + chamfer_d

◦ N: Substrate.substrate_h

7. Set the Label to patch.
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Figure 62: The Create Polygon dialog.

8. Click Create to create the polygon and to close the dialog.

Figure 63: Top view of the chamfered patch. Note that the face is set to perfect electric conductor (PEC) by default
(PEC is indicated by the colour orange).
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3.4.8 Creating the Patch Substrate
Create a finite substrate[15] by creating a cuboid. Set the region of the cuboid to the medium, ceramic.

Create the cuboid.

a) On the Construct tab, in the Create Solid group, click the  Cuboid icon.

b) Create the cuboid using the Base corner, width, depth, height definition method.

c) Use the following dimensions:

• Base corner (C): (-22.5, -22.5, 0)

• Width (W): Substrate.substrate_w

• Depth (D): Substrate.substrate_d

• Height (H): Substrate.substrate_h

• Label: substrate

Figure 64: The Create Cuboid dialog.

d) Click Create to create the substrate and to close the dialog.

15. An alternative method is to model the substrate using an infinite planar multilayer substrate. See
the Feko Example Guide for an example.
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3.4.9 Setting a Region to a Dielectric
Change the region property of the substrate to dielectric.

1. In the model tree, select substrate.

2. In the details tree, under Regions, select Region1.

3. From the right-click context menu, select Properties.

Figure 65: The right-click context menu options available for regions.

4. On the Modify Region dialog (Properties tab), set Medium to Ceramic.

Figure 66: The Modify Region dialog.

Tip:  Simplify workflow by using  Create new to define items when needed.

5. Click OK to modify the region property and to close the dialog.
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Note:  The  icon in the model tree and details tree indicate items set to dielectric.
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3.4.10 Creating the Feed Pin
Create the feed pin using a single line element.

1. On the Construct tab, in the Create Curve group, click the  Line icon.

2. On the Create Line dialog, enter the start and end point for the line.

• Start point: (0, feed_pos, 0)

• End point: (0, feed_pos, Substrate.substrate_h)

• Label: feed_line

Figure 67: The Create Line dialog.

3. Click Create to create the line and to close the dialog.
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3.4.11 Unioning the Geometry for Mesh Connectivity
Union the geometry (feed_line, patch and substrate) to create a single geometry part. A single
geometry part will ensure mesh connectivity when the model is meshed.

1. In the model tree, select feed_line, patch and substrate[16].

Tip:  To select multiple objects, press and hold Ctrl while you click the items.

Figure 68: The three geometry parts in the model tree.

2. On the Construct tab, in the Modify group, click the  Union icon.

Figure 69: The model tree showing Union1 (the union between feed_line, patch and substrate).

16. Alternative method is to select the items in the 3D view.
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3.4.12 Setting Faces to PEC
Change the surface property of the patch to perfect electric conductor (PEC).

1. Change the face of the patch to PEC.

a) In the 3D view, left-click on the patch face repeatedly until the face is highlighted in yellow.

Figure 70: Top view of patch and substrate. The yellow highlighting indicates that the patch face is
selected.

b) From the right-click context menu, select Properties.

c) On the Modify Face dialog (Properties tab), set the Medium to Perfect electric
conductor.

Figure 71: The Modify Face dialog.

d) Click OK to change the face property and to close the dialog.

Figure 72: Top view showing the face of the patch set to PEC.

2. Change the face of the bottom substrate to PEC.
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a) In the model tree, select Union1.

b) In the details tree, under Faces, go through the list of faces. For each face, click on  to

hide the face until only the bottom face[17] of the substrate remains.

Figure 73: Hidden items are greyed out when hidden in the 3D view.

c) From the right-click context menu, select Properties.

d) On the Modify Face dialog (Properties tab), set Medium to Perfect electric conductor.
e) Click OK to modify the face property and to close the dialog.

Figure 74: Bottom view showing the bottom substrate face set to PEC.

f) In the details tree, click on any of the faces. From the right-click context menu, click
Visibility, Show All in Model to make all faces visible again.

17. numbering could differ
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Note:  The  icon in the details tree indicate faces set to PEC.
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3.4.13 Ports, Sources and Loads in CADFEKO
Voltage sources and discrete loads are applied to ports and not directly to the model geometry or mesh.
A port must be defined before a source or load can be added.
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Creating the Port
Define a wire port on the feed pin. A voltage source will be added to this port.

Note:  A port is a mathematical representation of where energy can enter (source) or leave
a model (sink). Use a port to add sources and discrete loads to a model.

1. Open the Create Wire Port dialog using one of the following workflows:

• On the Source/Load tab, in the Ports group, click the  Wire Port icon.

• In the details tree, a right-click context menu is available on the wire. From the list, click
Create port > Wire Port.

2. Select the wire where the port is to be added.

a) In the model tree, select feed_line.

b) In the details tree, select the wire of feed_line.

3. Under Location on wire, select Start.

Figure 75: The Create Wire Port dialog.

4. Click Create to create the port and to close the dialog.

5. Change the label to Port1.
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Adding a Voltage Source
Add a voltage source to the port of the pin.

1. On the Source/Load tab, in the Sources on Ports group, click the  Voltage Source icon.

2. On the Add Voltage Source dialog, use the default settings.

Figure 76: The Create Voltage Source dialog.

3. Click Create to define the voltage source and to close the dialog.

Note:  The Configuration tab was selected automatically when you defined the
voltage source. You may also add sources, loads and set the frequency from here.
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3.4.14 Setting the Simulation Frequency
Specify the frequency range of interest. For this example continuous frequency sampling is used where
Feko automatically determines the frequency sampling for optimal interpolation.

1. On the Source/Load tab, in the Settings group, click the  Frequency icon.

2. On the Solution Frequency dialog, from the drop-down list, select Continuous (interpolated)
range.

3. In the Start frequency (Hz) field, enter 1.27e9.

4. In the End frequency (Hz), enter 1.85e9.

Figure 77: The Solution Frequency dialog.

5. Click OK to specify the frequency and to close the dialog.
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3.4.15 Modifying the Auto-Generated Mesh
When the frequency is set or local mesh settings are applied to the geometry, the automatic mesh
algorithm calculates and creates the mesh automatically while the GUI is active using default mesh
settings. When required, these mesh settings may be modified.

The patch requires a finer mesh as the standard mesh size[18] and a wire segment radius needs to be
specified.

1. Open the Modify Mesh Settings dialog using one of the following workflows:

• On the Mesh tab, in the Meshing group, click the  Create Mesh icon.

• Press Ctrl+M to use the keyboard shortcut.

2. Set the Mesh size to Fine.

3. Set the Wire segment radius to 0.7.

Figure 78: The Modify Mesh Settings dialog.

4. Click OK to create the mesh and to close the dialog.

Figure 79: Top view of the patch and substrate showing the mesh.

5. View the effect in the 3D view of specifying a Wire segment radius.

a) Press F5 to use the keyboard shortcut to zoom to extents the 3D view.

b) Enable a default cutplane. In the model tree (Construction tab), under Cutplanes, click the

 icon next to XZ‑Cut
[19] and from the right-click context menu, select Flip cutplane.

18. See the Feko User Guide Appendix A-3 for more information regarding automatic mesh sizes.

19. To change the default cutplane settings, double-click on the cutplane text (for example, XZ-Cut).
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Figure 80: Note that a cutplane icon is greyed out when the cutplane is not active.

Figure 81: The cutplane shows a cross-sectional view of the patch substrate. Note the thick feedpin as
specified by the Wire segment radius.

c) Disable the cutplane. Click the  button next to XZ-Cut again.
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3.4.16 Setting Local Mesh Sizes for Chamfered Edges
Refine the mesh locally at the chamfered edges.

The mesh can be refined globally but will result in an unnecessary large number of mesh elements. A
more efficient approach is to only refine the mesh locally where a finer mesh is required.

Note:  Local mesh refinement takes precedence over global mesh settings.

1. In the 3D view, select a chamfered edge.

Figure 82: Top view of patch and substrate. The blue edge indicates that it is selected.

2. From the right-click context menu, select Properties.

3. On the Modify Edge dialog (Meshing tab), specify the following:

a) Select the Local mesh size check box.

b) Set the Mesh size to 2.

Figure 83: The Modify Edge (Meshing tab) dialog.

4. Repeat Step 1 to Step 3 for the second chamfered edge.
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Figure 84: Top view of patch and substrate. The second chamfered edge is selected.

5. Click OK to apply the properties and to close the dialog.

Figure 85: Top view of patch and substrate showing the localised mesh refinement at the chamfered edges.

Note:  The  icon in the details tree indicate that a local mesh setting is applied.
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3.4.17 Adding a Far Field Request
Add a far field request to the model.

1. On the Request tab, in the Solution Requests group, click the  Far Fields icon.

2. On the Request Far Fields dialog, click 3D pattern.

Figure 86: The Request Far Fields dialog.

3. Click Create to create a far field request and to close the dialog.
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3.4.18 Deactivating Macro Recording
Deactivate the macro recording of the model, inspect the resulting Feko Lua script and use the script to
recreate the model.

1. Deactivate macro recording using one of the following workflows:

• On the Home tab, in the Scripting group, click the  Record Macro icon.

• Click the  icon in the status bar.

Macro recording is deactivated. The Script Editor window is displayed containing the Feko Lua script.

Figure 87: The Script Editor window.

2. Save the Feko Lua script.

a) On the Script Editor window, save the Feko Lua script by clicking on the  icon.

b) On the Save As dialog, browse to a folder and specify a file name.

c) Click Save to save the Feko Lua script and to close the Save As dialog.

3. Open a new project and recreate the model using the Feko Lua script.

a) On the Home tab, in the File group, click the  New Project icon.

b) On the Script Editor window, click the  icon to run the Feko Lua script.

The model is recreated using the Feko Lua script (see Macro Recording of Example 3).

Note:  For more information regarding scripts and the Feko application programming
interface (API), see the Feko Scripting and API Reference Guide.
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3.4.19 Macro Recording of Example 3
The CADFEKO macro recorded Lua script for Example 3 is given below.

application = cf.Application.getInstance()

-- NewProject
project = application:NewProject()

-- SetProperties
properties = application.Project.ModelAttributes:GetProperties()
properties.Unit = cf.Enums.ModelUnitEnum.Millimetres
application.Project.ModelAttributes:SetProperties(properties)

-- Add
properties1 = cf.Variable.GetDefaultProperties()
properties1.Expression = "18.8"
properties1.Label = "patch_size"
patch_size = application.Project.Definitions.Variables:Add(properties1)

-- Add
properties1.Expression = "4.3"
properties1.Label = "chamfer_d"
chamfer_d = application.Project.Definitions.Variables:Add(properties1)

-- Add
properties1.Expression = "-6.4"
properties1.Label = "feed_pos"
feed_pos = application.Project.Definitions.Variables:Add(properties1)

-- Add
properties1.Expression = "45"
properties1.Label = "substrate_w"
substrate_w = application.Project.Definitions.Variables:Add(properties1)

-- Add
properties1.Expression = "45"
properties1.Label = "substrate_d"
substrate_d = application.Project.Definitions.Variables:Add(properties1)

-- Add
properties1.Expression = "5"
properties1.Label = "substrate_h"
substrate_h = application.Project.Definitions.Variables:Add(properties1)

-- Add
properties1.Expression = "5.6"
properties1.Label = "ceramic_epsR"
ceramic_epsR = application.Project.Definitions.Variables:Add(properties1)

-- Add
properties1.Expression = "0.0041"
properties1.Label = "ceramic_tanD"
ceramic_tanD = application.Project.Definitions.Variables:Add(properties1)

-- CreateGroup
group1 = application.Project.Definitions.Variables:CreateGroup()

-- MoveIn
group1:MoveIn({patch_size, chamfer_d})

-- Setting Label
group1.Label = "Patch"

-- CreateGroup
group11 = application.Project.Definitions.Variables:CreateGroup()

-- MoveIn
group11:MoveIn({substrate_w, substrate_d, substrate_h})

-- Setting Label
group11.Label = "Substrate"

-- AddDielectric
properties2 = cf.Dielectric.GetDefaultProperties()
properties2.DielectricModelling.RelativePermittivity = "ceramic_epsR"
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properties2.DielectricModelling.LossTangent = "ceramic_tanD"
properties2.Label = "Ceramic"
ceramic = application.Project.Definitions.Media.Dielectric:AddDielectric(properties2)

-- Setting Colour
ceramic.Colour = "#aa55ff"

-- AddPolygon
properties3 = cf.Polygon.GetDefaultProperties()
properties3.Corners[1].U = "patch_size"
properties3.Corners[1].V = "patch_size"
properties3.Corners[1].N = "substrate_h"
properties3.Corners[2].U = "-patch_size + chamfer_d"
properties3.Corners[2].V = "patch_size"
properties3.Corners[2].N = "substrate_h"
properties3.Corners[3].U = "-patch_size"
properties3.Corners[3].V = "patch_size - chamfer_d"
properties3.Corners[3].N = "substrate_h"
properties3.Corners[4] = {}
properties3.Corners[4].U = "-patch_size"
properties3.Corners[4].V = "-patch_size"
properties3.Corners[4].N = "substrate_h"
properties3.Corners[5] = {}
properties3.Corners[5].U = "patch_size - chamfer_d"
properties3.Corners[5].V = "-patch_size"
properties3.Corners[5].N = "substrate_h"
properties3.Corners[6] = {}
properties3.Corners[6].U = "patch_size"
properties3.Corners[6].V = " -patch_size + chamfer_d"
properties3.Corners[6].N = "substrate_h"
properties3.LocalWorkplane.WorkplaneDefinitionOption
 = cf.Enums.LocalWorkplaneDefinitionEnum.UsePredefinedWorkplane
globalXY = application.Project.Definitions.Workplanes:Item("Global XY")
properties3.LocalWorkplane.ReferencedWorkplane = globalXY
properties3.Label = "patch"
patch = application.Project.Contents.Geometry:AddPolygon(properties3)

-- AddCuboid
properties4 = cf.Cuboid.GetDefaultProperties()
properties4.Origin.U = "-22.5"
properties4.Origin.V = "-22.5"
properties4.Width = "substrate_w"
properties4.Depth = "substrate_d"
properties4.Height = "substrate_h"
properties4.LocalWorkplane.WorkplaneDefinitionOption
 = cf.Enums.LocalWorkplaneDefinitionEnum.UsePredefinedWorkplane
properties4.LocalWorkplane.ReferencedWorkplane = globalXY
properties4.Label = "substrate"
substrate = application.Project.Contents.Geometry:AddCuboid(properties4)

-- SetProperties
properties5 = substrate.Regions:Item("Region1"):GetProperties()
properties5.Medium = ceramic
substrate.Regions:Item("Region1"):SetProperties(properties5)

-- AddLine
properties6 = cf.Line.GetDefaultProperties()
properties6.StartPoint.V = "feed_pos"
properties6.EndPoint.U = "0"
properties6.EndPoint.V = "feed_pos"
properties6.EndPoint.N = "substrate_h"
properties6.LocalWorkplane.WorkplaneDefinitionOption
 = cf.Enums.LocalWorkplaneDefinitionEnum.UsePredefinedWorkplane
properties6.LocalWorkplane.ReferencedWorkplane = globalXY
properties6.Label = "feed_line"
feed_line = application.Project.Contents.Geometry:AddLine(properties6)

-- AddUnion
union1 = application.Project.Contents.Geometry:Union({patch, substrate, feed_line})

-- SetProperties
properties7 = union1.Faces:Item("Face8"):GetProperties()
perfectElectricConductor = application.Project.Definitions.Media.PerfectElectricConductor
properties7.Medium = perfectElectricConductor
union1.Faces:Item("Face8"):SetProperties(properties7)

-- ToggleVisibility
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substrate.Faces:Item("Face2"):ToggleVisibility()

-- ToggleVisibility
substrate.Faces:Item("Face2"):ToggleVisibility()

-- SetProperties
properties8 = union1.Faces:Item("Face6"):GetProperties()
properties8.Medium = perfectElectricConductor
union1.Faces:Item("Face6"):SetProperties(properties8)

-- AddWirePort
properties9 = cf.WirePort.GetDefaultProperties()
edge19 = feed_line.Edges:Item("Edge19")
properties9.Wire = edge19
properties9.Label = "Port1"
port1 = application.Project.Contents.Ports:AddWirePort(properties9)

-- AddVoltageSource
properties10 = cf.VoltageSource.GetDefaultProperties()
properties10.Terminal = port1
properties10.Label = "VoltageSource1"
voltageSource1 =
 application.Project.Contents.SolutionConfigurations.GlobalSources:AddVoltageSource(properties10)

-- SetProperties
properties11 = application.Project.Contents.SolutionConfigurations.GlobalFrequency:GetProperties()
properties11.Start = "1.27e9"
properties11.End = "1.85e9"
properties11.RangeType = cf.Enums.FrequencyRangeTypeEnum.Continuous
application.Project.Contents.SolutionConfigurations.GlobalFrequency:SetProperties(properties11)

-- SetProperties
properties12 = application.Project.Mesher.Settings:GetProperties()
properties12.MeshSizeOption = cf.Enums.MeshSizeOptionEnum.Fine
properties12.WireRadius = "07"
properties12.Advanced.GrowthRate = 30
properties12.Advanced.RefinementFactor = 80
properties12.Advanced.MinElementSize = 80
application.Project.Mesher.Settings:SetProperties(properties12)

-- ToggleVisibility
application.Project.Contents.Cutplanes:Item("XZ-Cut"):ToggleVisibility()

-- ToggleVisibility
application.Project.Contents.Cutplanes:Item("XZ-Cut"):ToggleVisibility()

-- SetProperties
properties13 = union1.Edges:Item("Edge6"):GetProperties()
properties13.LocalMeshSizeEnabled = true
properties13.LocalMeshSize = "2"
union1.Edges:Item("Edge6"):SetProperties(properties13)

-- SetProperties
properties14 = union1.Edges:Item("Edge3"):GetProperties()
properties14.LocalMeshSizeEnabled = true
properties14.LocalMeshSize = "2"
union1.Edges:Item("Edge3"):SetProperties(properties14)

-- Add
properties15 = cf.FarField.GetDefaultProperties()
properties15.Theta.End = "180.0"
properties15.Theta.Increment = "5.0"
properties15.Phi.End = "360.0"
properties15.Phi.Increment = "5.0"
properties15.Label = "FarField1"
properties15.LocalWorkplane.WorkplaneDefinitionOption
 = cf.Enums.LocalWorkplaneDefinitionEnum.UsePredefinedWorkplane
properties15.LocalWorkplane.ReferencedWorkplane = globalXY
farField1 =
 application.Project.Contents.SolutionConfigurations:Item("StandardConfiguration1").FarFields:Add(properties15)

-- SaveAs
application:SaveAs("C:/Users/eh/Desktop/Example2.CADFEKO")
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3.4.20 Saving the Model
Save the model to a CADFEKO.cfx file.

1. Save the model using one of the following workflows:

• On the Home tab, in the File group, click the  Save icon.

• Press Ctrl+S to use the keyboard shortcut.

2. Save the model as Patch.cfx.

3. Click Save to close the dialog.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
3 GPS Patch Antenna p.117

3.5 Launching the Solver
Launch the Solver to calculate the results. No requests were added to this model since impedance and
current information are calculated automatically for all voltage and current sources in the model.

1. Launch the Solver using one of the following workflows:

• On the Solve/Run tab, in the Run/Launch group, click the  Feko Solver icon.

• On the application launcher toolbar, click the Feko Solver icon in the  group.

• Press Alt+4 to use the keyboard shortcut.

If the model contains unsaved changes, the Save Model dialog is displayed.

2. Click Yes to save the model and to close the Save Model dialog.

The Feko Solver is launched and the Executing runfeko dialog is displayed. The dialog gives step-by-
step feedback as the simulation progresses.

3. Click Details to expand the Executing runfeko to view the step-by-step feedback.

Figure 88: The Executing runfeko dialog.
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3.6 Viewing the Results in POSTFEKO
Display the model as well as the results using the post-processor component, POSTFEKO.
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3.6.1 Reviewing POSTFEKO and Launching OPTFEKO
Open POSTFEKO from within CADFEKO.

Use one of the following workflows to launch POSTFEKO:

• On the Solve/Run tab, in the Run/Launch group, click the  POSTFEKO icon.

• On the application launcher toolbar, click the POSTFEKO icon in the  group.

• Press Alt+3 to use the keyboard shortcut.

POSTFEKO opens by default with a single 3D view containing the model geometry.
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3.6.2 Viewing the Input Reflection Coefficient
View the input reflection coefficient on a Cartesian graph in dB.

1. On the Home tab, in the Create new display group, click the  Cartesian icon.

2. On the Home tab, in the Add results group, click the  Source data icon. From the drop-down

list, select VoltageSource1.

3. View the input reflection coefficient in dB versus frequency.

a) On the result palette, in the Traces panel, select VoltageSource1.

b) On the Quantity panel, confirm that Reflection coefficient is selected (default option).

c) On the Quantity panel, select the dB check box.

Figure 89: The result palette containing the Traces, Source, Slice and Quantity panels (listed from top to
bottom).

4. Change the legend position to bottom-right.

a) On the Display tab, in the Legend group, click the  Position icon. From the drop-down

list select Overlay bottom right.
5. Remove the graph footer.

a) On the Display tab, in the Display group, click the  Chart text icon.
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b) In the Graph footer field, clear the Auto check box and delete the text.

c) Click OK to apply the text changes and to close the dialog.

Figure 90: The input reflection coefficient in dB versus frequency.
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3.6.3 Viewing the Circular Components of the Far Field
1. On the Home tab, in the Create new display group, click the  Cartesian icon.

2. On the Home tab, in the Add results group, click the  Far field icon. From the drop-down

list, select FarField1.

3. Make a copy of the trace, FarField1.

a) On the result palette, in the Traces panel, select FarField1.

b) Duplicate the trace, FarField1, using one of the following workflows:

• On the Cartesian context tab, on the Trace tab, in the Manage group, click the

 Duplicate trace icon.

• Press Ctrl+K to use the keyboard shortcut.

A trace with label FarField1_1 is created.

4. Rename the trace, FarField1_1.

a) On the result palette, in the Traces panel, select FarField1_1.

b) Press F2 to use the keyboard shortcut and rename the trace to FarField2.

5. View the left-hand circular component of the far field in dB versus frequency.

a) In the Traces panel, select FarField1.

b) On the result palette, in the Quantity panel, click LHC.

c) On the result palette, in the Quantity panel, select the dB check box.

6. View the right-hand circular component of the far field in dB versus frequency.

a) In the Traces panel, select the duplicate trace, FarField2.

b) On the result palette, in the Quantity panel, click RHC.

c) On the result palette, in the Quantity panel, select the dB check box.

7. [Optional] Repeat Step 4 and Step 5 of Viewing the Input Reflection Coefficient to change the
legend position and remove the graph footer.
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Figure 91: The left-hand circular and right-hand circular components of the far field.
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3.7 Final Remarks
This example showed the construction, configuration and solution of a left-handed circular polarised
GPS patch antenna on a finite substrate.

The input reflection coefficient and circular components of the far field were calculated and displayed.
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4 GPS Patch on Quadcopter

The example considers the antenna placement of a GPS patch antenna on a quadcopter.

This chapter covers the following:

• 4.1 Example Overview  (p. 126)

• 4.2 Topics Discussed in Example  (p. 127)

• 4.3 Example Prerequisites  (p. 128)

• 4.4 Creating the Model in CADFEKO  (p. 129)

• 4.5 Launching the Solver  (p. 146)

• 4.6 Viewing the Results in POSTFEKO  (p. 147)

• 4.7 Final Remarks  (p. 149)
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4.1 Example Overview
Calculate the input reflection coefficient and circular components of a left-handed circular polarised GPS
patch antenna on a finite substrate close to 1.57 GHz placed on a quadcopter. Compare the results with
that of Example 3.
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4.2 Topics Discussed in Example
The topics discussed in this example are:

• CADFEKO

◦ Specify the model unit.

◦ Add a component from the component library.

◦ Import a model from a .cfx file.

◦ Create a workplane and perform transformations on the workplane (rotate).

◦ Use the Align tool for antenna placement.

◦ Run the .

◦ Show/hide the simulation mesh in the 3D view.

◦ Show/hide a part in the 3D view.

• POSTFEKO

◦ View the Lua script to set up the graphs (similar to Example 2) for the following:

∙ View the input reflection coefficient on a Cartesian graph.

∙ View the left-hand and right-hand circular components of the far field on a Cartesian
graph.

∙ View an example of a Lua script to configure graphs.

Note:  Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the application macro library[20]:

GS 4: GPS Patch on a Drone

20. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
4 GPS Patch on Quadcopter p.128

4.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1 or later should be installed.

• It is recommended that you watch the demo video before attempting this example.

• This example should not take longer than 40 minutes to complete.

Note:  When using CADFEKO over a remote desktop connection, you may need to enable

3D support for remote desktop[21] for the host's graphics card should a crash occur when
clicking New Project in CADFEKO.

21. See the Troubleshooting section in the Appendix of the Feko User Guide for more details.
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4.4 Creating the Model in CADFEKO
Create the model geometry using the CAD component, CADFEKO.
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4.4.1 Launching CADFEKO (Windows)
There are several options available to launch CADFEKO in Microsoft Windows.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

Figure 92: The Launcher utility.

• Open CADFEKO by double-clicking on a .cfx[22] file.

• Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

Note:  If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

4.4.2 Launching CADFEKO (Linux)
There are several options available to launch CADFEKO in Linux.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

• Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:

/home/user/2025.1/altair/feko/bin/cadfeko

• Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

. /home/user/2025.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

22. A .cfx file is created by CADFEKO and contains the meshed and/or unmeshed CADFEKO model as
well as the calculation requests.
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Note:  Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.
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4.4.3 Setting the Model Unit
Set the model unit to millimeters.

The default unit length in CADFEKO is metres. Since the structure that you will build is small, the model
unit is set to millimetres. All dimensions entered will be in the new model unit.

1. Set the model unit to millimetres using one of the following workflows:

• On the Construct tab, in the Define group, click the  Model unit icon.

• On the status bar, click .

2. On the Model Unit dialog, select Millimetres (mm).

3. Click OK to change the model unit to millimetres and to close the dialog.

Figure 93: The Model Unit dialog.
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4.4.4 Adding a Quadcopter from the Component Library
Select a simplified quadcopter model from the Component library and add it to the project.

1. On the Home tab, in the File group, click the  Component Library icon.

2. On the Component Library dialog, in the Filter field, enter the text quadcopter.

Figure 94: The Component Library dialog.

3. From the filtered results, click Quadcopter - Simple.

4. Click Add to model to add the quadcopter and to close the dialog.

5. On the Align dialog, under Destination workplane, in the Origin field, Z field, enter -100.
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Figure 95: The Align dialog.

Note:  The offset separates the patch from the quadcopter on import.

6. Click OK to place the quadcopter and to close the dialog.

Figure 96: The simple quadcopter model from the component library.
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4.4.5 Importing the GPS Patch
Import the GPS patch antenna (.cfx file) created in Example 3.

1. On the Home tab, in the File group, click the  Import icon. From the drop-down list select the

 CADFEKO Model (*.cfx) icon.

2. On the Import CADFEKO Model dialog, browse to the location of where you saved Example 3[23]

and click OK.

Figure 97: The Import CADFEKO Model dialog.

Figure 98: The imported GPS patch antenna is located above the quadcopter.

3. In the model tree, under Geometry, select Union1, press F2 and rename the part to Patch.

23. Alternatively, open GS 3: GPS Patch Antenna in the application macro library and save the model.
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4.4.6 Setting the Simulation Frequency
Specify the frequency range of interest. For this example continuous frequency sampling is used where
Feko automatically determines the frequency sampling for optimal interpolation.

1. On the Source/Load tab, in the Settings group, click the  Frequency icon.

2. On the Solution Frequency dialog, from the drop-down list, select Continuous (interpolated)
range.

3. In the Start frequency (Hz) field, enter 1.27e9.

4. In the End frequency (Hz), enter 1.85e9.

Figure 99: The Solution Frequency dialog.

5. Click OK to specify the frequency and to close the dialog.
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4.4.7 Hiding Parts of the Model
Entities in the model tree and details tree can be hidden by clicking on the entity’s icon.

1. In the model tree, click the icon next to Patch.
Note that Patch is greyed out in the model tree and hidden in the 3D view.

Figure 100: Patch is greyed out to indicate that the part is hidden in the 3D view.

2. Repeat Step 1 again to make the part visible again in the 3D view.

Tip:  Hide a wire/edge, face or region in the 3D view by clicking its icon in the details tree.
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4.4.8 Hiding the Simulation Mesh
Make the simulation mesh hidden in the 3D view focus on the geometry.

Hide the simulation mesh[24] using one of the following workflows:

• On the status bar, click the  Overlay icon.

• On the 3D View context tab, on the Display Options tab, in the Display Mode group, click the

 Overlay icon.

24. The simulation mesh refers to the final mesh used by the Solver. CAD always has to be meshed.
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4.4.9 Placing the Patch on the Quadcopter
To assist in placing the patch antenna, two workplanes are defined and used in the Align tool.

Rotating the Quadcopter
Rotate the quadcopter by 45°.

1. On the model tree, click Quadcopter_simple1 and from the right-click context menu, click
Transforms > Rotate.

2. On the Rotate dialog, under Rotation angle, in the Angle [degrees] field, enter 45°.

Figure 101: The Rotate dialog.

Figure 102: The quadcopter was rotated by 45°.
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Defining a Workplane on the Quadcopter
Define a workplane on the top face of the quadcopter.

1. On the Construct tab, in the Define group, click the  Add Workplane icon.

Figure 103: The Create Workplane dialog.

2. Press Ctrl+Shift while moving the mouse cursor over the top face centre of the quadcopter.

Note:  The circles with a black outline indicate special snapping points. The red outline
indicates the position of the mouse cursor.

Use snapping points to snap the workplane to an object. Although only special
snapping points are indicated, you can snap to any point in the 3D view.

Figure 104: Special snapping points are indicated by circles with a black outline.
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3. Press Ctrl+Shift+left click to snap the workplane to the top face centre of the quadcopter.

4. In the Label field, change the label to Workplane_quadcopter.

5. Click Create to create the workplane and to close the dialog.

Figure 105: Workplane has snapped to the top centre of the quadcopter.
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Defining a Workplane on the Patch
Define a workplane on the top face of the patch.

1. On the Construct tab, in the Define group, click the  Add Workplane icon.

2. Press Ctrl+Shift+left click to snap the workplane to the top face centre of the patch.

3. Click Create to create Workplane1 and to close the dialog.

Figure 106: Workplane has snapped to the top centre of the quadcopter.

4. In the model tree, under Workplanes, select Workplane1, press F2 and rename the workplane
to Workplane_patch.

Tip:  Transforms can be applied to workplanes. In the model tree, select the workplane and
from the right-click context menu, click Transforms.

Figure 107: A workplane can be rotated by using the right-click context menu option.
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Aligning the Patch and Quadcopter
Align the patch to the quadcopter.

1. In the model tree, select Quadcopter_simple1.

2. On the Transform tab, in the Transform group, click the  Align icon.

3. On the Align dialog, under Source workplane, select Predefined workplane. From the drop-
down list, select Workplane_quadcopter.

Tip:  If Workplane_quadcopter is unavailable in the drop-down list, repeat Step 1.

4. On the Align dialog, under Destination workplane select Predefined workplane. From the
drop-down list, select Workplane_patch.

Figure 108: The Align dialog.

5. Click OK to align the quadcopter to the patch and to close the dialog.

Figure 109: The GPS patch antenna placed on the quadcopter.
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Unioning the Model for Mesh Connectivity
Create a single geometry part from the patch antenna and quadcopter to ensure mesh connectivity
when the model is meshed.

1. In the model tree, select Patch and Quadcopter_simple1.

2. Union the GPS patch antenna and the quadcopter using one of the following workflows:

• On the Construct tab, in the Modify group, click the  Union icon.

• Press U to use the keyboard shortcut.

Note:  The union operation is used to define connectivity between parts.

Parts that touch, but are not unioned, are not considered to be physically connected
and will result in an incorrect mesh.

3. Show the simulation mesh again.

a) On the status bar, click the  Overlay icon.

Figure 110: The patch antenna unioned with the quadcopter.
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4.4.10 Saving the Model
Save the model to a CADFEKO.cfx file.

1. Save the model using one of the following workflows:

• On the Home tab, in the File group, click the  Save icon.

• Press Ctrl+S to use the keyboard shortcut.

2. Save the model as Patch_on_Drone.cfx.

3. Click Save to close the dialog.
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4.5 Launching the Solver
Launch the Solver to calculate the results. No requests were added to this model since impedance and
current information are calculated automatically for all voltage and current sources in the model.

1. Launch the Solver using one of the following workflows:

• On the Solve/Run tab, in the Run/Launch group, click the  Feko Solver icon.

• On the application launcher toolbar, click the Feko Solver icon in the  group.

• Press Alt+4 to use the keyboard shortcut.

If the model contains unsaved changes, the Save Model dialog is displayed.

2. Click Yes to save the model and to close the Save Model dialog.

The Feko Solver is launched and the Executing runfeko dialog is displayed. The dialog gives step-by-
step feedback as the simulation progresses.

3. Click Details to expand the Executing runfeko to view the step-by-step feedback.

Figure 111: The Executing runfeko dialog.
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4.6 Viewing the Results in POSTFEKO
Display the model as well as the results using the post-processor component, POSTFEKO.
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4.6.1 Using a Lua Script to Configure Graphs
View the Lua script to set up the graphs for the input reflection coefficient and circular components of
the far field.

The step-by-step instructions to create this script is beyond the scope of the Feko Getting Started
Guide, but it is recommended to view the script and to compare it with setting up Graph 1 and Graph 2
from Example 3.

app = pf.GetApplication()
-- Graph 1
graph1 = app.CartesianGraphs:Add()
excitationTrace = graph1.Traces:Add(app.Models[1].Configurations[1].Excitations[1])
excitationTrace.Quantity.ValuesScaledToDB = true
graph1.Footer.Text = ""
graph1.Legend.Position = pf.Enums.GraphLegendPositionEnum.OverlayBottomRight

-- Graph 2
graph2 = app.CartesianGraphs:Add()
farFieldTraceLHC = graph2.Traces:Add(app.Models[1].Configurations[1].FarFields[1])
farFieldTraceLHC.Quantity.Type = pf.Enums.FarFieldQuantityTypeEnum.Gain
farFieldTraceLHC.Quantity.Component = pf.Enums.FarFieldQuantityComponentEnum.LHC
farFieldTraceLHC.Quantity.ValuesScaledToDB = true

farFieldTraceRHC = farFieldTraceLHC:Duplicate()
farFieldTraceRHC.Quantity.Type = pf.Enums.FarFieldQuantityTypeEnum.Gain
farFieldTraceRHC.Quantity.Component = pf.Enums.FarFieldQuantityComponentEnum.RHC
farFieldTraceRHC.Label = "FarField2"
    
farFieldTraceRHC.Quantity.ValuesScaledToDB = true
graph2.Footer.Text = ""
graph2.Legend.Position = pf.Enums.GraphLegendPositionEnum.OverlayBottomRight

Note:  For more information regarding scripts and the Feko application programming
interface (API), see the Feko Scripting and API Reference Guide.
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4.7 Final Remarks
This examples showed how to place a GPS patch antenna on a quadcopter that was obtained from the
component library.

The input reflection coefficient and circular components of the far field were calculated and displayed.
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5 EMC Coupling

The example considers the coupling between a typical monopole antenna and a loaded transmission line
above a ground plane.

This chapter covers the following:

• 5.1 Example Overview  (p. 151)

• 5.2 Topics Discussed in Example  (p. 152)

• 5.3 Example Prerequisites  (p. 153)

• 5.4 Creating the Model in CADFEKO  (p. 154)

• 5.5 Launching the Solver  (p. 172)

• 5.6 Viewing the Results in POSTFEKO  (p. 173)

• 5.7 Final Remarks  (p. 179)
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5.1 Example Overview
Consider the coupling between a monopole antenna and a loaded transmission line above a ground
plane.

Create the monopole antenna using a line and the loaded transmission line using a polyline. The ground
plane is modelled using an infinite ground plane.

Figure 112: The monopole antenna and the loaded transmission line above an infinite ground plane.
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5.2 Topics Discussed in Example
Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

• CADFEKO

◦ Create a monopole using a line. Specify the local wire radius for the monopole.

◦ Create the transmission line using a polyline.

◦ Define a ground plane using an infinite ground plane.

◦ Add a port and voltage source to the monopole.

◦ Specify the radiated power of the model.

◦ Add a port and complex load to the transmission line.

◦ Set the solution frequency. Use adaptive frequency sampling to obtain continuous data.

◦ Mesh the model.

◦ Run CEM validate to ensure the model is electromagnetically validated.

◦ Run the Solver.

• POSTFEKO

◦ View the simulated input impedance and currents on a graph.

◦ Change the line colour, marker style, marker colour of a trace on the graph.

◦ Add shapes (line, arrow, rectangle or circle) to highlight certain areas on the graph.

Note:  Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the application macro library[25]:

GS 5: EMC Coupling

25. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.
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5.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1 or later should be installed.

• It is recommended that you watch the demo video before attempting this example.

• This example should not take longer than 30 minutes to complete.

Note:  When using CADFEKO over a remote desktop connection, you may need to enable

3D support for remote desktop[26] for the host's graphics card should a crash occur when
clicking New Project in CADFEKO.

26. See the Troubleshooting section in the Appendix of the Feko User Guide for more details.
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5.4 Creating the Model in CADFEKO
Create the model geometry using the CAD component, CADFEKO.
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5.4.1 Launching CADFEKO (Windows)
There are several options available to launch CADFEKO in Microsoft Windows.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

Figure 113: The Launcher utility.

• Open CADFEKO by double-clicking on a .cfx[27] file.

• Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

Note:  If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

5.4.2 Launching CADFEKO (Linux)
There are several options available to launch CADFEKO in Linux.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

• Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:

/home/user/2025.1/altair/feko/bin/cadfeko

• Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

. /home/user/2025.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

27. A .cfx file is created by CADFEKO and contains the meshed and/or unmeshed CADFEKO model as
well as the calculation requests.
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Note:  Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.
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5.4.3 Creating a Monopole
Create a monopole antenna as a single line element with a local wire radius. Zoom to extents and hide
the main axes to view the full-length monopole in the 3D view.

Create the monopole antenna. The length of the monopole is 12 m along the Z axis.

1. Create a line.

a) On the Construct tab, in the Create Curve group, click the  Line icon.

b) On the Create Line dialog, enter the start point and end point for the line.

• Start point: (0, 0, 0)

• End point: (0, 0, 12)

Note:  Default values are used on geometry creation dialogs to allow a preview in
the 3D view. You may change the values as required.

Figure 114: The Create Line dialog.

2. Set the label to Monopole.

3. Click Create to create the line and close the dialog.

To view the full-length monopole in the 3D window, zoom the monopole to the window extent.

4. Zoom to extents of the 3D view using one of the following workflows:

• On the View tab, in the Zoom group, click the  Zoom to extents icon.

• Press F5 to use the keyboard shortcut.

Disable the main axes to view the monopole without the Z axis obstructing it.
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5. On the 3D View context tab, on the Display Options tab, in the Axes group, click the  Main

Axes icon.

6. Repeat Step 5 to enable the main axes display.
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5.4.4 Creating a Transmission Line
Create a transmission line using a polyline curve with four corners. The length of the polyline is 12 m
along the Y axis, placed 50 mm above ground.

1. On the Construct tab, in the Create Curve group, click the  Polyline icon.

Figure 115: The Create Polyline dialog.

2. Under Corner 1, add the following coordinates:

• Corner 1: (0, 2 0)

3. In the table, click on the second row to make Corner 2 active. Under Corner 2, add the following
coordinates:

• Corner 2: (0, 2, 0.05)

4. Click on Add row. Under Corner 3, add the following coordinates:

• Corner 3: (0, 14, 0.05)

5. Click on Add row. Under Corner 4, add the following coordinates:

• Corner 4: (0, 14, 0)

6. Set the label to Transmission_line.

7. Click Create to create the polyline and to close the dialog.

8. Zoom to extents of the 3D view using one of the following workflows:

• On the View tab, in the Zoom group, click the  Zoom to extents icon.

• Press F5 to use the keyboard shortcut.
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5.4.5 Defining an Infinite Ground Plane
Define a perfectly conducting (PEC) infinite ground plane. An infinite ground plane is an efficient method
to model a large ground plane compared to a discretised, finite sized ground plane.

Define the infinite ground plane.

a) On the Construct tab, in the Structures group, click the  Planes/Arrays icon. From the

drop-down list, select  Plane / Ground.

b) On the Plane / Ground dialog, from the Definition method drop-down list, select Perfect
electric (PEC) ground plane at Z=0.

Figure 116: The Plane / Ground dialog.

c) Click OK to create the infinite plane and to close the dialog.
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5.4.6 Ports, Sources and Loads in CADFEKO
Voltage sources and discrete loads are applied to ports and not directly to the model geometry or mesh.
A port must be defined before a source or load can be added.
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Adding a Wire Port to the Monopole
Define a wire port on the monopole. A voltage source will be added to this port.

1. Select the monopole using one of the following workflows:

• Click on the monopole in the 3D view.

• In the model tree, select Monopole. In the details tree, select Wire1.

Figure 117: Wire1 in the details tree is the wire element associated with Line1 in the model tree.

2. Define the wire port on the selected wire (monopole) using one of the following workflows:

• On the Source/Load tab, in the Ports group, click the  Wire Port icon.

• On the details tree, a right-click context menu is available on the edge. Click Create Port >
Wire Port.

Figure 118: The right-click context menu options for a wire in the details tree.

3. Use the default port settings.
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Figure 119: The Create Wire Port dialog.

4. Click Create to create the port and close the dialog.

Figure 120: Front view of the monopole and its wire port and the transmission line. The port is indicated by a
silver sphere.
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Adding a Wire Port to the Transmission Line
Define a wire port for the transmission line.

1. Select the short, vertical wire in the 3D view located farthest away from the monopole.
The wire element associated with the selected wire is highlighted in the details tree.

2. On the details tree, a right-click context menu is available on the edge. Click Create Port > Wire
Port (see Figure 2).

3. View the port preview in the 3D view to ensure the correct edge is selected.

4. Use the default settings for the port.

Figure 121: The Create Wire Port dialog.

5. Create Create to create the port and close the dialog.

Figure 122: Front view of the monopole and transmission line together with their wire ports. The ports are
indicated by silver spheres.
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Adding a Voltage Source
Add a voltage source to the port of the monopole.

1. On the Source/Load tab, in the Sources on Ports group, click the  Voltage Source icon.

The radiated power must be 1 Watt for this example. Since the input impedance for the monopole is not
known, the voltage can not be changed to scale the radiated power.

2. Ensure WirePort1 is selected in the drop-down list and use the default voltage settings.

3. Click Create to define the voltage source and to close the dialog.

Figure 123: Front view of the monopole and transmission line together with their wire ports. The wire port
with a voltage source applied to it, is indicated by a red sphere.
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Adding a Complex Load to a Port
Add a resistive load to the port of the transmission line.

1. On the Source/Load tab, in the Loads/Networks group, click the  Add Load icon.

2. Specify the port for the load as WirePort2.

3. Set the Real part of the complex impedance to 1000.

4. Click Create to create the load and close the dialog.

Figure 124: Front view of the monopole and transmission line together with their wire ports. The load is
indicated by a blue sphere.
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5.4.7 Setting the Radiated Power Level
Specify the power settings to scale the radiated power.

1. On the Source/Load tab, in the Settings group, click the  Power icon.

The radiated power should be 1 Watt. Power losses as a result of source mismatch are deducted before
the 1 Watt is calculated.

2. Click Total source power (no mismatch).

3. Enter a source power of 1 Watt.

4. Click OK to specify the source power and to close the dialog.
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5.4.8 Setting the Simulation Frequency
Specify the frequency range of interest. For this example continuous frequency sampling is used where
Feko determines the frequency sampling for optimal interpolation automatically.

1. On the Source/Load tab, in the Settings group, click the  Frequency icon.

2. On the Solution Frequency dialog, select Continuous (interpolated) range from the drop-
down list.

Specify the frequency range between 1 MHz and 30 MHz.

3. Enter the start frequency and end frequency.

• Start frequency (Hz): 1e6

• End frequency (Hz): 30e6

Figure 125: The Solution Frequency dialog.

4. Click OK to specify the frequency and to close the dialog.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
5 EMC Coupling p.169

5.4.9 Modifying the Auto-Generated Mesh
When the frequency is set or local mesh settings are applied to the geometry, the automatic mesh
algorithm calculates and creates the mesh automatically while the GUI is active using default mesh
settings. When required, these mesh settings may be modified.

Specify the global wire segment radius to be used in the model.

1. Open the Modify Mesh Settings dialog using one of the following workflows:

• On the Mesh tab, in the Meshing group, click the  Create Mesh icon.

• Press Ctrl+M to use the keyboard shortcut.

2. On the Modify Mesh Settings dialog, set the Wire segment radius to 0.004.

Figure 126: The Modify Mesh Settings dialog.

3. Click OK to create the mesh and to close the dialog.
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5.4.10 Setting a Local Wire Radius for the Monopole
Specify a local wire radius for the monopole.

The monopole and transmission line are each assigned a different wire radius. Due to the differences in
the wire radii, we specify a local wire radius for the monopole.

Note:  Local mesh refinement takes precedence over global mesh settings.

1. In the model tree (Construction tab), select Monopole. In the details tree, select Wire1.

2. From the right-click context menu, select Properties.

3. On the Modify Edge dialog (Properties tab), specify the following:

a) Select the Local wire radius check box.

b) Set the Radius to 0.015.

Figure 127: The Modify Edge dialog.

4. Click OK to apply the properties and to close the dialog.

Note:  The  icon in the details tree indicate that a local wire radius is applied.
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5.4.11 Saving the Model
Save the model to a CADFEKO.cfx file.

1. Save the model using one of the following workflows:

• On the Home tab, in the File group, click the  Save icon.

• Press Ctrl+S to use the keyboard shortcut.

2. Save the model as Coupling.cfx.

3. Click Save to close the dialog.
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5.5 Launching the Solver
Launch the Solver to calculate the results. No requests were added to this model since impedance and
current information are calculated automatically for all voltage and current sources in the model.

1. Launch the Solver using one of the following workflows:

• On the Solve/Run tab, in the Run/Launch group, click the  Feko Solver icon.

• On the application launcher toolbar, click the Feko Solver icon in the  group.

• Press Alt+4 to use the keyboard shortcut.

If the model contains unsaved changes, the Save Model dialog is displayed.

2. Click Yes to save the model and to close the Save Model dialog.

The Feko Solver is launched and the Executing runfeko dialog is displayed. The dialog gives step-by-
step feedback as the simulation progresses.

3. Click Details to expand the Executing runfeko to view the step-by-step feedback.

Figure 128: The Executing runfeko dialog.
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5.6 Viewing the Results in POSTFEKO
Display the model as well as the results using the post-processor component, POSTFEKO.
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5.6.1 Reviewing POSTFEKO and Launching OPTFEKO
Open POSTFEKO from within CADFEKO.

Use one of the following workflows to launch POSTFEKO:

• On the Solve/Run tab, in the Run/Launch group, click the  POSTFEKO icon.

• On the application launcher toolbar, click the POSTFEKO icon in the  group.

• Press Alt+3 to use the keyboard shortcut.

POSTFEKO opens by default with a single 3D view containing the model geometry.
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Viewing the Load Current
View the load current of the transmission line on a Cartesian graph.

1. Create a new Cartesian graph.

a) On the Home tab, in the Create new display group, click the  Cartesian icon.

2. Add the load current to the Cartesian graph.

a) On the Home tab, in the Add results group, click the  Loads/Networks icon. From the

drop-down list, select Load1.

3. View the load current (in dB) versus frequency.

a) On the result palette, on the Traces panel, select Load1.

b) On the Quantity panel, from the drop-down list select Current.
c) On the Quantity panel, select the dB check box.

4. Change the legend position to top-right.

a) On the Display tab, in the Legend group, click the  Position icon. From the drop-down

list select Overlay top right.
5. Remove the graph footer.

a) On the Display tab, in the Display group, click the  Chart text icon.

b) In the Graph footer field, clear the Auto check box and delete the text.

c) Click OK to apply the text changes and to close the dialog.

Figure 129: The load current in dB versus frequency.
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Viewing the Input Impedance
View the source input impedance (real and imaginary) of the transmission line on a Cartesian graph.

1. Create a new Cartesian graph.

a) On the Home tab, in the Create new display group, click the  Cartesian icon.

2. Add the source input impedance to the Cartesian graph.

a) On the Home tab, in the Add results group, click the  Source data icon. From the drop-

down list, select VoltageSource1.

3. View the real part of the impedance and rename the legend text.

a) On the result palette, in the Traces panel, select VoltageSource1.

b) Press F2 and rename the trace to Real.
c) On the Quantity panel, from the drop-down list select Impedance.

d) On the Quantity panel, click Real.
4. Duplicate the VoltageSource1 trace using one of the following workflows:

• On the Cartesian context tab, on the Trace tab, in the Manage group, click the

 Duplicate trace icon.

• Press Ctrl+K to use the keyboard shortcut.

5. View the imaginary part of the impedance and rename the legend text.

a) On the result palette, in the Traces panel, select VoltageSource1_1.

b) Press F2 and rename the trace to Imaginary.

c) On the Quantity panel, click Imaginary.

6. [Optional] Repeat Step 4 and Step 5 of Viewing the Load Current to change the legend position
and remove the graph footer.
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Figure 130: The input impedance (real and imaginary) versus frequency.
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Formatting the Graph
Format the line colour, marker colour and marker style of a trace. Add a line, arrow (single or double),
rectangle or circle to the graph to highlight certain aspects of the graph.

1. Select a trace to format.

a) On the result palette, in the traces panel, select VoltageSource1_1.

2. Change the line colour to red.

a) On the Format tab, in the Line group, click the  Line colour icon. From the drop-down

list, select the colour red.

3. Change the marker style to a triangle.

a) On the Format tab, in the Marker group, click the  Marker style icon. From the drop-

down list select the triangle.

4. Change the marker colour to match the colour of the trace.

a) On the Format tab, in the Marker group, click the  Marker colour icon. From the drop-

down list select the colour red.

Figure 131: An example of a formatted graph.

5. [Optional] Add a line, arrow, double arrow, rectangle or circle to the graph to highlight an aspect
on the graph.

a) On the Format tab, in the Drawing group, click the  Shapes icon. Select the required

item from the drop-down list.
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5.7 Final Remarks
This example showed the construction, configuration and solution of an EMC coupling scenario. The
model consists of a monopole antenna and transmission line on an infinite PEC ground plane. Coupling
of current into the transmission line is viewed from 1 MHz to 30 MHz.
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6 Waveguide Power Divider

The example considers the transmission and reflection coefficients of a waveguide power divider.

This chapter covers the following:

• 6.1 Example Overview  (p. 181)

• 6.2 Topics Discussed in Example  (p. 182)

• 6.3 Example Prerequisites  (p. 183)

• 6.4 Creating the Model in CADFEKO  (p. 184)

• 6.5 Launching the Solver  (p. 206)

• 6.6 Reviewing POSTFEKO and Launching OPTFEKO  (p. 207)

• 6.7 Final Remarks  (p. 211)
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6.1 Example Overview
Calculate the transmission and reflection coefficients of a waveguide power divider.

Create the power divider to split equally the power between the two output ports while minimising
any power reflected back to the source port. The power is split by placing a metal pin at the junction
between the three waveguide sections. The model utilises symmetry to reduce memory requirements
and calculation speed.

Figure 132: The waveguide power divider and instantaneous near field.
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6.2 Topics Discussed in Example
Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

• CADFEKO

◦ Create the pin using a cylinder.

◦ Create the waveguide sections using cuboids.

◦ Define waveguide ports on each end of the waveguide.

◦ Add a waveguide source.

◦ Set the solution frequency.

◦ Specify local (fine) meshing for the waveguide ports.

◦ Specify symmetry to save computational resources.

◦ Specify near fields on a plane inside the waveguide.

◦ Mesh the model.

◦ Run CEM validate to ensure the model is electromagnetically validated.

◦ Run the Solver.

• POSTFEKO

◦ View the simulated input reflection coefficient on a graph.

◦ View the instantaneous near field inside the waveguide.

◦ View an animation of the near fields.

Note:  Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the application macro library[28]:

GS 6: Waveguide Power Divider

28. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.
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6.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1 or later should be installed.

• It is recommended that you watch the demo video before attempting this example.

• This example should not take longer than 30 minutes to complete.

Note:  When using CADFEKO over a remote desktop connection, you may need to enable

3D support for remote desktop[29] for the host's graphics card should a crash occur when
clicking New Project in CADFEKO.

29. See the Troubleshooting section in the Appendix of the Feko User Guide for more details.
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6.4 Creating the Model in CADFEKO
Create the model geometry using the CAD component, CADFEKO.
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6.4.1 Launching CADFEKO (Windows)
There are several options available to launch CADFEKO in Microsoft Windows.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

Figure 133: The Launcher utility.

• Open CADFEKO by double-clicking on a .cfx[30] file.

• Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

Note:  If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

6.4.2 Launching CADFEKO (Linux)
There are several options available to launch CADFEKO in Linux.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

• Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:

/home/user/2025.1/altair/feko/bin/cadfeko

• Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

. /home/user/2025.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

30. A .cfx file is created by CADFEKO and contains the meshed and/or unmeshed CADFEKO model as
well as the calculation requests.
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Note:  Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
6 Waveguide Power Divider p.187

6.4.3 Setting the Model Unit
Set the model unit to millimeters.

The default unit length in CADFEKO is metres. Since the structure that you will build is small, the model
unit is set to millimetres. All dimensions entered will be in the new model unit.

1. Set the model unit to millimetres using one of the following workflows:

• On the Construct tab, in the Define group, click the  Model unit icon.

• On the status bar, click .

2. On the Model Unit dialog, select Millimetres (mm).

3. Click OK to change the model unit to millimetres and to close the dialog.

Figure 134: The Model Unit dialog.
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6.4.4 Adding Variables
Define variables to create a parametric model.

A model is parametric when it is created using variable expressions. When a variable expression is
modified, any items dependent on that variable are re-evaluated and automatically updated. It is the
recommended construction method when creating a model, but not compulsory.

Defined variables are stored as part of the model in the .cfx file.

1. Open the Create Variable dialog using one of the following workflows:

• On the Construct tab, in the Define group, click the  Add Variable icon.

• On the model tree, a right-click context menu is available on Variables. From the list, select
Add Variable.

Figure 135: The model tree (Construction tab).

• On the model tree, click the  icon. From the drop-down list, select Add Variable.
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Figure 136: The  drop-down list available in the model tree.

• Press # to use the keyboard shortcut.

2. Create the following variables:

a) Optional: Add the variable comments.

Name Expression Comment

freq 9e9 The operating frequency.

lambda c0/freq*1000 Free space wavelength.

pin_r 1 Pin radius.

wg_h 10 Waveguide height.

wg_w 20 Waveguide width.

Tip:

• Click Add to keep the Create Variable dialog open and add more variables.

• Click Create to add a variable and close the Create Variable dialog.
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6.4.5 Creating the Power Dividing Pin
Create the power dividing pin using a cylinder.

1. Create a cylinder located at the origin along the Z axis.

a) On the Construct tab, in the Create Solid group, click the  Cylinder icon.

b) Create a cylinder using the Base centre, radius, height definition method.

c) Use the following dimensions:

• Radius (R): pin_r

• Height (H): wg_h

Note:  Default values are used on geometry creation dialogs to allow a preview in the
3D view. You may change the values as required.

a) Click Create to create the cylinder and to close the dialog.

Figure 137: The Create Cylinder dialog.

2. Zoom to extents of the 3D view using one of the following workflows:

• On the View tab, in the Zoom group, click the  Zoom to extents icon.

• Press F5 to use the keyboard shortcut.
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6.4.6 Creating the Waveguide Sections
Create the waveguide sections using two cuboids.

1. Create the first waveguide section.

a) On the Construct tab, in the Create Solid group, click the  Cuboid icon.

b) Create the cuboid using the Base centre, width, depth, height definition method.

c) Use the following dimensions:

• Base centre (C): (0, 0, 0)

• Width (W): wg_w

• Depth (D): 2*wg_w

• Height (H): wg_h

• Label: Cuboid1

Figure 138: The Create Cuboid dialog.

d) Click OK to create the waveguide section and to close the dialog.

2. Create the second waveguide section.

a) On the Construct tab, in the Create Solid group, click the  Cuboid icon.

b) Create the cuboid using the Base corner, width, depth, height definition method.

c) Use the following dimensions:

• Base corner (C): (wg_w/2, -wg_w/2, 0)
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• Width (W): wg_w

• Depth (D): wg_w

• Height (H): wg_h

• Label: Cuboid2

Figure 139: The Create Cuboid dialog.

d) Click OK to create the waveguide section and to close the dialog.

Figure 140: The two waveguide sections and power dividing pin.
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6.4.7 Unioning the Geometry for Mesh Connectivity
Union the geometry (Cuboid1 and Cuboid2) to create a single geometry part. A single geometry part
will ensure mesh connectivity when the model is meshed.

1. In the model tree, select Cuboid1 and Cuboid2[31].

Tip:  To select multiple objects, press and hold Ctrl while you click the items.

Figure 141: Cuboid1 and Cuboid2 selected in the model tree.

2. On the Construct tab, in the Modify group, click the  Union icon.

Figure 142: The model tree showing Union1 (the union between Cuboid1 and Cuboid2).

31. Alternative method is to select the items in the 3D view.
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6.4.8 Removing Redundant Faces
Use the simplify tool to remove redundant faces.

1. In the model tree, select Union1.

2. On the Transform tab, in the Simplify group, click the  Simplify icon.

3. Use the default settings on the Simplify dialog.

Figure 143: The Simplify dialog.

4. Click Create to simplify Union1 and to close the dialog.

The redundant face at the junction between the two cuboids is removed.

Figure 144: The waveguide section after the redundant faces were removed.
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6.4.9 Changing the Waveguide to a Shell (Hollow) Part
Change the solid waveguide part to a shell (hollow) part with metal walls.

1. In the model tree, select Union1.

2. In the details tree, under Regions, select Region1.

3. From the right-click context menu, select Properties.

Figure 145: The right-click context menu options available for regions.

4. On the Modify Region dialog (Properties tab), set Medium to Free space.

Figure 146: The Modify Region dialog.

5. Click OK to modify the region properties and to close the dialog.
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6.4.10 Unioning the Waveguide and Power Dividing Pin
Create a single geometry part from the waveguide and power divider pin to ensure mesh connectivity
when the model is meshed.

1. In the model tree, select Cylinder1 and Union1[32].

Tip:  To select multiple objects, press and hold Ctrl while you click the items.

2. On the Construct tab, in the Modify group, click the  Union icon.

Figure 147: Select Cylinder1 and Union1 in the model tree.

32. Alternative method is to select the items in the 3D view.
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6.4.11 Ports, Sources and Loads in CADFEKO
Voltage sources and discrete loads are applied to ports and not directly to the model geometry or mesh.
A port must be defined before a source or load can be added.
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Adding Waveguide Ports
Define waveguide ports with the correct orientation.

Note:  A port is a mathematical representation of where energy can enter (source) or leave
a model (sink). Use a port to add sources and discrete loads to a model.

Waveguide ports without sources are considered to be absorbing waveguide terminations.

1. Add the first waveguide port on the face at the most positive X position.

a) In the 3D view, repeatedly left-click until the face is highlighted.

Figure 148: The face at the most positive X position is selected.

b) Open the Create Waveguide Port dialog using one of the following workflows:

• On the Source/Load tab, in the Ports group, click the  Waveguide Port icon.

• In the details tree, a right-click context menu is available on the face. From the list, click
Create Port > Waveguide Port.

Figure 149: The Create Waveguide Port dialog.

c) Use the default settings for the port.
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Figure 150: The preview of the waveguide port is displayed in green.

Note:  The white line is the reference vector and shows the direction of m, where
m is the number of half-wavelengths across the width of the waveguide.

d) Click Add to add the waveguide port, but do not close the dialog.

2. Add the second waveguide port at the face at the most negative Y position.

a) On the dialog, click on the Face user input field to make it active. An active field is
highlighted in blue (see Figure 149).

b) In the 3D view, repeatedly left-click until the face is highlighted.

c) Click Add to add the waveguide port, but do not close the dialog.

3. Add the third waveguide port at the face at the most positive Y position.

a) On the dialog, click on the Face field to make it active. An active field is highlighted in blue.

b) In the 3D view, repeatedly left-click until the face is highlighted.

c) Click 180 degrees to ensure the correct reference direction.

d) Click Create to add the port and to close the dialog.

4. Enable the port annotations. On the 3D View context tab, on the Display Options tab, in the

Entity Display group, click the  Port Annotations icon.

Figure 151: The waveguide power divider with three defined waveguide ports.
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Adding a Waveguide Source
Add a waveguide source to the first port using the fundamental mode.

Note:  Default values are used in this example. The fundamental mode for this source will
be excited (TE10).

Add multiple modes as a single source by selecting Specify modes manually.

1. On the Source/Load tab, in the Sources on Ports group, click the

 Waveguide Source icon.

2. In the drop-down list, select WaveguidePort1.

Figure 152: The Create Waveguide Source dialog.

3. Click Create to create the source and to close the dialog.

Figure 153: A port with a source is indicated in red.
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6.4.12 Setting the Simulation Frequency
Specify the frequency range of interest.

1. On the Source/Load tab, in the Settings group, click the  Frequency icon.

A variable was created at the beginning of the example that contains the solution frequency.

2. In the Frequency (Hz) field, enter freq.

3. Click OK to close the dialog.

With the frequency set to freq, the actual frequency is 9 GHz. In the model tree, click the
Configuration tab to view the specified simulation frequency.
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6.4.13 Adding a Near Field Request
Add a near field request to calculate the fields on a surface through the centre of the waveguide.

1. On the Request tab, in the Solution Requests group, click the  Near Fields icon.

2. On the Request near fields dialog, enter the values as indicated.

Dimension Start End Number of Field Points

U -10 30 32

V -20 20 32

N wg_h/2 wg_h/2 1

3. Clear the Sample on edges check box.

Note:  A near field request on PEC boundaries will result in a warning by the Solver.

4. In the Label field, use the default (NearField1).

5. Click Create to add the near field request and to close the dialog.
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6.4.14 Setting Local Mesh Sizes for Waveguide Port Faces
Refine the mesh locally at the waveguide port faces. The faces for the waveguide ports require a finer
mesh to represent the highest mode that should be taken into account. The higher order modes are
typically evanescent modes.

1. In the 3D view, select the three waveguide port faces.

2. From the right-click context menu, select Properties.

3. On the Multiple Entities dialog (Meshing tab), specify the following:

a) Select the Local mesh size check box.

b) Set the Mesh size to lambda/20.

Figure 154: The Multiple Entities (Meshing tab) dialog.

4. Click OK to apply the properties and to close the dialog.

Figure 155: Note the localised mesh refinement at the waveguide port faces.
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Note:  The  icon in the details tree indicate that a local mesh setting is applied.
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6.4.15 Saving the Model
Save the model to a CADFEKO.cfx file.

1. Save the model using one of the following workflows:

• On the Home tab, in the File group, click the  Save icon.

• Press Ctrl+S to use the keyboard shortcut.

2. Save the model as Waveguide_Divider.cfx.

3. Click Save to close the dialog.
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6.5 Launching the Solver
Launch the Solver to calculate the results. No requests were added to this model since impedance and
current information are calculated automatically for all voltage and current sources in the model.

1. Launch the Solver using one of the following workflows:

• On the Solve/Run tab, in the Run/Launch group, click the  Feko Solver icon.

• On the application launcher toolbar, click the Feko Solver icon in the  group.

• Press Alt+4 to use the keyboard shortcut.

If the model contains unsaved changes, the Save Model dialog is displayed.

2. Click Yes to save the model and to close the Save Model dialog.

The Feko Solver is launched and the Executing runfeko dialog is displayed. The dialog gives step-by-
step feedback as the simulation progresses.

3. Click Details to expand the Executing runfeko to view the step-by-step feedback.

Figure 156: The Executing runfeko dialog.
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6.6 Reviewing POSTFEKO and Launching OPTFEKO
Open POSTFEKO from within CADFEKO.

Use one of the following workflows to launch POSTFEKO:

• On the Solve/Run tab, in the Run/Launch group, click the  POSTFEKO icon.

• On the application launcher toolbar, click the POSTFEKO icon in the  group.

• Press Alt+3 to use the keyboard shortcut.

POSTFEKO opens by default with a single 3D view containing the model geometry.
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6.6.1 Viewing the Input Reflection Coefficient
Plot the input reflection coefficient on a Cartesian graph in dB.

The model was solved at a single frequency only. Therefore the graph will contain a single data point.

1. Create a new Cartesian graph.

a) On the Home tab, in the Create new display group, click the  Cartesian icon.

2. Add the input reflection coefficient to the Cartesian graph.

a) On the Home tab, in the Add results group, click the  Source data icon. From the drop-

down list, select WaveguideSource1.

3. View the input reflection coefficient in dB.

a) On the result palette, in the Traces panel, select WaveguideSource1.

b) On the Quantity panel, select the dB check box.

4. Change the legend position to top-right.

a) On the Display tab, in the Legend group, click the  Position icon. From the drop-down

list select Overlay top right.
5. Remove the graph footer.

a) On the Display tab, in the Display group, click the  Chart text icon.

b) In the Graph footer field, clear the Auto check box and delete the text.

c) Click OK to apply the text changes and to close the dialog.

6. [Optional] Add annotations to the graph.

a) On the Cartesian context tab, on the Measure tab, on the Custom annotations group,

click the  Point icon. From the drop-down list, click  Global maximum.
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Note:  The power reflected back to Port1 is more than 30 dB lower than the power
applied to the same port.
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6.6.2 Viewing the Near Fields
Display the calculated near fields in the 3D view. Animate the instantaneous near field.

1. Select the 3D View1 window.

2. Enable mesh opacity to view the near field inside the waveguide.

a) On the 3D View contextual tabs set, on the Mesh tab, in the Opacity group, click the

 Mesh opacity icon. From the drop-down list, select a value of 40%.

3. On the Home tab, in the Add results group, click the  Near Fields icon. From the drop-down

list, select NearField1.

4. Animate the phase of the near field.

a) In the result palette, in the Quantity panel, select Instantaneous magnitude.

b) On the 3D View contextual tabs set, on the Animate tab, on the Settings group, click the

 Type icon. From the drop-down list, select the  Phase icon.

5. Start the animation process.

a) On the 3D View contextual tabs set, on the Animate tab, on the Control group, click the

 Play icon.

b) Stop the animation by clicking the  Play icon again.

Figure 157: The near field in the power divider (refer to the WebHelp to view the animation of the instantaneous
magnitude).
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6.7 Final Remarks
This example showed the construction, configuration and solution of a waveguide power divider. The
model consists of a hollow cuboidal sections with a cylinder (pin) in the centre. The near field and input
reflection coefficient was calculated and displayed.
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7 Optimisation of Bent Dipole and Plate

The example considers the optimisation of the gain of a bent dipole in front of a plate.

This chapter covers the following:

• 7.1 Example Overview  (p. 213)

• 7.2 Topics Discussed in this Example  (p. 214)

• 7.3 Example Prerequisites  (p. 215)

• 7.4 Creating the Model in CADFEKO  (p. 216)

• 7.5 Launching the Solver  (p. 234)

• 7.6 Reviewing POSTFEKO and Launching OPTFEKO  (p. 235)

• 7.7 Closing Remarks  (p. 242)
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7.1 Example Overview
Calculate and maximise the gain of a bent dipole in front of a plate. Optimise the dipole-plate
separation distance and the dipole bend-angle.

The goal is to maximize the maximum gain in the azimuth plane at a single frequency.

Figure 158: Sketch of the model showing dimensions and other relevant parameters.
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7.2 Topics Discussed in this Example
Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

• CADFEKO

◦ Define an optimisation search in CADFEKO.

◦ Run the optimiser (OPTFEKO).

◦ Add a wire port to a wire segment.

◦ Specify symmetry to save computational resources.

◦ Add a voltage source to a wire port.

◦ Mesh the model.

◦ Run CEM validate to ensure the model is electromagnetically validated.

◦ Run the Solver

• POSTFEKO

◦ View the optimisation results in POSTFEKO.

Note:  Follow the example steps in the order it is presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the application macro library[33]:

GS 7: Optimisation of a Bent Dipole and Plate

33. The application macro library is located on the Home tab, in the Scripting group. Click the
Application Macro icon and from the drop-down list, select Getting Started Guide.
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7.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1 or later should be installed.

• It is recommended that you watch the demo video before attempting this example.

• This example should not take longer than 20 minutes to complete.

Note:  When using CADFEKO over a remote desktop connection, you may need to enable

3D support for remote desktop[34] for the host's graphics card should a crash occur when
clicking New Project in CADFEKO.

34. See the Troubleshooting section in the Appendix of the Feko User Guide for more details.
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7.4 Creating the Model in CADFEKO
Create the model geometry using the CAD component, CADFEKO.
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7.4.1 Launching CADFEKO (Windows)
There are several options available to launch CADFEKO in Microsoft Windows.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

Figure 159: The Launcher utility.

• Open CADFEKO by double-clicking on a .cfx[35] file.

• Open CADFEKO from other components, for example, from inside POSTFEKO or EDITFEKO.

Note:  If the application icon is used to launch CADFEKO, no model is loaded and the
start page is shown. Launching CADFEKO from other Feko components automatically
loads the model.

7.4.2 Launching CADFEKO (Linux)
There are several options available to launch CADFEKO in Linux.

Launch CADFEKO using one of the following workflows:

• Open CADFEKO using the Launcher utility.

• Open a command terminal. Use the absolute path to the location where the CADFEKO executable
resides, for example:

/home/user/2025.1/altair/feko/bin/cadfeko

• Open a command terminal. Source the “initfeko” script using the absolute path to it, for example:

. /home/user/2025.1/altair/feko/bin/initfeko

Sourcing initfeko ensures that the correct Feko environment is configured. Type cadfeko and
press Enter.

35. A .cfx file is created by CADFEKO and contains the meshed and/or unmeshed CADFEKO model as
well as the calculation requests.
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Note:  Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko for the changes to be applied to the current shell and not a
sub-shell.
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7.4.3 Adding Variables
Define variables to create a parametric model.

A model is parametric when it is created using variable expressions. When a variable expression is
modified, any items dependent on that variable are re-evaluated and automatically updated. It is the
recommended construction method when creating a model, but not compulsory.

Defined variables are stored as part of the model in the .cfx file.

1. Open the Create Variable dialog using one of the following workflows:

• On the Construct tab, in the Define group, click the  Add Variable icon.

• On the model tree, a right-click context menu is available on Variables. From the list, select
Add Variable.

Figure 160: The model tree (Construction tab).

• On the model tree, click the  icon. From the drop-down list, select Add Variable.
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Figure 161: The  drop-down list available in the model tree.

• Press # to use the keyboard shortcut.

2. Create the following variables:

Name Expression

alpha 60

alpha_rad alpha*pi/180

d 0.25

lambda 1

freq c0/lambda

Tip:

• Click Add to keep the Create Variable dialog open and add more variables.

• Click Create to add a variable and close the Create Variable dialog.
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7.4.4 Creating the Bent Dipole
Create the bent dipole using a polyline.

To illustrate the usage of custom workplanes, the bent dipole is created using a custom workplane.

1. On the Construct tab, in the Create Curve group, click the  Polyline icon.

Figure 162: The Create Polyline dialog showing the default values. Active fields are outlined in yellow.

Note:  Default values are used on geometry creation dialogs to allow a preview in the
3D view. You may change the values as required.

Tip:  An active field allowing point-entry is indicated by a yellow outline.

Point-entry allows a variable or named points to be entered by pressing
Ctrl+Shift+left click on a variable or named point in the model tree.

2. Create a polyline.

a) Under Corner 1, add the following coordinates:

• Corner 1:

◦ U: lambda/4*cos(alpha_rad)

◦ V: 0

◦ N: lambda/4*sin(alpha_rad)

b) In the table, click on the second row to make Corner 2 active. Add the following
coordinates:
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• Corner 2:

◦ U: 0

◦ V: 0

◦ N: 0

c) Click Add row for Corner 3. Click on the third row to make Corner 3 active. Add the
following coordinates:

• Corner 3:

◦ U: lambda/4*cos(alpha_rad)

◦ V: 0

◦ N: -lambda/4*sin(alpha_rad)

d) Set the Label to Bent_dipole.

3. Modify the origin and orientation of the polyline.

a) Click the Workplane tab.

b) Click Custom workplane.

c) Under Origin, in the X field, enter d.

d) Under U Vector, in the X field, enter -1.

4. Click Create to create the polyline and to close the dialog.

Figure 163: The bent dipole with corner point on the X axis.
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7.4.5 Creating the Plate
Create the plate with a vertical orientation located at the origin using a rectangle.

1. On the Construct tab, in the Create Surface group, click the  Rectangle icon.

2. Create a rectangle using the Base centre, width, depth definition method.

a) Base centre (C): (0, 0, 0)

b) Width (W): lambda

c) Depth (D): lambda

d) Label: Reflector

Figure 164: The Create Rectangle dialog.

3. Modify the orientation of the rectangle.

a) On the Create Rectangle dialog, click the Workplane tab.

b) Click Predefine workplane.

c) From the drop-down list, select Global YZ.

4. Click Create to create the rectangle and to close the dialog.
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7.4.6 Ports, Sources and Loads in CADFEKO
Voltage sources and discrete loads are applied to ports and not directly to the model geometry or mesh.
A port must be defined before a source or load can be added.
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Creating the Port
Define a wire port on the feed pin to excite the dipole. A voltage source will be added to this port.

Note:  A port is a mathematical representation of where energy can enter (source) or leave
a model (sink). Use a port to add sources and discrete loads to a model.

1. Select the wire where the port is to be added.

a) In the model tree, select Bent_dipole.

b) In the details tree, select one of the wires of Bent_dipole.

2. Open the Create Wire Port dialog using one of the following workflows:

• On the Source/Load tab, in the Ports group, click the  Wire Port icon.

• In the details tree, a right-click context menu is available on the wire. From the drop-down
list, click Create port > Wire Port.

3. Under Place port on, click Segment.

Figure 165: The Create Wire Port dialog.

4. Under Location on wire, select End to place the port on the X axis for the selected wire.

5. Click Create to create the port and to close the dialog.
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Adding a Voltage Source
Add a voltage source to the port of the bent dipole.

1. On the Source/Load tab, in the Sources on Ports group, click the  Voltage Source icon.

2. On the Add Voltage Source dialog, use the default settings.

Figure 166: The Create Voltage Source dialog.

3. Click Create to create the voltage source and to close the dialog.

Note:  The Configuration tab was selected automatically when you defined the
voltage source. You may also add sources, loads and set the frequency from here.
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7.4.7 Setting the Simulation Frequency
Specify the frequency range of interest. For this example, a single frequency point is used.

1. On the Source/Load tab, in the Settings group, click the  Frequency icon.

A variable was created at the beginning of the example that contains the solution frequency.

2. In the Frequency (Hz) field, enter freq.

Figure 167: The Solution Frequency dialog.

3. Click OK to set the frequency and to close the dialog.

Note:  With the frequency set to freq, the actual frequency is 299.792 MHz. In the
model tree, click the Configuration to view the specified simulation frequency.
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7.4.8 Requesting Far Fields
Add a far field request (in the azimuth direction) to the model.

1. On the Request tab, in the Solution Requests group, click the  Far Fields icon.

2. On the Request Far fields dialog, click Horizontal cut (UV plane).

Figure 168: The Request Far Fields dialog.

3. Use the default label.

4. Click Create to create a far field request and to close the dialog.
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7.4.9 Defining an Optimisation Search
Add an optimisation search to maximise the maximum gain in the azimuth direction.

1. On the Request tab, in the Optimisation group, click the  Add Search icon.

2. On the Create Optimisation Search dialog, set the Optimisation convergence accuracy to
Normal (default).

3. Click Create to create the new optimisation search and to close the dialog.

Figure 169: The Create Optimisation Search dialog.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
7 Optimisation of Bent Dipole and Plate p.230

7.4.10 Specifying the Optimisation Parameters
Specify the optimisation parameters. Choose from existing variables and specify their minimum and
maximum values

1. In the model tree (Construction tab), select the relevant search. On the Request tab, in the

Optimisation group, click the  Parameters icon.

2. Populate the fields on the Modify Optimisation Parameters dialog as given in the table.

Variable Min value Max value Start value

alpha 20 110 80

d 0.7 0.9 0.8

3. Click OK to set the parameters and to close the dialog.
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7.4.11 Specifying the Far Field Goal
Specify the goal focus, the operations to perform on the goal, and the goal objective.

1. In the model tree, on the Construction tab, select OptimisationSearch1.

2. On the Request  tab, in the Optimisation group, click the  Add Goal Function icon. From

the drop down list, select  Far Field Goal.

3. Under Goal focus, specify the requested output from the Solver.

a) Under Focus source type, select Defined in CADFEKO.

b) In the Focus source field, from the drop-down list, select FarField1.

c) In the Focus type field, from the drop-down list select Gain.

d) In the Polarisation field, from the drop-down list select Total.
4. Under Focus processing steps, specify the processing to be performed prior to comparing with

the objective.

a) In the Operation column, from the drop-down list, select Max.

5. Under Goal operator, specify how the objective and focus is compared.

a) In the Operator type drop-down list, select Maximise to maximise the gain.

• The Goal objective is the value or values with which the focus is compared. For
maximisation and minimisation the Goal objective is hidden.

• For multiple goals, the Weight will determine the contribution of the particular goal to
the global error function during the fitness evaluation.

Figure 170: The Create Far Field Goal dialog.

6. Click Create to create the new far field goal and to close the dialog.
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7.4.12 Modifying the Auto-Generated Mesh
When the frequency is set or local mesh settings are applied to the geometry, the automatic mesh
algorithm calculates and creates the mesh automatically while the GUI is active using default mesh
settings. When required, these mesh settings may be modified.

1. Open the Modify Mesh Settings dialog using one of the following workflows:

• On the Mesh tab, in the Meshing group, click the  Create Mesh icon.

• Press Ctrl+M to use the keyboard shortcut.

2. On the Modify Mesh Settings, set the Mesh size to Coarse.

3. Set the Wire segment radius to 0.001.

Figure 171: The Modify Mesh Settings dialog.

4. Click OK to create the mesh and to close the dialog.
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7.4.13 Saving the Model
Save the model to a CADFEKO.cfx file.

1. Save the model using one of the following workflows:

• On the Home tab, in the File group, click the  Save icon.

• Press Ctrl+S to use the keyboard shortcut.

2. Save the model as Dipole_Optimisation.cfx.

3. Click Save to close the dialog.
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7.5 Launching the Solver
Launch the Solver to calculate the results. No requests were added to this model since impedance and
current information are calculated automatically for all voltage and current sources in the model.

1. Launch the Solver using one of the following workflows:

• On the Solve/Run tab, in the Run/Launch group, click the  Feko Solver icon.

• On the application launcher toolbar, click the Feko Solver icon in the  group.

• Press Alt+4 to use the keyboard shortcut.

If the model contains unsaved changes, the Save Model dialog is displayed.

2. Click Yes to save the model and to close the Save Model dialog.

The Feko Solver is launched and the Executing runfeko dialog is displayed. The dialog gives step-by-
step feedback as the simulation progresses.

3. Click Details to expand the Executing runfeko to view the step-by-step feedback.

Figure 172: The Executing runfeko dialog.
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7.6 Reviewing POSTFEKO and Launching OPTFEKO
Open POSTFEKO from within CADFEKO.

Use one of the following workflows to launch POSTFEKO:

• On the Solve/Run tab, in the Run/Launch group, click the  POSTFEKO icon.

• On the application launcher toolbar, click the POSTFEKO icon in the  group.

• Press Alt+3 to use the keyboard shortcut.

POSTFEKO opens by default with a single 3D view containing the model geometry.
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7.6.1 Setting Up POSTFEKO to View Optimisation Progress
Create a 3D view with the far field results as well as two Cartesian graph to view the distance
parameter and far field goal.

When POSTFEKO is opened, the model is displayed in a single 3D view.

1. Display the far field in the 3D view.

a) On the Home tab, in the Add results group, click the  Far field icon.

b) From the drop-down list select FarField1.

Figure 173: The far field result for the bent dipole and plate.

2. Add a Cartesian graph and view the optimised parameter, alpha.

a) On the Home tab, in the Create new display group, click the  Cartesian icon.

b) On the Home tab, in the Add results group, click the  Optimisation icon. From the

drop-down list, select Optimisation.

c) In the result palette, in the Trace list, select alpha.

Figure 174: The Optimisation panel in the result palette.

3. Duplicate the first graph (to create a second graph) to view the optimised parameter, d.
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a) On the Cartesian context tab, on the Display tab, in the Duplicate group, click the

 Duplicate view icon.

b) In the result palette select the trace, Optimisation.

c) In the result palette, in the Trace  field, select d.

4. Duplicate the first graph (to create the third graph) and view the far field goal versus optimisation
run number.

a) On the Cartesian context tab, on the Display tab, in the Duplicate group, click the

 Duplicate view icon.

b) In the result palette select the trace, Optimisation.

c) In the result palette, in the Trace field, select
optimisationsearch1.goals.farfieldoptimisationgoal1.

5. [Optional] Arrange (tile) the four windows to view the multiple windows at once.

a) On the View tab, in the Window, click the  Tile icon.

Proprietary Information of Altair Engineering



Altair Feko 2025.1
7 Optimisation of Bent Dipole and Plate p.238

7.6.2 Launching OPTFEKO
Run OPTFEKO and view the output of the optimisation progress.

The following steps are performed in POSTFEKO, but the optimiser can also be launched from CADFEKO

1. On the Home tab, in the Run/Launch group, click the  OPTFEKO icon.

Note:  The Executing optfeko dialog is displayed in a condensed format.

Click Details to view any problems encountered during the optimisation process.

Figure 175: The Executing optfeko dialog in condensed format.

2. Scroll to the bottom of the Executing optfeko window output to view the convergence
information, as well as the optimal parameters.

Note:  Sensitivity information is included if sufficient data is available for the analysis.

Figure 176: The Executing optfeko dialog with details.

The Executing optfeko window displays the optimum values as follows:
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• alpha: 83.733°

• d: 0.782 meters
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7.6.3 Viewing the Optimisation Results
View the optimisation results obtained by OPTFEKO.

The graphs have already been configured to view the progress of the optimisation process.

View the final results of OPTFEKO for the optimisation parameters on the previously defined 3D view
and 2D graphs.

Figure 177: The optimisation run number on a Cartesian graph.

Note:  For more details on the optimisation process, view the log file,
Dipole_Optimisation.log, that was created in the same directory as the current model.

OPTFEKO creates multiple CADFEKO (.cfx) models for each iteration, located in the same directory as
the current model. For example:

Dipole Optimisation_opt_1.cfx
Dipole Optimisation_opt_2.cfx
Dipole Optimisation_opt_3.cfx
.
.
Dipole Optimisation_opt_17.cfx

including the model with the variables set to the optimum values (indicated by the _optimum file
extension).

Dipole_Optimisation_optimum.cfx
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Figure 178: The optimised far field for the bent dipole and plate.
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7.7 Closing Remarks
This example showed the construction and optimisation of a bent dipole in front of a plate.

Many concepts were introduced in this simple example that are applicable to models commonly created
in CADFEKO. This example has demonstrated how to configure a CADFEKO model as well as how
optimisation in CADFEKO is executed. The optimisation process as well as the optimum values for the
model parameters were displayed in POSTFEKO, but can also be viewed in the .log file.
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