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Technical Support
Altair's support resources include engaging learning materials, vibrant community forums, intuitive
online help resources, how-to guides, and a user-friendly support portal.

Visit Customer Support to learn more about our support offerings.
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1 Wi-Fi Router in a Building

This example considers the application of analyzing a Wi-Fi router in a building.

This chapter covers the following:

• 1.1 Example Overview  (p. 13)

• 1.2 Topics Discussed in Example  (p. 14)

• 1.3 Example Prerequisites  (p. 15)

• 1.4 Introduction to Wall Manager (WallMan)  (p. 16)

• 1.5 Introduction to Propagation Manager (ProMan)  (p. 36)
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1.1 Example Overview
This example considers the application of analyzing a Wi-Fi router in a building.

The antenna pattern was obtained using Altair Feko, but the steps on how to use Feko to obtain the
antenna pattern are not in the scope of this example.

The 3D model of a building is created in WallMan.

Coverage plots are produced using ProMan for a Wi-Fi router located inside the building using two
different propagation models, namely: multi-wall model (COST 231) and 3D ray tracing (SRT) model.

The main elements and terminology in the WallMan and ProMan graphical user interface (GUI) are also
discussed.

Note:

This example does not specify the exact floor plan for the building, but instead, it highlights
the steps to create these structures in WallMan.

You are encouraged to create your own floor plan and internal structures using WallMan.

Proprietary Information of Altair Engineering
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1.2 Topics Discussed in Example
Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

• WallMan

◦ Launch WallMan.

◦ View the WallMan graphical user interface (GUI).

◦ Create a new indoor database (3D model of the building) using WallMan.

• ProMan

◦ Launch ProMan.

◦ View the ProMan graphical user interface (GUI).

◦ Specify the computation method.

◦ Launch the Solver.

◦ View the prediction results.

Note:  Follow the example steps in the order they are presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the Altair installation directory, for example:

Altair\2025.1\help\winprop\examples\GetStarted_models
\Project1_Indoor_Scenario.
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1.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1[1] or later should be installed.

1. WinProp is included as part of the Feko installation.
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1.4 Introduction to Wall Manager (WallMan)
WallMan tool is used to prepare a geometry database (3D model) that is used as part of a ProMan
project. Preparing geometries in WallMan, or even just converting them from other sources in WallMan,
is a common step in indoor and urban scenarios.

1.4.1 Launching WallMan
Launch WallMan in Microsoft Windows using the Feko and WinProp Launcher utility.

1.4.2 User Interface Layout
View the main elements and terminology in the WallMan graphical user interface (GUI).

1. Standard toolbar
The standard toolbar gives access to commonly used menu items including New Database,
Open Database, and Save Database.

2. View toolbar

The view toolbar gives access to tools related to navigating the 2D views, changing the
view, single wall view, and navigating the 3D view.

The 2D views in WallMan show the database as a cross-section with a specified plane. The

plane moves along the third axis (for example, the Z-axis in the X/Y view). Click the  icon

to modify the cut plane.

Proprietary Information of Altair Engineering
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Figure 1: The 3rd Coord Settings X/Y View dialog.

3. Objects toolbar
The objects toolbar gives access to tools to create indoor objects, outdoor objects, and tools
to select these objects.

4. Status bar
The Status bar is a small toolbar that gives quick access to absolute coordinates at the
location of the mouse cursor in the 2D view and also displays the currently active 2D
window.

5. Preprocessing toolbar
The preprocessing toolbar gives access to tools such as New Project, Open Project, Save
Project, and defining the preprocessing area.

6. Indoor lego toolbar
The indoor lego toolbar gives access to basic wall combinations for indoor database creation,
for example, Rectangular room, T-shaped room, Stairs, and Roof.

7. Clutter toolbar
The clutter toolbar gives access to tools such as editing or displaying clutter databases.

Note:  A clutter[2] database is a pixel matrix and contains information about
the land usage at a given location, for example, forest, water, residential or
industrial.

8. Cross-section view at the X/Y plane
The active view (for this example) as indicated by the text (X/Y)  in red. A cross-section
view of the model in the X/Y cut plane is displayed.

9. Cross-section view at the X/Z plane
A cross-section view of the model in the X/Z cut plane is displayed.

2. These are also called morpho databases or land usage databases.
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10. 3D view
A 3D view of the model showing the location of the three cut planes ( X/Y plane, X/Z plane,
and Y/Z plane) in purple.

11. Cross-section view at the Y/Z plane
A cross-section view of the model in the Y/Z cut plane is displayed.

1.4.3 Creating a New Indoor Database
Define a new indoor vector database of a building or multiple buildings.

An indoor database is used when you want to create a model of a single building or multiple buildings (if
the number of buildings is small).

Tip:  Use an urban database if the model contains several thousand of buildings.

1. On the File menu, click New Database.

Figure 2: The Select type of new database dialog.

2. Use the default settings for Select type of new database dialog.

3. Under Material catalogue, browse to GlobalMaterialCatalogue.mcb[3].

4. Click OK to close the Select type of new database dialog.

3. Project1_Indoor_Scenario\Database\GlobalMaterialCatalogue.mcb
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1.4.4 Specifying Default Values for New Objects
Define the default values for an object. Modify the default values before you create a new object to
define objects with different upper and lower coordinates (for example, a window versus a door).

The Default Values for New Objects dialog should be displayed after completing Creating a New
Indoor Database.

1. Specify the default values for new walls.

a) In the Height of walls relative to current plane field, enter a value of 3 m.

b) In the Material Properties of new Walls drop-down list, select Brick; thickness: 10 cm.

2. Specify the default values for new sub-division material (doors).

a) In the Material Properties of new Subdivisions drop-down list, select Wood (Fir);
thickness: 5 cm.

Figure 3: The Default Values for New Objects dialog.

3. Click OK to close the Default Values for New Objects dialog.
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1.4.5 Enabling the Grid for 2D Views
Enable the grid and specify the grid size for 2D views.

1. On the Settings menu, click Local settings.

Figure 4: The Settings dialog.

2. Under Drawing Help, select the Grid check box.

3. In the Grid Size field, enter a value of 0.25 m.

4. Click OK to close the Settings dialog.

1.4.6 Adjusting the Zoom Level
The zoom level of the 2D views is adjusted by enabling the Mouse Pan and Zoom Tool and using the
mouse wheel to zoom.

1. On the view toolbar, click the  Mouse Pan and Zoom Tool icon to activate the tool.

2. Use the mouse wheel to zoom in the 2D views until the grid is visible.
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Note:  The absolute coordinates of the mouse cursor is displayed in the status bar.

3. Click and drag the mouse to pan.

1.4.7 Adjusting the Cut Plane
Modify the third coordinate to move the cut plane. The cut plane results in a cross-section of the model
in the 2D view that allows you to view detail and verify the model.

1. Verify that the X/Y window is active, or activate it by clicking in it.
The X/Y symbol in the top-left of the window is red when the window is active.

2. Open the dialog to modify the cut plane using one of the following workflows:

• On the View toolbar, click the  3rd Coordinate Settings icon.

• On the Display menu, click Show 3rd Coord Dialog.

Figure 5: The 3rd Coord Settings X/Y View dialog.

Note:  The current active window determines the cut plane that can be modified.

3. Move the slider and observe how the cross-section and 3D view change.

Figure 6: The XZ cut plane at -3.95 m.
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Figure 7: The XZ cut plane at 3.90 m.

4. Close the dialog again using one of the following workflows:

• Click the  in the top-right corner of the dialog.

• On the View toolbar, click the  3rd Coordinate Settings icon.

1.4.8 Display Settings
Change the display settings of objects to validate the model visually.

On the Settings menu, click Local settings to launch the Settings dialog (see Figure 4).

Fill Objects
This option allows you to visualize the model as a 3D solid and reduce visual complexity.

Figure 8: On the left, a model without fill, to the right, a model with fill.

Display Thickness of Walls
This option allows you to validate the model by viewing the thickness of objects.
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Figure 9: On the left, a model is displayed without the thickness of the walls, to the right, a model is
displayed with wall thickness .

1.4.9 Creating a Model of the Building
Use WallMan to create a model of the building.

The model consists of a concrete floor, outer walls, interior walls, wooden doors, glass patio doors, and
glass windows. The building has a height of 3m.

Figure 10: A 3D model of the building, consisting of planar polygons. Glass windows and glass patio doors are
indicated in light blue and wooden doors in yellow.

Note:

This example does not specify the floor plan, or give exact locations or number of interior
walls, wooden doors or windows, but instead, it highlights the steps to create these
structures.

You are encouraged to create your own floor plan and internal structures.

Specifying Coordinates of Objects
There are two workflows available when specifying coordinates of objects in WallMan.

• Create the object by viewing the current coordinates in the Status bar. Click at the exact location in
the 2D view when drawing an object.
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• Create the general shape of the object - the coordinates do not have to be precise. Select the
object and on the Object Properties dialog, edit the coordinates.

Note:  Both workflows are demonstrated through the course of this example.

Drawing the Outer Walls
Define the outer walls of the building.

1. Verify that the X/Y window is active, or activate it by clicking in it.
The X/Y symbol in the top-left of the window is red when the window is active.

2. Create outdoor walls in the X/Y window using one of the following workflows:

• On the Objects menu, click Enter Basic Objects > Enter Polygonal Object (3D).

• On the Objects toolbar, click the  Add polygonal objects with orthogonal walls and a

ceiling icon.

3. Click twice at (-10, 6) to specify the first corner the polygon.

4. Click at the following coordinates to specify the corners of the polygon, for example:

• (-5, 6)

• (-5, 0)

• (7, 0)

• (7, -5)

• (-10, -5)

5. Right-click at (-10, 6) to close the polygon.

Figure 11: View of the model in the XY plane (top view) showing the outer walls.

Note:  All outer surfaces (including the floor and ceiling) of the building are created.
The material is brick with a thickness of 10 cm.

6. Exit the draw mode using one of the following workflows:
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• On the Objects menu, click Select Objects > Select Single Object (Mouse).

• On the Objects toolbar, click the  Select Object icon.

• Press F10 to use the keyboard shortcut.

Drawing the Interior Walls
Define the interior walls of the building.

1. Verify that the X/Y window is active, or activate it by clicking in it.
The X/Y symbol in the top-left of the window is red when the window is active.

2. Create the interior walls in the X/Y window using one of the following workflows:

• On the Objects menu, click Enter Basic Objects > Enter Orthogonal Object.
• On the Objects toolbar, click the  Add Objects Orthogonal icon.

• Press F9 to use the keyboard shortcut.

Note:  This tool creates a rectangle that is right-angled to the current projection plane.
The rectangle is a line in the 2D view.

3. Click twice in the X/Y window to specify the start point of the interior wall.

4. Click again to specify the end point of the interior wall.

Figure 12: View of the model in the XY plane (top view) showing the outer and interior walls.

Note:  The interior walls are created and consist of brick with a height of 3m.
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Drawing Wooden Doors
Define the wooden doors in the building.

1. Verify that the X/Y window is active, or activate it by clicking in it.
The X/Y symbol in the top-left of the window is red when the window is active.

2. On the Edit menu, click Default Values.

3. Specify the height of the doors.

a) Under Geometrical Parameters for Orthogonal Drawing Mode, select Upper and lower
coordinate defined individually (and absolute) field.

b) In the Min. Coord field, enter a value of 0.

c) In the Max. Coord field, enter a value of 2.5.

4. Specify the material properties for the doors.

a) Under Material Properties, from the Material Properties of new Subdivisions drop-
down list, confirm that the material properties are set to Wood (Fir); thickness: 5 cm.

Note:  The default material properties for new sub divisions were set in
Specifying Default Values for New Objects.

5. Click OK to close the Default Values for New Objects dialog.

6. Create a door in the X/Y window.

Note:  Create several doors. An exact layout is not important for this example.

a) On the Objects toolbar, click the  Add Objects Orthogonal icon.

b) Click twice in the X/Y window to specify the start point of the door.

c) Click again to specify the end point of the door.

The Insert Subdivision dialog is displayed.

Figure 13: The Insert Subdivision dialog.

7. Click OK to insert the door and to close the dialog.

A door is created perpendicular to the XY plane with a height of 2.5 m.
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Figure 14: View of the model in the XY plane (top view) showing the outer and interior walls. The wooden doors are
indicated in yellow.

Drawing Glass Windows
Define the glass windows in the building.

1. Verify that the X/Y window is active, or activate it by clicking in it.
The X/Y symbol in the top-left of the window is red when the window is active.

2. On the Edit menu, click Default Values.

3. Specify the upper and lower coordinates of the windows in the X/Y window.

a) Under Geometrical Parameters for Orthogonal Drawing Mode, select Upper and lower
coordinate defined individually (and absolute) field.

b) In the Min. Coord field, enter a value of 1.

c) In the Max. Coord field, enter a value of 2.5.

4. Specify the material properties for the windows.

a) Under Material Properties, from the Material Properties of new Subdivisions drop-
down list, select Glass; thickness: 5 mm.
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Figure 15: The Default Values for New Objects dialog.

5. Click OK to close the Default Values for New Objects dialog.

6. Create a window in the X/Y window.

Note:  Create several windows. An exact layout is not important for this example.

a) On the Objects toolbar, click the  Add Objects Orthogonal icon.

b) Click twice in the X/Y window to specify the start point of the window.

c) Click again to specify the end point of the window.

The Insert Subdivision dialog is displayed.
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Figure 16: The Insert Subdivision dialog.

7. Click OK to insert the window and to close the dialog.

A glass window is created perpendicular to the XY plane with a height of 1.5 m.

Figure 17: View of the model in the XY plane (top view) showing the outer and interior walls. The glass windows
are indicated in light blue.

Drawing Glass Patio Doors
Define the glass patio doors in the building.

1. Verify that the X/Y window is active, or activate it by clicking in it.
The X/Y symbol in the top-left of the window is red when the window is active.

2. On the Edit menu, click Default Values.

3. Specify the height of the glass patio doors.

a) Under Geometrical Parameters for Orthogonal Drawing Mode, select Upper and lower
coordinate defined individually (and absolute) field.

b) In the Min. Coord field, enter a value of 0.
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Figure 18: The Default Values for New Objects dialog.

4. Specify the material properties for the windows.

a) Under Material Properties, from the Material Properties of new Subdivisions drop-
down list, select Glass; thickness: 5 mm.

5. Click OK to close the Default Values for New Objects dialog.

6. Create a glass patio door in the X/Y window.

Note:  An exact layout is not important for this example.

a) On the Objects toolbar, click the  Add Objects Orthogonal icon.

b) Click twice in the X/Y window to specify the start point of the glass patio door.

c) Click again to specify the end point of the glass patio door.

The Insert Subdivision dialog is displayed.
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Figure 19: The Insert Subdivision dialog.

7. Click OK to insert the glass patio door and to close the dialog.

Figure 20: View of the model in the XY plane (top view) showing the outer and interior walls. For emphasis, the
material color for glass was changed to green.

A glass patio door is created perpendicular to the XY plane with a height of 2.5 m.

Drawing a Floor
Define the floor of the building. The concrete floor should be large enough to be underneath the entire
building, and includes an outdoor sitting area.

1. Verify that the X/Y window is active, or activate it by clicking in it.
The X/Y symbol in the top-left of the window is red when the window is active.

2. Confirm that the third coordinate (Z value) is at 0 m using one of the following workflows:

• On the View toolbar, click the  3rd Coordinate Settings icon.

• On the Display menu, click Show 3rd Coord Dialog.
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Figure 21: The 3rd Coord Settings X/Y View dialog.

3. On the Edit menu, click Default Values.

4. Specify the material properties for the floor.

a) Under Material Properties, from the Material Properties of new Walls drop-down list,
select Concrete; thickness: 20 cm.

5. Click OK to close the Default Values for New Objects dialog.

6. Create the floor in the X/Y window using one of the following workflows:

• On the Objects menu, click Enter Basic Objects > Enter Rectangular Objects.

• On the Objects toolbar, click the  Add Rectangular Objects icon.

• Press F8 to use the keyboard shortcut.

7. Click twice in the 2D view to specify a corner.

8. Click again in the 2D view to specify the last corner.

9. Exit the draw mode using one of the following workflows:

• On the Objects menu, click Select Objects > Select Single Object (Mouse).

• On the Objects toolbar, click the  Select Object icon.

• Press F10 to use the keyboard shortcut.
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1.4.10 Adding an Angled Prediction Plane
Define an additional and arbitrary polygonal prediction plane.

Figure 22: A 3D model of the building showing the additional prediction plane to be added to the model (indicated
with a blue outline).

1. Create a polygon using one of the following workflows:

• On the Objects menu, click Enter Basic Objects > Enter Polygonal Object.
• On the Objects toolbar, click the  Add Polygonal Objects icon.

• Press F7 to use the keyboard shortcut.

2. Create the general shape of the prediction plane (in this example, a rectangle).

Figure 23: View of the model in the X/Y plane (top view). The general shape of the prediction plane is
illustrated in green.

a) Click twice to specify the first corner of the polygon.

b) Click twice to specify corner 3 and corner 4.

c) Right-click at the first corner to close the polygon.

3. Edit the coordinates of the prediction plane.

a) Select the prediction plane by clicking on the outline of the polygon.

Proprietary Information of Altair Engineering



Altair WinProp 2025.1
1 Wi-Fi Router in a Building p.34

b) Right-click on the selected prediction plane and from the right-click context menu, click
Properties.

c) On the Object Properties dialog, specify the precise coordinates:

• (-11, 6, 4)

• (8, 6, 4)

• (8, -5, -1)

• (-11, -5, -1)

4. Click Change Type.
The Wall Type dialog is displayed.

5. Under Selected Type, from the drop-down list, select Prediction Plane.

Figure 24: The Wall Type dialog.

6. Click OK to close the Wall Type dialog.

7. Click OK to close the Object Properties dialog.

Figure 25: A 3D model of the building showing the angled prediction plane (indicated with a blue outline).

Note:  The new prediction plane must also be included in the simulation when setting
up the project parameters in ProMan, see Step 5.

1.4.11 Saving the Indoor Database
Save the new indoor database to file.

1. On the File menu, click Save Database As.
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2. Enter rooms_1.idb as the file name for the indoor database and click Save.

Note:  The .idb file extension stands for indoor database binary.
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1.5 Introduction to Propagation Manager (ProMan)
The ProMan (propagation) tool is designed to predict path loss accurately between transmitter and
receiver. The ProMan (network) software offers network planning modules.

1.5.1 Launching ProMan
Launch ProMan in Microsoft Windows using the Feko Launcher utility (which includes WinProp and
newFASANT).

1.5.2 User Interface Layout
View the main elements and terminology in the ProMan graphical user interface (GUI).

1. Standard toolbar
The standard toolbar gives access to commonly used menu items including New Project,
Open Project, Open Result, and Save.

2. Project toolbar
The project toolbar gives access to tools related to editing project parameters, transmitters,
sites, prediction points and launching simulations.
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3. Component toolbar
The component toolbar gives access to tools related to components, including add cable,
add antenna, and add transceiver.

4. Status bar
The Status bar is a small toolbar that gives quick access to absolute coordinates at the
location of the mouse cursor in the 2D view.

5. Utility toolbar
The utility toolbar gives quick access to, for example, ray display settings, line plot, and
probability density function.

6. Edit toolbar
The edit toolbar gives quick access to editing tools such as zooming to result, zooming to
prediction area, enabling the 3D view and display settings.

7. Tree view
The tree view is a panel that organizes the model into network configuration-specific items
and propagation results.

8. 2D view/3D view
If the 2D view is enabled, the 2D view displays a top view of the model. If the 3D view is
enabled, an isometric view of the model is displayed.

9. Legend
The legend is displayed to the right of the 2D view or 3D view and is linked to the displayed
data.

1.5.3 Creating a New Project
Load the indoor database that was created in WallMan.

1. On the File menu, click New Project.
The New Project dialog is displayed.

2. Under Scenario, from the drop-down list, select Indoor Scenarios (3D vector databases for
arbitrary 3D scenarios).

3. In the 3D indoor building data (Vector database) field, browse to rooms_1.idb.

4. Under Polarimetric Analysis, select Full (limited to selection of scenarios and propagation
models).

full polarimetric analysis
Angle-dependent polarization information is obtained from Feko .ffe file. This option is only
for indoor and urban scenarios using standard ray tracing, intelligent ray tracing, and multi-
wall model with Fresnel coefficients/UTD.
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standard polarimetric analysis
The antenna pattern can come from a Feko .ffe field or other sources but may not contain
polarization information. The polarization information is defined in ProMan, where selected
polarization and cross polarization apply to all angles.

Figure 26: The New Project dialog.

5. Click OK to close the New Project dialog.
The Define Display Height dialog is displayed.

6. In the Height field, enter a value of 1 m as this is the height of a typical table with a computer
with Wi-Fi connection.

7. Click OK to define the display height and to close the dialog.
A cross-section is displayed at Z = 1 m.
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Figure 27: A cross-section of the model at Z = 1 m.

Note:  The red rectangle indicates the extent of the computational domain.

1.5.4 Defining the Antenna Site and Antenna
For this example, a single antenna site and antenna are defined.

1. Specify the transmitter type and settings using one of the following workflows:

• On the Project menu, click Sites > Site: New.

• On the Project toolbar, click the  Set Site icon.

Figure 28: The Transmitter Type dialog.
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2. Use the default settings.

Note:  Use Omni Site (1 Cell/Sector) as only a single antenna is defined per site.
This option does not imply an omnidirectional antenna.

3. Click OK to close the Transmitter Type dialog.
In the 2D view, the mouse cursor is displayed as a circle to indicate that the Set site tool is
enabled.

4. Click near point (X, Y) = (4, -1) in the 2D view to place the site.

Tip:  The coordinates at the current mouse cursor are displayed in the Status bar.

The Site dialog is displayed.

5. On the Site dialog, click on Site 1 to select and click Edit.

Figure 29: The Site dialog.

The Cell dialog is displayed.

6. Specify the transmitter settings.

a) Under Transmitter Settings, in the Frequency (used for propagation) field, enter a
value of 2400 MHz.

b) Under Transmitter Settings, in the Tx Power field, enter a value of 0.5 W.

7. Specify the location of the antenna.

a) Under Location of Antenna, in the x / Longitude field, enter a value of 4 m.

b) Under Location of Antenna, in the y / Latitude field, enter a value of -1 m.

c) Under Location of Antenna, in the z / Height field, enter a value of 2 m.

8. Specify the antenna pattern.
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a) Under Antenna Pattern, click Directional / Sector antenna.

b) Browse to the file router_FF3D.ffe and click Open.

9. Click OK to close the Cell dialog.

Figure 30: The Cell dialog. Note that the maximum antenna gain is displayed in the Gain of antenna field.

10. Click OK to close the Site dialog.

11. Disable the Set site tool by clicking again on the  Set Site icon.

1.5.5 Main Computation Methods
The three main computation methods for indoor databases in ProMan are the 3D ray tracing (SRT)
model, dominant path model (DPM), and the multi-wall model (COST 231).

• 3D ray tracing (SRT) model
This method is accurate but can be computationally expensive if many interactions are taken
into account.

• dominant path model (DPM)
This method is the right balance between accuracy and simulation time but not available with
the fully polarimetric option.
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• multi-wall model (COST 231)
This method is fast but may be too pessimistic when a ray traverses multiple walls. Rays that
diffract around corners are not considered.
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1.5.6 Using the Multi-Wall Model (COST 231)
The indoor database is solved using the multi-wall model (COST 231).

Specifying the Prediction Resolution and Height
Define the resolution grid for the result matrices and the height at which the prediction results are
computed.

1. Launch the Edit Project Parameters dialog using one of the following workflow:

• On the Project menu, click  Edit Project Parameters.

• On the Project toolbar, click the  Edit Project Parameters icon.

• Press F3 to use the keyboard shortcut.

2. Click the Simulation tab.

3. Under Resolution of prediction results, in the Resolution field, enter a value of 0.05 m.
The prediction result will be computed with a resolution (grid) of 0.05 m.

4. Under Prediction Heights (relative to ground), in the Heights field, enter a value of 1 m.
The prediction result will be computed at the height of 1m (height of a desk with a Wi-Fi router).

5. Under Additional Prediction Planes, select the Prediction Planes defined in database check
box.

Figure 31: The Edit Project Parameters dialog - Simulation tab.
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Note:  Keep the dialog open to define additional project parameters.

Specifying the Output Folder for the Prediction Results
Specify the folder for the prediction results to be computed using the multi-wall model (COST 231).

1. Click the Propagation tab.

2. Specify the output folder for the results to be computed using the multi-wall model (COST 231).

a) Under Output Directory / Basic Filename for Propagation Results, in the Directory
field, change the default PropName to Prop01_MW.

Figure 32: The Edit Project Parameters dialog - Propagation tab.

Note:  Keep the dialog open to define additional project parameters.

Defining the Prediction Requests
Specify the predictions to be computed.

1. Under Computed Prediction Results, select the Field strength check box.
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2. Under Computed Prediction Results, select the Path loss check box.

3. Under Additional Prediction Data (exported into ASCII file during computation - required
to show CIR and Paths), select the Channel Impulse Response (CIR) check box.

Tip:  Select the Consider Antenna of MS[4] check box if you want to define a
receiving antenna pattern to determine how much power would be received at every
location by that mobile station.

In the fully polarimetric case, this requires a ray-tracing method and requires the
computation of the transmission matrix.

4. Under Additional Prediction Data (exported into ASCII file during computation - required
to show CIR and Paths), select the Propagation Paths check box.

Note:  Keep the dialog open to define additional project parameters.

Specifying the Computation Method
Select the multi-wall model (COST 231) as the computation method.

1. Click the Computation tab.

2. Under Empirical Propagation Models, click Multi-Wall Model (COST 231).

3. Under Computation of signal level along propagation path (valid for all propagation
models), click Fresnel Coefficients....

4. mobile station
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Figure 33: The Edit Project Parameters dialog - Computation tab.

Note:  We have imported an antenna pattern from Altair Feko with the complete
angle-dependent polarization information (as opposed to a pattern that might only
specify a dominant polarization direction and a cross-polarization level).

To use this information in the interactions of the rays with the geometry, select Fresnel
+ GTD/UTD coefficients rather than empirical coefficients for transmission, reflection,
and edge diffraction.

4. Click OK to close the Edit Project Parameters dialog.

Saving the Project
Save the new project to file.

1. On the File menu, click Save Project As.

2. Enter Indoor_router.net as the file name for the project and click Save.

Launching the Solver
Compute the propagation for the antenna to obtain the prediction results.

Launch the Solver using one of the following workflows:

• On the Project toolbar, click the  Computes propagation for all antennas icon.
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• On the Computation menu, click Propagation: Compute All.

The Solver is launched and the Computation dialog is displayed.

Figure 34: The Computation dialog.

Note:  For this example, several warnings are displayed. Ignore these warnings, as it only
states that the imported pattern is a directivity pattern rather than a gain pattern.

Viewing the Prediction Results in 2D
Display the power prediction results in 2D using the multi-wall model (COST 231).

1. In the tree, expand Results: Propagation and click Power.

Figure 35: The tree in ProMan showing the results.

2. View the power prediction results in the 2D view.

Note:  Expect the results to take a minute or so to load.
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Figure 36: Prediction of received power, by a hypothetical isotropic antenna, using the multi-wall model
(COST 231).

Note:

• Rays from the Wi-Fi router are straight.

• Distance and number of walls determine the field strength.
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1.5.7 Using the 3D Ray Tracing (SRT) Model
The indoor database is solved using the 3D ray tracing (SRT) model.

Specifying the Output Folder for the Prediction Results
Specify the folder for the prediction results to be computed using the 3D ray tracing (SRT) model.

1. Launch the Edit Project Parameters dialog using one of the following workflow:

• On the Project menu, click  Edit Project Parameters.

• On the Project toolbar, click the  Edit Project Parameters icon.

• Press F3 to use the keyboard shortcut.

2. Click the Propagation tab.

3. Specify the output folder for the results to be computed using the 3D ray tracing (SRT) model.

a) Under Output Directory / Basic Filename for Propagation Results, in the Directory
field, change Prop01_MW to Prop01_SRT.

Note:  Keep the dialog open to define additional project parameters.

Specifying the Computation Method
Select the 3D ray tracing (SRT) model as computation method.

1. Click the Computation tab.

2. Under Ray Optical Propagation Models, click 3D Ray Tracing (SRT - without preprocessed
data) as this the second computation method that is considered for this example.

3. Click OK to close the Edit Project Parameters dialog.

Launching the Solver
Compute the propagation for the antenna to obtain the prediction results.

Launch the Solver using one of the following workflows:

• On the Project toolbar, click the  Computes propagation for all antennas icon.

• On the Computation menu, click Propagation: Compute All.

The Solver is launched and the Computation dialog is displayed.

Note:  For this example, several warnings are displayed. Ignore these warnings, as it only
states that the imported pattern is a directivity pattern rather than a gain pattern.
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Viewing the Prediction Results in 2D
Display the power results using the 3D ray tracing (SRT) model.

1. In the tree, expand Results: Propagation and click Power.
2. View the power prediction results in the 2D view.

Figure 37: Prediction of received power using the 3D ray tracing (SRT) model.

Note:

• The effect of diffraction around a corner (indicated in red).

• The deepest shadows are now less deep.

• Fields have more ways to reach all locations.

The multi-wall model (COST 231) was too pessimistic in its prediction.

1.5.8 Viewing the Differences in Prediction Results
Display the difference between the two sets of prediction results obtained using the multi-wall model
(COST 231) and the 3D ray tracing (SRT) model.

View the power results for the Wi-Fi router using the 3D ray tracing (SRT) model.

1. Subtract the data using one of the following workflows:

• On the Edit menu, click Subtract Data > Value (File, linear).

• Press Alt+4 to use the keyboard shortcut.

2. Browse to the folder that contains the multi-wall model (COST 231) results as specified in Step 2.

3. Select the Site 1 Ant 1 Power.fpp file and click Open.
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Figure 38: Difference between the predicted received power using the multi-wall model (COST 231) and 3D
ray tracing (SRT) model.

Note:  Main difference between models are visible in the deep shadows (indicated by
the red areas). Contributions through diffraction are significant.

The multi-wall model (COST 231) is too pessimistic in its prediction, but the 3D ray tracing (SRT) model
is reliable.

1.5.9 Viewing the Prediction Results in 3D
In ProMan, the indoor database can be viewed in 3D to validate the physical structure and results.

1. View the model and results in 3D.

a) On the Edit toolbar, click the  3D View icon.

Figure 39: A 3D view of the model with power prediction results. The default prediction planes as well
as the angled prediction plane are displayed.
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2. View the results on the angled prediction plane.

a) On the Settings menu, click Local Settings.

b) On the Display Settings dialog, click the Layout tab.

Figure 40: The Display Settings dialog.

c) Clear the Prediction data check box to disable the default prediction results and only show
the results on the angled prediction plane.

Figure 41: A 3D view of the model with power prediction results displayed only on the angled prediction
plane.

3. Draw horizontal walls and objects to verify that the Wi-Fi router is below the ceiling.

a) On the Settings menu, click Local Settings.

b) On the Display Settings dialog, click the Layout tab.

c) In the Indoor database field, click Options.

d) On the Display of Walls dialog, under 3D Display, select the Draw horizontal walls/
objects check box.
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Figure 42: The Display of Walls dialog.

Figure 43: A 3D view of the model with power prediction results. on the angled prediction plane.
Horizontal objects such as the floor and roof are visible.

4. Return to the 2D view of the model.

a) On the Edit toolbar, click the  3D View icon again to disable the 3D view.

1.5.10 Final Remarks
This example showed how to analyze a Wi-Fi router in a building, to create the 3D model (indoor
database) using WallMan and to obtain coverage plots using ProMan.

Many concepts were introduced in this example that apply to models commonly created in WallMan and
ProMan.
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2 Indoor Cell-Phone Reception

This example considers the application of analyzing the indoor cell-phone reception, set in an urban
environment.

This chapter covers the following:

• 2.1 Example Overview  (p. 55)

• 2.2 Topics Discussed in Example  (p. 56)

• 2.3 Example Prerequisites  (p. 57)

• 2.4 Exporting the Antenna Pattern in Feko  (p. 58)

• 2.5 Creating the Geometry Database in WallMan  (p. 59)

• 2.6 Setting Up the Simulation in ProMan  (p. 75)
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2.1 Example Overview
This example considers the application of analyzing cell phone reception inside a building, set in an
urban environment. The urban environment includes buildings and vegetation.

The 3D model of the urban environment is created in WallMan using an imported aerial photograph,
tracing the building and assigning a height to the buildings. A model of a building, as created in
Example 1, is imported onto the urban environment.

The antenna pattern was obtained using Altair Feko, but the steps on how to use Feko to obtain the
antenna pattern are not in the scope of this example.

Coverage plots are produced using ProMan to determine the cell phone reception inside a building which
is set in an urban environment. Two different propagation models are used, namely: dominant path
model and COST 231 - extended Walfisch-Ikegami model.

Note:

This example does not specify the exact coordinates where to add buildings and vegetation
in the urban environment or where to place the building, but instead, it highlights the steps
to create these structures in WallMan.

You are encouraged to create your own urban environment and structures using WallMan.
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2.2 Topics Discussed in Example
Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

• WallMan

◦ Launch WallMan.

◦ Import an aerial photograph to create the urban environment.

◦ Trace the buildings on the aerial photograph and assign a height to the buildings.

◦ Add vegetation to the urban environment.

◦ Import the indoor database (3D model of the building) onto the urban environment.

• ProMan

◦ Launch ProMan.

◦ Specify the computation method.

◦ Launch the Solver.

◦ View the prediction results.

Note:  Follow the example steps in the order they are presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the Altair installation directory, for example:

Altair\2025.1\help\winprop\examples\GetStarted_models
\Project2_Hybrid_Urban_Indoor_Scenario.
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2.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1[5] or later should be installed.

5. WinProp is included as part of the Feko installation.
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2.4 Exporting the Antenna Pattern in Feko
An antenna pattern is exported to a .ffe file using POSTFEKO.

In POSTFEKO, export the antenna pattern to farfield_gain_3d.ffe file[6].

Figure 44: The antenna pattern (directivity) as displayed in POSTFEKO.

Note:  The antenna pattern represents a base-station sector pattern, broad in the azimuth
direction and relatively narrow in the elevation direction.

6. View the Feko User Guide for more information.

Proprietary Information of Altair Engineering



Altair WinProp 2025.1
2 Indoor Cell-Phone Reception p.59

2.5 Creating the Geometry Database in WallMan
Create a hybrid urban/indoor geometry database in WallMan.

The workflow for creating a hybrid urban/indoor geometry database for this example:

1. Create an urban database by importing an aerial photograph. Draw buildings and vegetation by
tracing the image and specifying a height for the objects.

2. Import the indoor database (building) into the urban database.

2.5.1 Launching WallMan
Launch WallMan in Microsoft Windows using the Feko and WinProp Launcher utility.

2.5.2 Creating a New Hybrid Urban/Indoor Database
Define a new urban building database.

1. Create a new database using one of the following workflows:

• On the File menu, click New Database.

• On the Standard toolbar, click the  New Database icon.

• Press Ctrl+N to use the keyboard shortcut.

2. Under Type of new database, click Urban building database.

3. Under Mode of operation, click Draw with bitmap in background.

4. Under Material catalogue, browse to GlobalMaterialCatalogue.mcb[7].

Figure 45: The Select type of new database dialog.

7. Project2_Hybrid_Urban_Indoor_Scenario\Database\GlobalMaterialCatalogue.mcb
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5. Click OK to close the Select type of new database dialog.
The Coordinate System dialog is displayed.

Figure 46: The Coordinate System dialog.

6. Under Datum of coordinates, keep the default option, WGS 84 (World Geodetic System).[8]

7. Under UTM or Geodetic, in the Zone Nr. field, enter an integer value of 11.[9]

8. Click OK to close the Coordinate System dialog.
The Default Values for New Buildings dialog is displayed.

Figure 47: The Default Values for New Buildings dialog.

2.5.3 Specifying Default Materials for New Objects
Define the default materials for new buildings and vegetation.

1. Specify the default material for new buildings.

a) Click Buildings and the Material dialog is displayed.

b) Under Select Material, from the drop-down list, select 10: Concrete; thickness: 20 cm.

8. This option is required for geo-referencing and not relevant to this example.

9. The Universal Transverse Mercator (UTM) system describes a position on a map using a system of
coordinates. For this example you can enter any zone number of your choice.

Proprietary Information of Altair Engineering



Altair WinProp 2025.1
2 Indoor Cell-Phone Reception p.61

Figure 48: The Material dialog.

c) Click OK to close the Material dialog.

2. Specify the default material for new vegetation.

a) Click Vegetation and the Material dialog is displayed.

b) Under Select Material, from the drop-down list, select 73: Default Vegetation.

Figure 49: The Material dialog.

c) Click OK to close the Material dialog.

3. Click OK to close the Default Values for New Buildings dialog.
The Image configuration dialog is displayed.

Figure 50: The Image Configuration dialog.

Note:  Keep the Image configuration dialog open.
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2.5.4 Urban Database
Create an urban environment for the hybrid urban/indoor database which includes the buildings and
vegetation.

Importing an Aerial Photograph
Import an image representing an aerial photograph of an office park.

1. Under Image Files, click Add to browse to UrbanArea.jpg[10] and click Open.

2. Under Image Properties, in the Width field, enter a value of 350 m.

3. Click Apply and then click Close.

Figure 51: The aerial photograph is displayed in the X/Y plane (on the left) and 3D view (to the right).

Scaling the Imported Aerial Photograph
Scale the image by drawing a line with a known length on the image.

For the imported aerial photograph, we know that a certain building is 20 m wide.

10. Altair\2025.1\help\winprop\examples\GetStarted_models
\Project2_Hybrid_Urban_Indoor_Scenario\Database\UrbanArea.jpg
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Figure 52: The red arrow indicates the building width of 20 m.

1. On the Edit menu, click Scale All Objects.

2. Under Fixpoint, click Center of all Objects.

Figure 53: The Scale Objects dialog.

3. Click OK to close the Scale Objects dialog.
The Please draw a line now... message is displayed.

Figure 54: A WallMan information dialog is displayed.

4. Click OK to close the Please draw a line now... message.

5. Click twice in the X/Y plane to specify the start point of the line.
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Note:  A black line is drawn. The end point is indicated with a “+” at the mouse cursor.

6. Click again to specify the end point of the line (this is the end point of the red arrow in Figure 52).
The Scale dialog is displayed.

Figure 55: The Scale dialog.

7. In the Enter length of the specified line field, enter a value of 20 m.

8. Click OK to close the Scale dialog.
The The entire database will be resized... message is displayed.

Figure 56: A WallMan information dialog is displayed.

9. Click Yes on the The entire database will be resized... message to resize the database.

The imported aerial photograph is scaled.

Adding Marker Points to Geo-Reference the Image
Use marker points to position database objects (geo-referencing) relative to one another.

Note:  Marker points are generally used when drawing multiple and complex buildings
relative to one another. It is not required for this example, but the steps are highlighted.

1. Add a marker point using one of the following workflows:

• On the Edit menu, click Edit > Marker points.

• On the View toolbar, click the  icon.

2. Click in the X/Y window.
A marker point is placed on the image at the location of the mouse click. The marker point is

indicated by a  blue crosshair.
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3. Activate the marker point by clicking again on the marker.

The marker point is now indicated by a  red crosshair.

4. Right-click on the red crosshair and from the right-click context menu, click Assign Reference.

Figure 57: The Marker Point Referencing dialog.

5. Under Position Assignment, in the New Coordinate field, enter the coordinates of the marker.

6. Click OK to close the Marker Point Referencing dialog.

Drawing Buildings
Trace building outlines on the imported aerial photograph to draw buildings.

1. Trace the building in the X/Y window using one of the following workflows:

• On the Objects menu, click Enter Basic Objects > Enter Polygonal Object.
• On the Objects toolbar, click the  Add Polygonal Objects icon.

• Press F7 to use the keyboard shortcut.

2. Click twice to specify the start point of the building.

3. Trace the building by clicking on the corners of the building.

Tip:  Press Esc to exit the creation of the current polygon.
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4. Right-click at the start point to close the polygon.

5. Repeat Step 2 to Step 4 and trace multiple buildings.

Figure 58: Drawn buildings are indicated in grey.

6. Exit the draw mode using one of the following workflows:

• On the Objects menu, click Select Objects > Select Single Object (Mouse).

• On the Objects toolbar, click the  Select Object icon.

• Press F10 to use the keyboard shortcut.

7. Select the building by clicking on the outline of the building.
A selected object is indicated in red.
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Figure 59: A selected building is indicated in red.

8. Right-click on the selected building and from the right-click context menu, click Properties.
The Object Properties dialog is displayed.

Figure 60: The Object Properties dialog.

9. Under Corners, select a corner and click Edit to modify the height of the buildings.

Note:  You can modify the height of any corner to change the height of the building.
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Figure 61: The 3D view of the buildings after their heights were modified. The aerial photograph was hidden
for demonstrative purposes.

10. Click OK to close the Enter Coordinates dialog.

11. Save the outdoor database.

a) On the File menu, click Save Database As.

b) Enter Office_Park_partial.odb as the file name for the outdoor database and click Save.

Note:  The .odb file extension stands for outdoor database binary.

Drawing Vegetation
Trace tree outlines on the imported aerial photograph to draw vegetation.

1. Enable the drawing of vegetation in the X/Y window using one of the following workflows:

• On the Objects menu, click Enter vegetation.

• On the Objects toolbar, click the  Enter vegetation icon.

2. Enable the drawing of polygonal objects in the X/Y window using one of the following workflows:

• On the Objects menu, click Enter Basic Objects > Enter Polygonal Object.
• On the Objects toolbar, click the  Add Polygonal Objects icon.

• Press F7 to use the keyboard shortcut.

3. On the Objects toolbar, click the  Add Polygonal Objects icon.

4. Click to specify the start point of the vegetation.

5. Trace the vegetation by clicking on the corners of the trees.

6. Right-click at the start point to close the polygon.

7. Repeat Step 4 to Step 6 and trace vegetation.
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Figure 62: Drawn vegetation is indicated in green.

8. Exit the draw mode using one of the following workflows:

• On the Objects menu, click Select Objects > Select Single Object (Mouse).

• On the Objects toolbar, click the  Select Object icon.

• Press F10 to use the keyboard shortcut.

9. Select the vegetation by clicking on the outline of the vegetation.
A selected object is indicated in red.

10. Right-click on the selected vegetation and from the right-click context menu, click Properties.
The Object Properties dialog is displayed.
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Figure 63: The Object Properties dialog.

11. Under Corners, select a corner and click Edit to modify the height of the vegetation.

Figure 64: The 3D view of the buildings after their heights were modified. The aerial photograph was hidden
for demonstrative purposes.

12. Click OK to close the Object Properties dialog.

13. Save the outdoor database.

a) On the File menu, click Save Database As.

b) Enter Office_Park_partialwithvegetation.odb as the file name for the outdoor database
and click Save.
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2.5.5 Indoor Database
Import and place the indoor geometry (building) onto the hybrid urban/indoor database.

Adding an Indoor Database
Insert an indoor database of a building on the imported aerial photograph.

The database created thus far is now ready for a standard urban simulation. However, we want to add
an indoor database near the bottom of the image. Using a hybrid urban/indoor database, the urban
database is solved using high simulation speed while the indoor database is solved using high accuracy.

1. Import an indoor database (building) using one of the following workflows:

• On the Objects menu, click the Import Indoor Database.

• Press Alt+F6 to use the keyboard shortcut.

2. Browse to the location of the file rooms_1.idb that was created in Example 1 and click Open.

The CNP[11] Building dialog is displayed.

Figure 65: The CNP Building dialog.

3. Click OK to close the CNP Building dialog.
The Database to be imported must contain... message is displayed.

Figure 66: The Database to be imported must contain... message.

4. Click Yes to continue.
The The imported database contains... message is displayed.

11. Combined network planning (CNP) is the model that allows for the combination of urban and indoor
predictions.
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Figure 67: The The imported database contains... message.

5. Click OK to close the message.
The The imported building is now in the clipboard... message is displayed.

Figure 68: The The imported building is now in the clipboard... message.

6. Click OK to close the message.

7. Click to place the indoor database on the imported aerial photograph.

Figure 69: The indoor database is placed onto the urban environment.
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Rotating the Indoor Database
Place the indoor database at the correct location by rotating the building.

1. Select the indoor database by clicking with the mouse on the outline of the indoor database.
A selected object is indicated in red.

2. On the Objects menu, click Rotate selected objects.
The Rotate Objects dialog is displayed.

Figure 70: The Rotate Objects dialog.

3. Under Rotation around Axes, in the Z field, enter a value to rotate the indoor database around
the Z axis.

4. Click OK to close the Rotate Objects dialog.

The indoor database is rotated.

Figure 71: The indoor database is rotated to fit between the vegetation (in green).
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Figure 72: 3D view of the buildings, vegetation, and indoor database. The aerial photograph was hidden for
demonstrative purposes.

2.5.6 Saving the Hybrid Urban/Indoor Database
Save the new hybrid urban/indoor database to file.

1. On the File menu, click Save Database As.

2. Enter Office_Park.odb[12] as the file name for the completed hybrid urban/indoor database and
click Save.

3. On the File menu, click OK to exit WallMan.

12. Project2_Indoor_Urban_Scenario\Database\Office_Park.odb
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2.6 Setting Up the Simulation in ProMan
Set up the propagation simulation parameters. Solve the hybrid urban/indoor database and inspect the
indoor reception.

The hybrid urban/indoor database is solved using the dominant path model and COST 231 - extended
Walfisch-Ikegami model.

2.6.1 Launching ProMan
Launch ProMan in Microsoft Windows using the Feko Launcher utility (which includes WinProp and
newFASANT).

2.6.2 Creating a New Project
Load the hybrid urban/indoor building database that was created in WallMan.

1. On the File menu, click New Project.
The New Project dialog is displayed.

Figure 73: The New Project dialog.

2. Under Scenario, from the drop-down list, select Urban Scenario (vector data for urban
buildings and pixel topo data).
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3. Under Databases, in the 3D building data (Vector database) field, browse to

Office_Park.odb[13].

4. Under Polarimetric Analysis, select Standard (suitable for all scenarios and propagation
models).

5. Click OK to close the New Project dialog.

6. Browse to the location of the file, UrbanArea.jpg[14] and click Open.
The Define Display Height dialog is displayed.

Figure 74: The Define display Height dialog.

7. In the Height field, use the default value of 1.5 m.

Note:  This value is used only to specify the display height. This value has no impact
on the height at which the prediction results are calculated.

8. Click OK to close the Define Display Height dialog.
The office park is displayed.

Figure 75: A top view of the office park.

Note:  The red rectangle indicates the extent of the computational domain.

13. Project2_Hybrid_Urban_Indoor_Scenario\Database\Office_Park.odb

14. Project2_Hybrid_Urban_Indoor_Scenario\Database\UrbanArea.jpg
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2.6.3 Defining the Antenna Site and Antennas
For this example, a single antenna site with three antennas is defined.

The height of the building where the antennas are to be placed is 5 m. The height of the antenna mast
is 4 m with the result that the antenna will be located at the 9 m.

1. Specify the transmitter type and settings using one of the following workflows:

• On the Project menu, click Sites > Site: New.

• On the Project toolbar, click the  Set Site icon.

2. Under Settings, click 3 Sector Site.

Figure 76: The Transmitter Type dialog.

3. Click OK to close the Transmitter Type dialog.
The mouse cursor is displayed as a circle to indicate that the Set site tool is enabled.

4. Click near point (X, Y) = (143.88, 187.90) in the 2D view to place the site (the location of the
antenna site is indicated by an orange circle).

Figure 77: A partial view of the 2D view. Place the antenna site at the location of the orange dot.
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Note:  The exact coordinates is not important for this example, but the above
coordinate is used in the steps that follow.

Tip:  The coordinates at the current mouse cursor are displayed in the Status bar.

The Site dialog is displayed.

5. In the z / Height field, enter a value of 5 m.

6. Click on Site 1 Antenna 1 to select and click Edit.
The Cell dialog is displayed for antenna 1.

7. Under Transmitter Settings, in the Frequency (used for propagation) field, enter a value of
1800 MHz.

8. Under Location of Antenna, in the z / Height field, enter a value of 9 m.

9. Under Antenna Pattern, click Directional / Sector antenna.

10. Under Antenna Pattern, click Select to browse to the file farfield_gain_3d.ffe[15].

Figure 78: The Cell dialog for antenna 1.

11. Click OK to close the Cell dialog.

12. Repeat Step 6 to Step 10 to define antenna 2.

13. Repeat Step 6 to Step 10 to define antenna 3.

15. Project2_Hybrid_Urban_Indoor_Scenario\Antennas\farfield_gain_3d.ffe
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Figure 79: The Site dialog.

14. Click OK to close the Site dialog.

15. Disable the Set site tool by clicking again on the  Set Site icon.
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2.6.4 Using the Dominant Path Model (DPM)
The hybrid urban/indoor database is solved using the dominant path model.

Specifying the Area of Simulation
Increase the extent of the computational domain.

View Figure 77 and observe that the default extent of the computational domain (indicated by the red
rectangle) does not include the antenna site. Modify the computational domain to include antenna site.

1. Launch the Edit Project Parameters dialog using one of the following workflow:

• On the Project menu, click  Edit Project Parameters.

• On the Project toolbar, click the  Edit Project Parameters icon.

• Press F3 to use the keyboard shortcut.

2. Click the Simulation tab.

3. Specify the lower left corner.

a) In the x / Longitude field, in the Lower Left Corner column, enter a value of 50.

b) In the y / Latitude field, in the Lower Left Corner column, enter a value of 10.

4. Specify the upper right corner.

a) In the x / Longitude field, in the Upper Right Corner column, enter a value of 210.

b) In the y / Latitude field, in the Upper Right Corner column, enter a value of 200.
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Figure 80: The Edit Project Parameters dialog - Simulation tab.

Note:  Keep the dialog open to define additional project parameters.

Specifying the Prediction Resolution and Height
Define the resolution grid and the height where the prediction results are to be calculated.

1. Under Resolution of prediction results, in the Resolution field, enter a value of 0.25 m.
The prediction results will be computed with a resolution (grid) of 0.25 m.

2. Under Prediction Height (relative to ground), in the Height field, enter a value of 1.5 m.

Tip:  Multiple prediction heights can be specified by entering space-separated values.

For example: 1.5 2 2.5

Note:  Keep the dialog open to define additional project parameters.

Specifying the Output Folder for the Prediction Results
Specify the folder for the prediction results to be computed using the dominant path model (DPM).

1. Click the Propagation tab.
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2. Specify the output folder for the results to be computed using the dominant path model.

a) Under Output Directory / Basic Filename for Propagation Results, in the Directory
field, change the default PropName to Prop02_DPM.

Figure 81: The Edit Project Parameters dialog - Propagation tab.

Note:  Keep the dialog open to define additional project parameters.

Defining the Prediction Requests
Specify the predictions to be computed.

Under Computed Prediction Results, select the Field strength check box.

Note:  Keep the dialog open to define additional project parameters.

Specifying the Computation Method
Select the dominant path model (DPM) as computation method.

1. Click the Computation tab.
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2. Under Prediction model (Urban), click Dominant Path Model.
3. Under Indoor Prediction, select the CNP Indoor prediction (including indoor walls (only if

available)) check box.

Note:  This option applies to hybrid (urban/indoor) simulations.

Figure 82: The Edit Project Parameters dialog - Computation tab.

4. Click OK to close the Edit Project Parameters dialog.

Saving the Project
Save the new project to file.

1. On the File menu, click Save Project As.

2. Enter Hybrid_Urban_Indoor.net as the file name for the project and click Save.

Tip:  To export the project along with its antenna pattern and geometry database to
an archive using relative file paths, click File > Export > Export Project as ZIP

archive.[16]

16. This allows you to exchange project files between different machines and users.
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Launching the Solver
Compute the propagation for all antennas to obtain the prediction results.

Launch the Solver using one of the following workflows:

• On the Project toolbar, click the  Computes propagation for all antennas icon.

• On the Computation menu, click Propagation: Compute All.
• Press F5 to use the keyboard shortcut.

The Solver is launched, and the Computation dialog is displayed.

Note:  For this example, several warnings are displayed. Ignore these warnings, as it only
states that the imported pattern is a directivity pattern rather than a gain pattern.

Viewing the Prediction Results
Display the power results using the dominant path model.

1. View the power using the dominant path model in the urban environment.

a) In the tree, expand  Results: Propagation to view site 1.

b) In the tree, expand  Site 1 to view the three antennas.

c) In the tree, expand  Site 1 Antenna 3 to view the Field Strength and Power entries.

d) In the tree, click  Power to view the results.

Figure 83: Power calculated using the dominant path model (DPM).

2. View the power for the indoor database.

a) Zoom in on the indoor database.
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b) Right-click on the legend and from the right-click context menu, click Thresholds >
Manual.

c) In the Max field, enter a value of -50 dBm.

d) In the Min field. enter a value of -90 dBm.

Figure 84: Power calculated using the dominant path model (DPM) for the indoor database.
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2.6.5 Using COST 231: Extended Walfisch-Ikegami Model
The hybrid urban/indoor database is solved using the COST 231 - extended Walfisch-Ikegami model.

This method is suited for high transmitters in urban scenarios when the dominant path is expected to be
in the vertical plane over rooftops.

transmitter

hTX
hroof receiver

hRX

b
d

w
building

rooftop

Figure 85: Urban propagation scenario using the COST 231 Walfisch-Ikegami Model.

In this case, the transmitter is not very high, so we expect lower accuracy. Also, any time the dominant
path is not purely in the vertical plane, this method will under-estimate the received fields, but it will be
faster in comparison to the dominant path model.

Specifying the Output Folder for the Prediction Results
Specify the folder for the prediction results to be computed using the COST 231 - extended Walfisch-
Ikegami model.

1. Launch the Edit Project Parameters dialog using one of the following workflow:

• On the Project menu, click  Edit Project Parameters.

• On the Project toolbar, click the  Edit Project Parameters icon.

• Press F3 to use the keyboard shortcut.

2. Click the Propagation tab.

3. Specify the output folder for the results to be computed using the dominant path model.

a) Under Output Directory / Basic Filename for Propagation Results, in the Directory
field, rename Prop02_DPM to Prop02_COST231.

Note:  Keep the dialog open to define additional project parameters.

Specifying the Computation Method
Select the COST 231 - extended Walfisch-Ikegami model as computation method.

1. Click the Computation tab.

2. Under Prediction model (Urban), click Empirical Vertical Plane Model: COST 231:
Extended Walfisch-Ikegami-Model.
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3. Click OK to close the Edit Project Parameters dialog.

Launching the Solver
Compute the propagation for all antennas to obtain the prediction results.

Launch the Solver using one of the following workflows:

• On the Project toolbar, click the  Computes propagation for all antennas icon.

• On the Computation menu, click Propagation: Compute All.
• Press F5 to use the keyboard shortcut.

The Solver is launched, and the Computation dialog is displayed.

Note:  For this example, several warnings are displayed. Ignore these warnings, as it only
states that the imported pattern is a directivity pattern rather than a gain pattern.

Viewing the Prediction Results
Display the field strength results using the COST 231 - extended Walfisch-Ikegami model.

1. View the field strength using the COST 231 - extended Walfisch-Ikegami model in the urban
environment.

a) In the tree, expand  Results: Propagation to view site 1.

b) In the tree, expand  Site 1 to view the three antennas.

c) In the tree, expand  Site 1 Antenna 3 to view the Field Strength and Power entries.

d) In the tree, click  Power to view the results.

e) Right-click on the legend and from the right-click context menu, click Thresholds > Auto
defined.
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Figure 86: Power calculated using the COST 231 - extended Walfisch-Ikegami model.

2. View the power for the indoor database.

a) Zoom in on the indoor database.

b) Right-click on the legend and from the right-click context menu, click Thresholds >
Manual.

c) In the Max field, enter a value of -50 dBm.

d) In the Min field. enter a value of -90 dBm.

Figure 87: Power calculated using the COST 231 - extended Walfisch-Ikegami model for the indoor database.

Note:

• Propagation is along straight lines only (always in the vertical plane between
transmitter and point of interest).

• The power is lower than with the dominant path model.

• Effects of windows and doors are visible.
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2.6.6 Final Remarks
This example showed how to analyze the cell-phone reception in a building, to create the hybrid urban/
indoor database using WallMan and to obtain coverage plots using ProMan.

Many concepts were introduced in this example that apply to models commonly created in WallMan and
ProMan.
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3 Base Stations in a City

This example considers the application of analyzing base stations in a city, set in an urban environment.

This chapter covers the following:

• 3.1 Example Overview  (p. 91)

• 3.2 Topics Discussed in Example  (p. 92)

• 3.3 Example Prerequisites  (p. 93)

• 3.4 Exporting the Antenna Pattern in Feko  (p. 94)

• 3.5 Creating the Geometry Database in WallMan  (p. 95)

• 3.6 Setting Up the Simulation in ProMan  (p. 107)

• 3.7 Final Remarks  (p. 126)
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3.1 Example Overview
This example considers the application of analyzing base stations in a city.

The antenna pattern was obtained using Altair Feko, but the steps on how to use Feko to obtain the
antenna pattern are not in the scope of this example.

An urban database is imported from a .dxf and converted to a WinProp format. The urban database is
modified, a tower and vegetation are added.

Coverage plots are produced using ProMan to determine the cell phone reception inside a building which
is set in an urban environment. Two different propagation models are used, namely: dominant path
model and COST 231 - extended Walfisch-Ikegami model.

Note:

This example does not specify the exact coordinates where to add buildings and vegetation
in the urban environment, but instead, it highlights the steps to create these structures in
WallMan.

You are encouraged to create your own urban environment and structures using WallMan.
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3.2 Topics Discussed in Example
Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

• WallMan

◦ Launch WallMan.

◦ Import an urban database from a .dxf and convert to a WinProp format.

◦ Modify a building in the urban database.

◦ Add a tower to a standard building.

◦ Add vegetation to the urban environment.

◦ Save the urban database.

• ProMan

◦ Launch ProMan.

◦ Specify the antenna sites, orientations and properties.

◦ Specify the simulation parameters.

◦ Specify the computation method.

◦ Save the project.

◦ Launch the Solver.

◦ View the prediction results.

Note:  Follow the example steps in the order they are presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the Altair installation directory, for example:

Altair\2025.1\help\winprop\examples\GetStarted_models\Project3_Urban_Scenario.
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3.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1[17] or later should be installed.

17. WinProp is included as part of the Feko installation.
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3.4 Exporting the Antenna Pattern in Feko
An antenna pattern is exported to a .ffe file using POSTFEKO.

In POSTFEKO, export the antenna pattern to farfield_gain_3d.ffe file[18].

Figure 88: The antenna pattern (directivity) as displayed in POSTFEKO.

Note:  The antenna pattern represents a base-station sector pattern, broad in the azimuth
direction and relatively narrow in the elevation direction.

18. View the Feko User Guide for more information.
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3.5 Creating the Geometry Database in WallMan
Create an urban geometry database in WallMan.

The workflow for creating an urban geometry database for this example:

1. Import an urban database from a .dxf file and convert to a WinProp format.

2. Select and modify buildings.

3. Add a tower and vegetation.

3.5.1 Launching WallMan
Launch WallMan in Microsoft Windows using the Feko and WinProp Launcher utility.

3.5.2 Importing Geometry from a .DXF File
Import geometry representing a city from a .dxf file. Convert the geometry to a WinProp format.

1. Convert the urban database using one of the following workflows:

• On the File menu, click Convert Urban Database > Vector Database.

• Press Ctrl+D to use the keyboard shortcut.

2. Under Format of source file, in the Selection of import filter drop-down list, select AutoCAD
(*.dwg, *.dxf).

Figure 89: The Conversion of Urban Vector Database dialog.

3. Keep the default settings on the dialog.
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4. Click OK to close the Conversion of Urban Database dialog.

5. Browse to the location of the file, Frankfurt_modified.dxf19 and click Open.

6. Specify the file name as Frankfurt.odb19 and click Save.
The AutoCAD Conversion Settings dialog is displayed.

Figure 90: The AutoCAD Conversion Settings dialog.

7. In the LayerName column (second column), select layer 0.

For this example, there is only a single layer.

8. Under Select Layer to be Converted, click Convert to walls.

The  icon is displayed in column 1 for layer 0.

19. Project3_Urban_Scenario\Database\Frankfurt_modified.dxf
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Figure 91: The AutoCAD Conversion Settings dialog with layer 0 converted to walls.

9. Click Start conversion to convert to WinProp format.
The 2D object found dialog is displayed.

Figure 92: The 2D object found dialog.

Note:  The .dxf file for this example only contains 3D objects (no 2D objects).

10. Click Ignore all 2D objects.

Note:  The option to extrude 2D objects to 3D is not applicable to this example as the
file only contains 3D objects.

11. Click OK to close the 2D object found dialog.
The Conversion of database finished... message is displayed.
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Figure 93: The Conversion of database finished... message.

12. Click OK to close the message.

Figure 94: Top view of Frankfurt (on the left) and 3D view (to the right).

The urban database is converted and saved as an outdoor database binary (.odb) file.

3.5.3 Display Settings
Change the display settings of objects to validate the model visually.

On the Settings menu, click Local settings to launch the Settings dialog.
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Figure 95: The Settings dialog.

Fill Objects
This option allows you to visualize the model as a 3D solid and reduce visual complexity.

Figure 96: A model without fill (on the left) and a model with fill (to the right).

Display Building Heights in Status Bar
This option allows you to validate the model by viewing the height of an object. In the X/Y view
hover with the mouse over a building to view the height of the building in the Status bar.
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3.5.4 Modifying the Height of a Building
Change or correct the height of a building

1. Select a building by clicking on the outline of the building.
A selected object is indicated in red.

Figure 97: A selected building is indicated in red. Top view of Frankfurt (on the left) and 3D view (to the
right).

2. Right-click on the selected building and from the right-click context menu, click Properties.
The Object Properties dialog is displayed.

Figure 98: The Object Properties dialog.

3. Verify the building type of the selected building.

a) Next to Object, click Change Type.
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b) Under Selected Type, verify that Standard Building[20] is selected.

Figure 99: The Wall Type dialog.

c) Click OK to close the Wall Type dialog.

4. Under Corners, select a corner and click Edit to modify the height of the building.
The Enter Coordinates dialog is displayed.

Figure 100: The Enter Coordinates dialog.

5. In the Z field, enter a new height for the building.

6. Click OK to close the Enter Coordinates dialog.

7. Click OK to close the Object Properties dialog.

The height of the selected building is updated.

Figure 101: The height of the selected building is increased.

20. Other building types also supported are: horizontal plates, courtyards and towers, vegetation block
and virtual buildings, see the WinProp User Guide for more information.
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3.5.5 Modifying the Shape of a Building
Change or correct the shape of a building.

1. Select a building by clicking on the outline of the building.
A selected object is indicated in red.

2. Click with the mouse on a corner of the selected building and drag to the required coordinate.
An arrow is displayed at the location of the mouse cursor while modifying the shape.

Figure 102: A corner of the selected building (in red) is modified.

The building is updated to include the modification to the corner point.

3.5.6 Courtyards and Towers
A courtyard or tower is a special type of building that allows you to create complex building structures.

A standard building is defined using corners where you specify the X, Y, and Z coordinates for each
corner. The height of the building is determined by the value of the Z coordinate. If you change the Z
value of one corner, the height of the entire building changes.

Note:  A standard building defined completely inside another standard building is ignored.

A courtyard/tower is a special building type where you define the courtyard/tower inside a standard
building. Although this results in overlapping structures, a courtyard/tower object has a higher priority
and will not lead to validation errors. Towers and courtyards are indicated in yellow (when unselected)
in the X/Y view and 3D view.
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The difference between a courtyard and tower is:

• Courtyard: The height of the courtyard is less than the height of the standard building that contains
it.

Figure 103: Top view of the courtyard (on the left) and 3D view (to the right). The Fill Objects display setting
was disabled for demonstrative purposes.

• Tower: The height of the tower is greater than the height of the standard building that contains it.

Figure 104: Top view of the tower (on the left) and 3D view (to the right).

Note:  Courtyards are not visible when the Fill object[21] display setting is enabled but are
still part of the geometry and included in the simulation.

21. See the display settings in Display Settings on how to disable.
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Adding a Courtyard
Add a rectangular courtyard to the city.

1. Draw a tower in the X/Y window using one of the following workflows:

• On the Objects menu, click Enter Basic Objects > Enter Polygonal Object.
• On the Objects toolbar, click the  Add Polygonal Objects icon.

• Press F7 to use the keyboard shortcut.

2. Click twice to specify the start point of the courtyard.

3. Create the courtyard by clicking on the corners of the courtyard.

Tip:  Press Esc to exit the creation of the current polygon.

4. Right-click at the start point to close the polygon.

Figure 105: The Would you like to define this object... message.

Figure 106: The tower is indicated in yellow in the X/Y view.

5. Click Yes to close the Would you like to define this object... message.

6. Exit the draw mode using one of the following workflows:

• On the Objects menu, click Select Objects > Select Single Object (Mouse).

• On the Objects toolbar, click the  Select Object icon.

• Press F10 to use the keyboard shortcut.

7. Select the courtyard by clicking on the outline of the courtyard.
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8. Right-click on the selected building and from the right-click context menu, click Properties.
The Object Properties dialog is displayed.

9. Under Corners, select a corner and click Edit to modify the height of the tower.

Note:  You can modify the height of any corner to change the height of the courtyard.

The Enter Coordinates dialog is displayed.

Figure 107: The Enter Coordinates dialog.

10. In the Z field, enter a value of 3 for the height of the tower.

11. Click OK to close the Enter Coordinates dialog.

12. Click OK to close the Object Properties dialog.

Figure 108: The 3D view of the urban database. To view the courtyard in the 3D view, disable the Fill
Objects display settings.

13. Save the urban database.

a) On the File menu, click Save Database As.

b) Enter Frankfurt_modifed.odb as the file name for the outdoor database and click Save.

3.5.7 Drawing Vegetation
Draw a polygon and set the material properties to vegetation.

1. Enable the drawing of vegetation in the X/Y window using one of the following workflows:

• On the Objects menu, click Enter vegetation.

• On the Objects toolbar, click the  Enter vegetation icon.

2. Enable the drawing of polygonal objects in the X/Y window using one of the following workflows:

• On the Objects menu, click Enter Basic Objects > Enter Polygonal Object.
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• On the Objects toolbar, click the  Add Polygonal Objects icon.

• Press F7 to use the keyboard shortcut.

3. Click twice to specify the start point of the vegetation.

4. Draw the vegetation by clicking at the corners of the trees.

5. Right-click at the start point to close the polygon.

Figure 109: Drawn vegetation is indicated in green.

6. Exit the draw mode using one of the following workflows:

• On the Objects menu, click Select Objects > Select Single Object (Mouse).

• On the Objects toolbar, click the  Select Object icon.

• Press F10 to use the keyboard shortcut.

7. Select the vegetation by clicking on the outline of the vegetation.

8. Right-click on the selected vegetation and from the right-click context menu, click Properties.
The Object Properties dialog is displayed.

9. Under Material Properties, verify that the material is set to Default Vegetation.

10. Click OK to close the Object Properties dialog.

3.5.8 Saving the Database
Save the new and completed urban database to file.

1. On the File menu, click Save Database As.

2. Enter Frankfurt_modified.odb[22] and click Save.

3. On the File menu, click Exit to exit WallMan.

22. Project3_Urban_Scenario\Database\Frankfurt_modified.odb
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3.6 Setting Up the Simulation in ProMan
Set up the propagation simulation parameters. Solve the urban database and inspect the coverage
plots.

The base stations set in an urban environment, is solved using the following two methods: the
dominant path model and COST 231 - extended Walfisch-Ikegami model.

3.6.1 Launching ProMan
Launch ProMan in Microsoft Windows using the Feko Launcher utility (which includes WinProp and
newFASANT).

3.6.2 Creating a New Project
Load the urban geometry database that was created in WallMan.

1. On the File menu, click New Project.
The New Project dialog is displayed.

2. Under Scenario, from the drop-down list, select Urban Scenario (vector data for urban
buildings and pixel topo data).

3. Under Databases, in the 3D building data (Vector database) field, browse to

Frankfurt_modified.odb[23].

4. Under Polarimetric Analysis, select Standard (suitable for all scenarios and propagation
models).

23. Project3_Urban_Scenario\Database\Frankfurt_modified.odb

Proprietary Information of Altair Engineering



Altair WinProp 2025.1
3 Base Stations in a City p.108

Figure 110: The New Project dialog.

5. Click OK to close the New Project dialog.
The Define Display Height dialog is displayed.

Figure 111: The Define display Height dialog.

6. In the Height field, use the default value of 1.5 m.

Note:  This value is used only to specify the display height. This value has no impact
on the height at which the prediction results are calculated.

7. Click OK to close the Define Display Height dialog.
The top view of the urban geometry database is displayed.
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Figure 112: A top view of Frankfurt.

Note:  The red rectangle indicates the extent of the computational domain.

3.6.3 Verifying All Building Heights
Verify that all building heights are correct.

1. View all building heights using one of the following workflows:

• On the Settings menu, click  Local Settings (Display of data).

• On the Edit toolbar, click the  Local Settings (Display of data) icon.

The Display Settings dialog is displayed.
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Figure 113: The Display Settings (Layout tab) dialog.

2. Next to the Urban database (vector data) check box, click Options.
The Display of Buildings dialog is displayed.

Figure 114: The Display of Buildings dialog.

3. Under Height of buildings, click Display for all buildings.

4. Click OK to close the Display of Buildings dialog.

5. Click OK to close the Display Settings dialog.

6. Confirm that all buildings heights are correct.
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Figure 115: The height of each building is displayed. Zoom in to read specific values.

Note:  All building heights are displayed using rounded values.

7. Disable the display of all building heights by repeating Step 1 to Step 3, but click Do not display.

3.6.4 Determining Building Height for Antenna Placement
In an urban scenario, antennas are usually placed at the top of a building. When defining an antenna
site, you require the height of the building to ensure that the antenna is placed above the building not
inside.

1. Determine the height of a specific building using one of the following workflows:

• On the Display menu, click  Balloon Tips.

• On the Utility toolbar, click the  Balloon tip icon.

The mouse cursor changes from a “+” to an “X”.

2. Hover with the mouse over a building to view the building height in a balloon tip.
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Figure 116: The height of the building at the mouse cursor is displayed in a balloon tip.

3. Repeat Step 1 to disable the balloon-tip mode.

3.6.5 Defining the First Antenna Site and Antennas
Define the first antenna site with three antennas.

The height of the building where the antenna 1 is to be placed is 135.84 m[24]. The height of the
antenna mast is 15 m with the result that the antenna will be located at 150.84 m.

1. Specify the transmitter type and settings using one of the following workflows:

• On the Project menu, click Sites > Site: New.

• On the Project toolbar, click the  Set Site icon.

The Transmitter Type dialog is displayed.

24. Determine the building height as described in Determining Building Height for Antenna Placement.
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Figure 117: The Transmitter Type dialog.

2. Under Settings, click 3 Sector Site.

3. Click OK to close the Transmitter Type dialog.
In the 2D view, the mouse cursor is displayed as a circle to indicate that the Set site tool is
enabled.

4. Click near the point (indicated by an orange circle) in Figure 118.

Figure 118: Place the first antenna site at the location of the orange dot.
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Note:  The exact coordinates are not important for this example, but the above
location is used in the steps that follow.

The Site dialog is displayed.

Figure 119: The Site dialog.

5. Under Location, in the z/Height field, enter a value of 135.84 m.

6. On the Site dialog, click on Site 1 Antenna 1 to select and click Edit.
The Cell dialog is displayed for antenna 1.

7. Under Transmitter Settings, in the Frequency (used for propagation) field, enter a value of
1800 MHz.

8. Under Location of Antenna, in the z / Height field, enter a value of 150.84 m.

9. Under Antenna Pattern, click Directional / Sector antenna.

10. Under Orientation, in the Downtilt field, enter a value of 4°.

11. Under Antenna Pattern, click Select to browse to the file farfield_gain_3d.ffe.

12. Click OK to close the Cell dialog.
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Figure 120: The Cell dialog for antenna 1.

13. Repeat Step 6 to Step 12 to define antenna 2.

14. Repeat Step 6 to Step 12 to define antenna 3.

15. Click OK to close the Site dialog.

16. Disable the Set site tool by clicking again on the  Set Site icon.

3.6.6 Defining the Second Antenna Site and Antennas
Define the second antenna site with three antennas.

The height of the building where the antenna 2 is to be placed is 30.11 m[25]. The height of the antenna
mast is 15 m with the result that the antenna will be located at 45.11 m.

1. Specify the transmitter type and settings using one of the following workflows:

• On the Project menu, click Sites > Site: New.

• On the Project toolbar, click the  Set Site icon.

The Transmitter Type dialog is displayed.

25. Determine the height of the building as described in Determining Building Height for Antenna
Placement.
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Figure 121: The Transmitter Type dialog.

2. Under Settings, click 3 Sector Site.

3. Click OK to close the Transmitter Type dialog.
In the 2D view, the mouse cursor is displayed as a circle to indicate that the Set site tool is
enabled.

4. Click near the point (indicated by an orange circle) in Figure 122.

Figure 122: Place the second antenna site at the location of the orange dot.
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Note:  The exact coordinates are not important for this example, but the above
coordinate is used in the steps that follow.

The Site dialog is displayed.

5. Under Location, in the z/Height field, enter a value of 30.11 m.

6. On the Site dialog, click on Site 2 Antenna 1 to select and click Edit.
The Cell dialog is displayed for antenna 1.

7. Under Transmitter Settings, in the Frequency (used for propagation) field, enter a value of
1800 MHz.

8. Under Location of Antenna, in the z / Height field, enter a value of 45.11 m.

9. Under Antenna Pattern, click Directional / Sector antenna.

10. Under Orientation, in the Downtilt field, enter a value of 4°.

11. Under Antenna Pattern, click Select to browse to the file farfield_gain_3d.ffe.

Figure 123: The Cell dialog for antenna 1.

12. Click OK to close the Cell dialog.

13. Repeat Step 6 to Step 12 to define antenna 2.

14. Repeat Step 6 to Step 12 to define antenna 3.

15. Click OK to close the Site dialog.

16. Disable the Set site tool by clicking again on the  Set Site icon.
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3.6.7 Using the Dominant Path Model (DPM)
The urban database is solved using the dominant path model.

The dominant path model (DPM) is ideally suited to compute coverage predictions in very large areas as
the model does not require preprocessing of the vector building database. The DPM model only focuses
on the dominant path or paths between the transmitter and receiver, which leads to short computation
time. The accuracy of this method is nearly identical to a ray-tracing model.

Specifying the Prediction Resolution and Height
Define the resolution grid and the height where the prediction results are to be calculated.

1. Launch the Edit Project Parameters dialog using one of the following workflows:

• On the Project menu, click  Edit Project Parameters.

• On the Project toolbar, click the  Edit Project Parameters icon.

• Press F3 to use the keyboard shortcut.

2. Click the Simulation tab.

3. Under Resolution of prediction results, in the Resolution field, enter a value of 2 m.
The prediction results will be computed with a resolution (grid) of 2 m.

4. Under Prediction Height, in the Height field, enter a value of 1.5 m.

Tip:  Multiple prediction heights can be specified by entering space-separated values.

For example: 1.5 2 2.5
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Figure 124: The Edit Project Parameters dialog - Simulation tab.

Note:  Keep the dialog open to define additional project parameters.

Specifying the Output Folder for the Prediction Results
Specify the folder for the prediction results to be computed using the dominant path model.

1. Click the Propagation tab.

2. Specify the output folder for the results to be computed using the dominant path model.

a) Under Output Directory / Basic Filename for Propagation Results, in the Directory
field, change the default PropName to Results\Prop03_DPM.
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Figure 125: The Edit Project Parameters dialog - Propagation tab.

Note:  Keep the dialog open to define additional project parameters.

Defining the Prediction Requests
Specify the predictions to be computed.

1. Under Computed Prediction Results, select the Field strength check box.

2. Under Computed Prediction Results, select the Path Loss check box.

3. Under Computed Prediction Results, select the LOS[26] Analysis check box.

Note:  Keep the dialog open to define additional project parameters.

26. Line-of-sight (LOS) condition: Direct line of sight between transmitted and receiver.
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Specifying the Computation Method
Select the dominant path model (DPM) as computation method.

1. Click the Computation tab.

2. Under Prediction model (Urban), click Dominant Path Model.
3. Under Indoor Prediction, select the  Indoor Coverage (without indoor walls) check box.

Note:  The option computes an estimation of the indoor coverage.

Figure 126: The Edit Project Parameters dialog - Computation tab.

4. Click OK to close the Edit Project Parameter dialog.

Saving the Project
Save the new project to file.

1. On the File menu, click Save Project As.

2. Enter Frankfurt.net as the file name for the project and click Save.

Launching the Solver
Compute the propagation for all antennas to obtain the prediction results.

Launch the Solver using one of the following workflows:

• On the Project toolbar, click the  Computes propagation for all antennas icon.

• On the Computation menu, click Propagation: Compute All.
• Press F5 to use the keyboard shortcut.
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The Solver is launched, and the Computation dialog is displayed.

Note:  For this example, several warnings are displayed. Ignore these warnings, as it only
states that the imported pattern is a directivity pattern rather than a gain pattern.

Viewing the Prediction Results
Display the power results using the dominant path model.

1. View the power in the 3D view using the dominant path model in the urban environment.

a) On the Edit toolbar, click the  3D View icon.

b) In the tree, expand  Results: Propagation to view the sites.

c) In the tree, expand  Site 2 to view the three antennas.

d) In the tree, expand  Site 2 Antenna 3 to view the Power.

Figure 127: View the power (dBm) in the 3D view.

a) Click the  3D View icon again to return to the 2D view.

2. View the power using the dominant path model in the urban environment.

a) In the tree, expand  Results: Propagation to view Site 2.

b) In the tree, expand  Site 2 to view the three antennas.

c) In the tree, expand  Site 2 Antenna 3 to view the Field Strength and Power entries.

d) In the tree, click  Power to view the results.
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Figure 128: Power calculated for Site 2 Antenna 3 using the dominant path model (DPM).

3. View the power inside the buildings.

a) On the Settings menu, click Local Settings (Display of Data).

b) Click the Layout tab and next to the Urban database (vector data), click Options.

c) On the Display of buildings dialog, under Drawing of buildings, clear the Fill Buildings
check box.

d) Click OK to close the Display of Buildings dialog.

e) Click OK to close the Display Settings dialog.

Figure 129: Power calculated for Site 2 Antenna 3 using the dominant path model (DPM). The Fill
Buildings display setting is disabled.
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3.6.8 Using COST 231: Extended Walfisch-Ikegami Model
The urban database is solved using the COST 231 - extended Walfisch-Ikegami model.

This method is suited for high transmitters in urban scenarios when the dominant path is expected to be
in the vertical plane over rooftops, followed by diffraction down into the street.

transmitter

hTX
hroof receiver

hRX

b
d

w
building

rooftop

Figure 130: Urban propagation scenario using the COST 231 Walfisch-Ikegami Model.

A wave that is guided along a street between buildings would not be included. Simulations using COST
231 - extended Walfisch-Ikegami model tends to be fast.

Specifying the Output Folder for the Prediction Results
Specify the folder for the prediction results to be computed using the COST 231 - extended Walfisch-
Ikegami model.

1. Launch the Edit Project Parameters dialog using one of the following workflow:

• On the Project menu, click  Edit Project Parameters.

• On the Project toolbar, click the  Edit Project Parameters icon.

• Press F3 to use the keyboard shortcut.

2. Click the Propagation tab.

3. Specify the output folder for the results to be computed using the dominant path model.

a) Under Output Directory / Basic Filename for Propagation Results, in the Directory
field, change Prop03_DPM to Results\Prop03_COST231.

Note:  Keep the dialog open to define additional project parameters.

Specifying the Computation Method
Select the COST 231 - extended Walfisch-Ikegami model as computation method.

1. Click the Computation tab.

2. Under Prediction model (Urban), click Empirical Vertical Plane Model: COST 231:
Extended Walfisch-Ikegami-Model.
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3. Under Indoor Prediction, select the  Indoor Coverage (without indoor walls) check box.

4. Click OK to close the Edit Project Parameter dialog.

Launching the Solver
Compute the propagation for all antennas to obtain the prediction results.

Launch the Solver using one of the following workflows:

• On the Project toolbar, click the  Computes propagation for all antennas icon.

• On the Computation menu, click Propagation: Compute All.
• Press F5 to use the keyboard shortcut.

The Solver is launched, and the Computation dialog is displayed.

Note:  For this example, several warnings are displayed. Ignore these warnings, as it only
states that the imported pattern is a directivity pattern rather than a gain pattern.

Viewing the Prediction Results
Display the power results using the COST 231 - extended Walfisch-Ikegami model.

1. In the tree, expand  Results: Propagation to view Site 2.

2. In the tree, expand  Site 2 to view the three antennas.

3. In the tree, expand  Site 2 Antenna 3 to view the Field Strength and Power entries.

4. In the tree, click  Power to view the results.

Figure 131: Power calculated for Site 2 Antenna 3 using the COST 231 - extended Walfisch-Ikegami model.
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3.7 Final Remarks
This example showed how to analyze base stations in a city, to create the urban database using
WallMan and to obtain coverage plots using ProMan.

Many concepts were introduced in this example that apply to models commonly created in WallMan and
ProMan.

The base stations, set in an urban environment, were solved using the dominant path model and COST
231 - extended Walfisch-Ikegami model. The dominant path model is in general recommended over
empirical models because it includes all relevant effects that influence the actual radio channel.
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4 Base Stations on Hills Near a City

This example considers the application of analyzing base stations on hills near a city, set in a rural or
suburban hilly terrain.

This chapter covers the following:

• 4.1 Example Overview  (p. 128)

• 4.2 Topics Discussed in Example  (p. 129)

• 4.3 Example Prerequisites  (p. 130)

• 4.4 Pixel Databases for Rural/Suburban Scenarios  (p. 131)

• 4.5 Setting Up the Simulation in ProMan  (p. 133)

• 4.6 Final Remarks  (p. 151)
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4.1 Example Overview
This example considers the application of analyzing base stations in a rural or suburban hilly terrain.

The 3D model of the rural/suburban environment is created by importing topography and clutter
databases to allow for accurate predictions of the signal level.

The antenna patterns were obtained using AMan, but the steps on how to obtain the antenna pattern
are not in the scope of this example.

Coverage plots are produced using ProMan to determine the cell phone coverage for two base stations
set in hilly terrain. Two different propagation models are used, namely the dominant path model (DPM)
and the deterministic two ray model (DTR).
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4.2 Topics Discussed in Example
Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

• ProMan

◦ Launch ProMan.

◦ Import topography and clutter databases.

◦ Specify the antenna sites, orientations and properties.

◦ Specify the simulation parameters.

◦ Specify the computation method.

◦ Save the project.

◦ Launch the Solver.

◦ View the prediction results and compare the results using different models.

Note:  Follow the example steps in the order they are presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the Altair installation directory, for example:

Altair\2025.1\help\winprop\examples\GetStarted_models
\Project4_Rural_Suburban_Scenario.
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4.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1[27] or later should be installed.

27. WinProp is included as part of the Feko installation.
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4.4 Pixel Databases for Rural/Suburban Scenarios
Pixel databases are used to describe the topography, land usage and buildings in a rural/suburban
scenario to obtain accurate predictions.

The wave propagation in rural and suburban scenarios is often characterized by multipath propagation
due to interactions (reflections, diffractions, scattering) at various obstacles (hills, buildings, towers).

For the multipath propagation model, such as the rural ray-tracing model, considering phenomena like
multiple reflections and waveguiding effects in canyons is required to obtain accurate predictions of the
signal level and the spatial channel impulse response.

However, this approach requires rural pixel databases for the description of topography, land usage, and
buildings within the simulation environment.

4.4.1 Topography Database
A topographical database is a pixel database that contains surface elevation information as a function of
position.

Figure 132: An example of a topographical database for the Grand Canyon.

Convert a third-party format to the WinProp data format by clicking Data > Topography Database >
Convert in ProMan.

4.4.2 Clutter Database
A clutter database is a pixel matrix and contain information about and usage at a given location.

Land usage databases are also called clutter databases or morpho databases. Land usage influences the
wave propagation in a rural or suburban scenario.

Note:  The use of clutter databases are optional and not mandatory for predictions.
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Figure 133: An example of a clutter database for Seoul.

Convert a third-party format to the WinProp data format by clicking Data > Clutter (Morpho)
Database > Convert.
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4.5 Setting Up the Simulation in ProMan
Set up the propagation simulation parameters. Solve the rural/suburban database and inspect the
coverage plots for various models.

The rural/suburban database is solved using the following models:

• dominant path model (DPM)

• deterministic two ray model (DTR) with knife edge diffraction

4.5.1 Launching ProMan
Launch ProMan in Microsoft Windows using the Feko Launcher utility (which includes WinProp and
newFASANT).

4.5.2 Creating a New Project
1. On the File menu, click New Project.

The New Project dialog is displayed.

2. Under Scenario, from the drop-down list, select Rural and Suburban Scenarios (Pixel
databases for topo and clutter).

a) Select the Consider additionally land usage (clutter, morpho) check box.

3. Under Databases, select the three database file:

a) In the Topography (Pixel Database) field, browse to HillyTerrain.tdb[28].

b) In the Land usage / Clutter (Pixel database) field, browse to HillyTerrain.mdb[29].

c) In the Land usage / Clutter (Class Definitions) field, browse to HillyTerrain.mct[30].

Note:  Topography and clutter databases are supplied by external vendors and can be
converted to WinProp file formats.

28. Altair\2025.1\help\winprop\examples\GetStarted_models
\Project4_Rural_Suburban_Scenario\Database\HillyTerrain.tdb

29. Altair\2025.1\help\winprop\examples\GetStarted_models
\Project4_Rural_Suburban_Scenario\Database\HillyTerrain.mdb

30. Altair\2025.1\help\winprop\examples\GetStarted_models
\Project4_Rural_Suburban_Scenario\Database\HillyTerrain.mct
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Figure 134: The New Project dialog.

4. Click OK to close the New Project dialog.
A top view of the topography database is displayed.

Figure 135: Top view of the topography database.
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4.5.3 Viewing the Clutter Database
View the clutter database to obtain information regarding land usage.

1. In the tree, expand  Database to view the imported databases.

2. In the tree, click  Clutter/Morpho to view the land usage of the hilly terrain.

Figure 136: Top view of the clutter database.

Note:  The city center is located at the top right, indicated in pink.

3. Observe the land usage in Figure 136.

• Upper left of database: medium-density urban and low-density urban

• Upper right of database: city center and industrial zone

• Center of database: Forested hills

4. View the topography database along with the clutter database.

a) On the Settings menu, click  Local Settings (Display of data).

b) Click the Layout tab.

c) Select the Topography database (DEM) check box.

Figure 137: Top view of the clutter database along with the topography.
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4.5.4 Defining the First Antenna Site and Antennas
Define the first cellular base station located on the highest hill. The antennas are placed 30 m above
ground.

1. Specify the transmitter type and settings using one of the following workflows:

• On the Project menu, click Sites > Site: New.

• On the Project toolbar, click the  Set Site icon.

The Transmitter Type dialog is displayed.

Figure 138: The Transmitter Type dialog.

2. Under Settings, click 3 Sector Site.

3. Click OK to close the Transmitter Type dialog.
In the 2D view, the mouse cursor is displayed as a circle to indicate that the Set site tool is
enabled.

4. Place the cellular base station with a left-mouse click on the highest hill in the model, at or near
(X, Y) = (513628, 5400187), as indicated in Figure 139.
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Figure 139: Location of the first cellular base station. The base station is located on the highest hill.

Note:  The exact coordinates are not important for this example, but the above
location is used in the steps that follow.

The Site dialog is displayed.

Figure 140: The Site dialog.

5. In the Site ID field, change the label to Highest_45.

6. Under Location, in the z/Height field, enter a value of 0 m.

7. Click on Site 1 Antenna 1 to select and click Edit.
The Cell dialog is displayed for antenna 1.
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8. Under Transmitter Settings, in the Frequency (used for propagation) field, enter a value of
1800 MHz.

9. Under Location of Antenna, in the z / Height field, enter a value of 30 m.

10. Under Antenna Pattern, click Directional / Sector antenna.

11. Under Orientation, in the Azimuth field, enter a value of 45°.

12. Under Orientation, in the Downtilt field, enter a value of 0°.

13. Under Antenna Pattern, click Select to browse to the file Sector.apb[31].

Note:  Sector.apb is an antenna pattern created in AMan.

14. Click OK to close the Cell dialog.

Figure 141: The Cell dialog for antenna 1.

15. Repeat Step 7 to Step 14 to define antenna 2.

a) For the antenna orientation, change Azimuth to 165°.

16. Repeat Step 7 to Step 14 to define antenna 3.

a) For the antenna orientation, change Azimuth to 285°.

17. Click OK to close the Site dialog.

31. Altair\2025.1\help\winprop\examples\GetStarted_models
\Project4_Rural_Suburban_Scenario\Antennas\Sector.apb
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18. Disable the Set site tool by clicking again on the  Set Site icon.

4.5.5 Defining the Second Antenna Site and Antennas
Define the second cellular base station located on a lower hill. The antennas are placed 30 m above
ground.

1. Specify the transmitter type and settings using one of the following workflows:

• On the Project menu, click Sites > Site: New.

• On the Project toolbar, click the  Set Site icon.

The Transmitter Type dialog is displayed.

Figure 142: The Transmitter Type dialog.

2. Under Settings, click 3 Sector Site.

3. Click OK to close the Transmitter Type dialog.
In the 2D view, the mouse cursor is displayed as a circle to indicate that the Set site tool is
enabled.

4. Place the cellular base station with a left-mouse click on a lower hill closer to town in the model,
at or near (X, Y) = (516000, 5402142) as indicated in Figure 143.
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Figure 143: Location of the second cellular base station. The base station is placed on a lower hill.

Note:  The exact coordinates are not important for this example, but the above
location is used in the steps that follow.

The Site dialog is displayed.

Figure 144: The Site dialog.

5. In the Site ID field, change the label to Mediumheight_45.

6. Under Location, in the z/Height field, enter a value of 0 m.

7. Click on Site 2 Ant 1 to select and click Edit.
The Cell dialog is displayed for antenna 1.
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8. Under Transmitter Settings, in the Frequency (used for propagation) field, enter a value of
1800 MHz.

9. Under Location of Antenna, in the z / Height field, enter a value of 30 m.

10. Under Antenna Pattern, click Directional / Sector antenna.

11. Under Orientation, in the Azimuth field, enter a value of 45°.

12. Under Orientation, in the Downtilt field, enter a value of 0°.

13. Under Antenna Pattern, click Select to browse to the file Sector.apb[32].

Note:  Sector.apb is an antenna pattern created in AMan.

14. Click OK to close the Cell dialog.

Figure 145: The Cell dialog for antenna 1.

15. Repeat Step 7 to Step 14 to define antenna 2.

a) For the antenna orientation, change Azimuth to 165°.

16. Repeat Step 7 to Step 14 to define antenna 3.

a) For the antenna orientation, change Azimuth to 285°.

17. Click OK to close the Site dialog.

32. Altair\2025.1\help\winprop\examples\GetStarted_models
\Project4_Rural_Suburban_Scenario\Antennas\Sector.apb
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18. Disable the Set site tool by clicking again on the  Set Site icon.
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4.5.6 Using the Dominant Path Model (DPM)
The rural/suburban database is solved using the dominant path model (DPM).

Specifying the Prediction Resolution and Height
Define the resolution grid and the height where the prediction results are to be calculated.

1. Launch the Edit Project Parameters dialog using one of the following workflows:

• On the Project menu, click  Edit Project Parameters.

• On the Project toolbar, click the  Edit Project Parameters icon.

• Press F3 to use the keyboard shortcut.

2. Click the Simulation tab.

3. Under Resolution of prediction results, in the Resolution field, enter a value of 20 m.
The prediction results will be computed with a resolution (grid) of 20 m.

4. Under Prediction Height, in the Height field, enter a value of 1.5 m.

Figure 146: The Edit Project Parameters dialog - Simulation tab.

Note:  Keep the dialog open to define additional project parameters.
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Specifying the Output Folder for the Prediction Results
Specify the folder for the prediction results to be computed using the DPM.

1. Click the Propagation tab.

2. Specify the output folder for the results to be computed using the dominant path model.

a) Under Output Directory / Basic Filename for Propagation Results, in the Directory
field, change the default PropName to Results\Prop04_DPM.

Figure 147: The Edit Project Parameters dialog - Propagation tab.

Note:  Keep the dialog open to define additional project parameters.

Defining the Prediction Results
Specify the predictions to be computed.

1. Under Computed Prediction Results, select the Field strength check box.

2. Under Computed Prediction Results, select the Path Loss check box.
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Note:  Keep the dialog open to define additional project parameters.

Specifying the Computation Method
Select the dominant path model (DPM) as computation method.

1. Click the Computation tab.

2. Under Prediction model, click Dominant Path Model (DPM).

Figure 148: The Edit Project Parameters dialog - Computation tab.

3. Click OK to close the Edit Project Parameter dialog.

Saving the Project
Save the new project to file.

1. On the File menu, click Save Project As.

2. Enter HillyTerrain.net as the file name for the project and click Save.
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Launching the Solver
Compute the propagation for all antennas to obtain the prediction results.

Launch the Solver using one of the following workflows:

• On the Project toolbar, click the  Computes propagation for all antennas icon.

• On the Computation menu, click Propagation: Compute All.
• Press F5 to use the keyboard shortcut.

The Solver is launched, and the Computation dialog is displayed.

Viewing the Prediction Results
Display the power results using the dominant path model (DPM).

1. View the power using the DPM for the base station located on the highest hill.

a) In the tree, expand  Results: Propagation to view the results for the two base stations.

b) In the tree, expand  Highest_45 to view the base station on the highest hill.

c) In the tree, expand  Site 1 Ant 1 to view the result entries.

d) In the tree, click  Power to view the power result.

e) Right-click on the legend and from the right-click context menu, click Thresholds >
Manual.

f) In the Max field, enter a value of -30 dBm.

g) In the Min field. enter a value of -120 dBm.

Figure 149: Power calculated for the base station located at the highest hill - Site 1 Ant 1 using the DPM.
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Note that this antenna has broad coverage over a large area, but not towards the city center. It
has no line of sight to the city center; a few lower hills are in the way.

2. View the power using the DPM for the base station located on a lower hill.

a) In the tree, expand  Results: Propagation to view the results for the two base stations.

b) In the tree, expand  Mediumheight_45 to view the base station on the lower hill.

c) In the tree, expand  Site 2 Ant 1 to view the result entries.

d) In the tree, click  Power to view the power result.

Figure 150: Power calculated for the base station located on a lower hill - Site 2 Ant 1 using the DPM.

Note that this antenna has great coverage of the city and poor coverage elsewhere.
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4.5.7 Using the Deterministic Two Ray Model (DTR)
The rural/suburban database is solved using the deterministic two ray model (DTR).

Specifying the Output Folder for the Prediction Results
Specify the folder for the prediction results to be computed using the DTR.

1. Click the Propagation tab.

2. Specify the output folder for the results to be computed using the deterministic two ray model.

a) Under Output Directory / Basic Filename for Propagation Results, in the Directory
field, change the default PropName to Results\Prop04_DTR.

Specifying the Computation Method
Select the deterministic two ray model (DTR) as computation method.

1. Click the Computation tab.

2. Under Prediction model, click Deterministic Two Ray Model (incl. visibility check).

3. Under Additional Modules for Prediction Models, select the Consideration of Knife Edge
Diffraction in Vertical Plane check box.

Note:

The deterministic two ray model only predicts power for pixels that can be reached by
the direct and/or ground-reflected ray.

For pixels farther away, the knife edge diffraction method extends the results of the
two-ray model by considering diffractions at hilltops and obstacles.

4. Click OK to close the Edit Project Parameter dialog.

Launching the Solver
Compute the propagation for all antennas to obtain the prediction results.

Launch the Solver using one of the following workflows:

• On the Project toolbar, click the  Computes propagation for all antennas icon.

• On the Computation menu, click Propagation: Compute All.
• Press F5 to use the keyboard shortcut.

The Solver is launched, and the Computation dialog is displayed.

Proprietary Information of Altair Engineering



Altair WinProp 2025.1
4 Base Stations on Hills Near a City p.149

Viewing the Prediction Results
Display the power results using the deterministic two ray model (DTR).

1. View the power using the DTR for the base station located on the highest hill.

a) In the tree, expand  Results: Propagation to view the results for the two base stations.

b) In the tree, expand  Highest_45 to view the base station on the highest hill.

c) In the tree, expand  Site 1 Ant 1 to view the result entries.

d) In the tree, click  Power to view the power result.

Figure 151: Power calculated for the base station located at the highest hill - Site 1 Ant 1 using the DTR.

2. View the power using the DTR for the base station located on a lower hill.

a) In the tree, expand  Results: Propagation to view the results for the two base stations.

b) In the tree, expand  Mediumheight_45 to view the base station on the lower hill.

c) In the tree, expand  Site 2 Ant 1 to view the result entries.

d) In the tree, click  Power to view the power result.
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Figure 152: Power calculated for the base station located on a lower hill - Site 2 Ant 1 using the DTR.

The DTR model only provides line-of-sight predictions. If the rays are shadowed by obstacles, the rays
are not considered. The received power is only predicted for pixels which can be reached by the direct
ray and/or the ground reflected ray. To get a prediction for the non-line-of-sight pixels, the DTR must be
combined with the knife edge diffraction model to include the diffractions at the topographical obstacles.

The white pixels in the results indicate results below -120 dBm as the legend threshold range was
specified from -30 dBm to -120 dBm.
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4.6 Final Remarks
This example showed how to analyze two cellular base stations set in a rural/suburban scenario with
hilly terrain and to obtain coverage plots using ProMan.

Many concepts were introduced in this example that apply to models commonly created in ProMan. The
two cellular base stations in a hilly terrain were solved using two different models. The dominant path
model (DPM) is the best choice for rural/suburban scenario with hilly or mountainous terrain.
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5 Network Planning

This example considers the application of analyzing three base stations, set in a building. The network
planning simulation is based on a pre-defined air interface file.

This chapter covers the following:

• 5.1 Example Overview  (p. 153)

• 5.2 Topics Discussed in Example  (p. 154)

• 5.3 Example Prerequisites  (p. 155)

• 5.4 Predefined Air Interface File (.WST)  (p. 156)

• 5.5 Setting Up the Simulation in ProMan  (p. 157)
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5.1 Example Overview
This example considers a network planning simulation in ProMan.

Note:

A network-planning simulation starts with regular propagation simulation that provides
results like received power over the area of interest.

As a second step, a network planning simulation is launched that adds results like Signal-
to-Noise and Interference ratio (SNIR), cell assignment, and maximum data rate. Network
planning can be regarded as the post-processing of a propagation simulation.

For this example, three base station sites are defined in an indoor scenario. For each site, an isotropic
antenna is placed and the carriers are defined.

Coverage plots are produced using a propagation simulation to determine the cell phone reception
inside a building. The propagation model used to solve the database is the dominant path model (DPM).

A network planning simulation is launched that uses the propagation results to provide the best cell
assignment and interference levels.
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5.2 Topics Discussed in Example
Before starting this example, check if the topics discussed in this example are relevant to the intended
application and experience level.

The topics discussed in this example are:

• ProMan

◦ Launch ProMan.

◦ Specify a predefined air interface file (.wst)[33].

◦ Specify the antenna sites, powers, and carriers of the three base stations.

◦ Specify the simulation parameters.

◦ Specify the computation method.

◦ Save the project.

◦ Launch the Solver (propagation simulation).

◦ Launch the Solver (network simulation).

◦ View the prediction results (for example, Signal-to-Noise and Interference Ratio (SNIR))

Note:  Follow the example steps in the order they are presented as each step uses its
predecessor as a starting point.

Tip:  Find the completed model in the Altair installation directory, for example:

Altair\2025.1\help\winprop\examples\GetStarted_models
\Project5_Network_Planning.

33. Available for most of the common wireless technologies.
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5.3 Example Prerequisites
Before starting this example, ensure that the system satisfies the minimum requirements.

The requirements for this example are:

• Feko 2025.1[34] or later should be installed.

34. WinProp is included as part of the Feko installation.
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5.4 Predefined Air Interface File (.WST)
Network parameters can be loaded from a predefined .wst file which is available for most of the
common wireless technologies.

For network planning, the air interface (for example, CDMA, OFDM), requires parameters to be defined
related to the carriers (number, bandwidth, separation), transmission modes, coding, and the required
signal-to-noise-and-interference ratio at the receiver. This information may be loaded from a .wst

file[35].

Tip:  Find a list of predefined .wst files in the Altair installation directory, for example:

Altair\2025.1\help\winprop\examples\ExampleGuide_models\Example-A07-
Air_Interfaces_aka_Wireless_Standards.zip.

35. Alternatively, you can define the individual air interface manually (only recommended for
experienced users).
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5.5 Setting Up the Simulation in ProMan
Define the three base station sites, antennas and carriers.

The indoor database is solved using the dominant path model (DPM).

5.5.1 Launching ProMan
Launch ProMan in Microsoft Windows using the Feko Launcher utility (which includes WinProp and
newFASANT).

5.5.2 Creating a New Project
1. On the File menu, click New Project.

The New Project dialog is displayed.

Figure 153: The New Project dialog.

2. Under Wireless Technology (Air Interface), from the drop-down list, select
Network Planning based on description file for air interface and browse to

LTE_Band1_BW_05MHz_FDD.wst[36].

3. Under Scenario, from the drop-down list, select Indoor Scenarios (3D vector databases for
arbitrary 3D scenarios).

36. Altair\2025.1\help\winprop\examples\GetStarted_models\Project5_Network_Planning
\LTE_Band1_BW_05MHz_FDD.wst
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4. Under Databases, in the 3D indoor building data (Vector database) field, browse to

Office.idb[37].

5. Under Polarimetric Analysis, select Standard (suitable for all scenarios and propagation
models).

6. Click OK to close the New Project dialog.
The Define Display Height dialog is displayed.

Figure 154: The Define display Height dialog.

7. In the Height field, use the default value of 1.5 m.

Note:  This value is used only to specify the display height. This value has no impact
on the height at which the prediction results are calculated.

8. Click OK to close the Define Display Height dialog.

5.5.3 Saving the Project
Save the new project to file.

1. On the File menu, click Save Project.
2. Save the new project as office.net.

Two files are written to disk:

• office.net

• office.nip

Note:

To share a network planning project, you require a .net file and one of the following:

• .nip (indoor scenario)

• .nup (urban scenario)

• .nrp (rural scenario)

37. Altair\2025.1\help\winprop\examples\GetStarted_models\Project5_Network_Planning
\Office.idb
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5.5.4 Defining the First Base Station
Define the first site, place the first omnidirectional antenna at this location, and assign a carrier. The
antenna is placed at a height of 2.5 m above ground.

The first antenna is placed at the intersection of the corridors (top, left) at a height of 2.5 m, see
Figure 155. A carrier is assigned to the antenna.

Figure 155: Location of the first antenna site.

1. Specify the transmitter type and settings using one of the following workflows:

• On the Project menu, click Sites > Site: New.

• On the Project toolbar, click the  Set Site icon.

Figure 156: The Transmitter Type dialog.
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2. Use the default settings.

Note:  Use Omni Site (1 Cell/Sector) as only a single antenna is defined per site.
This option does not imply an omnidirectional antenna.

3. Click OK to close the Transmitter Type dialog.
In the 2D view, the mouse cursor is displayed as a circle to indicate that the Set site tool is
enabled.

4. Click near point (X, Y) = (5.84, 6.35) in the 2D view to place the site.

Tip:  The coordinates at the current mouse cursor are displayed in the Status bar.

The Site dialog is displayed.

Figure 157: The Site dialog.

5. On the Site dialog, click on Site 1 Ant 1 to select and click Edit.
The Cell dialog is displayed.
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Figure 158: The Cell dialog.

6. Under Antenna Pattern, confirm that Omnidirectional (isotropic) antenna is selected.

7. Under Transmitter and Receiver Settings, click Assign Carrier.
The Carrier Assignment dialog is displayed.

Figure 159: The Carrier Assignment dialog.
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8. Under Available Carriers, double-click on a carrier to select.

Note:  For this site, ID 25 was selected as carrier.

The Carrier dialog is displayed.

Figure 160: The Carrier dialog.

9. Under Properties of the Carrier, set Max. TX Power to 10 dBm.

10. Click OK to close the Carrier dialog.

11. Click OK to close the Carrier Assignment dialog.

12. Click OK to close the Cell dialog.

13. Click OK to close the Site dialog.

14. Disable the Set site tool by clicking again on the  Set Site icon.

5.5.5 Defining the Second Base Station
Define the second site, place the second omnidirectional antenna at this location, and assign a carrier.
The antenna is placed at a height of 2.5 m above ground.

The second antenna is placed at the intersection of the corridors (bottom, right) at a height of 2.5 m,
see Figure 161. Use the same carrier for antenna 2 as was defined for antenna 1.
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Figure 161: Location of the second antenna site.

1. Specify the transmitter type and settings using one of the following workflows:

• On the Project menu, click Sites > Site: New.

• On the Project toolbar, click the  Set Site icon.

Figure 162: The Transmitter Type dialog.

2. Use the default settings.

Note:  Use Omni Site (1 Cell/Sector) as only a single antenna is defined per site.
This option does not imply an omnidirectional antenna.

3. Click OK to close the Transmitter Type dialog.
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In the 2D view, the mouse cursor is displayed as a circle to indicate that the Set site tool is
enabled.

4. Click near point (X, Y) = (63.6700, -22.8800) in the 2D view to place the site.

Tip:  The coordinates at the current mouse cursor are displayed in the Status bar.

The Site dialog is displayed.

Figure 163: The Site dialog.

5. On the Site dialog, click on Site 2 Ant 1 to select and click Edit.
The Cell dialog is displayed.
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Figure 164: The Cell dialog.

6. Repeat Step 6 to Step 14 to specify the antenna and its carrier.

Note:  In this example, the same carrier is assigned to base station 2 as was assigned
to base station 1.

5.5.6 Defining the Third Base Station
Define the third site, place the third omnidirectional antenna at this location, and assign a carrier. The
antenna is placed at a height of 2.5 m above ground.

The third antenna is placed at the intersection of the corridors (center, right) at a height of 2.5 m, see
Figure 165. A carrier is assigned to the antenna.
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Figure 165: Location of the third antenna site.

1. Specify the transmitter type and settings using one of the following workflows:

• On the Project menu, click Sites > Site: New.

• On the Project toolbar, click the  Set Site icon.

Figure 166: The Transmitter Type dialog.

2. On the Transmitter Type dialog, use the default settings.

Note:  Use Omni Site (1 Cell/Sector) as only a single antenna is defined per site.
This option does not imply an omnidirectional antenna.

3. Click OK to close the Transmitter Type dialog.
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In the 2D view, the mouse cursor is displayed as a circle to indicate that the Set site tool is
enabled.

4. Click near point (X, Y) = (63.1400, 6.1400) in the 2D view to place the site.

Tip:  The coordinates at the current mouse cursor are displayed in the Status bar.

The Site dialog is displayed.

Figure 167: The Site dialog.

5. On the Site dialog, click on Site 3 Ant 1 to select and click Edit.
The Cell dialog is displayed.
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Figure 168: The Cell dialog.

6. Under Antenna Pattern, confirm that Omnidirectional (isotropic) antenna is selected.

7. Under Transmitter and Receiver Settings, click Assign Carrier.
The Carrier Assignment dialog is displayed.

Figure 169: The Carrier Assignment dialog.
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8. Under Available Carriers, double-click on a carrier to select.

Note:  For this site, ID 75 was selected as carrier.

The Carrier dialog is displayed.

Figure 170: The Carrier dialog.

9. Under Properties of the Carrier, set Max. TX Power to 10 dBm.

10. Click OK to close the Carrier dialog.

11. Click OK to close the Carrier Assignment dialog.

12. Click OK to close the Cell dialog.

13. Click OK to close the Site dialog.

14. Disable the Set site tool by clicking again on the  Set Site icon.

5.5.7 Project Parameters
Before starting a propagation simulation and a network simulation, define the parameters related to the
project.
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Specifying the Air Interface Settings
Specify the parameters for the air interface (wireless standard).

Note:

The parameters for the air interface were already defined by loading the .wst file.

You are encouraged to explore the numerous settings available for the air interface.

1. Launch the Edit Project Parameters dialog using one of the following workflows:

• On the Project menu, click  Edit Project Parameters.

• On the Project toolbar, click the  Edit Project Parameters icon.

• Press F3 to use the keyboard shortcut.

2. Click the Air Interface tab.

Figure 171: The Edit Project Parameters dialog - Air Interface tab.

3. Under Multiple Access, click Settings.

The OFDM and OFDMA dialog is displayed.
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Figure 172: The OFDM and OFDMA dialog.

a) Under Subcarriers, view the Max. number of subcarriers (FFT Order).

b) Click OK to close the OFDM and OFDMA dialog.

4. Under Duplex Separation, click Settings.

The Duplex Properties FDD dialog is displayed.

Figure 173: The Duplex Properties FDD dialog.

a) Under Duplex Separation in Frequency Division Duplex (FDD), view the Separation
between Uplink and Downlink.

b) Click OK to close the Duplex Properties FDD dialog.
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5. Under Mobile Station / Subscriber Station, click Settings.

The Mobile/Subscriber Stations dialog is displayed.

Figure 174: The Mobile/Subscriber Stations dialog.

a) View the settings of the mobile/subscriber stations.

b) Click OK to close the Mobile/Subscriber Stations dialog.

Note:  Keep the dialog open to define additional project parameters.

Specifying the Prediction Resolution, Height, and Network Type
Define the resolution grid, the height where the prediction results are to be calculated, and the type of
simulation for the network planning.

1. Click the Simulation tab.

2. Under Resolution of prediction results, in the Resolution field, enter a value of 0.5 m.
The prediction results will be computed with a resolution (grid) of 0.5 m.

3. Under Prediction Height (relative to ground), in the Height field, enter a value of 1.5 m.

4. Under Type of Network Simulation, select Static Simulation (homogeneous traffic per
cell).

Note:  A static simulation with homogeneous traffic is the most common choice.
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Figure 175: The Edit Project Parameters dialog - Simulation tab.

Note:  Keep the dialog open to define additional project parameters.

Specifying the Traffic in the Network
Specify the cell load settings that will be used for interference calculations.

1. Click the Traffic tab.

2. Under Consideration of Traffic and Load in Network, select Cell load defined by user (no
location dependent traffic).
If the traffic is defined as independent of the location, a traffic map is not required because it is
assumed that the traffic is homogeneously distributed over the complete prediction area.

3. Under Definition of Cell Load and Noise Rise, in the Assumed mean Tx power in downlink
for each transmitter/cell field, enter a value of 100%.
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Note:

• A mean Tx power of 100% represents the worst case for interference, where every
transmitter operates at full power.

• Parameters can also be set per site.

Figure 176: The Edit Project Parameters dialog - Traffic tab.

Note:  Keep the dialog open to define additional project parameters.
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Specifying the Output Folder for the Network Results
Specify the folder for the network prediction results to be computed using the dominant path model
(DPM).

1. Click the Network tab.

2. Specify the output folder for the results to be computed using the dominant path model.

a) Under Output Directory for Network Results, in the Directory field, change the default
PropName to Results\dpm.

Figure 177: The Edit Project Parameters dialog - Network tab.

Note:  Keep the dialog open to define additional project parameters.
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Specifying the Output Folder for the Propagation Results
Specify the folder for the propagation prediction results to be computed using the dominant path model
(DPM).

1. Click the Propagation tab.

2. Specify the output folder for the results to be computed using the dominant path model.

a) Under Output Directory / Basic Filename for Propagation Results, in the Directory
field, change the default PropName to Results\dpm.

Figure 178: The Edit Project Parameters dialog - Propagation tab.

Note:  Keep the dialog open to define additional project parameters.

Proprietary Information of Altair Engineering



Altair WinProp 2025.1
5 Network Planning p.177

Specifying the Computation Method
The indoor database is solved using the dominant path model (DPM)

1. Click the Computation tab.

2. Under Semi-Deterministic Propagation Models, click Dominant Path Model (DPM).

Note:  The dominant path model is fast and can be used for network planning.

3. Under Computation of signal level along propagation path (valid for all propagation
models), select Empirical Losses for Transmission, Reflection, and Diffraction.

Figure 179: The Edit Project Parameters dialog - Computation tab.

4. Click OK to close the Edit Project Parameter dialog.
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5.5.8 Launching the Solver (Propagation Simulation)
Compute the network coverage for the three antennas to obtain the prediction results.

Launch the Solver (propagation simulation) using one of the following workflows:

• On the Project toolbar, click the  Computes propagation for all antennas icon.

• On the Computation menu, click Propagation: Compute All.
• Press F5 to use the keyboard shortcut.

The Solver is launched and the Computation dialog is displayed.

Viewing the Prediction Results
Display the power results using the dominant path model (DPM).

View the power using the DPM for the third antenna site.

a) In the tree, expand  Results: Propagation to view the results for the three antennas.

b) In the tree, expand  Site3 to view the third antenna.

c) In the tree, expand  Site 3 Ant 1 to view the result entries.

d) In the tree, expand  Carrier 75 to view the carriers.

e) In the tree, click  Power to view the power result.

Figure 180: Power calculated for Site 3 Ant 1 using the DPM.
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5.5.9 Launching the Solver (Network Simulation)
Compute the propagation for the three antennas to obtain the prediction results.

Launch the Solver (propagation simulation) using one of the following workflows:

• On the Project toolbar, click the  Network Simulation icon.

• On the Computation menu, click Network Simulation.

• Press F7 to use the keyboard shortcut.

The Solver is launched and the Computation dialog is displayed.

Viewing the Prediction Results
Display the results from the network planning simulation.

1. View the cell area to determine which site is received best (depending on the location and defined
settings).

a) In the tree, expand  Results: Network to view the network planning results.

b) In the tree, click  Cell Area to determine which site is received best.

Figure 181: The cell area showing which site is received best for each receiver pixel.

2. View the best server for each receiver pixel.

a) In the tree, expand  Results: Network to view the network planning results.

b) In the tree, click  Best server to determine the best server for each receiver pixel.
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Figure 182: The best server result for each pixel. Note that Site 1 and Site 2 use the same carrier.

3. View the received power for cell assignment.

a) In the tree, expand  Results: Network to view the network planning results.

b) In the tree, expand  Cell Assignment and click  Received Power.

Figure 183: The received power for the cell assignment.

Proprietary Information of Altair Engineering



Altair WinProp 2025.1
5 Network Planning p.181

4. View the Signal-to-Noise-and-Interference Ratio (SNIR).

a) In the tree, expand  Results: Network to view the network planning results.

b) In the tree, expand  Cell Assignment and click  DL: SNIR (max).

Figure 184: The SNIR is low in the lower-left quadrant.

5. View the interference results.

a) In the tree, expand  Results: Network to view the network planning results.

b) In the tree, expand  Cell Assignment and click  Pilot: Interference.
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Figure 185: The interference in the lower-left quadrant is high because Site 1 and Site 2 are on the same
carrier.

The interference occurs because both sites emit an individual signal on the same frequency.
This can be changed by either assigning different carriers or by keeping the same carriers but
making them transmit the same signal, so the signal from one is no longer the interference of the

other.[38]

6. View the minimum transmit power to determine if the chosen modulation scheme can be used.

a) In the tree, expand  Results: Network to view the network planning results.

b) In the tree, expand  64 QAM - R=3_4 and click  DL: Min Tx Power BS.

38. See Figure 160, under Transmitted Signal.
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Figure 186: In white areas, the chosen modulation scheme cannot be used (a slower one may still work).

7. View the data rate to determine if communication is possible for the chosen scheme.

a) In the tree, expand  Results: Network to view the network planning results.

b) In the tree, expand  64 QAM - R=3_4 and click  DL: Data Rate.

Figure 187: In non-white areas, communication can take place at the data-rate of the chosen scheme.
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5.5.10 Final Remarks
This example showed how to analyze three base stations set in an indoor scenario and to obtain
coverage plots using ProMan.

Many concepts were introduced in this example that apply to models commonly created in ProMan. The
three base stations were solved using the dominant path model (DPM).

As a first step, a propagation simulation was performed to determine the best cell phone reception
inside a building. As s second step, a network planning simulation was performed to provide the best
cell assignment and interference levels.
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