Generating a Multi-Sphere Particle from a CAD Template

You can use mesh files created in other packages as particle templates that provide guidance on how to create a particle with its properties automatically calculated.

Using a Particle Template

It is recommended to use a template if your model uses Multi-Sphere particles.

  1. Navigate to the Tools > Options > Particle Display.
  2. Click Import and navigate to the file of your choice. Any templates used in your model must first be imported here.
  3. Select View > Templates to display the imported template or when a particle shape is selected, choose from the Templates option.
  4. Create spheres to match the template outline.

Data related to the particle template is stored in the *.ptf file. If this file is deleted, the template information will no longer be stored within the model.

Generating Particles from a Template

You can create complex particle shapes based on a CAD template. The Generate Particle from Template option uses an imported mesh template of the particle and adds spheres to fill the volume generating a Multi-Sphere particle.

To use the sphere fitting tool, first import a template using the Options menu (from the Particle Template) or click Edit, which will launch the particle display menu.

Click Import and navigate to the file of your choice. Any templates used in your model must first be imported here.

Generating a Grid

Enter the number of grid cells, in the X, Y and Z direction.  This will produce a grid around the template that was imported. Increasing the number of grid cells will improve the Multi-Sphere particle's fidelity, but will also increase its computational cost.

Smoothing Values

After all spheres are generated, optimization is performed to remove unnecessary spheres. When a smoothing value is greater than 1, the fidelity of the particle will be reduced and the total number of spheres will decrease.

Smoothing Factor 1 2 5 10
Number of Spheres 835 263 69 22
Smallest Sphere (mm) 56 75 131 224

Minimum Particle Size

The minimum particle size is used to ensure that there are no particles in the Multi-Sphere which are excessively small.  Smaller spheres will require simulations to be run at a smaller Time Step, and therefore will be more computationally expensive. It is recommended that this setting is only adjusted after a few generation attempts as other options such as the hard boundary option may drastically affect the radius of the spheres. At this point, you can use the sphere table from the previous generation to visualize the radii of spheres in the particle and manually find a suitable value to use as a minimum radius.

Hard Particle Template

The smoothing value will grow particles outside the template boundary.  The hard template boundary will scale particles towards the center of the template. As stated above, the smoothing value increases the size of the spheres used to populate the particle, and can lead to a particle that is much larger than the template it was created from.

Checking the hard template boundary option will scale the particle back down towards the center of the template to ensure that the created particle is of similar size to the template. This option should be selected when using a large smoothing value.

Do not use this option in instances where the shape’s center of the bounding box is outside the template, such as toroids, as the particles will scale towards that point.

(c) 2023 Altair Engineering Inc. All Rights Reserved.

Intellectual Property Rights Notice | Technical Support