Exporting Data

You can export the data collected during your simulation for analysis.

Data can be exported from a single Time Step, a range of time steps, from all elements in your model, or just from a selection or bin group.

Creating a Configuration

Exporting data is carried out using queries. A query is used to define a single element attribute. For example, a query could be set up to extract the x-position of particles of type A in your model. Multiple queries can be grouped together under one Configuration ID and exported to a single file.

  1. Navigate to File > Export > Results Data.
  2. Click the + icon to create a new Configuration ID.
    Multiple queries can be created within a single configuration. In addition, multiple configurations can be created for any model. For example, one configuration may contain a number of queries relating to particles while it may have queries solely relating to contacts. You can modify configurations at any point, add new queries, or remove redundant queries.
  3. Select the output file format - EnSight (.case) or Text (.csv). For EnSight files, and ensure that the total number of characters (filename and directory) is not greater than 72.
  4. Specify a title, file name, and location for the configuration.

Export Data - General Settings

  1. Output Averages, Maximums, Minimums, and Totals in Columns
    Determines how data is laid out in the exported file. If this option is selected, data will be separated and extracted in unlabeled columns. The following figures show a sample of exported data. The data is the same in each case. In the first figure, the data is presented with this option not selected. The second figure shows data with the option selected.

  2. Output Domain
    Only available when exporting data to an EnSight file. If selected, information on the domain will be exported with the data. If it is not, a new domain will be created automatically when the file is loaded in EnSight.
  3. Delimiter and Line Break
    If you are exporting to a text file, optionally change the delimiter to use and set whether to start a new line after X columns. By default, EDEM inserts a line break at 256 columns (the maximum allowable by Microsoft Excel).
  4. Notation
    Allows you to specify the notation used in your exported data files. Choose from:
    1. Scientific (1.234567890 E08)
    2. Fixed-Point (123456789.0)
    3. Smart –switches from Fixed-point to Scientific at 1 E06 (or 1E-06)
  5. Precision
    Allows you to specify the precision of the exported data files. This can be changed at the export stage, or in Tools > Options > Section Options > Data Export Defaults, if you want to modify the default for all subsequent exports.
  6. Part Selection
    Only active when exporting data to an EnSight file. Choose to export data on all elements in your model or just from specified ones. The elements are categorized by geometry sections and particle types. Information on contacts cannot be exported. Double-click any element to remove it from the group. The listing will turn black indicating its exclusion. An element can be added into the list by double clicking on it a second time.
  7. Time Steps
    Allows you to extract data from all Time steps in your simulation or from a defined range. If a Time step is from a partial save (indicated by the Time step being grayed-out), data for the selected attributes may not be available. This is indicated by N/A in the exported file. A Step factor can be specified to extract data at a certain frequency despite the simulation deck containing more write-out points.

Export Data - Creating a Query

A configuration can contain multiple queries, each of which defines one data attribute. Queries define what information is exported.

  1. Click the Queries tab and click the + icon to create a new query.
    The attributes that can be exported are listed under the element they relate to (collisions, contacts, particles, or geometry).
  2. Click any attribute to select it and then select the component of that attribute.
    For example, the magnitude of a contact vector. All available attributes and their components are listed in the following  tables. 
  3. Select the Geometry section or type of particle or contact for which you want to export data.
    For example, select only collisions between certain particle types, or the force on a particular geometry section. Data can be extracted on all elements of the selected type (or geometry section) or it can be limited to just those contained within a particular bin group or selection group.
  4. To extract data on all elements, use the Selection dropdown where all the bin and selection groups that have been created are listed.
  5. Select the Apply to Sub-Selections checkbox to export a separate query for each bin in a group (if defined), rather than one combined query for the entire group.

Query Type

Used to determine which data values will be exported for a particular attribute. For example, if a query has been set up to export the velocity of particles of type A, you can select to export the maximum, minimum or average velocity per Time Step.

The following data is exported for each query type:

  1. Standard indicates the value of the attribute for every element of the selected type for each Time Step in the defined range: For example, the velocity of every particle at each Time Step.
  2. Total indicates the sum of the values of the attribute for every element of the selected type. For example, the total velocity of all particles per Time Step. The total can be calculated per Time Step or over the range specified in the General settings section.
  3. Total Over Time indicates the sum of attribute values for every unique element over a period of time, repeated elements will not added to the total. For example, the total mass of particles to pass through a selection bin. If particles are within the bin on multiple write-outs the mass will still only be added once. Per Timestep switch will output a value for every write-out instead of just the final total.
    Particles must be within the bin for at least one write-out to be included in the total. You must ensure that the frequency of write-out is small enough, or the bin is large enough to record every particle at least once.
  4. Maximum indicates the maximum value of the attribute across all elements of the selected type for each Time Step in the defined range: For example, the maximum particle velocity per Time Step. The maximum can be calculated and exported per Time Step or over the range specified in the General settings section.
  5. Minimum indicates the minimum value of the attribute across all elements of the selected type for each Time Step in the defined range. For example, the minimum particle velocity per Time Step. The minimum can be calculated and exported per Time Step or over a specified range.
  6. Average indicates the average value of the attribute across all elements of the selected type for each Time Step in the defined range: For example, the average particle velocity per Time Step. The average can be calculated per Time Step or over a specified range.
  7. CoG indicates the value of the attribute at the Center of Gravity (CoG) of the geometry.

To specify a value range for the data exported, select the Specify Range checkbox to limit the export to data that falls between two specified values. For example, only exporting particle velocity data for particles traveling between 3m/s and 5m/s.

Similarly, you can create further queries. Once all the queries have been set up, click Export to export your data to your specified file. For more information on attributes, see Appendix A: Attribute Definitions.

  1. Queries are ordered using the natural sort order where strings are ordered alphabetically except multi-digit numbers which are ordered as a single character.

Collision Elements

Affects all or any combination of specific particles types or geometry sections.

Attribute Components Query Type
Average normal force Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Average tangential force Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Duration N/A Standard, Avg., Min. or Max
End time N/A N/A
ID N/A N/A
ID Element n. N/A N/A
Maximum normal force Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Maximum tangential force Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Normal energy loss N/A Standard, Avg., Total, Min. or Max
Number of collisions N/A N/A
Position X, Y, Z N/A
Relative velocity Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Relative velocity normal Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Relative velocity tangential Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Start time N/A N/A
Tangential energy loss N/A Standard, Avg., Total, Min. or Max
Total energy loss N/A Standard, Avg., Total, Min. or Max
Velocity of element A Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Velocity of element B Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max

Torque query standard, average, maximum, or minimum will provide the torque values based on the individual triangular elements. The torque Specify Axis option is recommended or alternatively the torque Total via a specific axis.

Torque Query Type Total Component X, Y or Z for a named geometry component (for example, a screw blade) will provide a resulting torque values along the X,Y or Z axis for the geometry component through the geometry Center of Mass.

The torque Specify Axis allows you to determine which axis the torque is exported around, especially useful for geometry that is not aligned along the X,Y or Z axis or if the Center of Mass is not known. The following example shows the auger with a specified rotation.

Following is the recommended torque export.

The torque is exported along the user-defined axis which matches the axis of rotation of the auger.

Contacts Elements

Affects all or any combination of specific particles types or geometry sections.

Attribute Components Query Type
Contact Normal (Polyhedral) X, Y, Z Standard, Avg., Total, Min. or Max
Contact vector 1 Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Contact vector 2 Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Normal force Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Normal overlap N/A Standard, Avg., Total, Min. or Max
Number of contacts N/A Avg., Total, Min. or Max
Overlap Volume (Polyhedral) N/A Standard, Avg., Total, Min. or Max.
Penetration Depth (Polyhedral) N/A Standard, Avg., Total, Min. or Max
Position X, Y or Z N/A
Tangential force Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Tangential overlap N/A Standard, Avg., Total, Min. or Max
Custom property Depends on number of elements Standard, Avg., Total, Min. or Max

 

Geometry Elements

Affects all or any individual section (as specified in the Creator).

Attribute Components Query Type
Center of mass X, Y, Z Standard, Avg., Total, Min. or Max
Compressive force N/A Standard, Avg., Total, Min. or Max
ID N/A N/A
Node n. X, Y, Z N/A
Orientation All, XX, XY, XZ, YX, YY, YZ, ZX, ZY, ZZ N/A
Position     X, Y, Z N/A
Power N/A Total (-ive indicating power required to do work on particles)
Pressure     N/A Standard, Total Pressure, Max, Min
Surface normal All, X, Y, Z N/A
Torque Magnitude, X, Y, Z Standard, Avg., Total (Specify Axis), Min. or Max
Total force Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Velocity Magnitude, X, Y, Z Standard, Avg., CoG, Min. or Max
Angular velocity Magnitude, X, Y, Z Standard, Avg., CoG, Min. or Max
Custom property Depends on number of elements Standard, Avg., Total, Min. or Max
Area N/A Standard, Avg., Total, Min. or Max

 

Particle Elements

Affects all or any individual particle type (as specified in the Creator).

Attribute Components Query Type
Angular velocity Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Axial stress X, Y, Z Standard, Avg., Total, Min. or Max
Compressive force N/A Standard, Avg., Total, Min. or Max
Coordination Number N/A Standard, Avg., Total, Min. or Max
Diameter     N/A Standard, Avg., Total, Min. or Max
ID N/A N/A
Moment of inertia Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Kinetic energy N/A Standard, Avg., Total, Min. or Max
Mass N/A Standard, Avg., Total, Min. or Max
Number of particles N/A Avg., Total, Total over time, Min. or Max
Orientation     All, XX, XY, XZ, YX, YY, YZ, ZX, ZY, ZZ N/A
Position X, Y or Z N/A
Potential energy N/A Standard, Avg., Total, Min. or Max
Residence Time N/A Standard, Avg., Min or Max
Rotational kinetic energy N/A Standard, Avg., Total, Min. or Max
Stress tensor XX, XY, XZ, YX, YY, YZ, ZX, ZY, ZZ Standard, Avg., Total, Min. or Max
Torque     Magnitude, X, Y, Z Standard, Avg., Total, Min. or Max
Total energy N/A Standard, Avg., Total, Min. or Max
Total force Magnitude, X, Y, Z     Standard, Avg., Total, Min. or Max
Velocity Magnitude, X, Y, Z     Standard, Avg., Total, Min. or Max
Volume N/A Standard, Avg., Total, Min. or Max
Von Mises N/A Standard, Avg., Total, Min. or Max
Custom property Depends on the number of elements Standard, Avg., Total, Min. or Max

Stress Calculation details

Stress Tensor

The stress tensor for a single discrete element (particle) is calculated as follows:

where Vp is the volume of the particle p, npc the number of particles in contact with the particle p, Sc the vector connecting the particle center with the cth contact point and Fc the cth contact force.

 For averaging in a representative volume (bin), the stress tensor must be divided by the volume of the bin.

Axial Stresses

Axial stresses are calculated as follows:

Von Mises Stresses

Von Mises stresses are calculated as follows:

 

Truncating Results

Used to remove results data (time steps) from your simulation. Data can be removed entirely, or simply 'thinned out' by removing every nth result.

  1. Select File > Truncate File.
  2. In the Truncate File dialog box, specify the Start Time and End Time.
    The Start Time and End time cannot be partial Timesteps, but simulations including partial Timesteps can be truncated.
    This defines the Time steps between which you would like to remove data. 
  3. Set the Step Factor by selecting a factor from the list or specify a new value.
    This determines how often a Time Step in the range is removed. If the step factor is set to one, every Time Step will be retained. If it is set to greater than one, the data in the range will effectively be 'thinned out'. The greater the step factor, the more data is removed.
    By default, the selected data will be truncated from the current simulation deck.
  4. Select the Create New EDEM Simulation Deck checkbox to truncate to a new simulation deck.
    The original deck is unaffected.

Meta-Particle Data

Attribute Components Query Type
Length (bounding box, extent or distance based) N/A Standard, Avg., Total, Min. or Max
Mass N/A Standard, Avg., Total, Min. or Max
Number of Particles N/A     Standard, Avg., Total, Min. or Max
Volume N/A Standard, Avg., Total, Min. or Max
Position X, Y, Z Standard, Avg., Total, Min. or Max
Number of Elements N/A Standard, Avg., Total, Min. or Max

 

(c) 2023 Altair Engineering Inc. All Rights Reserved.

Intellectual Property Rights Notice | Technical Support