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[1] INTRODUCING ALTAIR MONARCH 

Monarch is a market leading desktop-based self-service data preparation solution. Monarch connects to multiple data 
sources, including structured and unstructured data, cloud-based data, and big data, and allows you to cleanse and 
manipulate data without the need for coding. 

WHAT IS THE ALTAIR MONARCH 
APPLICATION? 

Altair® Monarch® (Monarch) is a multi-component application that allows you to model and extract analytical assets 
from both structured and less-than-structured sources, such as PDFs, reports, and EDI streams, and then use the 
data obtained in a self-service manner on your desktop for broader analytical use. The main components of Monarch 
include Monarch Classic and Data Prep Studio.  

The complete features of your Monarch application depend on the license you purchased. In this Learning Guide, 
these licenses may be referred to as “Monarch versions.” Click here to learn more about the different Monarch 
licenses available.  

Monarch Classic 

When a computer generates a report, it creates a report file that contains all of the characters and control codes 
required by a printer to produce the actual report printout. Monarch Classic reads that same report file. Instead of 
producing a hardcopy printout with words and numbers frozen on the page, however, it creates a softcopy of the 
report on screen, with live data you can work with. 

Monarch reads report files created within any computing environment. These files are commonly known as print or 
spool files, but they are also referred to as text (TXT), formatted text, PRN, PDF, and SDF files. Monarch can also 
read a wide variety of input files, such as delimited (e.g., pipe, comma, semi-colon, etc.) text, HTML, MS Excel, MS 
Access, dBase, PDF, and XPS, among others, and is able to connect to OLE DB and ODBC sources.  

Monarch Data Prep Studio 

Data Prep Studio is a Monarch component intended to provide users with rapid data preparation (data prep) 
capabilities. As a quick data prep solution, Data Prep Studio offers several powerful features, including: 

❑ Drag and drop parsing and extraction 

❑ Report discovery and data combination  

❑ Real-time data preparation 

❑ Export capability to several file types 

 

  

https://help.altair.com/2024/monarch/help/Introduction__The_Monarch_Application.htm
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Data Prep Studio provides easy-to-use interfaces for you to: 

❑ Add data sources 

Data Prep Studio allows you to easily load information from databases, reports, and even HTML pages. Special 
Preview functionality allows you to review the information and improve data quality before committing these into 
the Data Prep Studio workspace. 

❑ Combine disparate data sources 

Data Prep Studio allows you to easily integrate information from various data sources.  

❑ Clean and transform your data 

Data Prep Studio’s data preparation capabilities include pre-built functions to quickly and consistently transform 
your data into clean, analysis-ready information. 

❑ Create summaries of your data 

Data Prep Studio allows you to create summaries of your data for improved analysis and decision-making. 

❑ Export data to various file types and applications 

Once prepped, data can be exported to several of the most popular formats, including XLSX, CSV, ACCDB, and 
JSON, among others. You can also export to applications such as IBM Cognos Analytics and Tableau Server. 

NEW FEATURES AND ENHANCEMENTS IN 
MONARCH CLASSIC 

Monarch Classic version 2024.0 includes the following new features and enhancements: 

❑ Monarch Server Library browser improvements 

❑ AES as the default encryption method for new exports 

❑ Various bug fixes and UX/UI enhancements 

NEW FEATURES AND ENHANCEMENTS IN 
DATA PREP STUDIO 

Monarch Data Prep Studio version 2024.0 includes the following new features and enhancements: 

❑ Dynamic date filtering operation 

❑ Alignment editor for PDF reports 

❑ Export tables, reports, and summaries to PDF 

❑ Implementation of case sensitivity for joins 

❑ Implementation of extract text by line number and search term operations 

❑ Preview Data improvements - Updated statistics, inclusion of file information, sort on column information, 
removal of unhelpful statistics 

❑ Application/Workspace settings improvements - Encoding / codepage options for delimited text, report page 
setup, etc. 

❑ Implementation of ability to test credentials for connectors including Splunk, Salesforce, Google Analytics, and 
IBM Cloudant 

❑ Change history item collapsing 

https://help.altair.com/2024/monarch/releasenotes/Altair_Monarch_2024_0_0_ReleaseNotes.pdf
https://help.altair.com/2024/monarch/releasenotes/Altair_Monarch_2024_0_0_ReleaseNotes.pdf
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❑ Monarch Server integration - Fixed text export, export column mapping 

❑ Implementation of Report Index in Report view 

❑ Implementation of display width and alignment for columns 

❑ Select/Deselect all for split operations 

❑ Format column dialog: allow specifying of precision for non-custom formats in which it makes sense 

❑ Make fixed precision (F<n>) an option in "Format Column" 

❑ Various bug fixes and UX/UI enhancements 

  



 

Altair Monarch 2024.0 Learning Guide  4 

 

THE MONARCH CLASSIC WORKFLOW 

Figure 1-1 shows how report data flow through a typical Monarch Classic session. A Monarch session begins when 
you load a report file into Report view. As the session unfolds, you can produce a variety of outputs from each 
window. The lessons in this guide correspond to the flow chart. You’ll learn how to bring a report into Monarch, and 
you will progress step-by-step through the tasks performed in each window. 

 

Input   Output 

   Report File 

  

Report View 

• View and explore report 

• Look things up (Find) 

• Use Report Index 

• Print pages 

• Copy to clipboard 

• Define data extraction template 

 

 

 

 

 

 

• Hardcopy printout of pages 

• Clipboard image of data copied from the 

report, with automatic formatting of the 

data when pasting into a worksheet 

• Export file in fixed width text or PDF format 

   Extracted data 

  

Table view 

• View extracted data 

• Apply filters to extracted data 

• Sort data 

• Calculate new fields 

• Copy to clipboard 

• Export selected records 

• Print selected records 

 

 

 

 

• Hardcopy printout of selected data in 

columnar report format 

• Clipboard image of data copied from the 

table, in both text and worksheet formats 

• Export file containing selected data in 

several formats, including XLS, XLSX, XLSM, 

PDF, ACCDB, MDB, DBF, HTML, TXT, XML, 

and delimited text. 

   Extracted data 

  

Summary Window 

• Analyze selected data 

• Copy data to the clipboard 

• Export analysis 

• Print analysis  

 

 

 

 

• Hardcopy printout of summary report  

• Clipboard image of summary (in both text 

and worksheet formats) 

• Export file containing selected data in 

several formats, including XLS, XLSX, XLSM, 

PDF, ACCDB, MDB, DBF, HTML, TXT, XML, 

and delimited text. 

Figure 1-1. The Monarch flow chart.  

Monarch reads both report files and data from database files and OLE DB/ODBC databases, and information from 
databases can be extracted, manipulated, analyzed, and transformed. It also allows users to access data from 
additional sources, share user-defined functions, and access data from files that are of the types XLS, XLSX, XLSM, 
PDF, XPS, DBF, DB, MDB, HTML, and delimited text, as well as any OLE DB- or ODBC-compliant data source, such 
as SQL Server, Oracle, and DB2 database management systems. 
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Input  Output 

   Database data 

  

Table view 

• Import data from any 

XLS, XLSX, XLSM, MDB, 

DBF, delimited text file, 

or from any OLE 

DB/ODBC compliant data 

source 

• View imported data 

• Apply filters to data 

• Sort data 

• Calculate new fields 

• Copy to clipboard 

• Export selected records 

• Print selected records 

 

 

 

 

 

 

• Hardcopy printout of data in 

columnar report format 

• Clipboard image of data copied 

from the table, in both text and 

worksheet formats 

• Export file containing selected data 

several formats including XLS, 

ACCDB, MDB, DBF, HTML, XLSX, 

XLSM, TXT, PDF, XML, and delimited 

text. 

   Imported data 
  

Summary Window 

• Analyze selected data 

• Copy data to clipboard. 

• Export analysis 

• Print analysis  

 

 

 

 

• Hardcopy printout of summary 

report  

• Clipboard image of summary (in 

both text and worksheet formats) 

• Export file containing selected data 

in several formats, including XLS, 

XLSX, XLSM, PDF, MDB, DBF, TXT, 

XML, and delimited text. 

 

Figure 1-2. The Monarch flow chart showing data imported from a database.  

Figure 1-2 shows how data imported from a database flow through Monarch Classic. You may begin a Monarch 
session by either opening an XLS, XLSX, XLSM, MDB, ACCDB, DBF, or delimited text file or by importing data from 
an OLE DB/ODBC data source. When importing from a database, you can use all of Monarch’s Table and Summary 
View capabilities to manipulate, transform, and analyze data. 

You can even combine data extracted from report files with database data through a mechanism called an external 
lookup.  

Note that as the capabilities of newer versions of Monarch improve, the expected outputs presented in this section 
may vary. The basic data flows, however, remain the same. 
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THE DATA PREP STUDIO WORKFLOW 

Figure 1-3 illustrates a typical Data Prep Studio workflow.  

 

Figure 1-3. The Data Prep Studio workflow. 

Tables from a variety of sources, such databases, Excel worksheets, PDF/Text reports, and Monarch files, may be 
previewed before they are brought into Monarch Data Prep Studio. If the data source contains multiple tables, you 
may select which table(s) to open. Once in Monarch Data Prep Studio, your data can be prepared, combined, 
transformed, and analyzed. These operations are carried out in what is called a workspace. When ready, you can 
either save your data to the workspace or export them to a variety of formats. 

USING THE MONARCH DOCUMENTS 

The Altair Monarch documentation consists of a Learning Guide and a Help file. This documentation is available 
upon installation of the software and here.  

Monarch Learning Guide 

This Learning Guide contains a short introduction to Monarch Classic and Data Prep Studio, collectively called 
Monarch Complete, along with a series of lessons designed to quickly acquaint you with the program. The lessons 
will first introduce you to Data Prep Studio and continue with each of the Monarch views: Report, Table, Summary, 
and Export.  

Each of the chapters describes a major area of Monarch. More specific lessons on unique functionalities, such as 
Report Design, Worksheet Design, and PDF Table Extractor are also provided. First-time users will be well rewarded 
for the time they spend working through these sections. Advanced topics should be tackled after you become familiar 
with the basic concepts of Monarch, as these topics will leverage what you learned in previous sections. Each lesson 
should take 20–30 minutes to complete. 

https://help.altair.com/2024/monarch/
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Monarch Help File 

The Monarch Help file provides detailed information and step-by-step instructions for performing numerous tasks in 
Monarch Classic and Data Prep Studio. To access the file while within Monarch, select File > Help > Help Topics. 
You can also launch relevant help topics from within the Monarch windows by clicking the  button located on the 
upper right-hand corner of most views.  

Monarch Training 

Altair provides Monarch training courses to help anyone in your organization rapidly improve his or her Monarch 
proficiency skills. Available in various locations around the country, these training classes are designed for all levels 
of expertise. Whether you are just getting started and need the basics or would like to hone your skills and learn new 
ways to use Monarch, Altair is ready to help you reach new levels of Monarch proficiency. Our objective is to help 
Monarch users succeed as quickly as possible. 

Taught by Altair’s seasoned staff of Monarch experts, the training courses guide you through all aspects of Monarch’s 
features and capabilities, including tips and techniques on effective, timesaving shortcuts. There is also a lab session 
at the end of class where you can bring in your own files and receive individual instruction and suggestions for using 
Monarch to meet your specific requirements. 

Monarch onsite training and personal web-based training courses are also available.  

To learn more about training, reach out to Altair Support. 

Monarch Model Building Service 

Altair provides a model building service for its Monarch customers. Altair’s highly trained team of Monarch experts will 
work with you one on one to create a model that meets your specifications and satisfaction. 

When you view your new Monarch model, you will be able to learn from the experts by viewing the way they have 
trapped your report, created calculated fields and filters, defined summaries, and more. Best of all, this is all done 
using your own reports.  

To learn more about the Monarch Model Building Service, reach out to Altair Support. 

https://help.altair.com/2024/monarch/help/
https://altair.com/customer-support
https://altair.com/customer-support
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[2] THE MONARCH USER 
INTERFACES 

THE MONARCH CLASSIC USER INTERFACES 

Monarch Classic provides three distinct views of report data, each with its own interface. Each view provides a 
specific set of functions and operations that will allow you to extract, view, and summarize data. A fourth view allows 
you to create exports.  

Report View 

When you load a report file, a softcopy of the report is displayed in Report view. 

 

Figure 2-1. The Report view of Monarch Classic. 

Report view displays opened reports and includes all of the tools you will need to work with them. It also allows you 
access to Report Design view, an interface through which you can create templates to extract data and create 
tables.  
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Table View 

Data extracted from the report display in Table view.  

 

Figure 2-2. The Table view of Monarch Classic.  

Table view allows you to work with the table produced by your report templates. You can click Table Design to edit 
your table and its fields. All of the changes you make to a table (e.g., filters, sorts, functions, etc.) display in this view.  

Some of the other activities you can perform in Table view include: 

❑ Set the active filter to limit the fields displayed 

❑ Set the active sort to sort fields 

❑ Auto-size columns 

❑ Hide or display fields 

❑ Find a specific field value 
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Summary View 

User-defined summaries, which analyze report data, are displayed in Summary view.  

 

Figure 2-3. The Summary view of Monarch Classic.  

Summary View allows you to work with summaries. From this View, you can also click Summary Design to create or 
edit summaries. 

From within Summary View, you can also do the following: 

❑ Navigate a summary 

❑ Zoom in or out 

❑ Automatically adjust column widths 

❑ Freeze panes 

❑ Collapse or expand a summary 

❑ Customize summary font and background 
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Export View 

Exports defined may be viewed in Export view. 

 

Figure 2-4. The Export view of Monarch Classic.  

From this window, you can also do the following: 

❑ Run exports 

❑ Create a new export 

Monarch Classic Hotkeys 

Keyboard shortcuts (hotkeys) for the main toolbar are enabled in Monarch Classic to help you quickly access the 
different views. The following table describes the main hotkeys available in Monarch Classic. 

Use this hotkey To 

ALT + F Open the File menu 

ALT + H Access the Home Page 

ALT + R Access Report View 

ALT + T Access Table View 

ALT + S Access Summary View 

ALT + E Access Export View 

ALT + 1 Access the Open Document menu 

ALT + L Launch the Monarch Help File 

 

A detailed list of the keyboard shortcuts available in Monarch Classic may be found here. 

https://help.altair.com/2024/monarch/help/Keyboard_Shortcuts.htm
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THE DATA PREP STUDIO USER INTERFACES 

Similar to Monarch Classic, Data Prep Studio includes several windows, each of which allow you to analyze, open, 
prepare, and export your data. 

The Getting Started Video 

First-time Data Prep Studio users will find the Getting Started video especially helpful in learning about this 
component’s capabilities.  

This video displays the first time Monarch is launched as well as every time the application is started thereafter 
unless the Show at start up box located at the lower left-hand corner of the screen is unchecked.  

Select Exit Tutorial to close this video window.  

 

Figure 2-5. The Getting Started video. 
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The Start Page 

The Start Page displays when the application is launched and the Getting Started video is closed (by clicking Exit 
Tutorial)/disabled. Besides providing access to video tutorials and related documentation and support, the Start 
Page is your primary jumping-off point for bringing data into the current data prep session.  

 

Figure 2-6. The Data Prep Studio Start Page. 

 

Data Prep Studio features one toolbar and several main screens. 

 

Figure 2-7. The Data Prep Studio toolbar. 

Each of these tools opens a unique window, dialog, or stage through which Data Prep Studio’s functions may be 
realized.  
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The Application Menu 

The Application Menu  button displays a list of other Data Prep Studio commands you may wish to apply to the 
current Data Prep Studio session.  

 

Figure 2-8. The Application Menu of Data Prep Studio. 

Using this menu, you can: 

❑ Open a new/existing workspace ❑ Import/export change lists 

❑ Save a workspace ❑ Import workspace tables 

❑ Close a workspace 

❑ Open a data source 

❑ Switch to or open a table in Classic mode  

❑ Exit Data Prep Studio 

 

NOTE The current version of Monarch Data Prep Studio no longer supports integration with 
Altair Knowledge Hub. Thus, when a workspace containing tables imported from 
Knowledge Hub is opened, the error message "Monarch Data Prep Studio no longer 
supports integration with Altair Knowledge Hub" displays. 

 

  



 

Altair Monarch 2024.0 Learning Guide  15 

 

The Settings Dialogs 

You can specify application default or current workspace settings by clicking the Settings  button located to the 
far right of the toolbar and selecting the appropriate option.  

Note that some application settings, folder tracking, for example, are applied only when Data Prep Studio is restarted. 
Also, settings are serialized from the last closed Data Prep Studio session. This means that when two concurrently 
running sessions of the application are closed, only settings from the session closed the last are saved and reflected 
when a new session is started. 

The Application Default Settings dialog allows you to specify row limits, default folders, conversion settings, and the 
like on a global level. You can also configure license settings and create new library files using this dialog.  

   

Figure 2-9. The Application Default Settings dialog of Data Prep Studio. 

The Current Workspace Settings dialog allows you to specify workspace-level conversion and time-interval settings.  

  

Figure 2-10. The Current Workspace Settings dialog of Data Prep Studio. 
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Details on each of these settings may be obtained here. 

The Preview Window 

The Preview window allows you to: 

❑ Open a file or a data source 

❑ Preview and confirm the data in the data source 

❑ Load a table into your workspace 

 

Figure 2-11. Data Prep Studio’s Preview window. 

Several tools are provided to enable you to open/preview more tables, select one or a group of tables, and close one 
or a group of tables.  

  

Figure 2-12. The Preview window tools. 

The Transform Pane 

You can quickly transform any table in the Prepare window by clicking on the Transform button of the Data Prep 
Studio toolbar. Doing so displays the Transform pane that will allow you to sort field, extract empty rows in the table, 
pivot/unpivot columns, group by specific columns, and remove duplicates.  

https://help.altair.com/2024/monarch/help/The_Settings_Dialog.htm
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Figure 2-13. Data Prep Studio’s Transform pane. 

The Prepare Window 

The Prepare window allows you to transform columns. Pre-defined functions include convert, extract, clean, replace, 
and split capabilities, among others. 

 

Figure 2-14. Data Prep Studio’s Prepare window. 

The panel to the left of the Prepare window is called the Table Selector and allows you to select tables. Right-clicking 
on any table in this panel or clicking on the drop-down button launches a context menu that allows you to: 

Action Description 

Object Description Clicking on the Object Description icon launches a text field into which you can 
enter a comment or description of the selected table. 

Edit in Report Design Allows you to modify templates created to capture data from report files 

Edit Append/Join/Transform Allows you to modify tables created from appends, joins, and transform 
operations 

Edit Load Options Allows you to specify how tables from some file types should be imported into 
the application. Some of these settings are as follows: 

https://help.altair.com/2024/monarch/help/Editing_Table_Load_Options.htm
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Action Description 

For MS Excel tables: 

❑ Indicate if the first row of an Excel file contains column names. This is 
active by default. 

❑ Ignore blank rows 

❑ Skip n number of lines. Using this option, you can, for instance ignore lines 
with containing spreadsheet titles. 

❑ Switch table - Replaces the contents of the original table with the data in 
the replacement table selected from the drop-down. 

❑ Import columns as text 

For MS Access tables: 

❑ Switch table - Replaces the contents of the original table with the data in 
the replacement table selected from the drop-down. 

For delimited text tables: 

❑ Ignore blank rows 

❑ First row has columns names 

❑ Allow embedded line breaks 

❑ Delimiter 

❑ Lines to skip 

❑ Text qualifier 

❑ Rows to scan for columns 

❑ Set data types for individual fields or a bulk data type for all fields 

For HTML tables: 

❑ Indicate if the first row of the table contains column names. 

❑ Lines to skip - Specify a number of lines starting from row 1 to ignore. The 
table will begin with the n+1 row. 

Edit Table Info Allows you to select a different table from a given datasource. 

Edit Credentials Allows you to provide the necessary details for tables requiring security 
credentials that were cleared when the workspace was saved. 

Edit File Path Allows you to change the path to a data source. 

Edit All File Paths Allows you to change the path to all open data sources. 

Map Columns Allows you to map the columns of two tables with dissimilar schemas without 
breaking an existing change list. 

Rename Allows you to change the name of a table. 

Duplicate Allows you to create a new instance of the table. 

The duplicate is initially named <TableName>n, where n is number that 
indicates how many instances of the table are currently in use. You can rename 
the table after duplication. 

Delete Allows you to delete the selected table. 

Pin Allows you to pin a table. When you do so and the workspace is saved, a user 
without direct access to the table source may open the pinned table when he 
opens the workspace. 

Row Limit Allows you to increase or decrease the rows displayed by Monarch Data Prep 
Studio for the current table. 

https://help.altair.com/2024/monarch/help/Editing_Credentials.htm
https://help.altair.com/2024/monarch/help/Changing_a_Table_File_Path.htm
https://help.altair.com/2024/monarch/help/Mapping_Columns.htm
https://help.altair.com/2024/monarch/help/Renaming_a_Table.htm
https://help.altair.com/2024/monarch/help/Renaming_a_Table.htm
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Action Description 

Decreasing the row limit can speed up the load time of the table and improve 
the response time when carrying out operations. However, this may allow you to 
miss exceptions and problematic rows, if these are not included in the limited 
row set. 

Refresh Data From Source Allows you load the latest data from your data source. Use this option if the 
values in your table are changed via an external application and you want these 
changes reflected in your workspace. 

Quick Export Allows you to quickly export the selected table into a number of formats via the 
Select an Export Type dialog. 

Create Workspace from 
Table 

Allows you to export tables to a new workspace. 

Save in Library Saves the data source in the Data Source Library. 

You can use the Data Source Library to easily access and include commonly-
used data sources as you define workspaces without having to open the data 
source and load tables. 

Swap with Library Table Allows you to replace the selected table with one from the Data Source Library. 

Undock Undocks the table from the Monarch Data Prep Studio work area so that you 
can: 

Move the table around (for instance, to a secondary monitor) 

Float one more tables and view their records simultaneously. 

 

The Combine Stage 

The Combine stage has a switch on/switch off function and allows you to join or append two or more tables to create 
a new one. The default view when this tool is clicked is the Join stage.  

 

Figure 2-15. Data Prep Studio’s Join stage is accessed by clicking Combine > Join. 

https://help.altair.com/2024/monarch/help/Exporting_Tables_as_Workspaces.htm
https://help.altair.com/2024/monarch/help/Working_with_the_Data_Library.htm
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Figure 2-16. Data Prep Studio’s Append stage is accessed by clicking Append Tables. 

The Report Design Window 

The Report Design window allows you to open PDF and PRN report files and extract specific fields from this report to 
create a table, which then becomes available in the Prepare Window. 

 

Figure 2-17. Data Prep Studio’s Report Design window. 
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You can also open reports, especially those that are text-heavy but contain tables you wish to bring into Data Prep 
Studio, in PDF Table Extractor. More information on this component is available here.  

Work in the Report Design window follows a system that closely mimics the report trapping steps in Monarch Classic. 
Details of each of the tools available in the Report Design window, as well as how they are used to create tables from 
PDF and PRN files are available here. 

The Analyze Drop-Down 

The Analyze drop-down is your take-off point for creating, viewing, modifying, and managing summaries. 

 

Figure 2-18. Data Prep Studio’s Analyze drop-down. 

The Export Window 

The Export window allows you to export table data, summaries, and reports from Data Prep Studio to a number of 
different file types.  

  

Figure 2-19. Data Prep Studio’s Export window. 

  

https://help.altair.com/2024/monarch/help/MTE_About_Datawatch_Monarch_Table_Extractor.htm
https://help.altair.com/2024/monarch/help/Preparing_a_Document.htm
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You can export table data to:  

❑ Microsoft Excel ❑ Tableau Server 

❑ CSV ❑ Tableau TDE 

❑ IBM Cognos Analytics ❑ Qlik 

❑ Microsoft Access ❑ SAS Transport File Format (XPORT) Version 5 

❑ Microsoft Power BI ❑ JSON 

❑ Fixed Text ❑ XML 

❑ PDF  

 

You can also export to a number of Altair products: 

❑ Altair Panopticon 

❑ Altair Knowledge Studio 

 

You can export summaries to:  

❑ Microsoft Excel ❑ Tableau TDE 

❑ CSV ❑ Qlik 

❑ Microsoft Access ❑ SAS Transport File Format (XPORT) Version 5 

❑ Fixed Text ❑ JSON 

❑ PDF ❑ XML 

 

You can export reports to:  

❑ Text 

❑ PDF 

 

NOTE The current version of Monarch Data Prep Studio no longer supports integration with 
Altair Knowledge Hub. Thus, when an export to Knowledge Hub is run from a 
workspace created in previous versions of DPS, the error message "Monarch Data 
Prep Studio no longer supports integration with Altair Knowledge Hub" displays. 

The Worksheet Design Window 

The Worksheet Design window displays if you opt not to open Excel files as a database. Worksheet Design is 
especially useful for capturing data from Excel files containing worksheets that do not have a tabular form. 
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Figure 2-20. Data Prep Studio’s Worksheet Design window. 

A lesson on the use of Worksheet Design is provided in Chapter 4 – Working with Worksheet Design of this Learning 
Guide.  

The PDF Table Extractor Window 

The PDF Table Extractor window displays when you open a PDF file in Data Prep Studio by selecting Open Data > 
PDF & Text > PDF Table Extractor from the Start window or Add > PDF & Text > PDF Table Extractor from the 
Prepare window. This interface provides an easy means to identify tables in text-heavy PDF files, select them, modify 
them if you wish, and then import them into Data Prep Studio for further data preparation.  

 

Figure 2-21. Data Prep Studio’s PDF Table Extractor window. 
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Chapter 4 – Working with PDF Table Extractor in this Learning Guide discusses how to work with this powerful Data 
Prep Studio component.  

Data Prep Studio Hotkeys 

Similar to Monarch Classic, keyboard shortcuts (hotkeys) for the main toolbar are also enabled in Data Prep Studio to 
help you quickly access the different windows. The following table describes the main hotkeys available in Data Prep 
Studio. 

Use this hotkey To 

ALT + S Access the Start Page 

ALT + V Access the Preview window 

ALT + P Access the Prepare window 

ALT + T Launch the Select Transform Type dialog 

ALT + C Access the Combine stage 

ALT + A Access the Analyze drop-down 

ALT + E Launch the Export window 

ALT + G Launch the Application Default Settings dialog 

ALT + F Launch the Application Menu 

 

A detailed list of the keyboard shortcuts available in Data Prep Studio may be found here. 

https://help.altair.com/2024/monarch/help/DPS_Keyboard_Shortcuts.htm
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[3] LAUNCHING THE MONARCH 
APPLICATION 

Depending on where you begin, the different components of the Monarch application can be launched in different 
ways.  

LAUNCHING MONARCH DATA PREP STUDIO 

Data Prep Studio may be launched in several ways 

❑ Launching Monarch for the first time after installing it. 

❑ Selecting Start > All Programs > Altair Monarch 2024 > Monarch Data Prep Studio 2024 

❑ Selecting the Data Prep Studio and Open Table in Data Prep Studio buttons in Monarch Classic’s Home and 
Table views, respectively. 

LAUNCHING MONARCH CLASSIC 

Monarch Classic may be launched in several ways 

❑ Selecting Start > All Programs > Altair Monarch 2024 > Monarch Classic 2024 

❑ Selecting File > Switch to Classic Mode from the Data Prep Studio menu. 

 



 

Altair Monarch 2024.0 Learning Guide  26 

 

[4] DATA PREP STUDIO LESSONS 

Because most data prep needs may be addressed by Data Prep Studio, we begin this Learning Guide with lessons 
on how to work with this exciting add-on.  

 

Figure 4-1. The Data Prep Studio Start Page. 

Data Prep Studio supports a number of main functions: 

❑ Add data from a wide variety of data sources 

❑ Add data using the Altair Data Connectors 

❑ Join and append table data to create new data tables 

❑ Clean and transform tables for further operations 

❑ Create summaries  

❑ Export tables  

❑ Save and load workspaces 

The lessons described in this section demonstrate how to use Data Prep Studio and aim to provide users with a basic 
overview of the application’s capabilities. If you wish to learn about Data Prep Studio’s functions in greater detail, 
consider consulting the application’s help file.  

  

https://help.altair.com/2024/monarch/help
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BEFORE YOU BEGIN 

Throughout the lessons, we make the following assumptions: 

❑ Monarch Complete is properly installed and the Monarch Classic and Data Prep Studio program items are 
available when you start Windows. 

❑ The lesson files are installed and Monarch’s default Report, Model, and Project folders are configured to point to 
the lesson files (the Setup program ideally automatically assigns these defaults the first time you install the 
product but you may want to assign other folders instead). 

❑ You are using an operating system for which Monarch is certified.  

❑ The Date Format setting in Monarch has been set to M/D/Y to handle dates in the sample reports correctly.  

 

NOTE If you use a different OS, some slight deviations from the steps listed in the lessons 
will occur (e.g., the default paths, the appearance of screens, and other minor 
differences), but you can effectively complete the lessons on all versions of Windows 
that Monarch supports. 

 

This Learning Guide also assumes that you have copies of the following files stored in your computer: 

❑ Beantown.mdb 

❑ Payroll.mdb 

❑ Classic.pdf 

❑ Patient.pdf 

❑ Canaccord 042215.pdf 

These files are typically installed along with Monarch and are found in C:\Users\Public\Documents\Altair 
Monarch\Data and C:\Users\Public\Documents\Altair Monarch\Reports. If you do not have these files, you can 
download them from here. 

We begin our lessons by adding data to a Data Prep session. 

  

https://help.altair.com/monarch/current/tutorial/DPS_TutorialFiles.zip
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ADDING DATA TO A DATA PREP SESSION 

A Data Prep session begins by placing data, either from a preexisting table or from a table created through the 
Report Design window, in the Prepare window.  

The following file types may be opened in Data Prep Studio: 

❑ Delimited text files (.csv) ❑ Print files (.dat, .prn, .rpt, .txt) 

❑ Fixed text files (.txt) ❑ PDF files (.pdf) 

❑ Microsoft Excel files (.xls, .xlsx, .xlsm, .xlsb) ❑ XPS files (.xps) 

❑ Microsoft Access files (.mdb, .accdb) ❑ HTML files (.htm, .html, .asp, .aspx) 

❑ JSON files (.json) ❑ Log files (.log) 

❑ XML files (.xml) ❑ Data Prep workspace files (.dpwx) 

❑ Monarch files (.dprj, .xprj, .dmod, .xmod)  

Adding Data from a Database File 

Steps: 

 Launch Data Prep Studio. 

 Select Open Data to display the Select Data Source to Open dialog. 

 

Figure 4-2. The Select Data Source to Open dialog. 

 Select the data source option Database and then double-click on Microsoft Access. 

 In the Open dialog that displays, navigate to the folder in which you stored Beantown.mdb, select this file, and 
then click Open. 
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The Access Explorer displays.  

 

Figure 4-3. The Access Explorer. 

The Access Explorer displays each time you load a Microsoft Access data source; using this explorer, you can 
select which tables to load to your workspace and even preview these tables before loading if necessary. A 
similar explorer is available for Excel files.  

 Since we want to load all three tables within the file, tick the box to the left of Table Name and then click Load 
Selected. 

You are brought to the Prepare window. Each of the tables that make up the database displays in this window.  

 

Figure 4-4. Tables brought into the Prepare window. 
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NOTE Letters beyond the 64th character are truncated when opening tables from Excel 
files with column names exceeding 64 characters because the Access driver 
used to read these files imposes a 64-character limit. 

 

Let’s take a moment to explore the Prepare Window.  

The Prepare Window is mainly divided into three views: the Table Selector on the left, the Data Preview in the middle, 
and the Change History panel on the right. The Table Selector and Change History panels can be hidden and 

displayed by clicking on the Hide  and Display  buttons, respectively. Let’s hide the Change History panel since 
we don’t need it for now. 

Clicking on the drop-down buttons located to the right of a table in the Table Selector displays a context menu that 
will allow you to perform table operations, including change row limits, edit file paths, pin tables, and the like.  

The bottom of the Prepare window presents several options that will allow you to navigate through your tables easily.  

Note that while a database may contain any number of tables, only those tables you selected and loaded display in 
the Prepare window. 

Limiting Rows 

You can change the default number of rows Data Prep Studio loads on a global basis when it opens tables by 

selecting Settings  from the Data Prep Studio toolbar and then selecting Application Default Settings from the 
options that display. This setting may be found in the Import > General tab. Note that while decreasing the row limit 
when opening tables can improve the performance of Data Prep Studio and speed up response times, this may also 
result in missed exceptions and problematic rows, particularly if these rows are not included in the limited row set. 

If you wish to change the row limit of a specific table that has been opened in the Prepare window, click on the drop-
down button located to the right of the table from the table selector and, from the options that display, select Row 
Limit. 

If you wish to change the row limit of a table while it is in Preview mode, select the Edit Source Row Limit  button 
and use the Edit Source Row Limit dialog that displays to do so.  

Changing File Paths 

You may wish to change the file path of an open table in the Prepare window (e.g., a file with the same name is 
located in a different folder in your machine or network). To do so, click on the drop-down button located to the right 
of the table from the table selector and, from the options that display, select Edit File Path or Edit All File Paths 
according to your needs. In the Edit (Workspace) File Path(s) dialog that displays, navigate to the file you wish to use 
and then click Open. You can only replace the contents of a table with those of another table with the same file 
extension. Data Prep Studio automatically detects the file extension of the open table to help guide your replacement 
choices.  

Editing Load Options 

When your table is one of several tables in an Access database or one of several worksheets in an Excel file, for 
example, you can select a different table to open by clicking on the drop-down button located to the right of the table 
from the table selector and, from the options that display, selecting Edit Load Options. When applicable, load 
options can also be accessed from the Column Information panel that displays when a table is previewed. 

 

  

https://help.altair.com/2024/monarch/help/Working_with_the_Table_List.htm
https://help.altair.com/2024/monarch/help/Navigating_Tables.htm
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ACCESS DATA SOURCES 

For Access data sources, the following dialog displays: 

 

Figure 4-5. The Access Options dialog. 

Select the new table you wish to load from the drop-down list provided and then click OK. 

 

EXCEL DATA SOURCES 

For Excel data sources, the following dialog displays: 

  

Figure 4-6. The Excel Options dialog. 

From the settings provided, specify those most applicable to the table you wish to open and then click OK.  

 

HTML DATA SOURCES 

For HTML tables, the following dialog displays: 

 

Figure 4-7. The HTML Load Options dialog. 
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After specifying the necessary details, click OK.  

 

DELIMITED TEXT FILES 

For delimited text files (e.g., CSV), the following dialog displays: 

 

Figure 4-8. The Delimited Text Options dialog. 

Using this dialog, you can specify whether to ignore blank rows or allow embedded line breaks. You can also define a 
delimiter by clicking on the drop-down button beside this field and choosing from several common delimiters which to 
apply to your table. If the delimiter you are looking for is not on this list (e.g., ^), simply type it into the field. Define a 
text qualifier by selecting one from the drop-down list provided. If you need to modify Encoding Options, click on the 
button provided to launch drop-down lists that will allow you to select an encoding type and code page, if applicable. 

More information on editing table load options can be found here. 

Pinning Tables 

When a table is pinned in the Prepare window (i.e., click on the drop-down button located to the right of the table from 
the table selector and, from the options that display, select Pin Table from the options that display) and the 
workspace is saved, a user without direct access to the table source may open the pinned table by opening this same 
workspace. When pinning a table, a user may also choose to pin the current rows opened (when a row limit has been 
set) or pin the entire data set.  

 

Figure 4-9. Pinning a table in the Prepare window. 

This functionality allows data-sharing with users who do not necessarily have rights to the source systems required to 
create working tables. Note, however, that the pinned table cannot be refreshed by a user without access to the data 
source.  

https://help.altair.com/2024/monarch/help/Editing_Table_Load_Options.htm
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Refreshing Table Data 

When a table (e.g., an Excel worksheet) is open in the Prepare window of Data Prep Studio, you essentially have a 
snapshot of the current state of this table. When you or another user makes changes to this table, your table 
“snapshot” must be rebuilt to reflect these changes. To do so, click on the drop-down button located to the right of the 
table from the table selector and, from the options that display, select Refresh Data From Source from the options 
that display. 

Tables obtained from drag-and-drop operations in web pages cannot be refreshed because such tables are not 
sourced from a file path or URL. Moreover, the Edit File Path, Edit Workspace File Paths, and Refresh Data From 
Source buttons are not available for such tables. 

Adding Data from a Report File 

PDF and PRN reports, when first opened in Data Prep Studio, display in the Report Design window, which will allow 
you to create templates and traps to enable consistent extraction of data from similarly structured report files. In the 
following example, we use the Report Design window’s Auto-Define feature to create traps and fields from our report. 
Note, however, that one should not depend solely on this feature as the application may be unable to process reports 
with more complex structures or irregularly arranged lines.  

To learn how to create templates and trap fields in the Report Design window in greater detail, click here. You may 
also want to review how trapping is done in Classic.  

Steps: 

 In the Prepare Window, click the Add button. 

 In the Select Data Source to Open dialog that displays, click PDF & Text and then double-click on PDF Report 
to display the Open dialog. 

 Navigate to the folder in which you stored Classic.pdf (typically C:\Users\Public\Documents\Altair 
Monarch\Reports), select this file, and then click Open. The report opens in the Report Design window.  

 Automatically define fields by selecting the Auto Define  button in the Template and Field 
Properties panel. 

 

Figure 4-10. Loading Classic.pdf into the Report Design window. 

https://help.altair.com/2024/monarch/help/ht_input_createtmp.htm
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 Click Accept on the Report Design toolbar to close the window and add the table extracted from the report to the 
Prepare window.  

  

Figure 4-11. The table extracted from Classic.pdf via the Report Design Window is added to the Prepare window. 
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If you wish to make changes to your newly defined table after bringing it into the Prepare window, click on the 
drop-down arrow beside its name in the table selector and then select Edit in Report Design.  

Doing this will bring up the Report Design window once more and allow you to make additional changes to your 
table.  

 

NOTE You can perform some changes to the table extracted from a report, including 
change its column names and fill nulls with the value preceding the empty cell, in the 
Report Design window. 

These changes do NOT form part of the session’s Audit Trail (Change History) 
because the Report Design window is a settings panel that creates a new table from 
the settings selected. The Change History function of Data Prep Studio only tracks 
changes to existing tables. 

If you wish to apply more changes to a table you extracted using the Report Design 
window and have these changes tracked, open the table in the Prepare window 
instead. 

 

Adding Data from a Website 

Data Prep Studio is unique from other data prep software because it is capable of intuitively determining tables from 
webpages and recreating these in the Prepare window.  

Steps: 

 On your browser, go to the webpage https://www.nasdaq.com/market-activity/stocks/altr/earnings. 

This webpage displays, among others, a table of Altair’s quarterly earnings surprise amounts over the last four 
quarters. 

  

Figure 4-12. Altair’s quarterly earnings surprise amounts reported in NASDAQ. 

 Use your mouse to highlight this entire table and then drag and drop the contents of the webpage into the 
Prepare window of Data Prep Studio.  

Data Prep Studio intelligently detects tables in webpages and recreates them.  

  

https://www.nasdaq.com/market-activity/stocks/altr/earnings
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Figure 4-13. The newly defined table in the Prepare window. 

Data Prep Studio allows you to open files stored on a web repository, such as Amazon S3, FTP, SFTP, and the like.  

To do so, launch the Select Data Source to Open dialog and then click the Open Web File  button located at 
the bottom of this dialog. This action launches an Open Data Source from Web dialog wherein you can enter the URL 
of the webpage containing the table you wish to bring into Data Prep Studio.  

Dragging and Dropping Webpage Content Versus Using the Open from Web Dialog 

You can drag and drop tables from HTML files/pages directly into the Prepare window. 

The browser is not only a rendering engine but also a scripting engine. For HTML with no Javascript that is delivered 
in its complete form and rendered in the browser, the copy/drag/drop content will be the same as the content 
obtained directly from the URL. 

However, if the HTML contains Javascript, which dynamically inserts the tables as HTML when rendered on the 
browser, only the copy/drag/drop will contain dynamically created tables; the HTML obtained directly from the URL 
will not contain these tables. 

Adding Data from XML and JSON Files 

Data Prep Studio allows you to explore and open JSON and XML files. 

Steps: 

 Navigate to the location of the JSON or XML file you wish to open, select the file, and then drag and drop it into 
the Prepare window.  
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The XML/JSON Explorer displays. 

 

Figure 4-14. The XML/JSON Explorer. A similar explorer is made available when opening XML files. 

XML and JSON files present a hierarchical arrangement of nodes or tables. Selecting a node (table) displays all 
of its fields on the right-hand side of the explorer and a preview of the data contained within it.  

When checked, the Use Simplified Column Names box located on the upper middle part of the explorer 
instructs Monarch to eliminate extraneous characters (e.g., the @ sign) from column names. Use the Encoding 
Options drop-down to select a character encoding system different from the default (UTF-8) if necessary. 

 

Figure 4-15. The XML/JSON Explorer with a node selected.  
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Selecting a node also shows the number of rows it contains if this number is more than one.  

 Select a node to open by clicking on it. 

 Select Row Expand Arrays or Column Expand Arrays to display JSON arrays into rows or columns, 
respectively.  

 Select an Encoding Option if necessary.  

 Click OK.  

Your table is loaded in the Prepare window. You can select and add this table to your list of open tables as usual. 
For the rest of the exercises, however, this is not necessary.  

Adding Data from Monarch Classic Files 

Data Prep Studio allows you to work with existing Monarch Classic models and projects. 

This means you can take advantage of the robust templating and extraction capabilities of Monarch Classic and use 
the pre-defined models to work with reports. 

However, note that tables that come from Monarch files behave differently from tables that come from other sources: 

❑ Tables associated with a Monarch Classic file are not displayed in the Preview window. 

❑ Data from reports associated with a Monarch file table are displayed as tables in the Prepare window but cannot 
be prepped. 

 

The following Monarch Classic features are translated in Data Prep Studio when you open a Monarch file: 

❑ Data captured by all trap types 

❑ Multi-column regions 

❑ Formula-based calculated fields using all built-in Monarch functions 

❑ Lookup table calculated fields 

❑ Multiple reports 

❑ PDF reports 

❑ Projects that use databases 

❑ Projects with named exports (with some exceptions) 

❑ External lookups 

❑ Runtime parameters 

❑ Named filters 

❑ Named sorts 

❑ Summary definitions 

❑ User-defined functions 

❑ Bookmarks 

❑ Report colors 

 

The following Monarch Classic features are currently not supported in Data Prep Studio: 

❑ External Models – External model definitions within a Monarch model are simply ignored when the model is 
imported into Data Prep Studio. 

❑ User-edited fields – User-edited fields are displayed in Data Prep Studio with null values. 

https://help.altair.com/2024/monarch/help/Working_with_Monarch_Files.htm
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❑ Redaction of report fields – Data Prep Studio does not support Consistent Alias Replacement (CAR)-type 
redactions. In the case where the Monarch model specifies a CAR redaction for some field, the Data Prep Studio 
substitutes a non-CAR redaction change that best emulates the CAR redaction specified. 

❑ Projects with inputs and models from S3, HTTPS, and FTPS (i.e., web sources that require authentication) 

❑ Report index – Any report index definitions present in the Monarch model are ignored in DPS 

 

To open Monarch Files in Data Prep Studio, the following steps are applied. 

Steps: 

 Launch the Select Data Source to Open dialog. 

 Click Monarch File and then double-click on Monarch Model or Monarch Project. From the Open dialog that 
displays, navigate to the folder in which your Monarch file resides, select it, and then click Open.  

If you open a Monarch model only, the model is displayed as a table in the Prepare window. To view data, you 
must add at least one report that is compatible with this model. To do so, in the Prepare window, click on the 
drop-down located to the right of this main table and select Report Options > Add Report. 

If you open a Monarch project, the model is displayed as the main table in the Prepare window and all other 
tables obtained from the report associated with the project are displayed as sub-tables. 

More information on working with Monarch Classic files in Data Prep Studio can be found here. 

Adding Data from Excel Files 

Excel files may be added to your workspace via the Select Data Source to Open dialog or simply dragging and 
dropping the file into the Start Page, Preview window, or Prepare window. 

You can open Excel files by using Worksheet Design, which allows you to capture data from Excel files with multiple 
levels of detail or the Excel Explorer. 

 

Figure 4-16. The Excel Explorer dialog. 

This dialog is used to specify which tables to open and how the data should be displayed. When the necessary 
specifications have been provided and Load Selected is clicked, the table(s) open as usual in the Prepare window. 

https://help.altair.com/2024/monarch/help/Working_with_Monarch_Files.htm
https://help.altair.com/2024/monarch/help/EXL_Overview__Worksheet_Design.htm
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More information on the Excel Explorer dialog may be found here. 

Trapping Data from Report Files 

Many of today’s reports come in the form of PDF, PRN, and TXT files. You could simply read these files off your 
computer screen and learn about whatever they contain, but what if you wanted to use the data in these reports to 
perform further analysis? Let’s say you had a 150-page PDF report listing individual patient visits over a span of 8 
months and want to find out which three symptoms are the most common among these patients. How would you go 
about doing so? Before you can do any such analysis, you clearly have to get data off the PDF and into your 
computer.  

Preparing Traps 

When you bring a report file into Data Prep Studio, you must create a model to extract data from it. A model is a 
collection of data extraction templates, and modeling is the process of creating these templates. You can define data 
extraction templates to quickly and consistently select data from a report and arrange them into an orderly table. 

Steps: 

1. Open Patient.pdf in Data Prep Studio. 

The report displays in the Report Design window. 

 

Figure 4-17. Opening Patient.pdf in the Report Design window.  

  

https://help.altair.com/2024/monarch/help/Adding_Data_from_Excel_Files.htm
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2. Click on the line selection area of the line beginning with Elmberry MO 63343 so that it is selected. Then, in the 
Template Properties panel, click + Detail. This instruction tells Data Prep Studio that we are creating a detail 
template. 

 

Figure 4-18. Selecting a line to trap. 

The Template Editor is activated. 

 

Figure 4-19. The activated Template Editor. 

Line selection 
area – Click here 
to select a line to 
use as a basis for 
trapping 
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3. Click into the trap line right above the word BILL and then, using your keyboard, type out the word BILL. Notice 
how all similar lines (i.e., those with the word BILL in the exact same position in the report) are highlighted. 
Guillemets also appear in the line selection area next to lines containing data that match the trap. 

 

Figure 4-20. Specifying characters to create a trap. 

You have just manually defined a trap, in this case, an exact trap. Let’s move on to defining fields. 

4. In the sample text line, highlight the numbers 1839.39. 

The Data Preview at the bottom of the Template Editor displays what would make the first column of your table. 
The rows of this table are populated with the bill amounts you have just instructed the application to pick up. 

 

Figure 4-21. Highlighting fields. 

Note also that a Field Properties section is added to the Template Properties panel. We’ll use this panel to give 
our field a more meaningful name. 

Trap Line – 
Enter trap 
characters here 
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5. Highlight the text in the Name field of the Field Properties section of the Template and Field Properties panel, 

rename the field Bill Amount, and then click the Accept  icon that displays next to the field name. 

 

Figure 4-22. Specifying a field name. 

The name of the field indicated in the Data Preview panel changes. 

   

Figure 4-23. A new field created from our trapping operation. 

Let’s capture more data from the report. 

6. Click on the line selection area next to the line beginning with Michael Canton and then, in the Template 
Properties panel, click + Append. 

The contents of the trap line and sample text line are updated with your selection. 
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Figure 4-24. Creating a new template to gather more data from the report. 

7. Let’s trap Service Code data. Click into the trap line directly above A in the service code A0028. Using the trap 
characters located above the trap line, create the following trap: 

 

Figure 4-25. Creating a new trap to capture the SVC_CODE field. 

In the present case, we cannot use an exact trap to capture field data because we expect service codes to 
change for each customer. However, we are sure that the service code will always begin with an alpha character 
followed by four numeric characters. The trap characters ÃÑÑÑÑ instruct Data Prep Studio to search all of the 
lines of the report that this specific pattern of characters at the specific location in which it is located. Notice that 
all lines containing data corresponding to this trap are highlighted in the report. Guillemets also appear in the line 
selection area beside these lines. 
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Figure 4-26. Rows are highlighted if they include data corresponding to the trap characters indicated. 

8. Highlight the text Michael Canton, A0028, and Son had Funny Bone Surgery. You can extend your 
highlighting a bit to capture names and symptoms that might be slightly longer than you are currently seeing.  

All of the data captured by the fields you have just defined display in the Data Preview panel. 

Editing Field Properties 

When fields are captured during report trapping, you can modify each field’s properties. Renaming fields, which we 
did for the first field we captured in this lesson is just one of several properties you can modify.  

Steps: 

 In the Data Preview panel, click on header of the field containing the entry Michael Canton so that its properties 
display at the bottom of the Template and Field Properties panel. Change the name of this field to Patient Info.  

 Click Next Field to define a new name for the field containing the entry A0028.  

 Change the name of this field to Service Code. 

 Repeat Step 2 and then rename the next field Symptoms. Your Data Preview panel should display as follows. 

 

Figure 4-27. Newly captured and renamed fields added to our table. 
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Now, note how, in the original report, the Symptoms field can span one or two lines. The Bill amount 
consistently begins on the third line of the record. Unless we make adjustments to the Symptoms field, we will be 
unable to capture all of the symptoms written in the original report.  

 Click on the Advanced tab of the field definition for Symptoms. This tab displays several options that will help 
you address multiple-line fields. At the moment, all we are concerned with is the end of the multiple-line field. 

 Locate the option End Field On > Line Count.  

 Ensure that the radio button for the option is selected and then use the counter to increase the line count to 2.  

  

Figure 4-28. Specifying advanced settings for a field. 

Note the immediate change in the Symptoms field. 

 

Figure 4-29. Specifying advanced settings can help capture fields completely. 

We’re almost done!  
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 Click Accept on the Report Design toolbar to save the table you have just created and display it in the Prepare 
window.  

 

Figure 4-30. A new table created from Patients.pdf. 

Using the Recent Files Panel to Load Data 

Clicking on the Recent Files button located on the upper left-hand corner of the Start Page or Preview window 
displays a panel from which you can view all recently opened workspaces, files, and tables. 

    

Figure 4-31. The Recent Files panel. 
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NOTE The Recent Files panel is populated with workspaces, files, and data connections 
opened from previous and the current data prep sessions. If you are using Data Prep 
Studio for the first time, no data sources and tables will display when you expand this 
panel. 

 

Selecting any item in this panel opens the related data source or table. This functionality allows you faster access to 
your data and eliminates the need for repeated launching of the Select Data Source to Open dialog just to load more 
data to the current data prep session.  

When clicking on an item in the Recent Files panel, say, an MDB file, all of the tables included in this file are loaded 
into the Preview window and made available for bringing into the Prepare window. In Figure 4-32, we selected 
Beantown.mdb from the Recent Files panel. The Access Explorer displays. From here, you can select which table(s) 
to open in the Prepare window as usual. 

 

Figure 4-32. Opening Beantown.mdb from the Recent Data Sources Panel. 

Items in the Recent Files panel may be closed (i.e., removed from the data sources list) by hovering your mouse on 

the data source you want to close and then clicking on the Remove  button that appears to its right.  
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Displaying Recent Data Sources in the Select Data Source to Open Dialog 

You can view and open recently opened data sources in the Select Data Source to Open dialog.  

 

Figure 4-33. Viewing recently opened data sources via the Select Data Source to Open dialog. 

Select any item on this list to load it into the Prepare window. Close data sources (i.e., remove them from the list) by 

hovering your mouse on the data source file you want to close and then clicking on the Remove  button that 
appears to its right.  

 

Figure 4-34. Closing a recently opened data source via the Select Data Source to Open dialog. 

Now that we know how to open data from a table, report, and webpage into the Add Window, we’ll explore how to 
open data from other database types using the Altair Data Connectors. Let’s save our current workspace and open 
a new one. 
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SAVING DATA SOURCES TO THE DATA 
SOURCE LIBRARY 

Data Prep Studio can save tables you opened in the Prepare window the Data Source Library. 

When you save a data source or table to this library, Data Prep Studio “remembers” the path or location of this source 
and applies it when the same is opened in another data prep session. Thus, you can use the Data Source library to 
access commonly-used data sources quickly and seamlessly without using the Open Data Source dialog, previewing 
the data source, and selecting individual tables to open.  

Let’s save the Accounting table to the Data Source library. 

Steps: 

1. In the Prepare window, go to the table selector, and then click on the drop-down arrow to the right of the 
Accounting table to display a context menu. 

  

Figure 4-35. Saving a data source to the Data Source Library. 

The Data Source Library displays your newly saved data source.  
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Figure 4-36. The saved data source displays in the Data Source Library. 

To load a data source from the library, select the Open Library  icon from the Data Prep Studio toolbar or Open 
Library from the Select Data Source to Open dialog. This action launches the Library dialog. Select the table you 
wish to add to your workspace and then click Load Selected.  

To perform an action on any data source in this list, select it to activate it and then choose an operation to execute. 
You can edit the table path, load the data source, preview the data source, or delete the selected data source. 

More information on the Data Source Library may be found here. 

 

SAVING A WORKSPACE 

Your workspace includes: 

❑ The data tables you have loaded 

❑ The join and append definitions you have created 

❑ The transform operations you have carried out 

❑ The change histories of the tables you opened 

You can save your workspace anytime as a Data Prep Workspace file (*.dpwx), and you can load this workspace in 
future Data Prep Studio sessions to continue preparing your data.  

Learn more about your workspace here. 

  

https://help.altair.com/2024/monarch/help/Working_with_the_Data_Library.htm
https://help.altair.com/2024/monarch/help/About_Your_Workspace.htm
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Steps: 

 Click the Application Menu  button on the Data Prep Studio toolbar and, from the menu that displays, select 
Save Workspace. 

 Select one of the following: 

• Save the workspace on your computer 

• Save the workspace on your computer with a different name 

• Save the workspace with a password 

• Save the workspace with a different name and password 

• Save to Monarch Server 

 In the Save As dialog that displays, navigate to the folder in which you want to save the workspace, enter 
Workspace1 into the File name field, and then select Save. 

 If you opted to save the workspace with a password, enter and confirm this password in the next dialog that 
displays. Select OK when you are finished.  

 If you opted to save your workspace to a Monarch Server container, choose the Container in which to save your 
workspace from the dropdown list, enter the new workspace name in the appropriate field of the Save 
Workspace to Monarch Server dialog, and then click OK. 

Note that this option requires that you have correctly set up a Monarch Server connection in Application Default 
Settings > Server.  

 Close the current workspace by selecting Application Menu  > Close Workspace. 

 

USING THE ALTAIR DATA CONNECTORS 

Data Prep Studio allows you direct access to a wide variety of database types through a set of built-in data 
connectors.  

    

Figure 4-37. The Altair data connectors. 

https://help.altair.com/2024/monarch/help/The_Application_Default_Settings.htm
https://help.altair.com/2024/monarch/help/The_Application_Default_Settings.htm
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Data Prep Studio allows you to access data from the following database sources and applications:  

❑ Active Directory 

❑ Altair Monarch Report Warehouse 

❑ Altair Monarch Server Library 

❑ Business Objects 

❑ DB2 

❑ Google Analytics 

❑ HubSpot 

❑ Informix 

❑ Microsoft Access 

❑ MySQL 

❑ NetSuite 

❑ ODBC 

❑ OLEDB 

❑ Oracle 

❑ PostgreSQL 

❑ Salesforce 

❑ ServiceNow  

 

❑ SharePoint 

❑ Snowflake 

❑ Splunk 

❑ SQL Server 

❑ SQL Azure 

❑ Sybase IQ 

❑ Amazon S3 

❑ Teradata 

 

It also allows you to access data from the following big data sources: 

❑ Amazon EMR Hive 

❑ Amazon Redshift 

❑ Cassandra 

❑ Cloudera CDH Hive 

❑ Cloudera Impala 

❑ Google BigQuery 

❑ Hadoop Hive  

❑ Hortonworks Hive 

❑ IBM Cloudant 

❑ MapR Hive 

❑ MongoDB 

❑ Spark SQL 

 

Finally, data from other sources, such as SAS Transport File Format Version 5, and OData, as well as those from 
cloud-based storage systems, such as Azure Data Lake Storage Gen2, Azure Blob Storage, Oracle Cloud 
Infrastructure, and Google Cloud Storage, are also supported in Data Prep Studio. 

To connect to any of these sources quickly and successfully, Data Prep Studio makes use of data connectors.  

To obtain access to data using these connectors, specific information, including host name, server name, user ID, 
password, and database name, among others, is necessary. Which information you need will depend on the 
database to which you are attempting to connect. If you wish to use any of the data connectors, contact your 
database administrator to obtain the necessary connection details.  

While connections to these data sources are beyond the scope of this Learning Guide, the Monarch Help file provides 
detailed information on what you’ll need to be able to gain access to data residing in these sources. Click here to 
learn more.  

  

https://help.altair.com/2024/monarch/help/Working_with_Data_Sources.htm
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NAVIGATING TABLES 

Tables opened in the Prepare window may be easily navigated in a number of ways.  

Navigation Controls 

The following controls have been enabled in Data Prep Studio to allow quick movement through a table.  

❑ Ctrl + Home – Go to first cell of the first row of the table 

❑ Ctrl + End – Go to the last cell of the last row of the table 

❑ Ctrl + Right arrow – Go to right-most cell in the current row 

❑ Ctrl + Left arrow – Go to the left-most cell in the current row 

Working with Rows 

The row number of any given table is provided at the bottom of your workspace. To go to a specific row in your table, 
simply enter the row number you wish in the row field provided. To go to the first and last rows of the table, click on 

the First Row  and Last Row  buttons, respectively. The Previous Page  and Next Page   buttons take 
you to views of previous and next pages of data, respectively. 

 

Figure 4-38. Viewing the row count of a table.  

You can increase row heights by selecting the Row Height  button to fit multi-line data into your rows.  

Searching for Data 

You can search for specific data in tables by using the Search field located at the bottom of your workspace. Enter 

the string you would like to search for and then either press Enter on your keyboard or click the Search for Next  
button located to the right of this field. The first cell including the string you are searching for is highlighted. Keep 

pressing Enter or clicking the Search for Next  button to locate all instances of this string. To reverse the search 

direction, click on the Search for Previous  button. If you wish, you can also cancel a search that has not been 
completed by clicking the Cancel button that displays during a search operation. 
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Figure 4-39. Searching for data in a table.  

Showing Nulls and Whitespace Characters 

Two buttons, which appear at the lower right-hand corner of the Prepare window, have been enabled in Data Prep 

Studio to help you visualize your data better. The Show Nulls  button helps you see null values (i.e., empty 

fields). Clicking on the Show Whitespace Characters  button displays spaces, tab indents, and line breaks 

between text characters; these whitespace indicators display as •, →, and ↵, respectively. 

Docking/Undocking Tables 

Docking a table helps you view multiple tables at once or move them to a different location, for example, a second 
monitor. To undock a table, right click on it from the Prepare window table selector and then select Undock Table 
from the options that display. You can also just drag the table anywhere on your screen. This action undocks the 

table and allows you to move it anywhere you wish. To dock a table, select the Dock Table  icon that appears on 
the upper right corner of an undocked table. This table is returned to the main interface.  
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LOADING A WORKSPACE 

Let’s load the workspace we saved as Workspace1 to continue with our tutorial. 

Steps: 

 Select Application Menu  > Open Workspace. 

 In the Open dialog that displays, go to the folder in which you saved Workspace1, select this file, and then click 
Open. 

All of the tables you loaded into Data Prep Studio, joins and appends you created, and transform operations you 
performed are displayed. 

 

Figure 4-40. All transformations to tables saved into a Workspace file are automatically performed when the file is loaded 
into Data Prep Studio. 

 

NOTE When a saved workspace is opened, Data Prep Studio attempts to load all of the 
tables added to the workspace using the file paths provided in a previous session. 
But what if the paths to these tables are changed or the table are renamed? Learn 
more about file reconciliation here. 

 

NOTE Several data sources available in previous versions of Monarch Data Prep Studio 
(i.e., versions 2022.1 and older) were deprecated in the 2023 version of the 
application and replaced with new ones. Thus, workspaces and library files 
containing tables obtained using older data connectors will not open properly unless 
these connectors are upgraded. You can perform either a manual upgrade of these 
deprecated tables as described here or a bulk upgrade using Monarch Utility. 

  

https://help.altair.com/2024/monarch/help/File_Reconciliation.htm
https://help.altair.com/2024/monarch/help/Upgrading_Deprecated_Datasources.htm
https://help.altair.com/2024/monarch/utility/Upgrading_Deprecated_Data_Connections.htm
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JOINING DATA IN A DATA PREP SESSION 

Data Prep Studio allows the following join types: 

❑  Left outer join  

A left outer join retains all of the rows of the “left” table, regardless of whether or not there is a row that matches 
on the “right” table. 

❑  Right outer join  

A right outer join retains all of the rows of the “right” table, regardless of whether or not there is a row that 
matches on the “left” table. 

❑  Full outer join  

A full outer join returns all rows from the left and right tables. The full outer join combines the results of both left 
and right joins. 

❑  Inner join  

An inner join yields the intersection of two tables, i.e., only the rows they have in common. 

 

These joins essentially allow you to create new tables from preexisting ones so that you can get more information out 
of your data and more detail into future visualization or analytics work.  

But what if you wanted more information on the data that can’t be joined? In this case, negative joins are what you 
will need to generate. You can create a left negative join, which shows all rows from the right table for which the join 
keys do not match, or a right negative join, which shows all rows from the left table without matching join keys. If 
you want to create lookups, you can do so using the Join Configuration dialog too. More information on this topic is 
available here.  

In this exercise, we will join data from two tables. Following the steps outlined in Adding Data to a Data Prep Session 
– Adding Data from a Database, load the table in Payroll.mdb into Data Prep Studio.  

Steps: 

 Select Combine from the Data Prep Studio toolbar to launch the Join stage. 

All of the tables you loaded are displayed on the table list to the left of the screen. Note that the table 
Compensation must display at the bottom of this list if you successfully opened Payroll.mdb in Data Prep 
Studio. 

 Drag Accounting from the table list and into the first Drag a Table box. This table will be the “left” table of the 
join. 

 Drag Compensation from the table list and into the second Drag a Table box. This table will be the “right” table 
of the join. 

 Select the Click to Join button that displays on top of these tables.  

The Join Configuration dialog displays. 

https://help.altair.com/2024/monarch/help/Joining_Tables.htm
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Figure 4-41. The resulting Join Configuration dialog. 

In this exercise, we will join the two tables via an inner join (i.e., we only want to see rows where key fields from 
both tables match).  

 Ensure that Standard displays in the Type drop-down and then select the Inner Join icon  from the 
available icons located below the Type field in the Join Configuration dialog.  

 Select Emp_ID as the key field for the Accounting table. 

 Select Emp_ID as the key field for the Compensation table.  

 Click on the check mark to the left of Emp_ID in the Compensation column section to deselect it. This step 
instructs Data Prep Studio to exclude the column in the table output.  

 If you wish to take advantage of Data Prep Studio’s fuzzy matching function, tick the Use Fuzzy Matching for 
Text Column Pairs box and then set an accuracy threshold using the slider that displays. 

 Select OK. 

The resulting table is created and added to the table list. A preview of the table resulting from this join also 
displays in the Join stage workspace. 
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In the Prepare window, the joined table is named, by default, Join. Succeeding joins will be named Join(1), 
Join(2), and so on. These tables can be renamed to whatever you wish.   

 

Figure 4-42. The results of our join operation. 

 Selecting Prepare on the Data Prep Studio toolbar shows the contents of this new table.  

 

Figure 4-43. The newly defined table in the Prepare window. 
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Analyzing Joins 

Data Prep Studio includes Join Analysis functionality to help you decide which joins will likely produce the best 
results. This functionality may be accessed by selecting Recommend Keys in the Join Configuration dialog.   

The Join Analysis dialog that displays provides suggestions as to which join fields may be combined to yield the most 
number of results. 

 

Figure 4-44. The Join Analysis dialog. 

Hovering over each of the boxes in the dialog displays more information about the suggested join. 

 

Figure 4-45. Viewing information of the suggested join. 

If you are satisfied with the projected join result, simply click on the box corresponding to the proposed join. The Join 
Configuration dialog displays and you can proceed with Step 8 of the instructions described above. 
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Creating a New Join 

If you would like to create a new join after completing a previous one, select the Create New Join  button located 
on the upper right-hand corner of the Join stage. Doing so removes all tables already placed in the Join stage, as well 
as any previous join defined. You can now begin creating a new join. 

Using Fuzzy Joins 

When joining data, Data Prep Studio makes an allowance for potential errors in spelling that would result in a 
mismatch even when the keys are highly similar (e.g., "bond" vs. "bund"). Such issues are addressed by using fuzzy 
joins. 

Fuzzy joining is activated by ticking the Use Fuzzy Matching for Text Column Pairs checkbox located near the 
bottom of the Join Configuration dialog. 

       

Figure 4-46. Activating Fuzzy Matching in the Join Configuration dialog. 

The options that display when fuzzy matching is employed allow you to specify an accuracy threshold for matching 
and whether or not to include columns detailing the fuzzy matching results in the table obtained from the join. 

Note that join keys MUST be defined before fuzzy matching can be accomplished. 

More information on fuzzy matching may be found here.  

https://help.altair.com/2024/monarch/help/Using_Fuzzy_Joins.htm


 

Altair Monarch 2024.0 Learning Guide  62 

 

WORKING WITH LOAD PLANS 

When you join, append, or transform tables, the resulting table displays in the table selector of the Prepare window as 
follows: 

 

Figure 4-47. The Load Plan of a table resulting from join, append, or transform operations. 

Clicking on the  icon of the main table minimizes the table display as follows: 

 

Figure 4-48. The minimized table display.  

The tables that display under a joined, appended, or transformed table (i.e., the “parent” tables) enable you to 
visualize which specific tables were employed to obtain the newer table (i.e., the “child” table). This functionality is 
called load plan visualization. 

Because joins, appends, and transforms are NOT recorded as changes, these operations will not display in a table’s 
change history and you may be unable to recreate child tables easily, especially when working with the same 
workspace at a later date. Load plan visualization addresses this issue by allowing you to recreate new tables from 
previously existing ones: you’ll know exactly which tables to use and what operation to apply to obtain a desired 
table.  

Note that when pre-existing tables are combined to create new ones, the former are displayed below the latter.  

  

Figure 4-49. Movement of tables in a load visualization plan.  

As with any other table in the Prepare window, clicking on the drop-down icon located to the right of child tables 
allows you to edit the operation and pin and refresh the table. You can also rename or close the table, duplicate the 
table (including all other tables used to achieve it), and discard the operation. In case of the latter, the child table 
disappears and only the parent tables remain.  
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APPENDING DATA IN A DATA PREP SESSION 

When working with reports that are generated periodically, such as monthly sales receipts, you may wish to combine 
them to produce a larger dataset on which you can base future business decisions. Data Prep Studio provides a 
convenient means to combine tables with an identical schema via appends.  

Appending Data in the Prepare Window 

You can append tables in the Prepare window through two routes: via the table context menu or the Edit Append 
dialog.  

Appending Data via the Context Menu 

For this exercise, open and load the tables of Beantown.mdb. 

Steps: 

1. Using CTRL+click, select the tables Data Processing and Marketing in this order. 

 

NOTE You can select multiple tables from the table selector only if they are of the same 
rank (e.g., they belong to the same hierarchy in their respective load plans). 

 

2. Right-click on your mouse and then select Append Tables >. 

You may opt to: 

• Match columns on name 

This option appends all tables based on name. 

• Match columns on name and type 

This option appends your tables first according to their field names and then according to their field type. 

• Match columns on order  

This option appends your tables according to the order in which you selected them regardless of name or 
type. If the data types do not match, the data types of the first table are carried over to the appended table. If 
the first table selected has fewer columns than the second table, the number of columns of the first table are 
retained.  

• Match columns on order, name, and type 

This option appends your table first according to the order in which you selected them and then according to 
their field names and types. This type of append is also called a strict append.  

3. As your tables are exactly matched, select any of these options listed above. 

A new append table, named Append, is created and added to your table selector. Succeeding appends will be 
named Append(1), Append(2), and so on. These tables can be renamed to whatever you wish.   
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Appending Data via the Edit Append Dialog 

The Edit Append Dialog can help you in customizing the append operation. Unlike other append methods, you can 
"force" Data Prep Studio to match columns even if they do not have the same location, name, and/or data type. 

 

Figure 4-50. The original Accounting table. 

For this exercise, double-click on the Last Name field header of the Accounting table and rename it to “Surname.” 
Click on the drop-down button beside this header and then select Column List from the menu that displays to launch 

the Column List dialog. Using your mouse, click on the drag-and-drop handle  of Surname, drag the field, and 
drop it after First Name. Do the same for the Department column and drop it after Gender. 

Your Accounting table should now look as follows: 

 

Figure 4-51. The modified Accounting table. 

Because we’ve made changes to the Accounting table, it is no longer an exact match to the Data Processing table (to 
check, select both tables and then append by order, name, and type – failure of the append indicates some difference 
between tables). 

Let’s use the Edit Append dialog to match these tables and produce a table with only the Department, First Name, 
and Surname fields. 
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Steps: 

1. Select the tables Accounting and Data Processing. Right-click on your mouse and then select Create New 
Append. 

 

Figure 4-52. Edit Append dialog. 

The Edit Append dialog is divided into three main panels.  

The Target Schema panel displays the columns of the first table, in this case Accounting. The panel in the 
middle displays the columns of the second table, in this case Data Processing. Note that if you had selected 
Data Processing first and then selected Accounting, the tables in these two panels would be reversed. The 
Output Columns panel displays the columns your appended table will have. 

The Append operation will automatically attempt to match the columns of your two tables. As seen in the figure 
above, most of the columns have been matched correctly by name and type. Columns in the first table selected 
that cannot be matched to the columns of the second table must be mapped manually.  

2. Under the columns of Data Processing, click on the drop-down of the column labeled “----" and then click Last 
Name from the options that display.  

This action tells the Edit Append operation that the contents of this column match those of the Surname column 
even if they do not have the same name.  

3. In the Output Columns panel, tick the box for Surname and then deselect the boxes for Emp_ID, Hire Date, and 
Gender. Click OK when you are finished. 
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The new table, named Append(1), displays in the table selector.  

 

Figure 4-53. The newly appended table.  

Appending Data via the Append Stage 

Besides joining tables, the Combine button on the Data Prep Studio toolbar also allows you to append tables. In this 
case, the tables are joined by name and data type.  

Steps: 

 On the Data Prep Studio toolbar, click Combine > Append Tables. The Append Stage displays. 

 

Figure 4-54. The Append stage. 

Drag and drop the tables Data Processing and Marketing into each of the fields marked Drag a Table in the 
Append stage workspace. You can add as many tables as you wish to the append provided that these tables 
feature identical schema.  
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NOTE When creating a new append, you cannot select the exact two (or n) tables used to 
create a previous append. 

 

 Click the Click to Append button that displays to the right of these tables. 

 

Figure 4-55. Completing the append operation. 

The appended table is added to the table list panel. 

 

Figure 4-56. The resulting appended table. 

TRANSFORMING DATA 
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A Transform pane is launched when you click  on the Data Prep Studio toolbar. This panel provides 
further options that will allow you to quickly change how your tables look and how your data are grouped. To reverse 
a transformation, click on the drop-down arrow to the right of the transformed table and then choose Discard 
Transform from the options that display. To edit a transformation, repeat these steps but select Edit Transform 
instead. 

Sorting Columns 

Sorts allow you to arrange the records on a table according to the ascending or descending values of one or more 
columns. 

Data Prep Studio allows you to sort column from several points: 

❑ From the context menu of a column 

❑ From the context menu of a table (via the Sort dialog) 

 

Figure 4-57. The Sort dialog. 

More information on sorting columns can be found here. 

Pivoting Columns 

Pivots allow you to transform column values into column headers, thereby changing the look of your data from 
tall+skinny to short+wide.  

For this exercise, open Classic.pdf. In the Report Design window, we create the following traps to extract the 
indicated fields: 

  

https://help.altair.com/2024/monarch/help/Sorting_a_Column.htm
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❑ Customer 

 

Figure 4-58. Extracting the Customer field from Classic.pdf via Report Design. 

❑ Media 

 

Figure 4-59. Extracting the Media field from Classic.pdf via Report Design. 

❑ Amount 
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Figure 4-60. Extracting the Amount field from Classic.pdf via Report Design. 

Right-click on the Media header and select Copy Value from Previous Record from the options that display to 
remove blank cells in your table and then accept your changes.  

The resulting table should look as follows in the Prepare window. 

 

Figure 4-61. The resulting table extracted from Classic.pdf. 

Now we’re ready to pivot your columns. 
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Steps: 

1. From the Prepare window, select Transform > Pivot to display the Pivot Column dialog. 

 

Figure 4-62. The Pivot Column dialog. 

2. In the Choose Columns portion of the dialog, click the Pivot  icon to the left of the Media column. 

3. In the Group Columns portion of the dialog, tick the box for Group on all columns. 

4. In the Choose Columns portion of the dialog, tick the box of the Amount column and ensure that the Aggregate 
Type assigned is Sum.  

5. Select OK when you are finished. 

Your table should be transformed as follows. 
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Figure 4-63. The pivoted table. 

Unpivoting Columns 

Unpivoting All of the Pivoted Columns of a Table 

When all of the pivoted columns of a table are unpivoted, the data are returned to their tall+skinny look.  

Steps: 

1. Click on the table you pivoted in the previous lesson in the Prepare window and then select Transform > 
Unpivot. 

2. In the Attribute Columns portion of the Unpivot dialog that displays, ensure that all columns are selected. 

3. Click the Unpivot icons to the left of the columns CD_Sum(Amount), DVD_Sum(Amount), LP_Sum(Amount), 
SACD_Sum(Amount), and BLU_Sum(Amount). These columns should move to the Unpivot Columns portion 
of the dialog.  

 Click OK. 

Your table returns to its original schema.  

Now you can use Data Prep Studio’s Split or Extract functions to revert entries in the Attribute column to their original 
values.  

 

NOTE If you are unpivoting all of the columns you pivoted in a table, effectively completely 
reversing your change, you can also simply click on the drop-down icon located to 
the right of the pivoted table and, from the options that display, select Discard 

Transform . 

 



 

Altair Monarch 2024.0 Learning Guide  73 

 

Unpivoting Select Columns of a Pivoted Table 

When you opt to unpivot select columns of a pivoted table, you are effectively instructing Data Prep Studio to display 
the data (values) of these columns (attributes) in a left-to-right manner but keep all other fields and their associated 
data in their top-bottom form. 

In this case, an Attribute column, which will contain the name(s) of the column(s) you unpivoted, and a Values 
column, which will contain all of the data corresponding to these columns, are created. Depending on the number of 
columns you choose to unpivot, the new table created could be much shorter than the original pivoted table.  

Steps: 

 Repeat the Pivoting Columns exercise to obtain a pivoted table. Ensure that this table is displayed in the Prepare 
window. 

 From the Data Prep Studio toolbar, select Transform > Unpivot. 

The Unpivot Columns dialog displays. 

 In the Attribute Columns portion of the Unpivot dialog that displays, ensure that all columns are selected. 

 Click the Unpivot icon to the left of the column BLU_Sum(Amount). This column should move to the Unpivot 
Columns portion of the dialog.  

 Check the box for BLU and then select OK. 

The newly transformed table displays as below. 

 

Figure 4-64. The newly transformed table. 

Transposing Columns 

The Transpose transformation allows you to use the rows of a column (vertical display) as column headers 
(horizontal display). 

Steps: 

 In the Prepare window, select the table you wish to transform. 

 Click Transform > Transpose to display the Transpose dialog. 

 

Figure 4-65. The Transpose dialog. 
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 Select the corresponding radio button if you wish to: 

• Transpose on first column 

• Transpose with generic column headers 

 Click OK when you are finished. 

Grouping Data 

The Group By transformation allows you to classify or consolidate rows that belong together according to some 
common value within the row. When you consolidate the records, you can also select column values to aggregate. 
Let’s use the table in the previous exercise to group our data. 

 

Figure 4-66. Data to be grouped. 

Steps: 

1. From the toolbar, select Transform > Group to display the Group dialog.  

 

Figure 4-67. The Group By dialog. 
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In the table above, we can group all media sales so that only the total amounts for each customer are displayed. 

2. Click the Group icon of the Customer column so that it moves to the Group Columns portion of the dialog. 

3. In the Value Columns portion of the dialog, ensure that the box to the left of the Amount column is ticked and 
that its Aggregation Type is Sum.  

4. Ensure that the box to the left of the Media column is unchecked.  

5. Select OK when you are finished. Your new table displays. 

 

Figure 4-68. The table resulting from a Group By operation. 
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Removing/Showing Duplicates 

You can remove or show duplicate rows from tables by selecting Transform and, in the dialog that displays, clicking 
the Duplicates option. 

Steps: 

 In the Prepare window, view the table from which you want to remove duplicate rows to remove and then select 
Transform > Duplicates. The Duplicates dialog displays. 

 

Figure 4-69. The Duplicates dialog. 

 Select the deduplicate operation to apply to your table from the drop-down provided 

You can: 

• Remove Duplicates - Keep first row 

• Show Duplicates - Show all except first row 

• Flag Duplicates - Mark with new column 

 Select the columns to evaluate for the deduplication operation by clicking on the Key icon located to the left of 
each column of interest. 

 Tick the boxes of the columns you wish to display in the table resulting from the deduplication operation.  

 Click OK. 

The resulting table displays. 

More information on how to remove duplicates from tables may be found here. 

  

https://help.altair.com/2024/monarch/help/Remove_Show_Duplicate_Rows.htm
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Extracting Rows 

To extract empty rows or rows with empty values in a table, select Transform from the toolbar and then click Extract 
Rows.  

 

Figure 4-70. The Extract Rows dialog. 

You can: 

❑ Exclude all rows where all key columns contain no content, nulls, or whitespace only 

❑ Exclude all rows where any key column contains no content, nulls, or whitespace only 

❑ Include all rows where any key column contains no content, nulls, or whitespace only 

Learn more about this topic here. 

  

https://help.altair.com/2024/monarch/help/Extracting_Blanks_Null_and_White_Spaces.htm
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WORKING WITH CALCULATED FIELDS 

The ability to create calculated fields is among the more important data prep operations you can perform. Calculated 
fields can be created from text, date/time, and numeric fields.  

A complete list of the functions available in the New Formula Column dialog, as well as their definitions and 
examples, may be found here. 

 

Figure 4-71. The New Formula Column dialog. 

For this exercise, let’s compute what the unit prices of various media from the Classic.pdf report would be if we 
applied a 10% discount to them.  

Steps: 

1. From the Classic.pdf report, extract the fields marked by Betty’s Music Store (Customer), Bartok, Sonata for 
Solo Violin (Description), MK-42625 (Label/No.), and 8.99 (Unt_Prc). Load this table into the Prepare window. 

2. Click on the drop-down button beside the Unt_Prc column and then select Column > New Formula Column. 

3. In the New Formula Column dialog that displays, enter Discounted Prices in the Field Name box.  

4. Double-click on Unt_Prc field in the Fields panel so that the field name appears in the Expression box.  

5. In the Operators panel, double-click on the multiplication operator. This operator appears in the Expression box. 

6. Using your mouse, click to the right of the multiplication operator in the Expression box and then type in 0.90. 
Select OK when you are finished. 

The New Formula Column dialog closes and a new column is added to your table. 

7. Select the drop-down button of the Discounted Prices column and then click Format. In the Format Discounted 
Prices dialog that displays, select Financial and then click OK. 

https://help.altair.com/2024/monarch/help/ht_table_functions.htm
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Your table is rebuilt. 

 

Figure 4-72. Adding a calculated field to a table. 

FILTERING DATA 

You can choose how much data to import from a table into your Data Prep Session by filtering your table and 
selecting the data you want to view. Let’s find out how using the table we produced from a PDF report. In this 
example, instead of viewing data for 20 customers, we’ll select only 5 customers and load their data into a new table.  

Steps:  

 Open Classic.pdf and then use the Auto-Define button in the Report Design window to extract data from the 
report. 

 View the resulting table in the Prepare window.  

 Click the drop-down button beside the Customer column and then select Filter > Define Filter.  

The Define Filter dialog displays.  

 

Figure 4-73. The Apply Filter dialog.  

 Click on the Expression drop-down and, from the options that display, select Multiple Selection. 
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A list of all unique values (i.e., Customer names) displays. 

 Using this list, tick the boxes (i.e., Include) for Betty’s Music Store, Big Shanty Music, Bluegrass Records, 
Canciones, and Chez Rudy. 

 Select OK when you are finished. The resulting table displays in the Prepare window.  

 

Figure 4-74. The table obtained from a filter operation.  

Note that the data of only five customers are displayed. 

Different filter operations are available for different field types. Numeric fields, for example, may be filtered by 
using ranges or specifying less than or greater than values. To filter date fields, you can specify a date range or 
before/after date. For text fields, you can specify strings or select discrete values.  
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PREPARING DATA 

You can prepare columns in a table to prepare them for future visualization or analytics operations. Data Prep Studio 
includes pre-built functions that allow you to quickly and consistently clean your data, turning them into analysis-ready 

information. Preparing data in Data Prep Studio is as easy as clicking on the drop-down  button located to the 
right of each column header. Doing so displays a list of prep operations you can perform on that column.  

      

Figure 4-75. Available prep operations for Date/Time fields in the Prepare window. 

Summary of Data Prep Operations 

The following table summarizes the data prep operations possible in Monarch Data Prep Studio. 

Details of each operation may be obtained by consulting Working with Data Prep Studio > Prep Data Column 
Operations in the Monarch Help file. 

Use this transformation To 

FILTER 

Define filter Create a filter for the selected column 

Discard all filters Remove all filters applied to a table 

 

SORT 

Sort selected columns Sort the column in ascending order 

Define sort Launch the Sort dialog to create a new sort definition 

 

COLUMN 

New formula column Add a new formula column to the table 

New constant value column Add a new constant-value column to the table 

https://help.altair.com/2024/monarch/help/Prep_Data_Column_Operations.htm
https://help.altair.com/2024/monarch/help/Prep_Data_Column_Operations.htm
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Use this transformation To 

New lookup column Add a new lookup column to the table 

New row number column Add a new row number column to the table 

New runtime parameter column Add a new runtime parameter column to the table 

Add or remove metadata columns Add metadata columns to your table 

Rename column Rename the column you selected 

Duplicate column Produce a duplicate of the column you selected 

Show hidden column Show a list of hidden columns. Selecting a column from this list 
displays it in the table once more.  

Hide column Hide the selected column 

Delete column Remove the selected column from the table 

 

ALIGNMENT 

Left  Align text to the left 

Center Align text to the center 

Right Align text to the right 

 

CASE 

Make proper case Convert to uppercase the first letter of each word in a string 

Make lower case  Convert the entire string to lowercase letters 

Make upper case  Convert the entire string to uppercase letters 

 

CLEAN 

Remove leading and trailing 
spaces  

Remove all leading and trailing spaces from a string 

Remove consecutive spaces Collapse multiple consecutive spaces into one space 

Remove specified characters Remove the sequence of characters from the values of the 
column you apply this operation to 

Remove non-alphanumeric 
characters 

Remove all characters that are not numbers or letters (e.g., 
periods, commas, other symbols) from the selected fields 

Remove numeric characters Remove all numerals from the selected fields 

Remove alpha characters Remove all alpha characters from the selected field 

 

CONVERT 

Text to number Convert the data type Text into Number 

Text to date/time Convert the data type Text into Date/Time 

HH:MM:SS to number of secs  Convert HH:MM:SS strings into a number of seconds 

Date/time to text Convert the data type Date/Time to Text 

Date/time to number Convert the data type Date/Time to Number 
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Use this transformation To 

Number to text Convert the data type Number into Text 

Number to date/time Convert the data type Number into Date/Time 

Advanced text to number Converts text fields with the values “X B,” “X M,” and “X K,” 
where “X” is any number, into “X,000,000,000,” “X,000,000,” 
and “X,000,” respectively 

EXTRACT 

Starting from left Extract n characters from the beginning of a string  

Starting from right Extract n characters from the end of a string  

Using position and length  Extract n characters from the xth position from the start 

Between start and end text Extract n characters starting from the start and end positions 
indicated by a string of characters 

Line of a text block by line number Extract a line from a text block based on the number of the line 
in the block 

Line of a text block by search term Extract a line from a text block based on a given search term 

 

INSERT TEXT 

Insert text Insert a text string at a specific location in the field 

 

FORMAT (for Date/Time fields) 

Short date Apply the MM/DD/YYYY form of a date/time field 

Long date Apply the Day, Date form of a date/time field 

Short date/time Apply the MM/DD/YYYY HH:MM AM/PM form of a date/time 
field 

Long date/time Apply the Day, Date HH:MM AM/PM form of a date/time field 

Time Apply the HH:MM AM/PM form of a date/time field 

Custom Specify a custom form (e.g., year, month, day, hour, minute, 
etc.) for the date/time field 

 

FORMAT (for Numeric fields) 

Fixed Format the number without a thousands separator  

Number Format the number with a thousands separator and two decimal 
places  

Financial Format the number with thousands separator and two decimal 
places. Negatives are enclosed in parenthesis. 

Currency Format the number with thousands separator and two decimal 
places. Adds a currency, and negatives are enclosed in 
parenthesis. 

Percent Multiply the number by 100 and add a % sign 

Scientific Format the number in exponential form 
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Use this transformation To 

Custom Specify a custom form (e.g., 000,000, #0.0E0, # ‘degrees,’ etc.) 
for the number field 

 

REPLACE 

Using position and length Replace strings of a certain length and located at a certain start 
position with another string 

Using find and replace Replace specific strings with another string 

Ditto Copy non-null values down to fill null values in subsequent rows 
in a column 

Blank values Replace blank values with a specific string 

Nulls Remove null values and replace with a specific string 

 

SPLIT 

Into parts from the Left Start from the left and split a column into two or more columns, 
depending on a separator you define. The separator may be a 
single character or substring 

Into Parts from the Right  Start from the right and split a column into two or more columns, 
depending on a separator you define 

Names Into Parts Split the value of a name column into its name parts. 

Addresses Into Parts  Split the value of a single address column into its component 
address or postal parts 

Date/Time into Parts Split a date/time column into two or more parts according to the 
date/time components you select. Parts include Year, Quarter, 
Month, Day, Hour, Minute, Second, Date, Time, DayofYear, 
HalfYear, and Week. 

Date/Time into ISO 8601 Parts Split a date/time field into two or columns according to the ISO 
8601 date/time components you select 

Date/Time into Fiscal Parts Split a date/time field into two or more columns according to the 
fiscal parts selected 

 

COMPUTE 

Round with Precision… Round numbers to a specified number of places to the right (or 
left) of the decimal point 

Round Up (Ceiling) Round numbers up to zero decimal places 

Round Down (Floor) Round numbers down to zero decimal places 

Remove Negative Signs (Abs) Return the absolute values of numbers 

Remove Decimals (Int) Return the integer portions of numbers 

Calculator Creates a calculated field using other numeric fields in the table 

  

OTHERS  

Macros Add and manage macros and apply the same to columns  
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Text Field Operations 

For text fields, the following data prep operations may be applied: 

Data Prep Operation Details 

Filter Define filter 

Discard filter 

Sort Sort selected columns 

Define sort 

Column New formula column 

New constant value column 

New lookup column 

New row number column 

New runtime parameter column 

Add or remove metadata columns 

Rename column 

Duplicate column 

Hide column 

Delete column 

Alignment Left 

Center 

Right 

Case Make proper case 

Make lower case 

Make upper case 

Clean Remove leading and trailing spaces (Trim) 

Remove consecutive spaces (Collapse) 

Remove specified characters 

Remove non-alphanumeric characters 

Remove numeric characters 

Remove alpha characters 

Convert  Text to number 

Advanced text to number 

Text to date/time 

HH:MM:SS to number of seconds 

Extract Starting from left 

Starting from right 

Using position and length 

Using start and end strings 

Line of a text block by line number 

Line of a text block by search term 

Insert text  

Merge  

Redact  
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Data Prep Operation Details 

Replace Ditto 

Nulls 

Blank values 

Using find and replace 

Using position and length 

Split Into parts from the left 

Into parts from the right 

Names into parts 

Addresses into parts 

Date/Time and Numeric Field Operations 

For date/time and numeric fields, the following data prep operations may be applied:  

Data Prep Operation Details 

Filter Define filter 

Discard filter 

Sort Sort selected columns 

Define sort 

Column New formula column 

New constant value column 

New lookup column 

New row number column 

New runtime parameter column 

Rename column 

Duplicate column 

Hide column 

Delete column 

Alignment Left 

Center 

Right 

Convert  Date/Time 

Date/time to text 

Date/time to number 

 

Numeric 

Number to text 

Number to date/time  

Format  

Merge  

Redact  

Replace Ditto 

Nulls 
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Data Prep Operation Details 

Split (Date/time) Date/time into parts 

Date/time into ISO 8601 parts 

Date/time into fiscal parts 

Compute (Numeric) Round with precision 

Round up (Ceiling) 

Round down (Floor) 

Remove negative signs (Abs) 

Remove Decimals (Int) 

Calculator  

Changing the Data Type of a Column 

Besides data prep operations, you can also change the field type of each of the columns in your table (e.g., change a 
numeric field into a date/time field). To do so, simply click on the field type icon found to the left of the column name 
and, from the options that display, select the new field type you wish to apply. 

 

Figure 4-76. Available prep operations for Text fields in the Prepare window. 

Searching for a Data Prep Operation 

If the data prep operation you are looking for is not immediately obvious, simply type in the operation into the Search 
field provided in the drop-down. Doing so filters the prep operations according to your search criteria and displays the 
results, if any.  
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Figure 4-77. Available prep operations for Text fields in the Prepare window. 
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Copying Table Data 

A number of copy operations can be done in Monarch Studio. Once copied, the data can be pasted to some other 
word processing application. 

❑ To copy all of the data in a single column, click on the drop-down button to the right of the name of the column 
you wish to copy and then select Copy from the options that display. If you wish to copy all of the data including 
the header of the column, choose Copy with headers instead.  

❑ To copy a portion of the data in a single column, highlight the data you wish to copy, right-click on your mouse 
and then select Copy from the options that display. If you wish to copy the data including the column headers, 
choose Copy with headers instead.  

❑ To copy data from two or more adjacent columns, highlight the data you wish to copy, right-click on your mouse 
and then select Copy from the options that display. If you wish to copy the data including the column headers, 
choose Copy with headers instead.  

❑ To copy data from a single column in Monarch Studio and automatically create a new table in your workspace 
from the selected data, click on the drop-down button to the right of the name of the column you wish to copy and 
then then select Create table from selection from the options that display. The headers of the columns from 
which you obtained the data are used as headers for the newly generated table.  

❑ To copy data from adjacent columns in Monarch Studio and automatically create a new table in your workspace 
from the selected data, highlight the data you wish to copy, right-click on your mouse and then select Create 
table from selection from the options that display. The headers of the columns from which you obtained the 
data are used as headers for the newly generated table.  

Modifying Column Information 

Column information (e.g., type, name, order, hide/unhide) can be modified via the Column List dialog. Select the 
drop-down button located to the right of each column and, from the options that display, click on Column List. Doing 
so displays the Column List dialog, which provides details of all of the columns included in your table. Here, the first 
name on the list represents the first column of your table, the second name represents the second table, and so on. 

 

Figure 4-78. The Column List dialog. 

Using this dialog, you can: 

❑ Rename a column – Click on the Edit button to the left of a column name and then enter a new name into the 
activated field. 
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❑ Change the data type of a column – Select a new data type from the Type drop-down located to the right of the 
column.  

❑ Hide a column – Tick the Hide box located to the right of a column you wish to hide. Untick the box to display a 
hidden column. If you wish to hide all columns, click the Hide All button. To display all hidden columns, click the 
Unhide All button. 

❑ Format date/time and numeric columns – An Edit button displays to the right of date/time and numeric columns. 
Click this button to bring up the Format dialog and select a different format for the column.  

❑ Adjust column width – Set the width of a column by using the up and down arrows. 

❑ Set alignment – Align the content of a column to the left, center, or right. Choose your preferred alignment from 
the dropdown menu. 

❑ Reorder columns – Select the drag-and-drop handle  to the left a column name and then drag and drop it to 

its new location. Alternatively, use the , , , and  buttons to move the column to the top of 
the list, one row up the list, one row down the list, and to the end of the list, respectively.   

 

A preview of your changes is provided at the right-hand side of the dialog. 

You can also work with macros in the Column List dialog.  

Setting a Row as a Column Header 

To change the table header and use values from a certain row as column names instead, click on the number of the 
row you would like to use as a header, effectively highlighting it, right-click on your mouse, and then select Set Row 
as Column Headers from the options that display. Note that when this operation is done, all rows above the row you 
selected as the column header are removed from the table and a new table (i.e., a transformation) is created.  

To reverse (undo) this transformation, in the table selector, right-click on the newly created table and then select 
Discard Transform from the options that display.  

Adding Metadata Columns to a Table 

You can add metadata from Excel, delimited text, and PDF/PRN reports as new columns to tables. This is done by 
clicking the Metadata Columns button that appears at the bottom of the Change History panels of tables opened 
from these file types.  

 

Figure 4-79. Adding metadata columns to a table opened from Excel, delimited text, and PDF/PRN reports. 

https://help.altair.com/2024/monarch/help/Working_with_Macros.htm
https://help.altair.com/2024/monarch/help/Adding_File_Metadata_Columns_to_Tables.htm
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Alternatively, you can expanding the context menu of any column in the table and selecting Column > Add or 
Remove Metadata Columns from the options that display. 

Let’s transform the Hire Date column of the table Join so that only the hire date and not the hire time displays. In this 
exercise, we will also transform the Salary and Bonus fields so that the values in these fields resemble monetary 
values more closely. 

Steps: 

 In the Prepare window, load the Join table, which we created in an earlier lesson. 

 Click on the drop-down  button located to the right of the Hire Date column header. 

 From the menu that displays, select Format. 

 From the Format Hire Date dialog that displays, select Short Date. 

 

Figure 4-80. The Format Hire Date dialog. 

 Select OK when you are finished  
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The new column displaying only the hire date (without the hire time) displays. Note that the column header has 
been changed to reflect at least part of the transformation we performed. 

 

Figure 4-81. The transformed Hire Date column of the Join (Accounting + Compensation) table in the Prepare window. 

 Click on the drop-down  button located to the right of the Salary column header and, from the menu that 
displays, select Format. 

 In the Format Salary dialog that displays, select Currency and then click OK. 

 Perform Steps 6 and 7 to transform the Bonus field.  

Your table should now look as below. 

 

Figure 4-82. A completely transformed Join (Accounting + Compensation) table in the Prepare window. 
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TRACKING CHANGES 

A change history is the record of all changes that have been made to a table. This list can be reapplied to any table 
that has columns of the same names and data types in the same order. Change histories may be imported and 
exported and applied to tables similar to that from which the imported/exported change history was created. 

Data Prep Studio features a nifty tool through which you can track your data transformations in a stepwise manner. 
This tool is called Change History and is found as a panel on the right-hand side of the Prepare window.  

 

Figure 4-83. Accessing the Change History panel. 

This panel shows each of the changes we performed in the previous exercise.  

If you want to undo an operation, select the Undo Change  button beside that operation. If you’d like to edit it, 

select the Edit  button. 

Note that selecting Undo for one operation will also undo all operations after it and that the Change History 
functionality is only available in the Prepare window.  

A complete discussion on Change History is provided here. 

Applying a Change List to a Different Table 

You can drag and drop single changes (using the header of a change) or whole change lists (using the drag-and-drop 
handle of the Change History panel) to other tables. When you do so, each of the changes specified in the change list 
are automatically applied in sequence to the new table if the latter has no change history.  

 

Figure 4-84. The drag-and-drop handle of the Change History panel. 

In Figure 4-85, the change list of the table Join (Accounting + Compensation) has been dragged to the table Join(1) 
(Data Processing + Compensation). Assuming that both tables contain the same fields but the latter has a different 
change list, you are asked if you would like to replace the Change History of the latter table.  

https://help.altair.com/2024/monarch/help/About_Change_History.htm
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Figure 4-85. The change list created from the Join (Accounting + Compensation) table was dragged and dropped to the 
Join(1) (Data Processing + Compensation) table. 

If you select Replace in the Change List Drop dialog, the exact same changes in the former table are applied to the 
latter one. If you select Append, the change list of the former is appended to the change list of the latter. If a field is 
hidden and a change must be applied to it, the hidden field is displayed and the change operations are completed.  

In another example below, the Change List of the Join table (Accounting + Compensation) has been dragged and 
dropped to the table Marketing. Because the Marketing table does not contain Salary or Bonus fields, the error 
shown in Figure 4-86 displays.  

 

Figure 4-86. The change list created from the Join (Accounting + Compensation) table was dragged and dropped to the 
Marketing table. 

Exporting a Change History List 

Change History lists may be exported for use in a similar table in another Data Prep Studio session. 
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Steps: 

 Select Application Menu  > Export Change List. 

Alternatively, you can select the Export Change List  icon on the Change History panel.  

 In the Save As dialog that displays, use the File Location drop-down to navigate to the folder in which you want 
to save the exported change list and then enter ExportChange1 into the File name field. 

 Click Save when you are done. 

The export list is saved into the nominated folder with the extension .dpcl. 

Importing a Change History List 

Importing Change History lists allows you to quickly and easily apply changes made to a previous table to a similar 
table. 

Steps: 

 Following the steps outlined in Joining Data in a Data Prep Session, join the tables Marketing and 
Compensation using an inner join and Emp ID as the key. 

The following table displays. 

 

Figure 4-87. The results of joining tables Marketing and Compensation. 

 Select Application Menu  > Import Change List. 

Alternatively, you can select Import Change List  icon on the Change History panel. 

 Using the Open dialog that displays, navigate to the folder in which you stored ExportChange1, select this file 
and then click Open.  
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The Hire Date, Salary, and Bonus fields of the joined table immediately reflect changes.  

 

Figure 4-88. The results of our Import Change List operation. 

Viewing the Change List history of the joined table yields the following results: 

 

Figure 4-89. The Change List History of the newly joined Marketing and Compensation tables. 

Modifying Items in a Change List 

Now that you know that you can reverse changes you have applied to your tables by using the Change History 
functionality, what happens if you simply want to modify – not reverse – a change, such as a formula field? You can 

modify changes, such as filters and calculated field definitions, by clicking on the Edit  icon that displays to the 
right of an editable change in the Change History list. Note that if this icon does not appear, the change cannot be 
modified.  

Clicking the Edit  icon launches the relevant dialog to enable you to modify your change.  
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WORKING WITH SUMMARIES 

Clicking the Analyze tab in the Data Prep Studio toolbar launches a drop-down panel that allows you to create and 
manage summaries.  

A summary tabulates information for selected fields and presents the results in a one- or two-dimensional matrix, 
thereby allowing deeper analysis of your data. For example, suppose you had a table that listed the details of items 
purchased by various customers over a span of three months from a record store. You can sort this table and see 
who bought how many copies of what each day but you wouldn't know how much in total sales each customer 
produced for the quarter or what percentage their purchases made up in total sales. 

 

Figure 4-90. An ordinary table, especially very large ones, does not allow deeper analysis of your data. 

In this lesson, we’ll learn how to create and work with summaries to address such issues. 
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Figure 4-91. A summary of total sales and percentage of sales for each customer. 

Summaries tabulate information about a single key field (i.e., row). In this summary, the key field is Customer. Any 
field that is tabulated (or summed) is called a measure. In each the summary shown above, the Amount field is used 
as the measure. 

The most basic summary requires a single key field, in this case, a row (if you are a Monarch Classic user, you will 
recognize rows as down keys), and a single measure. However, you can create summary reports that include 
multiple key fields, items, and measures. 

You can also add column fields (Monarch Classic users will recognize these as across keys) to your summary such 
as in the following summary. 

Creating Summaries 

The following steps describe how to create a simple summary. Here, we’ll create the summary we saw in Fig. 4-91. 

Steps: 

 Select the table Classic from the Prepare window and then click Analyze from the Data Prep Studio toolbar. 

The Analyze drop-down displays.  

 Click Add Summary  icon to launch the Add Summary dialog. 
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Figure 4-92. Creating a new summary. 

 In the Name field, replace Summary with Sales by Customer. 

 From the Source Fields panel, click on the Row icon for Customer. This field is transferred to the Rows panel 
of the dialog. 

 From the Source Fields panel, click on the Measures icon for Amount. This field is transferred to the Measures 
panel of the dialog. Use the Calculation drop-down provided to the right of the field to select the SUM operation. 

 Repeat Step 5 but this time, choose PCT as the calculation operation. 

 Ensure that the box for Insert total line is ticked and then specify 1 in Insert n blank lines before total line. 

 Click OK at the bottom of the dialog to accept your summary definition. 

Editing Summaries 

You can edit your summaries in the following ways: 

❑ Select new/remove rows, columns, and measures 

❑ Modify the field names of individual columns  

❑ Suppress duplicate field values 

❑ Insert blank lines to the summary 

❑ Insert total lines to the summary 

❑ Modify the calculation assigned to a given measure 

❑ Select different types of filters to apply to your summary to stratify your data even further 
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In this example, let’s add Column fields to our summary. 

Steps: 

 Use the Summary drop-down to ensure that the summary Sales by Customer is selected. 

 Click the Edit Summary  icon to display the Edit Summary dialog. 

 

Figure 4-93. The Edit Summary dialog. 

 Click on the Column icon of the field Media Qty and then click OK. 

Your summary should display as follows in Summary view: 
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Figure 4-94. The modified summary showing sales as total amounts. 

Now, instead of the 149-row table we extracted for Classic.pdf, we have a 20-row summary listing sales for each 
customer for each media type. This table is clearly much easier to read and you can quickly tell which media type 
is purchased the most by which customer.  

Note that when we created our original summary, we indicated two measures: sales as total amounts and sales 
as percentages. In our edited summary, only sales by total amounts display. Where did our column for sales as 
percentages go? 

 Use the Active Measure drop-down to select the measure calculation PCT(Amt). 

The summary is rebuilt, this time in terms of sales as percentages. 

 

Figure 4-95. The modified summary showing sales as percentages. 
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When multiple measures are defined for an across-key summary, you can only view one measure at a time. 

As seen in the above examples, summaries provide you with a global view of your data, and they can be created 
quickly and easily. You can even apply filters and sorts to them. Learn more about what summaries can do for 
you and how here.  

WORKING WITH WORKSHEET DESIGN 

This next lesson provides a simple demonstration of how to work with Worksheet Design. We will make use of the file 
Classic.xlsx, which is typically installed along with your Monarch sample files (typically in 
C:\Users\Public\Documents\Altair Monarch\Data). If you do not have access to this file, you can download it here.  

In many instances, the data included in Excel files are arranged in neat tables. Thus, when an Excel data source is 
added to Data Prep Studio, for example, by dragging and dropping, the form you see in the worksheet is identical to 
the form you see in the Prepare window. However, many other Excel files may contain multiple levels of data that 
cannot simply be brought into Data Prep Studio to form tables via drag and drop. In this case, further work by using 
Worksheet Design is necessary.  

To better understand the power of Worksheet Design, compare a worksheet with a standard format like this... 

 

Figure 4-96. A standard worksheet. 

  

https://help.altair.com/2024/monarch/help/Overview_Creating_Summaries_DPS.htm
https://help.altair.com/monarch/current/tutorial/Classic.zip
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... and a worksheet that displays levels of information via formatting like this: 

 

Figure 4-97. A worksheet with groupings (or levels of detail). 

For standard worksheets, you can just use the standard Excel connector (Open Data > Spreadsheet > Microsoft 
Excel) to easily load all your data. However, this method will not always work for worksheets with formatted levels of 
information. 

Worksheet Design was developed to extract levels of information from "complicated" worksheets. To do this, we 
define trapping logic using data extraction templates. 

How Templates Work 

To understand how templates work, consider again the Classical Music Distributors Monthly Shipping Report 
(Classic.xlsx), which shows information grouped into several levels: 

Customer is the highest sort level, followed by Contact, Order Number, and then Ship Date. The columns comprising 
the transactions are at the detail level. 
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Now, imagine taking a piece of cardboard and cutting holes in it at specific locations to only show specific information. 
You can create cutouts for the following: 

❑ Customer (purple), 

❑ Contact (yellow), 

❑ Order Number (green) 

❑ Ship Date (blue) 

❑ Details (red) 

 

 

Figure 4-98. The Excel worksheet, with only selected data showing through the "holes." 

Worksheet Design uses electronic templates to extract data from your Excel file. Instead of cutting holes, you define 
the traps and columns to be extracted. 

If your report file has multiple sort levels, you will define a separate template for each level that contains data you 
want to extract. 

In this tutorial, we will learn how to extract columns from Classic.xlsx. 

  



 

Altair Monarch 2024.0 Learning Guide  105 

 

We will first learn how to define a detail template and include the columns that belong to the detail. 

 

Figure 4-99. The data extracted by a worksheet template.  

We then build up the append templates to create a table that looks like this: 

 

Figure 4-100. The results of successfully trapping data in Worksheet Design.  
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Working with Traps 

A trap is a set of properties that uniquely identify a cell (or column of cells) among all others in the worksheet. 
Property sets include the following: 

❑ Value 

❑ Font 

❑ Alignment 

❑ Cell Properties 

For example, traps can be defined as discussed below given the sample data in this worksheet: 

 

Figure 4-101. Examining the report to identify traps that can be created.  

Order Number  

We can trap Order Number (cell C18) with the following properties: 

❑ Value: is number and non-blank 

❑ Font: name = Calibri, size = 11, color = black 

❑ Alignment: horizontal alignment = left 

Ship Date 

❑ We can trap Ship Date (cell C19) with the following properties: 

❑ Value: is date 

❑ Font: name = Calibri, size = 11, color = black 

❑ Alignment: horizontal alignment = left 

Media 

We can trap Media (cells C21-C24) with the following properties: 

❑ Value: is non-blank 

❑ Font: name = Calibri, size = 11, color = black 

❑ Alignment: horizontal alignment = left 

 

Worksheet Design normally defines the trap for you initially, but you can tweak the resulting templates to trap just the 
columns that you want. 
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Loading a Report 

To open a worksheet, we can go to Open Data > Spreadsheet > Excel Worksheet Design or drag the file to Data 
Prep studio. 

Steps: 

 Go to the location of Classic.xlsx and drag the file to Data Prep Studio. The Excel Import Options dialog displays: 

 

Figure 4-102. The Excel Import Options dialog.  

 Click Yes.  

The file is loaded into Worksheet Design: 

 

Figure 4-103. An open Excel report in Worksheet Design.  

Initially: 

• The left panel is bare. Eventually this will display the templates, traps, and columns that will be defined.  

• The right panel shows the worksheet.  
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Defining the Detail Template 

In this section we will define the detail template and its columns.  

A detail template extracts columns from the lowest sort level in the report, referred to as the detail level (also known 
as the transaction level or itemized level).  

You need to define the detail template first, and Worksheet Design actually forces you to do so; you cannot define 
other templates unless you have defined the detail first. 

To define the template, we trap the columns that we want to include. 

Steps: 

 Select the column value you want to trap. In our example, select column C21:  

 

Figure 4-104. Selecting a column to create a trap.  

 Select Add Column  from the Context Menu Action Panel. 

The column is added, and a trap is automatically defined based on the column’s properties: 

 

Figure 4-105. The first column obtained from a trap.  
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Note the following: 

• A trap is added to the Traps List. 

The initial entry says there is a trap based on column C based on value, alignment, and font. 

• A column is added to the Columns List.  

The initial entry says the column has a data type text, and the column name is currently C (the default name, 
assigned based on the Excel column name). 

• The columns that were trapped have solid triangles with a pink outline. 

This means that their formatting matches the trap criteria, and their values are added to the Preview Grid 

• The sample extracted data are shown in the Preview Grid, 

 Do the same for the other columns on the detail  

Follow the steps above to add the columns Qty, Description, and Amount. After doing so, your work area 
should look as follows: 

 

Figure 4-106. Four columns are extracted from our trapping operations.  

Note that, as you add a column, a new entry is added to the Columns list and new preview data are displayed. 
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Defining a Trap  

A trap is a set of properties that uniquely identify a cell (or column of cells) among all others in the worksheet. 

Defining a trap is as easy as adding a column. 

Steps: 

 Right click on the Amount value (F21) and select Add Trap from the context menu or Action Panel: 

 

Figure 4-107. Adding a trap. 

A new trap is added to the Traps List, and the trapped cells now have solid triangles at their top right corner. 

 

Figure 4-108. The results of a successful trapping operation in Worksheet Design.  
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 To view or edit the trap, select the edit icon beside the trap:  

 

Figure 4-109. Editing a trap. 

The trap properties display on an overlay panel: 

 

Figure 4-110. Trap properties in an overlay panel. 

This panel shows that: 

• Traps have been defined for Value, Font, and Alignment as indicated by the checked boxed. 

• For the Value trap, include the column if the value is a Number. 

 Select the Font trap to view the definition: 

 

Figure 4-111. Viewing details of the Font trap.  
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The panel indicates that column is included if it follows the following font properties: 

• Font Name is Calibri 

• Font Size is 11 

• Font Color is black 

You can refine the trap by selecting or unselecting other properties. 

 Select the back icon to go back to the main interface: 

 

Figure 4-112. Return to the main interface by selecting the back icon.  

Defining a Header  

By default, Worksheet Design uses the Excel column name as the default column names. You can define better 
headers.  

Steps: 

 Select the header cells on your worksheet. In our example, this will be C20–F20: 

 

Figure 4-113. Selecting a row to define headers. 

 Select Define Headers  from the Action Menu. 

The headers are applied to the to the Columns List and the Preview Grid. 
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Figure 4-114. Defining headers in Worksheet Design. 

Checking Traps and Including Rows  

Worksheet Design will do its best to apply the specified traps to all columns. However, some data may not be 
captured by this approach, so you need to check that all columns you want are included.  

If a row is not included in a trap, you can use the Include Row tool. 

Steps: 

 Scroll down the worksheet and check if rows you want to capture were not, in fact, captured.  

 

Figure 4-115. Checking for rows containing data that have not been captured correctly. 
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 If you do find excluded rows, select that row (in the example above, rows 52–56, but you only need to select row 
52) and then select Include Row from the Action Panel or context menu. 

The columns are included in the trap, and new rows are added to the Preview Grid. 

 

Figure 4-116. New rows added to the Preview Grid.  
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Adding an Append Template 

Append Templates include the columns above detail rows. In the Classical Music Distributors Monthly Shipping 
Report, the append levels include: 

❑ Customer 

❑ Contact 

❑ Order Number 

❑ Ship Date 

 

In this section, we will add the Ship Date.  

Steps: 

 Select a row or column you want to append. In this case, we will include the Ship Date, which is represented by 
a value in C50: 

 

Figure 4-117. Adding an append to the table. 

 Select Capture This Data as Append in the context menu or Action Panel. 

New data are captured. 
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Figure 4-118. Data successfully captured via an append template.  

Note the following:  

• A new template has been automatically defined and named, by default, Append. If you check the Templates 
list at the top left-hand quadrant of the Worksheet Design interface, we now have two templates listed. 

• A new set of traps and columns for the new template is created.  

Notice that this list changes as you select a template. 

• A new column is included to the right of the detail columns. By default, this column is named C. 

 Rename the new column. 

You can easily rename a column. Just double click on the name in the Preview Area to make it editable and then 
enter a new name. 

 

Figure 4-119. Renaming a column.  
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 Rename the template. 

By default, Worksheet Design renames Append templates Append, Append(1), and so on. However, you can 
easily rename the template by selecting the Edit icon beside the template name. This makes the name editable, 
and you can now enter a new name, in this case, Ship Date. 

 

 

Figure 4-120. Renaming the template.  

Adding a Worksheet Design Table to the Prepare Window 

When you have finished extracting data from your Excel file via Worksheet Design, simply click the Accept button to 
add your new table to the Prepare window. If there are multiple sheets in your Excel file, an Apply to… dialog 
displays to ask you whether the traps you have just defined should be applied to these sheets as well. In this case, 
simply make your selection and then click OK. The table you have just extracted from your Excel file displays in the 
Prepare window.  

All tables extracted by Worksheet Design can be prepared, transformed, joined, and used in summaries, similar to all 
other tables in Data Prep Studio. The extracted table can also be renamed, duplicated, saved to the Data Source 
Library, etc., via the context menu that displays when you select the table in the table selector and then right-click on 
your mouse. If you wish to apply the same template to other sheets in your Excel data source after opting not to when 
the table was originally extracted, select Apply to from the options that display in the context menu. The Apply to… 
dialog displays.  

If you wish to learn more about Worksheet Design and how to work with its interface further, click here. 

Demonstrations on how to work with Worksheet Design are also provided in: 

❑ Trapping Data Using Worksheet Design 

❑ Capturing and Refining Captured Data 

❑ Applying Templates to Multiple Sheets 

❑ Capturing Multicell Data 

❑ Capturing Multiline Headers 

❑ Capturing Data Tables 

❑ Including and Excluding Data 

  

https://help.altair.com/2024/monarch/help/EXL_Overview__Worksheet_Design.htm
https://help.altair.com/monarch/current/tutorial/videos/ExTr_1_Capturing_Data.mp4
https://help.altair.com/monarch/current/tutorial/videos/ExTr_2_Refining.mp4
https://help.altair.com/monarch/current/tutorial/videos/ExTr_3_Applying.mp4
https://help.altair.com/monarch/current/tutorial/videos/ExTr_4_Multicell.mp4
https://help.altair.com/monarch/current/tutorial/videos/ExTr_5_Multiline_Hdr.mp4
https://help.altair.com/monarch/current/tutorial/videos/ExTr_6_Data_tables.mp4
https://help.altair.com/monarch/current/tutorial/videos/ExTr_7_Inc_Exc.mp4
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WORKING WITH PDF TABLE EXTRACTOR  

PDF Table Extractor is designed for ordinary people who wish to do extraordinary things with PDF files. 

This functionality allows you to identify tables in text-heavy PDF files, select them, modify them if you wish, and then 
export them to Data Prep Studio for further data preparation.  

 

 

Figure 4-121. A typical PDF Table Extractor workflow.  

PDF Table Extractor provides easy-to-use interfaces to perform the following: 

❑ Automatically look for and define tables in a document 

• within a page, 

• in all pages, or 

• in specific pages. 

❑ Modify tables that have been defined (e.g., modify headers, rename columns, and delete columns) 

❑ Create a custom table 

❑ Export tables to Monarch Data Prep Studio 

 

The lessons outlined in this tutorial provide a very brief overview of what you can do with PDF Table Extractor. To 
learn more about this DPS component, click here. 

Opening a Document 

The following typical example describes how to open a PDF document and define tables using a file named 
Canaccord 042215.pdf. If you do not have access to this document now, simply follow along with this tutorial. 

Steps: 

 In the Start Page, click Open Data. 

 In the Select Data Source to Open dialog that displays, click PDF & Text > PDF Table Extractor > Get Data. 

 Use the Open browser that displays to navigate to the location of the PDF file you wish to open, select it, and 
then click Open. 

 

The PDF file displays in the PDF Table Extraction window.  

https://help.altair.com/2024/monarch/help/MTE_About_Datawatch_Monarch_Table_Extractor.htm
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Figure 4-122. Loading a PDF file into PDF Table Extractor.  

Canaccord 042215.pdf is loaded into the PDF Table Extractor window.  

Defining and Working with Tables 

Define one or all tables by selecting any one of the following from the Table Actions panel: 

❑ Auto Define > Current Page 

❑ Auto Define > Page Range 

❑ Auto Define > All Pages 

For this session, let us auto-define a page. In this section, we will auto-define tables, verify the tables, and delete one 
of them. 

Auto-Defining All Pages 

Select Auto Define > All Pages to instruct PDF Table Extractor to look for and then automatically define all tables in 
the PDF fi. 

Steps: 

 Go to the page you want to define. Use the page selectors at the top of the interface, or scroll and select using 
the page thumbnails. 

 Select Auto Define > All Pages on the Table Panel. 

PDF Table Extractor scans all of the pages of your document and then automatically defines tables for all 
tabulated data. 

 

It also does the following: 

• Creates a list of all the tables throughout the document. Tables are named Page <n> - Table <n> 
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• Displays data on the Preview panel. You can view a table by selecting the table on the Page/Table List, or 
by selecting that table's tab on the Preview panel. 

All tables that have been defined are highlighted on the Document page 

 

Figure 4-123. A table captured from a PDF file in PDF Table Extractor.  
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Viewing and Modifying a Table 

Data from the tables are displayed on the table panel.  

In addition, a Page/Table list shows the page where a table is located and all the tables defined for that page. 

Steps: 

 Select Page 1 – Table 3 on the Page/Table List. The table is highlighted on the document, and the values for the 
table are displayed on the Preview panel. 

 

Figure 4-124. Selecting a specific table in PDF Table Extractor. 

On the document, the table looks like this: 

 

Figure 4-125. A selected table in PDF Table Extractor. 

The table is surrounded by a dashed border with handles. Headers (which may be separate from the table) are 
highlighted in pink. Columns are highlighted in blue.  
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 Right click on a table, header, or column to display context menu items.  

 

Figure 4-126. Selecting a table to modify. 

The context menu items that display will allow you to, among others: 

• Copy the selection 

• Create a table from the selection 

• Set a selection as a table title  

• Create a new column 

• Exclude values from the table 

• Define headers 

• Set row as column headers  
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Deleting a Table 

You may not need all the tables defined by PDF Table Extractor. You can easily delete tables via the context menu or 
the Table panel menu. 

Steps: 

 Select Page 1 – Table 1 on the Page/Table List. 

This table is highlighted: 

 

Figure 4-127. Selecting a table to delete. 

Although this looks like a table, the values are not related as columns or rows. We can delete this table. 

 Click the Delete icon  located to the right of this table in the Page/Table list or Delete Selected from the 
Table Actions menu.  

Importing Tables into Data Prep Studio 

After defining your tables, you can import them to Monarch Data Prep Studio. Once the tables are imported and 
loaded, you can work on them using Monarch Data Prep Studio's features. 

Select: 

❑ Import all to import all of the tables obtained from the PDF file into Data Prep Studio. 

 

Figure 4-128. Importing all tables created in PDF Table Extractor to Data Prep Studio. 
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❑ Import selection to launch a dialog that will allow you to specify which tables to import into Data Prep Studio 

 

Figure 4-129. Importing specific tables created in PDF Table Extractor to Data Prep Studio. 

The tables you selected are imported into Data Prep Studio and display in the Prepare window.  

EXPORTING TABLES, SUMMARIES, AND 
REPORTS 

You can export tables, summaries, and reports in Data Prep Studio. Note that you can only export data from the 
Prepare window.  

 

You can export tables to the following formats: 

❑ Microsoft Excel (.xlsx, .xlsm, .xls) 

❑ Delimited text file (.csv) 

❑ Fixed text file (.txt) 

❑ PDF 

❑ XML 

❑ IBM Cognos Analytics 

❑ Microsoft Access (.accdb, .mdb) 

❑ Microsoft Power BI  

❑ Tableau Server 

❑ Tableau data extract file (.tde) 

❑ QlikView (.qvx) 

❑ SAS Transport File Format (XPORT) Version 5 

❑ JSON 
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You can also export tables to the following Altair products: 

❑ Altair Panopticon 

❑ Altair Knowledge Studio 

 

For summary tables, the following export file types are supported in Data Prep Studio: 

❑ Microsoft Excel (.xlsx, .xlsm, .xls) 

❑ Delimited text file (.csv) 

❑ Fixed text file (.txt) 

❑ PDF (.pdf) 

❑ XML (.xml) 

❑ Microsoft Access (.accdb, .mdb) 

❑ Tableau data extract file (.tde) 

❑ QlikView (.qvx) 

❑ SAS Transport File Format (XPORT) Version 5 

❑ JSON 

 

Reports can also be exported in text and PDF formats. 

 

An overview of the export process and the general details required by each export is provided here. 

Exporting to Microsoft Excel, Delimited Text, Microsoft Access, Tableau TDE, 
Qlik, SAS Transport File Format (XPORT) Version 5, JSON, Fixed Text, PDF, XML, 
Altair Panopticon, and Altair Knowledge Studio  

The following example details how exports to Microsoft Excel are performed. Exports to delimited text, Microsoft 
Access, Tableau TDE, Qlik, SAS Transport File Format (XPORT) Version 5, JSON, fixed text, PDF, XML, Altair 
Panopticon, and Altair Knowledge Studio are accomplished in the same manner. 

Steps: 

 Click Export on the Data Prep Studio toolbar. 

The Export window displays. 

https://www.altair.com/panopticon/
https://www.altair.com/knowledge-studio/
https://help.altair.com/2024/monarch/help/Exporting_Data_for_DPS.htm
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Figure 4-130. The Export window of Data Prep Studio. 

 Click the + Add New Export button located to the right of the Join(1) (Data Processing + Compensation) table 
and then select Microsoft Excel from the options that display. 

 

Figure 4-131. The Export Properties of the file type you are exporting to are displayed when you select an export type. 

NOTE When exporting data as summaries or reports, click the + Add New Export button 
and then choose Summary or Report from the options that display. Clicking the 
Summary and Report options shows the file types that you can export to.  

 

 Use the Browse button to navigate to the folder into which you want to save your export.  

Data Prep Studio will remember the export file path that you use so that you do not have to enter or select this 
each time you export to the same file type. 

 Specify a filename to which your export should be saved.  

 Specify other properties (e.g., table name, filter, sort, etc.) as necessary. Click here for a guide to these 
properties. 

https://help.altair.com/2024/monarch/help/Exporting_Data_for_DPS.htm


 

Altair Monarch 2024.0 Learning Guide  127 

 

If you are exporting multiple tables, note that you must specify export properties for each of these tables. For this 
exercise, maintain default values.  

 Click Export. 

When the export operation is completed, the results are displayed in the Results panel. 

 

Figure 4-132. Example of a successful export result. 

To view the exported file, simply click on the export link provided. Data Prep Studio navigates to the location of the 
exported file, which you can then select and open in the appropriate application. Data exported in Data Prep Studio to 
Excel files are exported as named ranges. Thus, when the table is opened, the worksheet name displayed 
corresponds to that of the named range. 

Exporting to IBM Cognos Analytics 

Cognos Analytics is a cloud-based application developed by IBM that allows the sharing of data and information 
across workgroups as well as the creation and/or personalization of dashboards and reports on various devices.  

 

Figure 4-133. The Welcome page of Cognos Analytics. 

Exporting to Cognos Analytics is only possible through Monarch Complete.  

Some information is necessary to successfully export and work with your data in IBM Cognos Analytics: 

❑ A correctly set up Cognos Analytics service 
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❑ Server URL – The URL of your Cognos Analytics service. This URL must be entered into the field provided in the 
Server tab of the Settings dialog of Data Prep Studio.  

❑ Namespace – The security connection type employed for the service 

❑ Username 

❑ Password  

Steps: 

 Go to the Server > IBM Cognos Analytics sub-tab of the Application Default Settings dialog and enter the URL 
of the Cognos Analytics Service you are connecting to. Select OK to save your changes.  

 Using the steps detailed in the previous exercise, export the table Join(1) (Data Processing + Compensation) to 
IBM Cognos Analytics. 

 Enter the necessary export information into the Export Properties panel. 

 

Figure 4-134. Export file information required by the exports to IBM Cognos Analytics. 

 If you wish to edit the default URL you provided in the Application Default Settings dialog, click the Edit Defaults 
button. The Application Default Settings dialog displays, and you can make the necessary revisions.  

 Select Export when you are finished.  
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The IBM Cognos Analytics login page displays. 

 

Figure 4-135. Entering IBM Cognos Analytics connection information. 

 Enter the connection information required by the dialog and then click OK. 

 

NOTE You will need to provide your login information only once per Data Prep Studio 
session. Subsequent exports to the same service will use the information you 
provided upon first export to Cognos Analytics. 

 

The table you exported should display in My Content when you log into your Cognos Analytics service.  

 

Figure 4-136. The exported table displays in the My Content page of IBM Cognos Analytics. 
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Exporting Data to Microsoft Power BI 

Data Prep Studio now supports exports to Power BI by creating files that are automatically placed in your Power BI 
workspace provided that you have a Microsoft Power BI account. Note that you must have a Microsoft Power BI 
account to execute exports of this type successfully. If you do not have one yet, you can sign up for an account here. 

Steps: 

 Using the steps detailed in the previous exercise, export the table Join(1) (Data Processing + Compensation) to 
Microsoft Power BI. 

When filling out the Export Properties panel for this export, note that table names must range from 1 to 100 
characters, should not be preceded or followed by whitespace characters, and cannot include any of the 
following characters:  

• Exclamation point 

• Backslash 

• Quotation mark 

• Dollar sign 

• Percent sign 

• Ampersand 

• Apostrophe 

• Round brackets 

• Asterisk 

• Plus sign 

• Comma 

• Period 

• Slash 

 

When the Export Selected button is clicked, the PowerBIforDPS login page displays. 

 

Figure 4-137. The PowerBIforDPS login dialog. 

https://powerbi.microsoft.com/en-us/pricing/
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 Enter a valid email or phone number and password into the fields provided in this dialog. Select Sign in when 
you are finished.  

The Authorize PowerBI Export dialog displays for first-time users.  

 

Figure 4-138. First-time users must authorize Microsoft to perform a number of actions to enable access to exports to 
Microsoft Power BI. 

 Click Accept. 

The export operation is performed, and the table is added as a new dataset in your Microsoft Power BI account. 
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Figure 4-139. The results of the current export operation. 

Exporting to Tableau Server 

Data Prep Studio allows you to export to or update existing worksheets in Tableau Server. 

However, to be able to do so successfully, you need to have installed the Tableau TABCMD program first. Click here 
to download and learn more about the utility. To facilitate exports to this application, provide the necessary 
information (e.g., server URL, username, password, etc.) in the Server > Tableau Server sub-tab of the Application 
Default Settings dialog. 

Steps: 

 Open the Export window. 

 Select the table you with to export, click + Add New Export button located to its right, and then select Tableau 
Server from the options that display. 

 Provide the necessary details in the Export Properties panel, including the following: 

• Export location 

• Data source name 

• Site 

• Publish Type 

• When file exists 

All properties are described here. 

 Export your table as usual.  

  

https://onlinehelp.tableau.com/current/server/en-us/tabcmd.htm
file:///C:/Users/bcanto/Desktop/Monarch/15/Monarch%2015/Monarch%20Help/!SSL!/Complete%20HTML5%2015/desktop/The_Application_Default_Settings.htm
file:///C:/Users/bcanto/Desktop/Monarch/15/Monarch%2015/Monarch%20Help/!SSL!/Complete%20HTML5%2015/desktop/The_Application_Default_Settings.htm
https://help.altair.com/2024/monarch/help/Exporting_Data_to_Tableau_Server.htm
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Exporting Summaries 

Summaries are exported in the same way ordinary tables are exported in Data Prep Studio, i.e., via the Export 
window. You can export summaries to the following formats: 

❑ Microsoft Excel (.xlsx, .xlsm, .xls) 

❑ Delimited text file (.csv) 

❑ Fixed text file (.txt) 

❑ PDF (.pdf) 

❑ XML (.xml) 

❑ Microsoft Access (.accdb, .mdb) 

❑ Tableau data extract file (.tde) 

❑ QlikView (.qvx) 

❑ SAS Transport File Format (XPORT) Version 5 

❑ JSON 

 

In this lesson, let’s export the summary we created and modified earlier in this guide. Here, we’ll export to CSV (the 
steps performed to export to Excel are similar). 

Steps: 

 In the Export window, click the Add Export button of the table Classic.pdf and then select Summary > CSV. 

 

Figure 4-140. Exporting a summary. 

 Modify the properties specified in the Export Definition panel as necessary.  
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Figure 4-141. Defining a summary export. 

PROPERTY SPECIFICATION 

Export Location C:\Users\Public\Documents\Altair Monarch\Classic.csv 

Active Measure SUM(Amt) 

Filter/Summary/Sort No Filter/Summary/Sort 

Include Column Headers  

Delimiter Comma 

Text Qualifier Double Quote 

When File Exists Overwrite 

Encoding Type UTF-8 

Code Page  

 

 Click Export.  
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When the export operation is completed, the Export Results panel displays. If the export was completed 
successfully, an export link will appear. Clicking on this link launches the folder to which you saved the exported 
summary. 

Note that data exported in Data Prep Studio to Excel files are exported as named ranges. Thus, when the table 
is opened, the worksheet name displayed corresponds to that of the named range. 

This section ends our discussion on summaries. If you would like to learn more about how to create, modify, and 
manage summaries, click here. 

SWITCHING FROM DATA PREP STUDIO TO 
MONARCH CLASSIC 

To access Monarch from Data Prep Studio, select Application Menu  > Switch to Classic Mode.  

The Home screen of Monarch Classic displays.  

 

Figure 4-142. Monarch Classic’s Home screen.  

Congratulations! You have just completed the Data Prep Studio lessons. We hope you have found them to be a 
helpful introduction to Data Prep Studio’s capabilities. For additional information not covered by this tutorial, we 
suggest you thoroughly explore Data Prep Studio’s help system. To do so, simply click here. 

Other documentation on Data Prep Studio is also available here. 

The previous lessons reveal that users who wish to open database tables quickly, clean them, and transform them for 
further application, such as in data visualization, may find Data Prep Studio a great solution to their needs. However, 
while data extraction from reports and export capabilities are also provided in Data Prep Studio, these features may 
not be adequate when you want to extract data from some file types, such as .txt, or export to a specific format not 
supported by Data Prep Studio. To do these, you will need to work with Monarch Classic.  

https://help.altair.com/2024/monarch/help/Overview_Creating_Summaries_DPS.htm
https://help.altair.com/2024/monarch/help/About_Data_Prep_Studio.htm
https://help.altair.com/2024/monarch/
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[5] MONARCH LESSONS 

This chapter introduces you to the Monarch lessons.  

These lessons are designed to quickly acquaint you with basic program operations. For additional material not 
covered in this guide, consult the Monarch Help file by clicking File > Help and then selecting  Help Topics. 

❑ Chapter 6 – Working in Report View  

Shows you how to load a report file, navigate the report on screen, look up information in the report, copy 
selected data to other applications, and print pages from reports.  

❑ Chapter 7 – Extracting Data from a Report  

Shows you how to create a template to extract data from a simple columnar report, view the data in the Table 
view, and save the template to a Monarch model file. 

❑ Chapter 8 – Special Data Extraction Techniques  

Deals with special problems caused by address blocks, fields that run together in a report, and data presented in 
multiple columns.  

❑ Chapter 9 – Working in Table View 

Shows you how to load and navigate through a table, format fields, create headers and footers, print table data, 
and copy data to other applications.  

❑ Chapter 10 – Working with Sorts 

Shows you how to sort the table, create multiple sort definitions, select a sort definition, and save sort definitions. 

❑ Chapter 11 – Working with Filters 

Shows you how to use a filter to select records based on any field value, create multiple filters, utilize value-
based filters, select an active filter, and save filter definitions.  

❑ Chapter 12 – Working with Calculated Fields  

Shows you how to create calculated fields to add information to the table database. 

❑ Chapter 13 – Working with Multiple Instances of a Report 

Shows you how data extracted from multiple reports may be sorted and analyzed in Table view. 

❑ Chapter 14 – Extracting Multiple Line Fields  

Shows you how to extract a multiple line text block from a report. It also introduces memo fields, which are used 
to hold the contents of a multiple line field, and covers exporting and printing memo fields. 

❑ Chapter 15 – Summaries  

Teaches you how to create a summary report from your Monarch data, specify summary design preferences, 
and create quick summaries. 

❑ Chapter 16 – Advanced Summary Capabilities  

Shows you how to reveal even more information about your data via Monarch’s advanced summary features.  

❑ Chapter 17 – Exporting Operations 

Discusses how to export reports, tables, and summaries.  

❑ Chapter 18 – Importing Data from HTML and External Databases 

Discusses how to import data from various external sources. 

❑ Chapter 19 – Creating External Lookups 

Discusses how external lookups are performed in Monarch. 
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❑ Chapter 20 – Using Digital Signatures 

Discusses how digital signatures are added to some exports in Monarch and viewed in Microsoft Excel. 

❑ Chapter 21 – Using Pivot Tables 

Discusses how pivot tables are added to some exports in Monarch and viewed in Microsoft Excel. 

❑ Chapter 22 – Working with Asian (CJK) Character Sets 

Discusses how to work with documents using Asian character sets 

❑ Chapter 23 – Using Monarch Utility 

Discusses how to use Monarch Utility to perform a number of functions. 

INSTALLING LESSON FILES 

When installing Monarch, the last screen of the Monarch Setup program provides a checkbox that asks whether to 
install the lesson files.  

When this box is ticked, the Setup program will install the lesson files in the appropriate folders under the Altair 
Monarch folder in C:\Users\Public\Documents. You can change the location of these folders later on.  

Note that the lessons in this Learning Guide assume that the lesson files are stored in their default locations.  

THE OPTIONS INTERFACE 

The Options interface allows users to configure several universal Monarch settings, including folders, input 
information, views, and exports, among others.  

 

Figure 5-1. The Options window.  
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Clicking specific buttons on the Options ribbon exposes settings you can modify. When you have modified the 

settings as you wish, simply click Accept  to accept your changes and close the interface. You may specify 

several options before selecting Accept . Select Cancel  to disregard any changes you made and close the 
interface. In this case, none of the previous settings are modified. 

The following table summarizes the functions of each of the buttons in the Options ribbon.  

Use this button… To… 

 Accept 
Accept the changes you made and close the interface 

 Cancel 
Cancel the changes you made and close the interface 

 Folders 
Expose folder settings 

 Input 
Expose input settings 

 View  
Expose view settings 

 Export 
Expose export settings 

 Clipboard 
Expose clipboard settings 

 Security 
Expose security settings 

 Altair Monarch Server Library 
Expose Altair Monarch Server Library settings 

 Time Intervals 
Expose time interval settings 

 Advanced 
Expose advanced settings 

 Cache 
Expose caching options 

 Themes 
Expose theme settings 

 Help 
Launch the Help file 

 

More information on each of the settings available in the Options window is available here. 

https://help.altair.com/2024/monarch/help/Options_Window.htm
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[6] WORKING IN REPORT VIEW 

In this chapter, you will learn how to work in Report view. Lesson topics include: 

❑ Starting a Monarch session 

❑ Opening report files 

❑ Navigating through reports 

❑ Using bookmarks 

❑ Copying data from reports 

❑ Printing data from a report 

❑ Using PDF and XPS files 

Most computer applications produce reports as output. Monarch is unusual because it uses reports as input. A 
Monarch session begins when you open an existing report. The report displays in Report view. 

The Report view gives you a scrollable view of your report. You can move around, look things up, copy data to other 
applications, and print pages on your local or network printer. In this lesson, you will learn the basics of these 
operations. In later lessons, you will learn how to extract and export data from reports. 

OPENING REPORT FILES 

In Monarch, you can open either one or several reports (up to 1,024 reports!) in a single session.  

Opening a Single Report File 

To begin working with Monarch, you need to open a report file. We use the term “report file” to describe any 
computer report stored on disk. These files are often referred to as print, spool, TXT, PRN, SDF, PDF, and formatted 
or fixed-width text files. 

Several report files are provided in each Monarch install for use with these lessons. In this lesson, we will first open 
single report files and then open multiple report files later.  

 

NOTE Monarch opens a report as a “read-only” file. Monarch can write a new file with data 
extracted from the report, but the original report remains safe because it cannot be 
altered. 

You can also open reports in zip files or web and other locations. 

If you have set up Altair Server Library credentials in the Options interface, you can 
even open files located in the specified Altair Server Library. 

 

Let’s open a report file, in this case, ClassJan.prn. 
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Steps: 

1. Launch the Monarch Classic application.  

2. On the File tab, select Open  > Report > Computer.  

 

Figure 6-1. The Open Report dialog.  

The Open Report dialog appears. The Files list displays all the files in the Reports folder with a DAT, PRN, RPT, 
SDF, or TXT extension. If you don’t see a list of files, make sure you are viewing the Altair Monarch > Reports 
folder and that the file type is set to Print Files (*.dat, *rpt, *.prn, *.sdf, *.txt), as shown in Figure 6-1.  

3. Select ClassJan.prn and then click Open. 

Monarch displays a softcopy of the report in Report view. The report shows customer shipments for a distributor 
of classical music recordings for the month of January. 

 

Figure 6-2. The ClassJan.prn shipping report.  
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Opening Multiple Instances of a Report 

The procedure for opening multiple instances of a report is similar to that required to open a single report.  

Since the January shipping report was opened in the previous lesson, we begin this lesson by opening the February 
shipping report. 

Steps: 

 Select File > Open  > Report > Computer.  

 Click on ClassFeb.prn and then choose Open. 

For each additional report you open, Monarch displays the Retention Options dialog.  

This dialog prompts you to discard or retain any currently open reports and model parameters before opening the 
new report. 

 

Figure 6-3. The Retention Options dialog.  

To replace the existing report and model with a new report, leave the Retain Current Reports and Retain Current 
Model check boxes unchecked. Since we want to open a new report without closing the currently open one, we’ll 
choose to retain current reports. 

 Ensure that Retain Current Reports is selected and then click OK. 

The February shipping report is added to the Report selector. Note that Monarch does not create a separate 
window to display each report. Instead, all open reports are viewed in one Report view, with a single report 
displayed at a time. You can select another report to view by clicking on it in the Report selector. The document 
selectors list all of the open reports, tables, and summaries in each Monarch session.  

Let’s open the March shipping report. 

 Select File > Open  > Report > Computer.  

 Click on ClassMar.prn and then choose Open. 

This time the Retain Current Reports check box is already selected. 

By preserving your most recent dialog settings, Monarch saves you a step each time you open a new instance of 
the report. 

 Choose OK. 

The March shipping report is opened and added to the Report selector. 
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GETTING TO KNOW REPORT VIEW 

The Report View Interface 

Let’s take a minute to explore what you can find in the Report interface. 

 

Figure 6-4. The Report interface.  

The Report interface is divided into three distinct areas. The Report ribbon is located on the top-most portion of the 
interface and spans the entire width of the screen. This ribbon will allow you to perform many of the report functions 
made available by Monarch. The Report selector displays as a panel on the left-hand side of the interface. You can 
choose specific reports to view from this selector, a functionality that is especially handy when you have multiple 
reports open. Finally, the actual report is displayed on the right-hand portion of the interface. 

Right-clicking in the Report selector launches a context menu that will allow you to: 

❑ Reopen a file 

❑ Close the current report 

❑ Print a report 

❑ Quick-print a report 

❑ Launch Print Preview 

❑ Create an export 

❑ Export the current report 

❑ View file information 
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The Report View Ribbon 

The following table summarizes the functions of each of the buttons in the Report ribbon.  

Use this button… To… 

 Report Design 
Launch the Report Design interface 

 Auto Define 
Automatically creates a template (or sets of templates, if 
applicable) for an open report. Note that this feature is 
only enabled in Monarch Complete and that the resultant 
model is applied to all other open reports.  

 Font Style Select a font style 

 Font Size Select a font size 

 Zoom to Fit Automatically resize the report into the available Report 
view using the best possible fit 

 Greenbar 
Add greenbar shading to the report 

 Select All 
Select all of the text in the report 

 Copy 
Copy text from the report 

 Search 
Search for information from the report 

 Find in Table 
Find the table entry corresponding to a specific line in the 
report 

 Previous Report 
Go to the previous report if multiple reports are open  

 Previous Page 
Go to the previous page of a multiple-page report 

 Go to Page  
Go to a specific page of a multiple-page report 

 Next Report 
Go to the next report if multiple reports are open 

Next Page 
Go to the next page of a multi-page report 

 Go to Chunk 
When chunking options have been defined, this button 
allows you to move to a specific chunk 

 Bookmark 
Add a bookmark to a specific record 

 Next Bookmark 
View the next bookmark 

 Previous Bookmark 
View a previous bookmark 

 Clear Bookmark 
Clear all bookmarks 

 Report Index 
Display or define the report index 

 PDF/XPS Options 
Specify character spacing options when opening 
PDF/XPS files 

 Chunk Options 
Launches the Set Chunk Options dialog, which you can 
use to define smaller portions (chunks) of very large 
reports 

https://help.altair.com/2024/monarch/help/Specifying_Chunking_Options.htm
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Use this button… To… 

 Open as a Table in Data Prep Studio 
Open the report as a table in Data Prep Studio  

 Help 
Launch the Help file 

 

The Report View Context Menu 

When you open a report in Report view and right-click on your mouse, a context menu displays. This menu will allow 
you to: 

❑ Run Report Verify 

❑ Copy text 

❑ Copy as table 

❑ Search for a record 

❑ Find in table 

❑ Add, edit, or remove bookmarks  

❑ Add a new template 

❑ Zoom to fit 

❑ Print 

❑ Print preview 

❑ Export the report to a PDF or TXT file 

❑ Change the encoding applied to the report file 

❑ Launch the Report Design view 

Each of these abilities will be discussed in detail throughout this Learning Guide.  

NAVIGATING THROUGH REPORTS 

Although the softcopy report looks just like its hardcopy cousin, you can use Monarch to zoom, scroll, page, jump, 
and quickly find information within it. These tasks would be a lot more difficult to carry out with a hardcopy report. 
Let’s look at some of the benefits of viewing and exploring a softcopy report on screen using the three files we 
opened previously. Make sure that you select the Report tab before you begin.  
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The Report Selector 

Report view opens and Monarch also displays, by default, a panel on the left side of the screen: the Report selector. 

 

Figure 6-5. The Report selector. 

Clicking on any report in the Report selector opens the report in Report view. 

The Search box allows you to search for open reports. This functionality would be useful if, for example, you had a 
large number of open financial reports and want to search specifically for sales reports for a certain year.  

 

Figure 6-6. The Search Selection box allows users to search for individual reports in the Report selector. 

Right-clicking on the Report selector displays a context menu that will allow you to perform the following operations: 

❑ Reopen a report 

❑ Close a report 

❑ Print a report 

❑ Quick print a report 

❑ Preview a report before printing 

❑ Export (all files) 

❑ Export a selected file 

❑ View the File Information dialog (includes details on file path, size, last modified date) 

Adding Greenbar 

Because Monarch operates in a graphical environment, you can adjust the display to enhance readability and suit 
your own visual preferences. Monarch can display a greenbar effect on the screen, which helps your eyes track 
across sparse columns in a wide report. If you prefer not to display greenbar, however, you can easily remove it. 
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Steps: 

1. On ClassJan.prn, select Greenbar  from the Report ribbon.  

2. The report displays with greenbar shading.  

 

 

Figure 6-7. The report displayed with greenbar shading.  

3. To remove greenbar shading, simply select Greenbar  again.  

Changing Fonts and Font Sizes 

Monarch allows you to change the font and font size used to display reports on screen. 

Steps: 

1. To change the font, in the Report ribbon, click the drop-down  button on the Font Style box.  

 

Figure 6-8. Changing font styles. 
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Only non-proportional fonts with fixed letter spacing are available because report columns may appear 
misaligned if proportionally spaced characters were used.  

2. Select the Lucida Console font from the list.  

The font style is changed throughout the entire report. 

You may change the font size to zoom in or out or a report. 

Steps: 

1. Click the drop-down  button on the Font Size box. 

 

Figure 6-9. Changing font sizes.  

Font sizes vary depending on the font style selected.  

If the size you want isn’t available, use the font list to select another font. You can let Monarch select the font 
size for you using the Zoom to Fit command. This selects the font size that best matches the report width to the 
display width, so you can view the entire width of the report on screen. 

2. To change the font size to match the report width to the display width, from the Report ribbon, select Zoom to 

Fit . 

If the report is too wide to fit on screen even at the smallest available font size, Monarch will select the smallest 
font size to fit as much of the report width as possible in the available display area. 

Moving to the Next Page of a Report 

It can be a tedious chore to dig through page after page of a big hardcopy printout. With softcopy reports on screen, 
however, your computer does most of the work for you. Monarch lets you move around with just a few clicks of your 
mouse. 

Like most Windows applications, Monarch provides a vertical scroll bar to help you scroll through a report. You can 
scroll through the report by pressing the up or down arrow on the scroll bar or by clicking and dragging the slider with 
your mouse.  

  



 

Altair Monarch 2024.0 Learning Guide  148 

 

For example, the following figure shows Page 8 of the ClassJan report.  

 

Figure 6-10. Scrolling through a report. 

To move through the different pages of a report, you can: 

❑ Use the Previous Page  button 

❑ Use the Next Page  button 

❑ Use the Go to Page  button 

When you select the Go to Page  button, the Go to Page dialog displays. 

 

Figure 6-11. The Go to Page dialog.  

Enter the desired page (e.g., 8) into the Page Number field and then click OK. Monarch displays the specified page in 
Report view.  

Dotted lines indicate page breaks. Monarch relies on page break characters in the report file to determine where 
breaks belong. If breaks are not explicitly defined in the report file, Monarch breaks pages after a fixed number of 
lines. 

To move left or right, press the left or right arrows on the horizontal scroll bar or drag the slider with your mouse. 
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Moving Through Several Reports 

To move through different reports when multiple reports are open, you can: 

❑ Use the Previous Report  button 

❑ Use the Next Report  button 

Finding Information in a Report 

It’s not always easy to find information buried deep in a hardcopy report. If you’re looking for a particular invoice in a 
report that is 75 pages long, for example, you can spend a lot of time and effort reading each page and you may not 
even find the report you want. Fortunately, Monarch can search reports at lightning speed to find whatever you want. 
Suppose you want to find all references to the composer, Mozart. You can use the Search function for this.  

Steps: 

 Select the ClassJan.prn report and ensure that you are on its first page. 

 Select Search  from the Report ribbon. 

A Search box displays on top of the Report view. 

 

Figure 6-12. The Search panel.  

 Type Mozart in the Search field and then click Find Next. 

The first occurrence of Mozart in the report will be highlighted. By default, search items are returned in a top-
down manner. To search in a bottom-up manner, check the Search Up box among the Search options. 

 Continue clicking the Find Next button to locate the next instances of Mozart.  
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NOTE You can make searches case-sensitive by selecting Match Case.  

The option Search all reports allows you to locate all instances of the search item in 
all open reports. 

 

 Close the panel by clicking the Close X icon to the right of the Search box. 

SPECIFYING AND MOVING THROUGH CHUNKS 

Large reports can be divided into more manageable "chunks." A 100-page report, for example, can be divided into 5-
page chunks. Once defined, users can select which chunk (e.g., the third chunk or pages 11-15) to load when the 
report is opened in Classic. Monarch then extracts and processes only this particular chunk of the report. 

Note that when a report in which chunking has been enabled is exported, the entire report is exported, as chunking is 
designed to limit the data loaded in Table View, not the actual report.  

Steps: 

 Using ClassFeb.prn, click Chunk Options in the Report ribbon.  

The Set Chunk Options dialog displays. 

 Tick the box marked Enable breaking report into chunks to begin defining chunks. Note that if this box is 
unchecked at any time during your Monarch session, your chunk definitions will not be not applied to the report.  

 Set a chunk size of 2 pages and specify a chunk to load of 2.  

Monarch loads pages 3-4 of your report only. Note how all other report pages above and below pages 3-4 are 
grayed out. When performing trapping operations, you will be able to trap on these two pages only.  

 

Figure 6-13. Viewing chunk #2 as defined in the Set Chunk Options dialog.  
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Chunking options apply to all open reports. A quick look at ClassJan.prn and ClassMar.prn should show the 
same results as in ClassFeb.prn. 

 Move through chunks by clicking on the Go To Chunk icon in the Report ribbon. Enter 4 into the dialog that 
displays.  

Monarch loads only pages 7-8 of ClassFeb.prn (and ClassJan.prn and ClassMar.prn).  

 Before moving forward with our lessons, click Chunk Options in the Report ribbon once more and then untick 
the box for Enable breaking report into chunks.  

USING BOOKMARKS 

Monarch allows you to set bookmarks within a session that can be used to navigate quickly between certain lines or 
sections of a report. You can even annotate bookmarks.  

 

NOTE Although bookmarks aren’t saved in model files, they are saved in project files. When 
exporting to a PDF file while in the Report view, bookmark comments will be 
displayed as comments within the PDF file. 

 

Let’s set bookmarks for Spinning Records. 

Steps: 

 Use the search tool to locate Spinning Records in the ClassMar.prn report.  

 Click in the left-hand margin next to CUSTOMER to highlight that line. 

 Select Bookmark  from the Report ribbon. The Add Bookmark dialog displays, and this dialog will allow you 
to add a comment to your bookmark. Let’s try doing this.  

  

Figure 6-14. The Add Bookmark dialog.  

 Type whatever text you’d like (e.g., This is a bookmark comment.) and then click the OK button. A bookmark 
indicator appears on the left-hand margin next to the highlighted line of text. 

 Place your mouse pointer over the bookmark indicator. The text you typed is displayed. 
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Figure 6-15. A bookmark is added to Spinning Records.  

 

NOTE You can click the OK button on the Add Bookmark dialog without actually entering a 
comment if you wish. To prevent the Add Bookmark dialog from displaying on a 
specific bookmark, clear the Show when adding check box. 

 

You can move through bookmarks by clicking either Next Bookmark  or Previous Bookmark  from the 
Report ribbon. To remove a specific bookmark, select the bookmark you would like to remove and then click the 

Bookmark  button from the Report ribbon. To clear all bookmarks, select Clear Bookmark  from the Report 
ribbon.  

COPYING DATA FROM REPORTS 

Monarch makes it easy to transfer report data to other applications. Just copy and paste! When you copy data from a 
report, Monarch creates both a text image and a worksheet image with separate columns and cells in the clipboard. 

Let’s copy a customer’s name and address into your word processor. You might use this feature, for example, if you 
want to insert this name and address into a letter. 

Steps: 

 Go to the first page of the ClassJan.prn report. 

 Click at the beginning of the customer’s name (Betty’s Music Store in this case) and drag diagonally down to 
the right to highlight the entire customer name and address, as in Figure 6-16.  
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Figure 6-16. Copying a portion of the report.  

 Select Copy from the Report ribbon. 

 Launch your word processor. 

 Position the cursor where you want the address to appear and use your word processor’s Paste (CTRL + V) 
command to insert the address into the document. 

 

Figure 6-17. Pasting to a word processor.  

 Exit your word processor without saving the document and return to Monarch. 

 

NOTE 
If you wish to copy all of the text in the report, select the Select All  button on the 

Report ribbon (or click CTRL + A on your keyboard) before clicking the Copy  
button. 
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PRINTING FROM A REPORT 

Monarch lets you print from the Report view. You can print a block of text, a page or series of pages, or the entire 
report. Let’s print a single page from the report. We’ll begin with Print Preview to see how the page will look before 
producing the actual printout. 

Steps: 

 Return to the first page of ClassJan.prn and click File > Print  > Print Preview . The Print Preview 
window displays.  

 

Figure 6-18. The Print Preview Window.  

 Examine the Print Preview window to see if your settings for font size, margins, and page orientation are 
appropriate to produce satisfactory output. If not, you can change the settings until everything looks just right. 
We’ll change settings in a minute, but, first, we’ll see how the Print Preview window works. 

 Click Zoom  on the upper left-hand corner of the window to zoom in or out.  

 Click the Next Page  or Previous Page  icons located at the bottom of the window to move forward or 
back. 

Now, we’ll adjust our page orientation, margins, and font settings. On many printers, the Classic report prints 
nicely with a portrait page orientation, half-inch margins, and a 9-point font. You may need to experiment to find 
the right settings for your printer. 

 Select the drop-down button of the Page Orientation  menu to confirm that the page orientation is set to 
Portrait. 
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 If you wish to change page margin settings, select Page Setup  to launch the Page Setup dialog and adjust 
the margin settings as necessary for your printer by double-clicking on the margin you wish to modify and 
entering your desired value. Note that the Page Setup dialog can also be accessed by clicking File > Page 
Setup.  

 

Figure 6-19. The Page Setup dialog.  

Select OK when you are finished making your changes. 

 When satisfied, close the Print Preview window by clicking the Close  button on the upper right-hand corner 
of the window. 

 Select File > Print  > Print . We’ll print Page 5 of the current report. 

 

Figure 6-20. The Print dialog.  
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 Select the printer you would like to use for this print operation.  

 Select the Pages radio button and then type 5 into the Pages box. 

 Select Print. 

The selected page will be printed. Monarch prints report pages as composed in the report file. Because Monarch 
adopts pagination from the report file, you must be careful to select an appropriate font size and margin settings 
to ensure that the full report image will fit on each page. Lines that do not fit will be carried over to a subsequent 
page, and columns that do not fit will be truncated. 

CLOSING REPORTS 

During each Monarch session, you may wish to use specific report files and thus need to close other reports. Let’s do 
that now. 

Steps: 

 Ensure that the report ClassMar.prn is selected in the Report selector. 

 Select File > Close  > Report .  

If you had other files open, such as a model, a database file, or a project, that you wish to close, you can also 
select these from the options presented when you select Close. 

 A message box displays to confirm closure of ClassMar.prn. Click Yes if you wish to continue.  

The selected report is closed and the Report selector displays the two remaining open reports.  

Repeat Steps 1–3 to close the remaining reports.  

If you had both report and model files open and wished to close these files at the same time, you can use the 

Close All command, which is called when you select File > Close All . When this command is called, you 
will be asked whether to save model changes if you defined templates during the Monarch session. 

WORKING WITH PDF AND XPS FILES 

When you import a PDF file into Monarch Classic, the application performs an analysis of the file to try and determine 
the optimum method of transforming the data accurately. In most cases, Monarch Classic’s auto-detection routines 
will produce the best results. Under certain conditions, however, adjustments to the PDF import options may be 
necessary. 

Previous PDF engines used in Monarch used the idea of monospaced and free-style text flow to adjust for text 
alignment. These older engines are usually adequate for: 

❑ PDF files containing tables with tightly compacted columns. 

❑ PDF files containing multiple font sizes and the data of interest is in a smaller font than most of the other text in 
the PDF, thereby causing the auto-calculated font size to be too large. 

❑ PDF files containing mixed mono- and variable-spaced fonts but the data of interest uses monospaced fonts. 

❑ PDF files containing mixed free-form and tabular data. 
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However, in newer PDF reports: 

❑ Text alignment on pages with sparse text is inconsistent. 

❑ Text wrapping may cause horizontal misalignment. 

❑ Alignment of centered text is unpredictable. 

Moreover, PDF reports are now published by numerous software products and may show some unpredictability in 
terms of their use of fonts, backgrounds, and line colors. Thus, a rendering engine that can tolerate any combination 
of fonts (including both monospaced and free-form fonts) and background colors is required. 

Monarch uses a new PDF engine (version 4.5) that improves the accuracy of text extraction by identifying graphical 
elements, such as vertical and horizontal lines and rectangles, on rendered PDF pages and using these elements to 
form grids to which text will be aligned. This new feature addresses alignment issues that render some trapping 
operations in PDF files extremely difficult. 

Let’s examine the PDF/XPS import options more closely and see how adjusting them will affect the transformation of 
data. 

Using PDF Engine Version 4.5 

The following text flow options are available when PDF reports are brought into Monarch Classic using PDF Engine 
version 4.5: 

❑ Snap Text Left  

Select this option to align the text to the left of the imputed PDF grid. 

❑ Snap Text Up  

Select this option to align the text to the top of the imputed PDF grid. 

❑ Always Align Left  

Select this option to always align text to the left of the imputed PDF grid. 

❑ Suppress Left Whitespaces 

Instructs Monarch to remove all left-side whitespaces when displaying the report. 

Using PDF Engine Version 4.4 and Below 

The following text flow options are available when PDF reports are brought into Monarch Classic using PDF Engine 
version 4.4 and below: 

❑ Mono-spaced  

Monarch’s Report view uses mono-spaced fonts, which are fonts bearing characters with the same width. For 
example, in a mono-spaced font, the “o” and “i” characters would have the same width (i.e., they would take up 
the same amount of horizontal space on a line). Other terms for mono-spaced are fixed-width and non-
proportional.  

 

NOTE The opposite of mono-spacing is proportional spacing, in which different characters 
have different widths, e.g., in a proportionally spaced font, the letter “o” would be 
wider than the letter “i.” 

 

Note that the Monospaced option is selected by default in the PDF/XPS Import Options window. When you 
import a PDF/XPS file into Monarch, Monarch tries to detect when mono-spaced fonts are used and optimizes 
the conversion accordingly. In some cases, Monarch may not detect that mono-spaced fonts were used for the 
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PDF/XPS file. When this failure occurs, it is usually due to the simultaneous presence of mono-spaced and 
proportional fonts in the same PDF/XPS file. If you know that the PDF/XPS file uses mono-spaced fonts, and the 
Monospaced option is not selected during the import analysis, you can select this setting to force Monarch to 
optimize for mono-spaced fonts. 

While proportionally spaced fonts look more appealing, mono-spaced fonts are superior for tabular data because 
the uniform width of each character makes alignment of columns easier. 

 

NOTE In general, PDF/XPS files generated using mono-spaced fonts will convert more 
successfully. Thus, if you are trying to optimize your PDF/XPS-producing application 
for Monarch, use mono-spaced fonts. Some of the more common fonts include 
Andale Mono, Anonymous, Crystal, Bitstream Vera Sans Mono, Courier, Courier 
New, Elronet Mono-space, Everson Mono Latin 6, Fixedsys, Lucida Sans Typewriter, 
Lucida Console, and PrestigeFixed. 

 

❑ Freeform  

The Freeform option tries to optimize text that is more free-form than columnar or grouped columnar. A 
columnar document is a simple table format, where grouped columnar might be something similar to one of the 
Monarch sample reports, such as Classic.pdf.  

A typical document that might benefit from using this setting would be an academic report that is 95% text, but 
which contains a few tables you want to extract. Selecting this setting will sometimes work effectively on 
columnar documents when the default settings do not produce good results. 

❑ Suppress Left Whitespaces  

This option instructs Monarch to remove all left-side whitespaces when displaying the report. 

Other Settings 

❑ Stretch  

The stretch option governs how much spacing is used during the conversion process. When Monarch analyzes a 
PDF/XPS file, it tries to match the spacing as closely as possible to the original document. However, many 
factors can make it necessary to introduce more spacing into the conversion than appears to exist in the original 
file, including hidden data in the PDF/XPS file itself, i.e., data which are not visible on screen but still exist within 
the file. For example, in columns with truncated data, missing data may not be apparent at first glance, but 
Monarch will still convert all of the data in the PDF/XPS file, not just what might be visible in a PDF/XPS viewing 
application. In this case, to try and maintain proper column justification, Monarch will recalculate and pad the text 
spacing, as the original column spacing may not be adequate to hold the data safely. 

In general, Monarch uses a larger amount of spacing (i.e., a higher stretch value) than that applied in the original 
document, which can make the document look like it is stretched wider than the original PDF/XPS. The 
application errs on the side of caution, so that columns do not run into each other in a document. This is also 
done so that if a later iteration of the same report (or a similar one) contains wider data values, the model will still 
“work” with it. 

If you know your reports well, you can decrease the stretch value to make the reports look more presentable by 
avoiding horizontal scrolling or very small font sizes in the Report view.  

Stretch values may be increased or decreased via the PDF/XPS Import Options window, which is launched when 

you select PDF/XPS Options  in the Report ribbon or when you open a PDF/XPS file. 
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❑ Crop  

The crop feature allows you to crop the outer edges of a document. For example, you may have a document 
printed from a website that has graphics or other non-tabular information around its edges that is unnecessary. 
Using the crop feature to discard the undesired information will not only reduce the amount of data you need to 
import, but also assist in the parsing of the data, ensuring the best possible alignment. 

❑ Auto-adjust 

Select this button to have Monarch automatically select the optimum settings for the displayed sample page. 
Note that if you have changed any of the PDF import settings, clicking this will likely restore the original settings. 

 

NOTE The PDF Import Options window provides an easy way to open PDF files and import 
them into Monarch for data extraction into tables, but it is not the only way to do so. 
Annual reports, for example, may include tabular data you wish to analyze, but their 
text-heavy nature cannot be properly addressed by just this window. In this case, the 
powerful features of Monarch’s Table Extractor may be necessary. 

 

Let’s try importing a PDF/XPS file that will require us to modify the PDF/XPS import options into Monarch. 

Customizing PDF/XPS Import Options 

Steps: 

 Close all previous reports.  

 Click File > Open  > Report > Computer. 

 In the Files of type drop-down box, select Adobe PDF files (*.pdf).  

 Select and open the CustomerSummary.pdf file.  

You can also perform the next steps with an XPS file. In this case, open CustomerSummary.xps instead.  

 Expand the options of the Use Engine Version drop-down list and select 4.2 from the options that display. 

Monarch opens the PDF Import Options window and displays the PDF file. Let’s zoom into the report (by 145% 
in the following example) so that we can view more of the sample data. 

 

Figure 6-21. A closer look at the CustomerSummary.pdf file.  

https://help.altair.com/2024/monarch/help/MTE_About_Datawatch_Monarch_Table_Extractor.htm
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Notice that for Bluegrass Records, the value in the Amount 1 column begins one space too far to the right, so 
that it doesn’t line up properly with the Amount 1 values for the other three customers.  

Let’s assume that we know the font used to generate this PDF was Tahoma, which is a proportional font. A quick 
visual investigation tells us this is not a freeform document but a columnar report. Let’s try adjusting the Stretch 
setting to see if this improves the conversion.  

 In the Stretch size indicator, shift the marker until the size reads 7.0. You may need to resize the window to the 
right to see all of the data. Monarch applies the stretch setting and shows the results on the sample page. Note 
that the Amount 1 value for Bluegrass Records now lines up correctly with the Amount 1 values of the other 
customers.  

 

Figure 6-22. Viewing the adjusted sample page.  

The current adjustment will now allow you to correctly capture the data in this column, a key Monarch feature, 
and place them in a table.  

 Click the Accept  button to close the PDF/XPS Import Options window and open the PDF file as a report.  

 

A closer look at all of the options available in the PDF/XPS Import Options window may be found here. 

This lesson completes Chapter 5. If you plan to go on to Chapter 6 now, you may leave Monarch open but select the 

File tab and then click Close All . Select No when asked if you want to save changes to the model or project you 
created. If you plan to go on to Chapter 6 at a later time, select File > Exit Monarch Classic.  

https://help.altair.com/2024/monarch/help/PDF_XPS_Options_Window.htm
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[7] EXTRACTING DATA FROM A 
REPORT 

In Chapter 6, you learned how to use the Report view to explore a report on screen. While this function is very useful, 
you probably won’t find anything new or useful that is different from simply reading the report off-screen.  

Monarch’s technology gives you access to the data buried in your reports and allows you to analyze them to obtain 
new information. By defining data extraction templates, you can extract data from any report and then analyze them 
using the Table and Summary windows. In this chapter, you will learn how to extract data from a typical report. The 
lesson topics include: 

❑ Determining what an extraction template is 

❑ Creating various data extraction templates 

❑ Displaying data in Table view  

❑ Modifying some template properties 

❑ Saving your work to a model file 

To get started on this lesson, close all previous reports and open Classic.prn. 

GETTING TO KNOW REPORT DESIGN VIEW 

Our jump-off point for creating data extraction templates is the Report Design interface, which is accessed by 

selecting Report Design  from the Report ribbon.  

The Report Design Interface 

  

Figure 7-1. Launching the Report Design interface and Template Editor. 
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Let’s take a minute to explore what you can find in the Report Design interface. The Report Design interface is 
divided into five distinct areas:  

❑ The Report Design ribbon is located on the top-most portion of the interface and spans the entire width of the 
screen. This ribbon will allow you to perform many of the report design functions made available by Monarch.  

❑ The Template Selector displays as a panel on the left-hand side of the interface. You can choose specific 
templates to view and modify from this selector, a functionality that is especially handy when you have defined 
multiple templates. You can also float, dock, dock as a document, auto-hide, or close this panel. 

❑ The Template Editor is displayed in the middle of the interface. The Template Editor remains disabled until you 
select a new template to create.  

❑ The right-hand side of the interface displays the general properties of a field in the Field Properties panel. Each 
field you define in a template has its own properties. You can set new properties or edit existing ones using this 
panel. Similar to the Template selector, you can also float, dock, dock as a document, auto-hide, or close this 
panel. 

❑ Below the Template Editor is a Data Preview panel. This panel automatically generates a preview of what your 
table will look like, including all of its content, while you build templates to extract the desired data from your 
report. Similar to the Template selector and Field Properties panel, you can float, dock, dock as a document, 
auto-hide, or close this panel. 

The figures below show examples of what a Data Preview panel might contain: 

   

Figure 7-2. The Data Preview tab provides users with a tabular sample of their extracted data In this example, data from a 
Detail template are shown.  

  

Figure 7-3. The Data Preview panel showing the data captured by an Order Number Level (append) template.  
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Figure 7-4. The Data Preview panel shows the data captured by a Page Header template.  

Note that as each template is selected from the Template selector, the corresponding columns defined by this 
template are highlighted in the Data Preview panel and characterized by a specific color, which we will learn to modify 
later in this chapter.  

The Report Design Ribbon 

The following table summarizes the functions of each of the buttons in the Report Design ribbon.  

Use this button… To… 

 Accept Accept the new template or changes to an existing 
template 

 Cancel 
Cancel the new template or changes to an existing 
template 

 Template Name 
Specify a new template name or modify an existing one 

 Template Role 
Display the role of the template selected 

 New Template 
Specify a new template  

 Delete Template 
Delete a template 

 Replace Sample Text 
Select a new line in the report with which to base a 
template  

 Redact Sample Text 
Apply redaction to selected text. More information is 
available here. 

 Clearing Template 
For footers and appends, remove “assumed” values 
copied up (for footers) or down (for appends) when only 
intermittent data are available. More information on this 
feature may be found here.  

 Auto-Define Trap 
Allow Monarch to automatically create traps for selected 
lines in the report 

 Auto-Define Fields 
Allow Monarch to automatically specify table fields based 
on selected lines in the report 

 Multi-Column Region 
Specify multi-column region settings 

 Run Report Verify 
Verify that the boundaries of fields are properly defined 

https://help.altair.com/2024/monarch/help/Redacting_Sample_Text.htm
https://help.altair.com/2024/monarch/help/Clearing_Template.htm
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 Report Colors 
Specify template colors 

 Help 
Launch the Help file 

 

The Report Design Context Menu 

When you open a report in Report Design view and right-click on your mouse in the Template Editor, a context menu 
displays. This menu will allow you to: 

❑ Copy text 

❑ Search for a record 

❑ Add, edit, or remove bookmarks 

❑ Zoom to fit 

EXTRACTING DATA USING TEMPLATES 

Imagine taking a piece of cardboard and cutting holes in it at certain locations. If you place this imaginary cardboard 
template on a printed report, you will see only the information that shows through the holes. Monarch uses electronic 
templates to extract information from your report files in a similar manner. If your report is sorted on several levels, 
i.e., if you have blocks of data arranged in a repeating manner throughout your report and you want to extract the 
same, you define a separate template for each sort level. 

Classic.prn report a simple structure, so extracting information from it is relatively easy. The file represents a monthly 
shipment report for a distributor of classical music recordings. Like many reports, Classic.prn is organized into 
multiple sort levels. The entire report is sorted by customer. Within each customer, orders are sorted by ship date. 
Within each order, shipments are itemized on detail lines. In addition, three header lines appear atop each page. 

  

Figure 7-5. Page 1 of the Classic.prn report.  
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In this chapter, Monarch will draw data out of each level in the report based on templates that you define. You will 
start by defining a detail template. Then, you’ll define an append template to extract fields from each sort level and 
a page header template to extract fields from the page header. Fields from the append templates and the page 
header template will be appended to fields from the detail template to produce database records. 

We’ll use a sample line to identify all of the other detail lines throughout the report via a process called trapping. By 
setting a trap, you tell Monarch which lines to capture and which to ignore. 

A detail trap identifies common features shared by all of the detail lines throughout the report, but not shared by 
other lines in the report, such as page header lines, lines containing labels, or lines from higher sort levels. A proper 
detail trap will capture only those lines we want while ignoring lines from headers and other sort levels. 

In the Classic.prn report, we need to look for features that differentiate the order information lines from the title, date, 
and page number lines at the top of each page. Specifically, we need to look for characters, such as letters, numbers, 
or punctuation, which always appear at the same position in the detail lines, but do not appear in any other lines. 

 

Figure 7-6. The Template Editor allows users to define templates with which to trap data.  

Selecting a new template to create or opting to edit an existing one activates the Template Editor. In the Template 
Editor, the Template Name and Template Role fields are automatically populated with the type of template we are 
going to create. In the example above, we opted to create a new detail template. The Template selector on the left 
side of the image also displays the template name. We can change this name by simply changing the entry in the 
Template Name field.  

 

Figure 7-7. The Template Selector.  
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Note also that most of the buttons that were previously deactivated in the Report Design view are activated in the 
Template Editor.  

The line you select for trapping displays on a yellow background on the Editor. This line is called the Sample Text 
box. Above the Sample Text box is the Trap line, which we will use to create our traps. The different trap types we 
can use are found in the Action bar. To the left of the Template Editor is the Line Selection area, which we will use 
extensively to select lines to trap.  

 

Figure 7-8. Specific areas of the Template Editor.  

Several types of traps are available: 

Use this trap… To… 

 Alpha trap  
Trap any letter 

 Numeric trap 
Trap any number 

 Blank trap 
Trap blank spaces 

 Not blank trap 
Trap any character that is not a space 

 Numeric OR trap 
A special trap, used to trap numbers which may or may 
not appear in certain positions. A good example is an 
accounting report, where a number may appear in a credit 
or debit column, but not both. Using two numeric OR traps 
will trap a number in either position. 

 Character trap 
Trap special characters 

 NOT trap 
Trap any character EXCEPT the specified trap character 

Exact match trap Trap a specific character or series of characters. Exact-
match traps are created by typing the exact characters or 
series of characters in the trap line.  

 

 

  

Action Bar 

Trap Line 

Sample Text Box 

Line Selection Area 
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Aside from simply creating traps, the Action bar allows you to perform other actions: 

Use this button… To… 

 Trap Type 
Specify the trap type to create: Standard Trap, Regular 
Expression Trap, or Floating Trap 

 Regular Expression Trap 
Options 

Select options to apply when creating regular expression 
traps: Ignore Case, Explicit Capture, or Ignore Pattern 
Whitespace 

 Trap Line 
Specify a different trap line on which to base a template if 
the sample text is composed of multiple lines 

 Push Left 
Adjust a selected trap character or field one character to 
the left 

 Push Right 
Adjust a selected trap character or field one character to 
the right 

 Reset Trap Line 
Discard all changes made to the Trap line and start again 

 Reset Fields 
Discard all fields specified and start again 

 Delete Field 
Delete a specific field 

 Edit Field 
Launch the Field Definition window 

 

To generate a table, Monarch produces one record for each detail line extracted from the report. The detail line 
contains the data that changes most often in the report and is usually the report’s lowest sort level. Append templates 
add, or append, information from higher sort levels to the table. In this lesson, we will extract fields from four levels in 
the report: the detail level, two sort levels, and the page header. 

CREATING A DETAIL TEMPLATE 

A detail template extracts data from the lowest level in the report, which, in this, case are the lines representing 
individual shipments.  

To create the detail template, we’ll select a sample detail line, use this line to identify other detail lines, and highlight 
the fields to extract. For this lesson, we’ll use Classic.prn and keep the Field Properties panel auto-hidden from view 
until we need it. 

Selecting a Line to Trap 

Steps: 

 In the Report ribbon, select the Report Design  button. 

The Report Design view displays.  
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As expected, most of the buttons in the ribbon are deactivated.  

 

Figure 7-9. Most of the buttons in the Report Design interface remain deactivated until you activate the Template 
Editor.  

 Click on the line selection area to the left of the line containing the item description Bartok, Sonata for Solo 
Violin.  

 On the Report Design ribbon, select New Template > Detail.  

 Type “Line Item Detail” into the Template Name field and then press Enter on your keyboard.  

This step changes the template name. Changes are immediately reflected in the Template Selector.  

 Ensure that the Trap Type is set to Standard Trap. 

Trapping the Detail Lines 

Let’s create our detail trap. 

Steps: 

 Click in the Trap line above the number 4. If the cursor is not positioned correctly, you can use the Push Left  

or Push Right  keys to move it to the correct position. 

 Click the Numeric Trap  icon. “Ñ” appears in the Trap line, representing any number in the designated 
column position. 

 Click the Blank Trap  button twice. “ßß” appears adjacent to the first trap character, representing a blank in 
each column. 

 Click the Non-blank Trap  button. “Ø” appears in the Trap line, representing any non-blank character. 

By combining these trap characters (see Figure 7-10), we’re telling Monarch to “trap only those lines with a 
number, followed by two blank characters, followed by a non-blank character in the specified positions.” 
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Figure 7-10. The completed trap definition.  

 Scroll through the report to ensure that the trap captured all of the detail lines and no other lines. 

The results of our trap are indicated by guillemets (») appearing in the line selection area to the left of each line 

that is selected by the trap, and only those lines including the data you wish to capture should display these 
marks.  

 

Figure 7-11. Results of the detail trap.  

NOTE If you make mistakes when entering the trap characters, you can highlight the 
incorrect trap characters and press DELETE on your keyboard to remove them. To 

delete all trap characters, click Reset Trap Line . 
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Highlighting Detail Fields 

When the trap you specified has captured all of the detail lines and no other lines, you’re ready to highlight the fields 
to extract. 

Although we can manually highlight and name the fields to be extracted, let’s try using the Template Editor’s Auto-
Define Fields feature, which allows us to automatically highlight fields in the template. This feature uses Monarch’s 
built-in parsing and data recognition capabilities to determine where fields begin and end.  

The Auto-Define Fields  button automatically highlights fields in your template. You can use this capability as a 
jump-start when highlighting fields in your templates, and we will in fact use this in our lesson, but you should not rely 
upon this feature exclusively, as Monarch cannot predict which fields you might want to extract and which you want to 
leave out, nor can it deal with the subtleties of report design that allow fields to wrap onto multiple lines or about one 
another.  

Steps: 

 Click Auto-Define Fields  on the Report Design ribbon. 

Each field that is found in the detail template is highlighted. 

 

Figure 7-12. Results of the Auto-Define Fields command.  

 Check the Data Preview panel to see what your table will look like with the information obtained by your 
template. 

 

Figure 7-13. Data Preview results of the Auto Define Fields command.  

 Click Accept  to accept your template definition.  

Congratulations! You have just created your first template. Figure 7-14 shows changes that occur in the Report 
view once a template is defined for a report. 
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Figure 7-14. The completed detail template.  

Verifying Field Boundaries 

Although you could scroll through the report to ensure that each field highlight is long enough to capture all of your 
data, this method becomes tedious when you are working with large reports. Therefore, a Field Verification feature 
is provided to read the entire report and verify that your fields are properly defined. 

When you activate the field verification feature, Monarch scans the entire report and examines field boundaries. If any 
characters are found immediately adjacent to a field, Monarch will highlight the field to alert you that the field 
definition may be too short to accommodate a field value or that the field may be defined at the wrong location.  

The Report Verify window displays when you select Run Report Verify  from the Report Design ribbon. The 
following table describes each of the buttons in this ribbon. 

Use this button… To… 

 Accept Accept the results of a verify operation 

 Cancel 
Cancel the verify operation 

 Adjust left 
Adjust the highlighting of the field one character to the left 

 Adjust right 
Adjust the highlighting of the field one character to the 
right 

 

 Adjust all fields 
Automatically adjust all field definitions, thereby 
eliminating the need to go over an entire report to ensure 
that all required fields are captured properly.   

 Ignore all 
Ignore all field-highlighting issues of the type reported in 
the template and continue with the verify operation; 
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Use this button… To… 

subsequent verify operations will not highlight issues of 
the type previously ignored 

 Continue 

Continue the verify operation after correcting an issue 

 Start over 
Restart the verify operation  

 Stop 
Stop the verify operation  

 Reset Ignore Rules 
Reverse the Ignore all command; subsequent verify 
operations will highlight issues previously ignored 

 Help 
Launch the Help file 

 

 

NOTE If multiple reports are loaded, Report Verify automatically scans through all of them. 
When Verify is started it always starts at the first page of the current report, and will 
continue to report verify hits from that and other reports until it has cycled through all 
of the reports, thereby completing a full pass.  

Verification will start over from the top of the current report and re-scan for verify hits 
(but with any ignores still in effect). Upon reaching the end of a pass without ever 
having stopped, the dialog returns a message saying that verification has been 
completed. In this way the user can clearly see when they have succeeded in making 
a complete "clean" pass through the report(s). 

 

Let’s verify that our field boundaries are correct. 

Steps: 

 Return to Report Design and then click Run Report Verify . 

A status dialog displays the current status of the verify operation. When the verify operation is completed without 
errors, Verify completed displays in this dialog. This status indicates that all of our fields are properly defined. 

 

Figure 7-15. A completed Verify operation.  

We can expect this result for the fields of our detail template because we used Monarch’s Auto-Define Fields 
feature to define them. 

 Click OK to close the Report Verify dialog and Accept  to accept the Report Verify results. 
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CREATING APPEND TEMPLATES 

In the Classic.prn report, orders are sorted by order number. Also at this sort level are ship data. We’ll create an 
append template to extract these two fields and an additional append template to extract the account number and 
contact fields that appear at the next higher level. 

The procedure for extracting fields from each sort level is the same as that for extracting detail fields. First, we’ll 
select a sample, then we’ll trap other occurrences of the sort level throughout the report, and then we’ll highlight the 
fields we want to extract. 

Steps: 

 In the same report, select Report Design  once more. 

 Select the line containing the words ORDER NUMBER. This line is indented and appears below the line 
containing several field names and above the item details. 

 On the Report Design ribbon, select New Template > Append. Ensure that the Trap Type is set to Standard 
Trap. 

The Template Editor is activated and the line we selected is copied into the Sample Text box. Note also that the 
Template Name and Template Role fields are updated to reflect our selected template tape.  

 

Figure 7-16. The selected ORDER NUMBER line.  

 

NOTE There can only be one detail template for any model you create. The total number of 
all append and footer templates cannot exceed 20. For each footer template used, 
there is one less append template available. For example, if you create three footer 
templates, then only 17 appends can be used. 
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Trapping the Ship Date Lines 

We’ll use an exact match trap to capture all lines representing the order number level. An exact match trap looks for 
an exact match of a character or series of characters.  

Steps: 

 Continuing from the previous exercise, click in the Trap line above the colon following ORDER NUMBER in the 
sample line.  

 Type a colon (:) in the Trap line directly above the first colon in the Sample Text box. 

 Type another colon (:) directly above the second colon in the Sample Text box. 

 Highlight the fields marked by 536017 and 04/10/10 in the Sample Text box as shown in Figure 7-17. 

 

NOTE Remember that your Date Format setting must be set to M/D/Y to properly capture 
date inputs in the sample reports we’ll be using for this guide. 

 

 

 

Figure 7-17. Highlighting the Order Number and Ship Date fields.  

 Scroll through the report to see the results. Note that, on the fourth page of the report, the “RETURN 
AUTHORIZATION” and “RECEIVED” fields have been highlighted (see Figure 7-18). We don’t want to capture 
these fields, so we need to edit our template definition. 
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Figure 7-18. Viewing the result of highlighting fields. Note that data from an unwanted field is captured in this 
example.  

 In the Trap line, place the cursor directly above the “5” that begins the order number (536017) in the sample line, 

click the Numeric trap  button, and then check the highlighted fields once more. 

The “RETURN AUTHORIZATION” and “RECEIVED” fields are no longer highlighted on Page 4 of the report. 

 

Figure 7-19. Viewing the results of amending the current trap.  
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 Replace Append 1 with Order Number Level in the Template Name field of the Template Editor. 

The fields trapped by the append template we just created can be easily distinguished from those trapped by the 
detail template due to the different colors that Monarch assigns them.   

 

Figure 7-20. Data preview of the highlighted fields.  

 Select Accept  to accept your changes and close the Template Editor. You are returned to Report view when 
you do so.  

Trapping the Account Number and Contact Lines 

This time, we’ll trap the account number and contact lines in another append template. Note that the “ACCOUNT 
NUMBER” and “CONTACT” fields are on different lines. To capture both fields, we’ll select a multiple line sample. 

Steps: 

 Switch to the Report Design view.  

 Click down in the line selection area to the left of ACCOUNT NUMBER and drag down two lines to highlight 
three lines including the CONTACT line. 

 On the Report Design ribbon, select New Template > Append. Ensure that the Trap Type is Standard Trap. 

The three lines we selected are displayed in the Sample Text box of the Template Editor. 

 

Figure 7-21. The Template Editor showing the selected sample lines.  

For a multiple line sample, you need to indicate which of the sample lines to trap. Generally, you will be able to 
trap on the first line by identifying features unique to that line. Occasionally, however, there will be no unique 
features that identify the first line. If it is not possible to trap on line 1, use the Trap Line drop-down to select 
another line with unique features.  
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Figure 7-22. Using the Trap Line drop-down to select a unique line from which to create a trap.  

In this lesson, we’ll trap on the first line of the sample, so you won’t need to adjust this setting.  

Note that an “ACCOUNT NUMBER” label always precedes the account number field. Let’s use this specific 
sequence of characters as an exact match trap. 

 Type Account Number at the beginning of the trap line. By default, Monarch traps are not case-sensitive, so 
you need not enter the text exactly as it appears in your sample line. 

 

NOTE You can specify “case-sensitive” as the default case setting for traps by selecting 

Options  in the Home ribbon. In the Options interface that displays, select the 
Input tab, go to the Trapping subtab, and then tick the Non-Regex Traps are case-
sensitive box. 

 

 Click Auto-Define Fields .  

 

Figure 7-23. Auto-highlighting the Account Number and Contact fields.  

Monarch highlights the fields in the report. You may need to scroll the report to see the results. 

 Replace Append 1 with Account Number Level in the Template Name box, and then click the Accept  
button to accept the template definition. 

Note that Monarch has assigned the same color to the fields trapped by the Account Number Level template as 
to those trapped by the Order Number Level template. This is because they are both append templates. 
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Figure 7-24. The results of your templating work thus far display in Report view.  

CREATING A PAGE HEADER TEMPLATE 

Page headers often include useful information, such as the report date. In the Classic.prn report, the page header 
includes the report date and the page number. Let’s extract these two fields. 

Steps: 

 Switch to the Report Design view.  

 Select the first line of the report as the sample text. 

 On the Report Design ribbon, select New Template > Page Header. Ensure that the Trap Type is set to 
Standard Trap. 

The Template Editor is activated and the line we selected displays on the Sample Text box.  

 

Figure 7-25. The sample line selected for the page header.  
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Trapping the Page Header 

Most reports have a form feed character (ASCII 12, HEX 0C) embedded at the page break. Monarch can use this 
character to identify the beginning of a page header, so you normally do not need to set a trap to capture page 
headers. However, if your reports do not include the form feed character, you will need to use a trap to capture these. 
If you are unsure about your report’s internal structure, you should play it safe and create a trap. That’s what we’ll do 
for this lesson. 

Steps: 

 Click the Numeric Trap button  twice and then type a forward slash (/) in the Trap line. This trap will capture 
the first line of each page header (where the date is represented in MM/DD/YY format). 

 Highlight the report date and the page number, as shown in Figure 7-26. 

 

NOTE 
The Auto-Define Fields  button will not be able to capture the report date field 
due to the logic it uses to distinguish fields from labels, headings and other static text 
that appears in reports. Any text that does not change throughout the report is 
considered a label, even if that text looks like, and, as in this case, is, a field. 

 

 

 

Figure 7-26. Highlighting the page header fields.  

The page header fields in the report are highlighted. 

 Click Accept  to accept the template definition. 

 

Since you did not name the template, a default name is assigned for you. For detail and page header templates, 
the default names are Detail and Page Header, respectively. For append and footer templates, the default 
names are Append n, and Footer n, where n is incremented for each new append or footer template. 

Note in the report that Monarch has highlighted the fields trapped by the page header template with a unique 
color to distinguish them from those trapped by other template types.  
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WORKING WITH MODEL FILES 

After you have created a data extraction template for a report, you can save it in a Monarch model file. A model file 
saves all of the templates and definitions that you have applied to a report during a Monarch session, including sorts, 
filters, user-defined functions, and the like. Models save work by allowing you to apply the same templates and 
definitions to a periodic report every time it is generated.  

In the previous lessons, for example, we created four templates that we can save to a single model file. If we had new 
report files with the exact same structure as Classic.prn (e.g., ClassJan.prn, ClassFeb.prn, and ClassMar.prn), we 
can reuse this model file to extract data from the new files without needing to rebuild any of the templates we’d 
already created.  

Note that in the current version of Monarch, model files are saved using the .dmod extension. Monarch can read 
model files saved in previous versions of Monarch using the .xmod extension, but it cannot save changes to this file 
type.  

Saving Model Files to a Local Folder 

Let’s save a model file to see how this works. 

Steps: 

 Select File > Save As  > Model > Computer.  

You can save model files to a local folder (i.e., Computer), a web server (Amazon S3), the Altair Server Library, 
or to a zip file. 

 Since we opted to save to a local folder in this example, a Save Model dialog displays. Using this dialog, 
navigate to the folder in which you want to save your model file and then provide a name for it in the File name 
field. 

 Ensure that the option Model Files (*.dmod) option is selected in the Save as Type drop-down. 

 

 

Figure 7-27. The Save Model dialog box.  

In the example above, we named our model file Save1. The .dmod extension will be automatically added to the 
file name once it is saved. 



 

Altair Monarch 2024.0 Learning Guide  181 

 

 Click Save to continue saving your model file.  

 If a model file with a name identical to the one you supplied in Step 2 is found in the location you specified, you 
will be asked to confirm the save operation. Click Yes in the dialog box that displays to continue saving your file. 
Note that continuing with the save operation will result in the newer model file replacing the older one.  

 Select File once more and then click Close All  to close the Classic.prn report and model. 

 

Saving Model Files to the Altair Monarch Server Library 

Monarch allows users to save and access models and projects from Altair Monarch Server via the Altair Monarch 
Server Library Browser. Note that this functionality is only available using Altair Server versions 12.5.1 and up.  

Follow the steps below to save a model to the Altair Monarch Server Library. 

Steps: 

 Select File > Save As > Project/Model > Altair Monarch Server Library. 

 If you had previously configured an Altair Monarch Server Library in the Options interface and opted to save 
models and projects to Altair Monarch Server as the default save behavior, a dialog like that in Figure 7-28 
displays.  

 

Figure 7-28. Saving a model to the Altair Monarch Server Library.  

Enter a filename for the model you are saving into the name field and then click Save as new. 

The model you have just saved is added to the Models list.  

 If you wish to revise a pre-existing model in the Models list, select its name from the list and then click Add 
Revision. 
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 Add a comment if necessary 

 

Figure 7-29. Adding a comment to a model saved to Altair Monarch Server.  

 Click OK when you are finished.  

More information on Altair Monarch Server is available at https://www.altair.com/monarch/monarch-server/. 

 

Saving Model Files to Amazon S3 

Monarch also allows users to save and access models and projects from Amazon S3.  

Steps: 

 Select File > Save As > Model > Web. 

A Save as Web File dialog displays. 

 

Figure 7-30. Saving a model file to an Amazon S3 folder.  

 Enter the S3 folder to which you want to save the model file in the text field provided and then select Connect. 

Loading Saved Model Files 

Now let’s load the same report with our new model file. 

Steps: 

 Select File > Open  > Report > Computer.  

 In the dialog that displays, Classic.prn.  

The Classic.prn report displays in Report view. 

 Select File > Open  > Model > Computer.  

 From the dialog box that displays, locate, select, and open Save1.dmod.  

  

https://www.altair.com/monarch/monarch-server/
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The Report view is updated to reflect the effects of the opened model. 

 

Figure 7-31. Loading the Classic.prn report and the Save1.dmod model file.  

SETTING TEMPLATE COLORS 

Monarch includes a function that allow users to clearly differentiate between the various types of templates that may 
be created (i.e., Detail, Append, Page Header, Group Footer) via template colors. Template colors allow you to easily 
determine what type of template is being used to extract information from a selection. Aside from being able to 
choose your own colors, Monarch also provides a pre-determined set of template colors. If you haven’t previously set 
your template colors yet, we’ll do so now.  

For this lesson, load Classic.prn and Lesson1.dmod. 

Changing Default Colors 

Template colors are changed via the Edit Report Colors dialog box. 

Steps: 

 Select Report Design  > Report Colors  to launch the Edit Report Colors dialog. 
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Figure 7-32. The Edit Report Colors dialog.  

Several color themes are available for use as template colors: 

• None shows no color backgrounds in the report after defining templates. 

• Gray background displays all templates defined in a report in a gray background. 

• Custom background for each template type assigns select colors for specific template types. This option 
is selected by default. 

 

Let’s try changing the color for Detail templates.  

 Click directly on the Detail button to launch the color selector. Note that right now, the button is yellow. 

 

Figure 7-33. The Edit Report Colors dialog displaying the color selector.  

 Select the first color on the first column, first row (#FF8080). 

 Click anywhere on the Edit Report Colors dialog to accept your selection and close the color selector. 

The color of the Detail button changes to bright salmon. 

 Select OK to close the dialog box. 

A quick look at the Template Editor shows that the Detail template is now a bright salmon color. 
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Figure 7-34. The Detail template color is updated with your changes.  

Resetting Default Colors 

Before we proceed to the next lessons, let’s change the Detail template color back to its original state. 

Steps: 

 On the Template Editor, click Report Colors  once more. 

 Select the Reset to default colors button in the dialog that displays.  

The Detail button now shows the original template color we saw earlier. 

 Click anywhere in the dialog to close the selector and then select OK to close the dialog box. 

NAMING FIELDS 

When data are extracted from a report, they are arranged in columns that are given generic names. You can change 
these names into more meaningful ones to better describe the contents of each column.  

Monarch allows you to name fields via three ways: 

❑ Immediately after highlighting them in the Template Editor using the Field Properties panel  

❑ Via the Table Design view 

❑ Via the Field Definition window.  

In this section, we’ll explore these options one by one using Classic.prn and Save1.dmod. 
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Using the Field Properties Panel 

Steps: 

 In Report view, select Report Design  to view the report (along with the highlighted fields) in Report Design 
view. 

 Select one template from the Template Selector (in the following example, we selected the Line Item Detail 
template). 

 

Figure 7-35. Viewing the original field names using the Data Preview panel.  

 Click on the highlighted field labeled CD in the Sample Text box and then click on the Field Properties button to 
expose the Field Properties panel (remember that we set this panel to auto-hide when we were creating our 
detail template at the beginning of this chapter).  

All of the details associated with this field display in the Field Properties panel. 
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Figure 7-36. The properties of a field display in the Field Properties panel.  

 In the Name field of the Field Properties panel, delete the current entry and enter Media in its stead. Click the 

 button that appears next to the field to accept your changes.  

The Data Preview panel is automatically updated to show your changes. Note that the column previously marked 
“eg_CD” is now labeled “Media.”  

 

Figure 7-37. Field properties of the field eg_CD. 

 Repeat Steps 3 and 4 to rename the rest of the fields in the detail template using the following guide: 

Rename this field… To… 

eg_4  Quantity 

eg_Bartok, Sonata for Solo Viol Description 

eg_MK-42625 Label Number 

eg_8_99 Unit Price 

eg_35_96 Amount 

 

 Once you’ve made all of your changes, click Accept  on the Report Design ribbon to save your changes and 
close the Template Editor. 
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Using the Table Design Interface 

When Monarch extracts data from a report, the data are placed in a table, which you can view and manipulate in 
Table Design view. Similar to the Field Definition window, the Table Design view allows you to change field names 
and properties; it also allows you to perform external lookups, specify formula fields, and define filters, sorts, and 
address blocks, among others. We’ll discuss these functionalities one by one in later chapters. For now, we’ll focus 
on changing field names using the Table Design window. 

In this lesson, we’ll rename the rest of the fields extracted from Classic.prn using Table Design view.  

Steps: 

 From the Report interface, select the Table tab and then click Table Design  from the Table ribbon. 

The Table Design view presents a list of all of the fields you have trapped and will appear on your table; the 
general properties of each field are also displayed.  

 

Figure 7-38. The Table Design interface displays names and properties for all fields.  

If you wish to view the properties of the template used to capture a field, simply check the box labeled Show 
Template Properties at the lower left-hand corner of the view. You’ll also see the now-familiar Data Preview 
panel at the bottom left corner of the interface.  

 In the name field, locate the cell with the entry ACCOUNT NUMBER and change it to Account Number by 
clicking on the cell and typing over the original entry. 

 Locate the cell with the entry CONTACT and rename it Contact. 

 Replace the name eg_536017 with Order Number. 

 Replace the name eg_04/10/10 with Ship Date.  

 Replace the field name eg_05/01/10 with Report Date. 

 Replace the field name eg_01 with Page Number.  
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Figure 7-39. Renaming fields using the Table Design interface.  

 Click Accept  on the Table Design ribbon to accept your field name definitions and close the view. 

The Table Design interfaces closes and you are returned to Table view.  

 Click Autosize Columns  on the Table ribbon to fit as much of the cell contents as possible to the column 
widths.  

 

Figure 7-40. The results of our renaming exercise.  
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Using the Field Definition Window 

The Field Definition window provides yet another means to rename columns. 

The Field Definition window is accessed by: 

❑ Selecting a field and then clicking Edit Field  from the Action bar of the Template Editor  

❑ Selecting Input Fields in Table Design view 

❑ Double-clicking on any field in Table view 

 

In the latter case, the properties of the field you double-clicked on display first in the field list provided.  

The Field Definition window displays. Let’s explore this window in detail. 

 

Figure 7-41. Field properties of the field eg_CD. 

The ribbon of the Field Definition window features a Template Name drop-down list from which you can choose any 
template whose fields you wish to define. The template name you select from the drop-down box specifies which 
template fields are displayed in the Field Selector located on the left-hand panel of the window. If you wish to display 
all of the fields from all of the templates simultaneously, simply check the box for Show fields from all templates. 

You can select any of the fields from the Template Selector and define properties for them. The Field Definition 
view displays the characteristics of a single field in three tabs: General, Template, and Advanced.  

The General tab displays the properties of each individual field, such as its name, type, format, and display width. 
This tab shows exactly the same content displayed in the Field Properties panel in Report Design view. Thus, if you 
wish to rename fields using the Field Definition window, you would do so in this tab.  

The Template tab displays the properties of fields in terms of template characteristics, such as whether the field is 
properly verified and whether empty cells (fields) in a table should be filled with the corresponding value from the 
record immediately preceding it. If you wish to redact some of the data you retrieved, you can also do so using this 
tab.  

Finally, the Advanced tab displays advanced field properties, which are useful when the field being defined spans 
several lines in a report.  



 

Altair Monarch 2024.0 Learning Guide  191 

 

USING THE REPORT INDEX 

Now that we’ve successfully extracted data from a report, let’s try using Monarch’s Report Index feature.  

The Report Index displays a hierarchy of field values within one or more reports, thereby allowing you to quickly and 
easily explore a report and zero-in on the information you are interested in. Using this tree, you can get a bird's eye 
view of your report data. When you find the information you desire, you can simply click on the field value to jump to 
the corresponding page in the report. 

For this exercise, we’ll use Classic.prn and Lesson1.dmod.  

Setting Up a Report Index 

Let’s build a Report Index so that we can see first-hand how helpful it can be. 

Steps: 

 Click the Report Index  drop-down button from the Report ribbon and then select Edit Report Index Fields.  

The Edit Report Index Fields dialog displays. 

   

Figure 7-42. The Edit Report Index Fields dialog.  

The fields extracted by the Lesson1 model display in the Available Fields list. We can use up to five of these 
fields to build our tree. 

 Select the Account Number field and then click the Add >> button. The Account Number field is removed from 
the Available Fields list and added to the Selected Fields list. 

You can also simply double-click a field in the Available Fields list to add it to the Selected Fields list. 
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 Select the Order Number field and then click the Add >> button. The Order Number field is added to the 
Selected Fields list. 

 Select the Description field and then click the Add >> button to add it to the Selected Fields list. 

Note that the fields are listed in alphabetical order in the Selected Fields list (see Figure 7-43). Their order in the 
actual Report Index hierarchy will be determined by their order in the report data, as we’ll see shortly. 

   

Figure 7-43. Viewing the Selected Fields list.  

Now that we’ve configured the tree definition, let’s see how the Report Index displays in Report view. 

 Click the OK button to close the Edit Report Index Fields dialog.  

Monarch displays the Report Index on the right side of the Table (or Report) window by default. Initially, the tree 
is collapsed. You can move the panel by clicking on the panel header and then dragging it anywhere you wish on 
the window.  
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Figure 7-44. Displaying the Report Index.  

 Expand the Classic.prn tree on the Report Index by clicking on the node ( ) to the left of the label Classic.prn.  

Navigating within Report Index 

Monarch provides two modes of navigation within the Report Index, passive navigation and active navigation. 
Passive navigation involves expanding or collapsing branches to view underlying items without updating the Report 
view display. Active navigation involves highlighting a branch in the tree. Whenever a branch is highlighted, the 
Report view is automatically updated to display the corresponding page in the report.  

Typically, you will use a combination of passive and active navigation in Report Index, e.g., you would click on the 
arrow (→) to the left of a branch to expand it (passive navigation), and then, when you find an item of interest to you, 
you would click the item to display the corresponding page of the report (active navigation). 

Let’s perform both modes of navigation within Report Index. 
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Passive Navigation 

Steps: 

 In the Report view, click the node ( ) next to the first account number (i.e., 11887) displayed in the tree, and 
then expand all the underlying branches by clicking their nodes ( ). Note that the two order numbers for the 
account are nested beneath the account number. 

  

Figure 7-45. Using passive navigation in Report Index.  

Active Navigation 

Steps: 

 Scroll down to the bottom of the Report Index pane and click the node ( ) next to the last account number (i.e., 
14162). Click on order number 536015. Click on the number itself, not the adjacent node ( ).  

Note that the report page (Page 19) containing the corresponding data displays in Report view and the data itself 
is highlighted. 
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Figure 7-46. Using active navigation in Report Index.  

 Expand the 536015 order number branch (either double-click it or click the node ( )) of the tree to reveal the 
individual line items and then select the second one (i.e., Liszt, Les Preludes). The corresponding line in the 
Report view is highlighted.  

 

NOTE When exporting a report as a PDF file, the Report Index is used to create a list of 
PDF bookmarks for easy navigation. 
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WORKING WITH PROJECT FILES 

Project files save time by reducing the number of steps required to store a previous Monarch session. When you 
save a project file, references to the input file(s) and the model file, as well as the active filter, sort order, summary, 
and view, are saved. Project files are saved via the File > Save As > Project > <Location> command.  

When you have saved your work to a project file and wish to continue your Monarch session (presumably at a later 
time), simply open the project file you saved by selecting File > Open > Project > <Location>. Doing so 
automatically loads the input file(s) and model you were working with. All objects defined in your previous Monarch 
session are also made available.  

Project File Limitations 

Project files contain only references to a Monarch session’s data source and model file; it does not encapsulate the 
data source or model file into the project file. Thus, if you delete, move, or rename the data source or model file 
referenced by the project, you will be unable to restore a previous Monarch session by opening the saved project. 
This is also true if you move the project file to a system that does not have access to the data source or model file, 
giving a project file limited portability beyond the system on which it was created. 

When a Monarch session using a database table is saved into a project and the column names of this table are 
changed (e.g., using an external application), an attempt to open the project launches the following prompt:  

 

Figure 7-47. Opening a project file with a modified table.  

Clicking Yes on this dialog launches an error message to describe the issues found: 

 

Figure 7-48. Errors observed when opening a project file using a table with a modified name. 

Clicking OK on this dialog takes you to the Edit Table Properties window, where you can select a new data source 
instead and/or modify other table properties.  
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Figure 7-49. The Edit Table Properties window. 

Project Files and Automator 

Altair Monarch Server Automator Edition (Automator) is a data conversion solution built for Monarch that uses 
existing ASCII or ANSI reports, PDF files, XPS files, ISAM files, Open XML spreadsheets, HTML files, and OLE 
DB/ODBC sources, among others, as sources of data. You can import report files into Automator and then export 
their data to a variety of formats or an OLE DB or ODBC destination. Automator also allows you to export files to a 
Microsoft Office SharePoint Server, FTP site, email destination, or distribution list. In short, Automator lets you 
extract, transform, move, and load data faster and more easily than previously possible.   

Automator offers far more than just an easy way to automate Monarch. It is an information delivery system, capable 
of distributing files over the network and to SharePoint locations. It can email users the files they need, or alert them 
that new files are available and where to get them, either over the network or via the Internet. RSS feeds can be 
created, integrating with newsreaders or corporate information portals. Thus, users are kept up-to-date on the latest 
information and can click to download or view the information via a browser. 

Automator makes use of project files to create processes. The project file referred to here is the same project file you 
create in Monarch when you save your work, including references all reports used, model(s), export(s), filter and sort 
definitions, and the like, to a file with the extension .dprj. 

For more information on Automator, click on the link https://www.altair.com/monarch/monarch-server/.  

https://www.altair.com/monarch/monarch-server/
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[8] SPECIAL DATA EXTRACTION 
TECHNIQUES 

In Chapter 7, we created a table using a report with multiple sort levels, but we didn’t extract the customer information 
from the highest sort level. In this chapter, we’ll use Monarch’s address block feature to extract the customer names 
and addresses. We’ll also familiarize ourselves with Monarch’s floating trap and multi-column region trapping 
features. The lesson topics include: 

❑ Special problems with addresses 

❑ Extracting an address block 

❑ Using the address block feature 

❑ Using the floating trap type 

❑ Using the multi-column region trapping feature 

 

To get started, we’ll load the Classic.prn report and Lesson1.dmod model file. 

 

Figure 8-1. The Classic report with the Lesson1 model file. 

The customer name and address, account number, and contact name are all at the same sort level in the report. 
Generally, we define one append template for each sort level. However, we will need to use a special technique to 
extract address fields, and that technique requires a separate template. 
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USING ADDRESS BLOCKS 

Special Problems with Addresses 

Most of the information in reports is contained in fields that are easily located for extraction. However, addresses 
present special problems. Some may contain three lines, while others have as many as six or seven. As well, fields 
containing state, province, and postal code information are not found at a fixed position on the lines they occupy. 
Monarch provides a specialized feature in Table view to solve these data extraction problems easily. 

To extract the address fields, Monarch provides the Address Block feature in Table view. The Address Block is 
capable of taking a block of text and extracting and categorizing the address information contained within it. 

Extracting an Address Block 

The procedure for extracting the address fields is similar to extracting other fields. First, we’ll select a sample address 
block, then we’ll set a trap to capture all other address blocks throughout the report, and finally, we’ll highlight the 
address fields to extract. 

Let’s start by selecting a sample address block from the report. 

Steps: 

 Select Report Design  on the Report ribbon.  

 Click on the line selection area to the left of the line containing CUSTOMER and the first line of the address (i.e., 
Betty’s Music Store). 

 On the ribbon of the Report Design view, select the drop-down button for New Template and then select 
Append. Ensure that the Trap Type is set to Standard Trap. 

The first line of the address block is copied into the Sample Text box of the Template Editor. 

 

Figure 8-2. First line of the address block in the Template Editor.  

 Name this template Address Block. 

 Type customer in the Trap line above CUSTOMER in the sample line. 

 Highlight the field in the sample line, making sure you allow plenty of space for long address lines throughout the 
report. 
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Figure 8-3. Trapping the first line for the address block. 

To capture the whole address block, regardless of the number of lines, we need to use the advanced field 
options available in Monarch.  

 Select Edit Field  from the Template Editor’s Action bar to launch the Field Properties window. 

 

Figure 8-4. Field Properties window.  

 In the General tab, change the field name to Customer Full and then click the  button that appears beside 
the field. 

 Change the field’s Type setting to Memo. 

 Click the Advanced tab and then, under the End Field On heading, select the Blank Field Values radio button 
to terminate the field when a blank line or a series of blank lines is encountered. It is important to note that 
Monarch does not require the entire line to be blank, only the column positions occupied by the field.  

 Enter the number of blank field values required to terminate the field, which in this case is 1. 

 Click Accept . 

The address fields in the report are highlighted. Scroll through enough of the report to confirm that all instances 
of the address have been captured. 



 

Altair Monarch 2024.0 Learning Guide  201 

 

 

Figure 8-5. Viewing the trapped address block. 

Note that this has correctly captured all of the addresses, even though some have four lines and some have five. 
This is the advantage of utilizing Advanced Field properties. 

 Click Accept  to accept the template and close the Editor. 

Defining Address Blocks 

When you open Table view, you will see that the field has been extracted and is displayed using standard memo field 
behavior. 

Now we can use the address block feature to extract the data from the block of text we have extracted. 

Steps: 

 In Table view, select Table Design  from the Table ribbon to launch the Table Design interface and then 
click Add > Address Block to begin defining your address block.  

The Name and Postal Code Formats tab opens. 

 

Figure 8-6. The Address Block Wizard. 
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 Enter Address1 in the Name field and then click the  button that appears beside the field. 

 Select the Input Fields tab. 

 In the Available Fields list, select Customer Full and then click the Add >> button to add the field to the 
Selected Fields list. This command specifies that our address block will be based on the Customer Full field.  

Double-clicking on a field in the Available Fields list also transfers the field to the Selected Fields list. 

 Click the Output Fields tab. 

 Select the Address Line 1 check box. 

 Replace the Address BlockLine1 entry in the Output Field Name field adjacent to the Address Line 1 field with 
Customer.  

 Select Address Lines 2 and 3, City, Region, Postal Code, and Country, and rename the fields as follows: 

• Address1 

• Address2 

• City 

• State 

• Zip 

• Country 

 Click the Accept  button after all the fields have been named.  

 Display the Table view window and then scroll right to display the address fields. You can click Autosize 

Columns  in the Table view ribbon to display all of the fields properly. 

 

Figure 8-7. Sample of extracted addresses in Table view (column widths adjusted to show all seven address fields). 

Note that Monarch has extracted all the information contained in the original address block and categorized it 
correctly into the defined fields.  

The final step in this exercise is to hide the original field we used to extract the address block information, 
Customer Full.  
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 Using your mouse, right-click anywhere on the Customer Full field. From the context menu that displays, select 
Hide Customer Full.  

The table displays once more without the Customer Full field.  

 

NOTE To redisplay hidden fields, right-click on your mouse in Table view and then select 
the Show Hidden fields option in the context menu that displays. A list of hidden 
fields appears. Select the field to redisplay from this list. 

 

 Close the lesson and model files without saving any changes.  

We will cover hiding fields more thoroughly in the next lesson. As you can see from the table, the Address Block 
is a simple but powerful feature, capable of extracting information from addresses around the world.  

USING THE AUTO-DEFINE FEATURE IN REPORT 
VIEW 

Now that we know how Monarch allows you to manually create traps to extract data from a report, let’s turn our 

attention to the Auto-Define  feature in Report view. This new feature allows you to automatically define detail 
traps.  

Steps: 

 Open the Employ.prn report. The report displays in Report view. 

 

Figure 8-8. The Employ.prn report. 
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 Click Auto-Define  on the Report view toolbar. The Template Editor displays with the trapping results. Note 
that the Trap line is automatically filled with trap characters. 

 

Figure 8-9. The Template Editor window showing the results of an Auto-Define trapping operation.  

 Scroll down to view the highlighted lines.  

Monarch analyzes the detail line we selected as our sample and selects all the other lines in the report that have 
the same format. 

USING THE AUTO-DEFINE TRAP FEATURE IN 
REPORT DESIGN VIEW 

Now that we’ve seen how Monarch allows you to manually create traps to extract data from a report, let’s turn our 

attention to the Auto-Define Trap  feature. This new feature allows you to automatically define traps.  

One way we can explore just how effective this tool can be is to use it on the report we were just working with. Using 
the Employ.prn report, we can compare the auto-define trapping process with the manual trapping procedure we just 
performed. 

There are three important things to consider when using the auto-define trap feature:  

❑ When selecting your sample line (Step 3 below), it is important to select a line that best represents the bulk of the 
lines in the report, since Monarch will trap all the lines that feature formatting that matches your sample line. 

❑ After you have selected the Auto-Define Trap  button (Step 4 below), be sure to examine more than just one 
or two pages of the report. If you fail to do so, you may overlook lines of the report that you wanted to capture but 
Monarch failed to trap due to some anomaly in them. 

❑ Lines left unchecked (Step 6 below) in the Auto-Define Trap window will not be trapped by Monarch, so be sure 
to select the check boxes of all of the lines you want trapped.  
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Steps: 

 Open the Employ.prn report. The report displays in Report view. 

 

Figure 8-10. The Employ.prn report. 

 Select Report Design  to activate the Report Design interface.  

 Click on the line selection area to the left of the detail line (e.g., the one containing Stephen McPherson) and 
then select New Template > Detail. Ensure that the Trap Type is set to Standard Trap. 
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Figure 8-11. Selecting the detail line. 

 Click Auto-Define Trap  on the toolbar. The Auto-Define Trap window displays. 

 

Figure 8-12. The Auto-Define Trap window.  
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 Scroll down to view the highlighted lines. Monarch analyzes the detail line we selected as our sample, and 
selects all the other lines in the report that have the same format. 

Note, however, that the auto-define trap feature has failed to select all of the detail lines.  

 

Figure 8-13. Viewing detail lines that haven’t been trapped.  

This is because, while the detail line we selected as our sample contained a street address that begins with a 
number (e.g., “410 Market Street”), a few of the street addresses in Employ.prn begin with a letter, as in “PO Box 
1752”. When comparing the sample line with all the detail lines in the report, the auto-define trap feature opted 
not to trap any lines with such a discrepancy. 

Note that, on the first page of the report, there are two detail lines which weren’t trapped. We obviously want 
these detail lines to be trapped, however, as well as any that may exist on other pages of the report. Fortunately, 
the Auto-Define Trap window provides an easy way to ensure that they are selected. 

4. Select the check boxes for the two detail lines whose street addresses are PO box numbers (see Rows 16 and 
30). Note that the text color for these two detail lines changes from black to red. This is simply to notify us that 
the lines don’t perfectly match the sample detail line. 

  

Figure 8-14. Selecting the additional detail lines.  

5. Click the Apply Changes  button. This tells Monarch to additionally trap any lines that match the format of 
the newly selected ones. The additional detail lines we selected are now highlighted.  
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Figure 8-15. Viewing the result of the recalculation.  

Although we could check the other pages of the report for detail lines which haven’t been trapped, let’s see if the 
detail lines we’ve selected are sufficient. 

6. Click the Accept  button to close the window, and then scroll down to make sure that all of the detail lines 
have been successfully trapped. 

 

Figure 8-16. Scrolling the report to make sure all the detail lines have been trapped. 

Note that the Trap line is automatically filled with trap characters.  
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USING FLOATING TRAPS 

In addition to the address block feature, Monarch has another special data extraction feature called the Floating trap 
type. Let’s take a few moments to learn about this powerful feature.  

In many reports, particular fields of data, such as names and addresses, occur in consistent locations (i.e., they begin 
at the same horizontal position throughout the report). For example, in the following report, note how all of the first 
names begin at the same horizontal position, as do all of the last names, streets, cities, etc. 

 

Figure 8-17. A report showing consistent data placement, as is typical of many reports.  

Because of the consistent placement of data within the report, defining a trap to capture each occurrence of any one 
of these fields would be quite easy. With some reports, however, a standard trap won’t work because data placement 
within them is irregular rather than consistent.  

In the following report, for example, note how the occurrences of the date/time field ("[23/Aug/2008...") begin at 
different horizontal positions. 

 

Figure 8-18. A report showing inconsistent placement of the date/time data.  

In reports such as this, a standard trap will not work. Fortunately, Monarch includes a special trap called the floating 
trap, which can successfully extract data from many log files, reports and HTML files in which the data placement is 
not fixed. 
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Using the Floating Trap to Capture Lines 

To familiarize ourselves with the floating trap, let’s open the above report and create a floating trap to capture the 
date/time fields it contains. 

Steps: 

 Open the Weblog.prn report and select the first line. 

 Select Report Design  to launch the Report Design interface.  

 Click in the line selection area to highlight the first detail line in the report and then select New Template > 
Detail. Ensure that the Trap Type is set to Standard Trap. 

 

Figure 8-19. Highlighting the first detail line in the report.  

 From the Trap Type drop-down, select Floating Trap. 

 In the Trap line, enter a left bracket directly above the left bracket in the Sample Text line, as in the following 
figure. 

 

Figure 8-20. Entering a left bracket in the Trap box.  

 In the Sample Text line, highlight the date/time field once more.  

 Scroll down through the report once again. Notice that all of the date/time fields are now highlighted, indicating 
that they will be successfully captured. 

The floating trap works by looking across the lines to find the trap characters horizontally, rather than vertically, 
as in a standard trap. The trap then uses the characters to decide when fields can possibly start and finish. The 
field we have chosen to trap has a fixed width, but we will explore fields that have variable widths later in the 
lesson. In this example, we have only defined that the field should begin after the bracket character; we could 
also define a close bracket to dictate where the field ends. 
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Figure 8-21. Previewing the template again. Note that all of the date/time fields are now highlighted.  

 In the Name field of the Field Properties panel, enter Date/Time to name the field and then click the  button 
that appears below the field. 

 On the Template Editor, replace Detail in the Template Name field with Date/Time to name the template, and 

then click the Accept  button. Monarch closes the Template Editor and returns to Report view. 

 Select the Table tab to view the Date/Time information in Table view. Scroll downward and note that all 916 
date/time fields within the report have been successfully extracted. 

 

Figure 8-22. Viewing the Date/Time table (scrolled to the bottom).  

Now that we’ve seen how the floating trap can define lines where the trap character appears, let’s explore 
another one of its capabilities.  
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Using the Floating Trap to Define Fields 

In addition to defining lines that contain the trap character, the floating trap can be used to define the width of variable 
length fields. If we return to our Weblog.prn report, we can see how this works. 

Steps: 

 Select the Report tab and then click Report Design  to launch the Template Editor.  

We now want to extract the data from the first field, which has a variable width. In order to do this, we can use a 
trap character to tell Monarch where the field begins and ends. Since this field is left justified, we only need to be 
concerned with where the field ends.  

 Position the cursor in the Trap line after .net, click the Blank Trap  button and then highlight the text in the 
sample line as in Figure 8-23.  

 

Figure 8-23. Floating Trap with the blank trap added.  

Note the results in the Report view portion of the window. 

 

Figure 8-24. Floating trap with variable width fields.  
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As you can see, the fields have been highlighted and the highlighting has shrunk to accommodate any field 
shorter than the fields we originally selected. There are some longer fields, however (e.g., “PPPa28-
Resale_Vancouver"), in which the field is wider than the highlighting. This would result in an incomplete 
extraction of data. To rectify this, we need to manually specify the length of this field.  

 Click the newly defined field eg_ezvl-30ppp187_epix_net in the Sample Text box and then select Edit Field to 
display its general properties in the Field Properties window.  

 Click the Template tab. 

 On the Template Width field in Field Properties, enter 60 and then click enter.  

 Press Accept  (on the Ribbon) to accept the sizes then view the result. 

Note that all of the data is now trapped correctly. 

 

Figure 8-25. Viewing the finished floating trap.  

 Select the Accept  button to return to the Report view and then select File > Close All  to reset the 
Monarch session. Select No when prompted to save changes to the model. 
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USING MULTI-COLUMN REGION TRAPS 

When working with Monarch, you may occasionally encounter a report that has a layout similar to that of a 
newspaper, i.e., one with multiple, adjacent columns of data on each page. For example, the following report contains 
a list of composers, numbered 1 through 90, and the list is broken into three columns, each containing thirty names. 

  

Figure 8-26. Viewing a report with multiple columns.  

To handle such reports, Monarch includes a Multi-column region (MCR) trapping feature which you can use to trap 
the data in multiple columns via only one template.  

Extracting data via the MCR trapping feature consists of three simple steps. First, you define the multi-column region 
via the Multi-Column Region Definition window, then you create a template to extract the desired data from the report, 
and finally you specify the vertical boundaries (i.e., beginning and ending points) for the columns. 

Let’s open a multi-column report and extract data from it via the MCR trapping feature. 
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Steps: 

 Open the Composers.prn report. 

 

Figure 8-27. The multi-column Composers report.  

This report contains the same list of composers we saw a moment ago. Composers.prn lists the names of ninety 
composers, arranged in three columns of thirty names, and ranked in order of popularity (1 = most popular, 90 = 
least popular) for each customer.  

Now that our multi-column report is open, let’s define the multi-column region.  

 Select the first line of the report, select Report Design  from the Report ribbon, and then click Multi-Column 

Region  on the Report Design interface. 

The Multi-Column Region (MCR) Definition window displays.  

 Select Enable MCR to activate the window. 
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Figure 8-28. The Multi-Column Region Definition window with a checked Multi-Column Region is active box.  

A series of red, vertical broken lines – or column indicators – appears over the report to indicate where the 
columns currently are. 

Now we need to examine the report to determine the number of columns we want the multi-column region to 
contain. This number should obviously equal the number of columns in the report which, in this case, is three.  

 Enter 3 in the Number of Columns box.  

The number of columns you specified determines the number of column indicators that appear. Since we entered 
3 in the Number of Columns box, three column indicators have appeared, as displayed in Figure 8-29.  
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Figure 8-29. Viewing the column indicators.  

Next, we need to specify a left margin for the leftmost column, i.e., specify the position where we want the 
leftmost column to begin. Since the text in the leftmost column begins at the left edge of the report, the current 
setting of 1 is the one we want, so we can leave it as is.  

 

NOTE If the text in the leftmost column began one space in from the left edge of the report, 
then we would enter 2 in the Left Position of First Column box. If the text began two 
spaces in from the edge of the report, we would enter 3 and so on. 

 

Now we need to adjust the width of the column indicators to match the width of the data columns in the report. 

 In the Width of Each Column box, adjust the value until you obtain the correct width. For this report it is 29.  

The column indicators move to the left to reflect the change to the column width. Note that all three columns of 
composer names and ranking numbers now fall within the column indicators (scroll down to see this, if 
necessary).  
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Figure 8-30. Viewing the column indicators in the Report view.  

 Click Accept  to accept the current MCR settings and close the window. 

The Report Design displays with the column indicators still displayed on the report.  

  

Figure 8-31. Viewing the column indicators in the Report view.  
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Now that we have determined the necessary number of columns, and have specified their width and the starting 
position of the leftmost column, we’re ready to define a template to extract the data. 

Creating a Template to Trap Multi-Column Data 

The process of trapping data in a multi-column region report is the same as that for any other report. The first step is 
to select a template sample. 

Steps: 

 Ensuring that you are in the Report Design interface, click on the line selection area to select the top line of 
composer names (i.e., the one beginning with PACHELBEL, J.), select the drop-down button for New Template, 
and then select Detail. Ensure that the Trap Type is set to Standard Trap.  

Note that the Multicolumn Design Mode button is selected in the Template Editor. 

Your screen should look as in Figure 8-32.  

  

Figure 8-32. Selecting the top line of composers.  

 In the Trap line, place the cursor above the “P” of Pachelbel in the Sample Text line, then click the Alpha Trap 

 button. 

 In the Trap Line, place the cursor above the “1” in the Sample Text line, then click the Numeric trap  button. 



 

Altair Monarch 2024.0 Learning Guide  220 

 

  

Figure 8-33. Viewing the results of the non-blank and numeric traps. 

 In the Sample Text line, highlight the composer name and then highlight the number 1. 

 

NOTE When highlighting the composer’s name, extend the highlight well beyond the end of 
the name, as some of the composers’ names are longer than the one in the Sample 
Text line. Likewise, when highlighting the number “1”, be sure to begin the highlight 
at least one space before the number, as the numbers extend into the double digits. 
See Figure 8-34 for an example of how you should highlight the fields. 

 

 

  

Figure 8-34. Highlighting the fields. 

 Select the number 1 in the Sample Text box to display its general properties in the Field Properties panel. 

 Type Rank in the Name field and then click the  button that appears below the field. 
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 Select the text PACHELBEL, J in the Sample Text box to display its general properties in the Field Properties 
panel.  

 Rename this field Composers and then click  to accept your field name definition.  

 Click Accept  to save your template definitions.  

  

Figure 8-35. Viewing the results of the Composers template in the Report view. 

Now let’s create an append template to extract the contact data from the report. This template will also help us 
specify our vertical boundaries for the MCR, which we will discuss in the next lesson.  

 Select Report Design  to activate the Report Design interface.  

 Click in the line selection area to highlight the first contact line (i.e., the line containing CUSTOMER: Betty’s 
Music Store), select the drop-down button for New Template, and then select Append. Ensure that the Trap 
Type is set to Standard Trap. 
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Figure 8-36. Selecting the template sample. 

 To create the trap, type customer in the Trap line above “CUSTOMER” in the sample line and then highlight 
Betty’s Music Store in the sample line. Be sure to extend the highlight well beyond the end of the last name, as 
in Figure 8-37. 

  

Figure 8-37. Highlighting the Contact field. 

 Rename the field eg_Betty’s Music Store to Contact in the Field Properties panel and then click the  button 
to accept your changes.  

 Rename the template Contact and then click the Accept  button to accept your changes. You are returned 
to Report view and fields corresponding to the Contact template you have just defined are highlighted.  

If we wanted to, we could now create additional append templates to capture more information from the report, 
such as “CUSTOMER” and “ACCOUNT NUMBER” fields. Instead, let’s move on and learn how to specify vertical 
boundaries for the MCR.  
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NOTE As an example of a model file that contains additional append templates, Monarch 
includes a Composers.xmod file in the Monarch Models folder. 

 

Specifying Vertical Boundaries for the MCR 

So far, we have configured the column indicators to the correct width and have created a detail template that extracts 
the composer’s names and rank numbers from the report. We also created a Contact append template, which will be 
helpful to us when specifying vertical boundaries for the multi-column region.  

 

NOTE When we specify vertical boundaries for the MCR, we specify the top and bottom 
boundaries for the columns within it. 

 

Steps: 

 Select Report Design  to activate the Report Design interface.  

 On the Report Design ribbon, select Multi-Column Region  to display the Multi-Column Region Definition 
window.  

 Select the Start after > Template radio button option and then ensure that Contact is selected from the 
Template drop-down list. 

A horizontal broken line appears at the top of the composer columns, just below the “CONTACT” line. This line 
indicates the top boundary of the multi-column region. Everything above this line will be excluded from the 
MCR.  
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Figure 8-38. Viewing the top boundary of the MCR (just below the CONTACT line). 

 Scroll down through the report to locate the bottom boundary of the multi-column region. 

Note that the current bottom boundary setting for the MCR is Stop at > Bottom of page. Notice that the bottom 
boundary of the MCR occurs just after the end of the columns on Page 1 and before the beginning of Page 2, as 
specified by the current bottom boundary setting. This boundary will suit our purposes as is, so we don’t need to 
adjust it.  
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Figure 8-39. Viewing the bottom boundary of the MCR. 

Now that you’ve seen how helpful templates can be when specifying the top and bottom boundary settings of the 
MCR, keep this in mind, as you can create blank traps solely for this purpose.  

 Click Accept  twice, once to save the current MCR settings and then a second time save the current 
template settings. 

Monarch redisplays the Report view. 

Let’s view the trapped data in Table view. 

 Select the Table tab to display the extracted data in Table view.  

 Select Autosize Columns  to view all of the fields properly.  

Monarch displays the extracted data in the Table view.  
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Figure 8-40. Viewing the extracted data in the Table view (column widths adjusted to show column names).  

At this point, you can either save your work or close the report and model.  

USING REGULAR EXPRESSION TRAPS 

Recall that in Chapter 8, we attempted to trap the Ship Date line but also picked up unwanted data as well, i.e., the 
Return Authorization and Received fields. We rectified this issue by creating an exact trap. We then showed how we 
can avoid this issue by using an exclusion trap. We could also have created a regular expression trap. Regular 
expression traps allow sophisticated Monarch users a high level of flexibility when creating templates because this 
type of trap automatically considers variable spaces between fields of interest. Thus, this trap can be very useful 
when field positions change on a page or when field positions change with respect to other fields.  

All of the traps we have described thus far may be translated into a regular expression trap, and the first step of 
creating such a trap involves selecting a line with fields we want to trap. Similar to all of the previous traps/templates 
we created, a detail trap must be created before append, header, or footer traps. 

Let’s trap the Customer line of Classic.prn using a regular expression trap. 

Steps: 

 Open Classic.prn and Lesson1.dmod. 

 Select Report Design, choose the line containing the text CUSTOMER as the sample text, and then select New 
Template > Append.  

 Rename this template as Customer. 

 From the Trap Type drop-down, select Regular Expression Trap. 

 Select Ignore Case from the Options drop-down that displays on the Action toolbar when the regular expression 
trap type is selected.  

 In the trap line, type in the following: customer:\s*(?<customer>[A-Z].*) 
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The trap we have just created instructs Monarch to look for a line marked “customer:” ignoring case and with any 
number of spaces following it and then select all of the text following this marker provided that the first character 
of the text to be captured begins with any character from A to Z.  

 

Figure 8-41. Creating a Regular Expression trap. 

Note that Betty’s Music Store is highlighted as though we have selected it as a field.  

 Right-click on Betty’s Music Store in the sample text line and select Create a field from this capture > 
customer. 

The Customer field is created  

 

Figure 8-42. Data preview of the newly created Customer field. 
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Note that regardless of the length of the customer name, the field is always captured correctly. 

 

Figure 8-43. The customer name “Die Melodie” is captured correctly even though we did not specify how large the 
field length should be. 

USING EXCLUSION TRAPS 

Monarch offers a solution for instances where you may wish to exclude specific lines from being picked up by a 
previously defined template. To address this issue, you can create an exclusion template. 

Steps: 

 Open the Classic.prn report and go to page 4. 

Note that this page includes details for a return authorization as well as the received date. 

 

Figure 8-44. Page 4 of the Classic.prn report includes Return Authorization entries.  
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If we were to trap the order numbers using an exact trap (e.g., a colon), the return authorization will also be 
picked up. When we trapped the order number line in a previous exercise, we used an exact trap and specified 
that all order numbers beginning with 5 must be captured. But what happens when the order number begins with 
a 3 or a 4? Let’s use an exclusion template to address this issue. 

 Click on the line containing the return authorization entry and then select Report Design. 

 Select New Template > Exclusion. Ensure that the Trap Type is set to Standard Trap. 

 On the trap line, click on the position right above the first letter of the word “Return” and then type in return. Note 
the change to the report shown below. 

 

Figure 8-45. Excluding Return Authorization entries with an exclusion trap.  

 Select Accept.  

The template we have just defined instructs Monarch to not pick up data from lines marked with “return” at 
position 7. In Report view, the Return Authorization line is marked as follows: 

 

Figure 8-46. Report view showing markings of an exclusion template. 
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You can now trap the Order Number line using a semi-colon if you wish. 

USING START AND END REGION TRAPS 

A Start Region trap identifies a line in a report where all other types of trapping (e.g., detail traps, append traps) 
should begin. Correspondingly, an End Region trap identifies a line in a report where other types of trapping should 
end. These trap features may be used in combination to specify a section (or similar sections) of a report containing 
data that should be further trapped.  

Start/End Region traps generally make use of exact-match traps to specify at which line of a report trapping should 
begin/end. Only one Start and one End Region trap may be created in a model/project.  

 

NOTE Start and End Region traps are not generally used to specify sections that should not 
be trapped. In this case, exclusion traps should be used. 

 

In the following example, we’ll create start and end traps spanning the first 10 entries of a patient report and then 
extract the patient name and service code from these entries.   

Steps: 

 Open the report file Patient.prn. 

 In Report Design view, choose the line in the report beginning with “Michael Canton” as the sample text and then 
select Start Region from the New Template drop-down. 

 Create the trap shown below.   

 

Figure 8-47. Establishing a Start Region trap. 

Note that guillemets mark the first instance of “Michael” in the report and that all other lines before this one are 
marked with an X. 

Because the entry “Michael Eagan” in page 2 of this report, we can’t simply use the trap “Michael.” Otherwise, 
data beginning from this line and continuing downward would also be captured.  
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 Click to the left of the line beginning with “St Louis MO” so that the line is selected and then choose End Region 
from the New Template drop-down. 

 Create the trap shown below. 

 

Figure 8-48. Data preview of the newly created Customer field. 

Note that guillemets appear to the left of the line marked “St Louis MO” and that all other lines after this one are 
marked with an X. 

 Click on the first line of the report marked “Michael Canton” once more and then select Detail from the New 
Template Region. 

 Create the trap shown below. 

 

Figure 8-49. Trapping specific patient information. 
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 Highlight the fields Michael Canton and A0028. Extend these fields to ensure that all of the names are correctly 
captured. 

 Click Accept to finish trapping and then select the Table tab.  

The trapped data display as follows. 

 

Figure 8-50. The results of the present trapping operation. 
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[9] WORKING IN TABLE VIEW 

Since you’ve learned how to create several templates for and extract data from a report in the previous lesson, let’s 
see how you can work between the Report and Table views.  

This lesson will show you the basics of navigating and working in the Table view. Later lessons describe how to use 
Monarch’s built-in expressions to calculate new fields, create filters, and create sort definitions in the Table view. 

When analyzing data in Table view, you may want to refer to the actual report to verify whether or not the captured 
information is correct. You may also want to refer to the Table view, when in the Report view, to obtain a summary of 
the information relevant to a specific record. The ability to switch between Report view and Table view with ease will 
certainly benefit your working experience with Monarch.  

To start, open the Classic.prn report and the Lesson1.dmod model. 

GETTING TO KNOW TABLE VIEW 

The Table View Interface 

Let’s take a minute to explore what you can find in the Table view interface. 

  

Figure 9-1. An open table in Table view.   

The Table interface is divided into three distinct areas. The Table ribbon is located on the top-most portion of the 
interface and spans the entire width of the screen. This ribbon will allow you to perform many of the table functions 
made available by Monarch. The Table Selector displays as a panel on the left-hand side of the interface, and the 
actual table is displayed on the right-hand portion of the interface. 

Right-clicking on the Table selector displays a context menu that will allow you to perform the following operations: 

❑ Perform a quick export - This export operation uses the default file extension and values specified in Export 
Settings and presents the Create Export dialog with all elements prefilled 

❑ Rebuild the table 
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❑ Add an external lookup to a table 

❑ Print a table 

❑ Quick print a table 

❑ Preview a table before printing 

❑ View model information 

❑ View project information 

❑ View the model audit trail 

❑ View the project audit trail 

The Table View Ribbon 

The following table summarizes the functions of each of the buttons in the Table ribbon.  

Use this button… To… 

 Table Design  
Launch the Table Design interface 

 Font Style 
Select a font style 

 Font Size 
Select a font size 

 Zoom to Fit 
Set the zoom level to fit all fields on screen 

 Autosize Columns Resize columns in a table  

 Select All 
Select all of the records in the table 

 Copy 
Copy records in the table 

 Search 
Search for a specific record in the table 

 Active Filter 
Select a filter to apply to the table 

 Active Sort 
Select a sort to apply to the table 

 Go to Row 
Locate a specific row or column in a table 

 Find in Report 
Find the line in the report from which the value in a table 
row was obtained  

 Rebuild Data View 
Recalculate the table. This can be useful if you use 
external lookups and wish to check for the most current 
data. 

 Show Field Contents 
Show the contents of memo fields 

 Freeze Panes 
Freeze specific columns and/or rows while scrolling 
through a table 

 Open Table in Data Prep Studio 
Open the table in Data Prep Studio 
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The Table View Context Menu 

Right-clicking on any column in Table view reveals a menu that will allow you to quickly do the following: 

❑ Copy text 

❑ Copy with formatting 

❑ Search for a specific record 

❑ Go to a specific row 

❑ Go to a specific column 

❑ Find a specific record in a report 

❑ Autosize columns 

❑ Adjust column widths 

❑ Launch the Field Properties window 

❑ Rename a field 

❑ Hide a field 

❑ Show hidden fields 

❑ Create a new calculated field 

❑ Apply a filter or sort  

❑ Print the table 

❑ Launch print preview 

❑ Export the table 

❑ Launch a specific tab of the Table Design view 

GETTING TO KNOW TABLE DESIGN VIEW 

The Table Design Interface 

The Table Design interface allows you to actively work with your data to obtain the information you need using the 
fields you extracted in a report. This interface initially shows you a list of all of the fields you extracted, as well as their 
properties, and a ribbon from which you can select several tools to further build your data table.  
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Figure 9-2. The Table Design interface.  

At the bottom of the Table Design interface is a Data Preview panel, which functions exactly like the Data Preview of 
the Template Editor. This panel will show you how your Table view is going to look once changes made using the 
Table Design interface have been applied.  

The Table Design Ribbon 

The following table summarizes the functions of each of the buttons in the Table Design ribbon.  

Use this button… To… 

 Accept Accept the new template or changes to an existing 
template 

 Cancel 
Cancel the new template or changes to an existing 
template 

 Add 
Add a new field to the table. This table could be a 
formula field, a lookup field, a runtime field, etc. 

 Duplicate 
Duplicate the summary 

 Delete  
Delete a selected field 

 External Lookups  
Add an external lookup to the table 

 Field List 
Display the field list 

 Input Fields 
Display the properties of each input field 

 Database fields 
Display the properties of each database field. This 
button only displays when a database table is opened. 
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Use this button… To… 

 Formula Fields 
Add a formula field to the table 

 Lookup Fields 
Add a lookup field to the table 

 Runtime Parameter Fields 
Add a runtime parameter field to the table 

 User Edit Fields 
Add a user-edited field to the table 

 Filters 
Add a filter definition to the table 

 Sorts 
Add a sort definition to the table 

 Address Blocks Extract data from addresses 

 Functions 
Add a field function to the table 

 Help 

Launch the Help file 

 

NAVIGATING THROUGH A TABLE 

Finding Information in a Table 

While working with Monarch, you may need to locate information in Table view. You can easily do this if the report is 
short enough using the scroll bars. Classic.prn, for example, spans only 149 rows, so you might opt to use the scroll 
bar to search for information in this report. However, what if the report spans 1,376 lines? How would you search 
these lines to locate a single record? Monarch presents an easy way to do this via the Search box, which may be 
accessed by clicking Search on the Table ribbon. 

The search options for Table view varies significantly from the search options for Report view in that the former 
includes a search option for expressions. 

 

Figure 9-3. The Search panel for Table view.  

Since we already know how to do basic keyword searches, let’s try searching through Table view using the 
Expression Builder. Before we do so, ensure that the first field of the first column is selected, signaling the 
beginning of the table.  

Steps: 

 In Table view, select Search  from the ribbon so that the Search box displays at the top of the table. 

 Check the box for Expression Search. 

 Let’s search for all records with amounts of greater than or equal to 100. In the search box, type in Amount 
>=100 and then click Find Next.  
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Record 49 in Table view is highlighted. If you scroll all the way to the right of this record, you will see that it has a 
total amount of 307.20. A quick look through all other amounts preceding Record 49 shows no other record with 
an amount greater than or equal to 100.  

 

Figure 9-4. Record 49 is highlighted, signifying the first record for which the expression Amount >= 100 is true as a 
search parameter.  

 Click Find Next once more.  

This time, Record 78 is highlighted, signifying the second record with an Amount value greater than or equal to 
100. 

 Close the Search box by clicking the Close X icon located to the right of the Search box.  

Displaying the Source of a Record 

To locate the source of Record 28, we’ll use the Find in Report  button.  

Steps: 

 From the top of the table, scroll down until Row 28 is visible. 

Notice that Record (Row) 28 has a value of –59.90 entered in the Amount column. 

 In the Table ribbon, select Find in Report .  

The Report view displays, showing the report for Record 28 in the table. The line from which the detail fields 
were extracted is highlighted (see Figure 9-5). 
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Figure 9-5. The details for Record 28 in the Table view are located in the Report view.  

NOTE 
Using the Find in Table  Button 

You can also locate the record number (table record) of any item within a report, 
along with pertinent information regarding the item (the amount of information you 
can obtain depends on the templates you’ve set up) from the Report view. To do so, 
click on the detail item of interest in the Report view and then select Find in Table 

 from the Report ribbon. Table view displays the record number, as well as other 
information, for the detail item. 

 

Changing Fonts and Font Sizes 

As in Report view, Monarch allows you to change the font and font size used to display tables on screen.  

Steps: 

1. To change the font, in the Table ribbon, click the drop-down  button on the Font Style box.  
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Figure 9-6. Changing font styles. 

2. Select the Trebuchet MS font from the list.  

The font style is changed throughout the entire report. 

 

You may also change font size in order to zoom in or zoom out on the table. Experiment with the font size until you 
find the size you like best. 

Steps: 

1. Click the drop-down  button on the Font Size box. 

 

Figure 9-7. Changing font sizes.  

Font sizes vary depending on the font style selected. If the size you want isn’t available, use the font list to select 
another font.  

2. To change the font size to match the table width to the display width, from the Table ribbon, select Autosize 

Columns . 

This selects the font size that matches the table width to the display width so that you can view the entire width of 
the table, or as much of it as possible, on screen. 

If the table is too wide to fit on screen even at the smallest available font size, Monarch will select the smallest 
font size to fit as much of the table width as possible in the available display area. 
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FORMATTING FIELDS 

As we’ve seen, Monarch automatically formats the data as it builds the table. The column width is also set for each 
field to display the widest field value. You can override these automatic assignments, and you can make several 
other format adjustments, as discussed in the next few sections.  

You will learn how to: 

❑ Fill empty cells 

❑ Adjust field widths 

❑ Move fields 

❑ Hide fields 

For this lesson, ensure that Classic.prn and Lesson1.dmod are open in Monarch and that you are viewing the Table 
interface.  

Filling Empty Cells 

Sometimes the report data includes “assumed dittos.” An example would be the Media column sample shown in 
Figure 9-8. 

 

Figure 9-8. An assumed ditto in the Report view.  

In this list, the media identifier “CD” obviously applies to the first three entries in the list, rather than just the first entry, 
even though it is only shown explicitly in the first entry. When these entries appear in the table (Records 1–3 in Table 
view), the “CD” is missing from the last two entries. 

Monarch has an easy solution to this. 

Steps: 

 In Table view, double-click on the Media field to display its properties via the Field Definition window.  

 Select the Template tab of the Field Definition window to display the template properties of the Media field. 

 Check the box for Empty Cells: Copy value from previous record and then click Accept  to close the Field 
Definition window. 

The table is rebuilt and Monarch fills in the blank cells in the Media field. 
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Figure 9-9. Blank cells are no longer present in the field.  

Adjusting Field Widths 

When you view a table, the columns may sometimes not be wide enough to display the entire field name. When this 
happens, the field name will appear truncated. In other instances, even when the field values are not truncated, the 
columns may appear too close together. 

 

Figure 9-10. The widths of the fields Order Number and Description are too narrow.  

In the figure above, for example, the field width for the Order Number column is so narrow that the field name is 
truncated and the field width for the Description field is so narrow that the individual records (rows) are truncated.  

You can resize field widths to properly display field names and records via four ways: 

❑ Using the Field Definitions window 

In the Field Definition window, select the field whose width you want to increase and then increase the number 

shown in the Display Width box in the General tab that displays. Select Accept  twice when you are done to 
apply your changes.  

❑ Using the mouse 

Move the mouse pointer to the right edge of the relevant field title. The mouse pointer will become a resizing 
handle, which you can drag left or right to resize the field. 
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❑ Using the Autosize Columns  button  

The use of this button resizes all fields to match the widest field value or the field name, whichever is wider. 

If you reduce the width of a character field or a date field to less than the length of a field value, the field value is 
truncated on screen. If you reduce the width of a numeric field to less than the width of a field value, the field 
value is truncated as well.  

❑ Using the Column Widths functionality 

Right-clicking on a field produces a menu from which you can choose “Column Widths” and then three other 
options for resizing the width of a field. 

You can either: 

• Set the column size to the width of the widest column label, or 

• Set the column size to the width of the widest data value, or 

• Set the column size to the width of a specific field 

 

NOTE The column width setting affects only the appearance of the data on screen and in 
printed output. It does not affect the underlying data. 

Ordering Fields 

Table fields may be ordered any way you wish by dragging and dropping a field or several fields into a new location in 
the table or using the Move Up/Move Down buttons in Table Design view.  

Hiding Fields 

Frequently, you may want some data hidden from view but not deleted from the table.  

 

NOTE Hidden table fields are not available for export and copy operations. 

 

 

For example, the Report Date and Page fields contain useful information, but you may not want them visible while 
working with data from the other fields. Let’s hide these fields. To do so: 

Steps: 

 In Table view, click anywhere on the Report date field. 

 Using your mouse, right-click and then select Hide from the context menu that displays.  

The field is immediately hidden.  

 Repeat Steps 1 and 2 to hide the Page field. The selected fields are now hidden (see Figure 9-11). 
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Figure 9-11. The Report Date and Page fields are now hidden.  

ASSIGNING FIELD TYPES 

When Monarch builds a table, it automatically assigns a field type to each field based on the first instance of that field 
in the report. If Monarch finds a number when it first extracts a field, for example, it assigns the numeric format. 
Usually, the first instance of a field is representative of other instances; when it is not, however, you must manually 
override the assigned format to assign the proper format. 

You can set fields to have one of the following formats: 

❑ Character 

❑ Numeric 

❑ Date/Time 

❑ Memo 

When Monarch assigns an incorrect field format, you can change the setting to a more appropriate one using either 
the Field Definition window or the Table Design interface. 

❑ Using the Field Definitions window 

Double-click on the field of interest in Table view. In the Field Definitions window that displays, select the 
appropriate field type from the Type drop-down field in the General tab.  

❑ Using the Table Design view 

On Table view, select Table Design . Select the field whose format type you wish to change from the list that 
displays and then click its corresponding cell under the column Type. A drop-down button displays to the right of 
the cell. Use this drop-down to select a new field type.  

At this point, you can either save your work or simply close the report and model you opened.  
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CREATING HEADERS AND FOOTERS 

Creating a Page Header 

Monarch allows you to add a descriptive title to the top of each printed page via the Header Layout settings of the 
Page Setup dialog. 

A page header is divided into three sections, Left, Center, and Right, all of which represent locations in which you 
may want to add information. You can dynamically add information to the page header, including page numbers, the 
print date and time, the names of the active filter and sort, as well as the first value of any field in the table. You can 
also add any text you wish and even specify the font to use in the header.  

Before we begin, ensure that you have the Classic.prn report and Lesson1.dmod model open and that you are in 
Table view. 

Steps: 

 Select File > Page Setup . 

Note that because you have both a report and a table open in the current Monarch session, the Page Setup 
dialog slightly differs from the dialog we saw in Chapter 6.  

 

Figure 9-12. Adding a page header to the printout.  

 On the left-hand side of the dialog, select Table from the list of available views. 

The Page Setup dialog displays page options available for Table view. 
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Figure 9-13. Page preferences for Table view.  

 Select the Header Layout tab. 

 Double click on the first cell of the column labeled Left. 

A menu options arrow displays on the cell. 

 

Figure 9-14. Adding a page header to the printout.  

 Click the arrow that appears and then select Date from the options that display.  

 Double-click on the first row of the column labeled Center. 

 Type Classical Music Distributors into the cell.  

 Double-click on the first row of the column labeled Right. 

 Click the arrow on the cell and then select Page Number from the options that display.  

 Double-click on the second row of the column labeled Left. 

 Type Report: followed by a space, and then click the arrow on the cell. Select Input Name from the options that 
display. 

 Double-click on the third and last row of the column labeled Left. 
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 Type Model: followed by a space, and then click the arrow on the cell. Select Model File Name from the options 
that display. 

Figure 9-15 shows how the Page Header section of your Page Setup dialog should look when you are finished.  

 

Figure 9-15. A fully set up page header.  

 Click OK to accept your changes and close the Page Setup dialog. 

 To view your new header, select File > Print  > Print Preview. 

 

Figure 9-16. A fully set up page header.  
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NOTE If your table is wider than it is long, you may wish to change your paper orientation to 

landscape. To do so, select the Paper Orientation  icon on the Print Preview 
window and then select Landscape. 

 

Creating a Page Footer 

Creating a page footer is no different from creating a page header except that, this time, your definition appears at the 
foot of the page. Select Footer Layout from the Page Setup dialog to format a page footer for your table.  

PRINTING TABLE DATA 

In this lesson, you will learn how to print and copy data from Table view.  

This chapter assumes you are familiar with importing and viewing report files, creating data extraction templates and 
working in the Table view. 

Adjusting Page Setup Options 

Several page setup options are provided, and you can use these options to establish margins, add a page header to 
each page, print column titles and row numbers, and print the grid lines that you see on-screen. 

To edit the page setup options, we’ll use the Page Setup dialog. 

Steps: 

 Select File, and then click Page Setup . The Page Setup dialog displays. 

 On the left-hand side of the dialog, select Table from the list of available views. 

The Page Setup dialog displays page options available for Table view. 

 

Figure 9-17. The Page Setup dialog.  
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The tab shows the current margin settings and print options for the table. 

 Ensure that the Show Row Numbers box is unchecked to deactivate row numbers in our printout. Click OK 
when you are finished setting up your page options. 

Printing Table Data 

The table is usually much wider than the report as Monarch combines fields from various levels in the report to create 
each row of the table. When Monarch prints data from the table, it prints as many fields as will fit across the page. If 
all of the fields will not fit on a single page, the remaining fields are wrapped to the next page. The amount of 
information that will fit on each page is determined by several factors: 

❑ The font size has a dramatic effect on the amount of data that fits on each page. To fit all the fields across the 
page, you may need to select a smaller font size. 

❑ The Paper orientation setting specifies the direction that text will print. For wide tables, set the paper orientation 
to Landscape to print the text sideways on the page. 

❑ Margins affect how close text is allowed to print to the edge of the page. You can use the margins to make small 
adjustments to the amount of text that will fit on each page. 

Monarch lets you print just the data you need. You can print the entire table or any selection from the table. Let’s 
select and print the first page of the report. 

Steps: 

 Select File, and then click on the arrow of the Print  menu. Select Print from the options that display. 

The Print dialog displays. 

 

Figure 9-18. The Print dialog.  

 Select the printer you would like to use to print the first page of the report if it has not been selected yet. In the 
above screenshot, for example, the printer HP Laserjet Professional M1212nf MFP was selected.  
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 In the Page Range section, select the button for Pages, and then type the number 1 in the box beside it. 

 Choose Print to print the page. 

The first page of the report is printed. 

COPYING DATA TO OTHER APPLICATIONS 

You can use the Windows clipboard to copy table data to other applications. When you copy data to the clipboard, 
Monarch creates both a text image and a worksheet image (with separate rows and columns). When you 
subsequently paste the data to another application, the application selects the format it needs. 

Let’s copy the records for Betty’s Music Store to your spreadsheet. 

Steps: 

 Return to Table view.  

 Select the first 9 records in the table by clicking down on the row selector to the left of Record 1, then dragging 
down to Record 9. 

 Select Copy from the Table ribbon. 

 Launch your spreadsheet. If you don’t have a spreadsheet, just follow along in the tutorial. 

 Position the cell pointer where you want the data to appear and use your spreadsheet’s Paste command to 
paste the data. For some spreadsheet applications, you may need to use the Paste Special > Text command. 

 Adjust the column fields as necessary to view all of the data. 

 

Figure 9-19. Pasting to a spreadsheet.  

 Adjust column widths and cell formats in your spreadsheet as necessary. 
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NOTE Monarch does not set the column widths automatically because this might alter an 
existing worksheet’s column widths when the data is pasted. If the spreadsheet that 
you are pasting into is empty, you may prefer to export the data using the Export 
command. When data is exported, the column widths are set appropriately for the 
data. 

 

 Exit your spreadsheet without saving it. 

REDACTING FIELDS 

The redaction feature provides a way to remove private or sensitive data from a report. A simple form of redaction 
involves overstriking the sensitive data with “X”s. More advanced forms involve replacing the sensitive data with 
“pseudo” data, i.e., values which are similar in form but have no relation to the actual data. For example, suppose a 
report contains Social Security numbers. It would be difficult to publish an analysis of this report without 
compromising the privacy of the SSNs involved. Monarch’s SSN redaction capability solves this problem by replacing 
the actual SSNs with “pseudo” SSNs – 9 digit numbers that look like Social Security numbers but are actually just 
patterns of digits. The cleansed data may then be analyzed and published without fear of compromise. 

Redacting a Single Field 

To define redaction for any report field, simply choose the desired type of redaction from the Redaction dropdown 
located on the Template tab of the report field editor, as shown below. Choose None if no redaction is desired. Newly 
created report fields always start with redaction set to None. 

 

Figure 9-20. Specifying a redaction format for a single field.  
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Redacting an Entire Model 

It is possible to enable or disable the report field redactions across the entire model, via a checkbox on the Options > 
Input page as shown below. When this box is checked, each report field is redacted (or not) according to its specific 
redaction setting. When this box is not checked, then report field redactions are disabled, so each report field 
behaves as if its redaction was set to None. It should be noted that this setting affects only redactions specified for 
report fields – it has no effect on the behavior of any redaction functions used in calculated field expressions. 

The figure below, for example, shows the redaction properties for all models to be applied in the current Monarch 
session.  

 

Figure 9-21. Specifying redaction for an entire model.  
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[10] WORKING WITH SORTS 

In this chapter, you will learn how to sort data in Table view. The lesson topics include: 

❑ Sorting the table 

❑ Creating a sort definition 

❑ Sorting on multiple fields 

❑ Duplicating a sort order definition 

❑ Restoring the original sort order 

This chapter assumes that you are familiar with importing and viewing report files and working in Table view. 

When you extract data from a report file, the information is arranged in the Table view in the order that it appears in 
the report but you may want to view, print, or export the data in another order. Sorting allows you to re-order the table 
to suit your needs. 

To sort the data in the Table view, you create a sort order definition, which specifies the parameters for sorting. The 
sort order definition includes the fields to sort on, the sort order for each field (ascending or descending), and the 
hierarchy for the sort. You can create multiple sort order definitions and switch between them to see different views of 
your data. 

To start this lesson, load Monarch and open the Classic.prn and Lesson2.dmod. 

CREATING A SORT ORDER DEFINITION 

The Classic report is sorted by Customer and Ship Date. When the report data are extracted and assembled as 
records in the Table view, the records appear in the same order. Records for Betty’s Music Store appear first, then 
records for Big Shanty Music, and so on. Within each customer, the records are sorted by ship dates. While this sort 
order is useful, you may want to view the data in another order. Let’s sort the table based on the Description field. 

To sort the table, you use the Sort Order Definition window to create a sort definition.  

Steps: 

 Select Table Design  from the ribbon to launch the Table Design interface and then click Add > Sort  
from the Table Design ribbon.  
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The Sort Order Definition window displays.  

 

Figure 10-1. The Sort Order Definition window.  

From this window, you can create multiple sort definitions and switch between them to see different views of the 
table. 

The Available Fields box displays the fields from the table. The Selected Fields box displays the fields used in 
the sort definition, from highest sort level to lowest. To add a field to the definition, select the field from the Fields 
box, then click Add >>. To remove a field, select the field from the Selected Fields box, then click << Remove. 

 Type Product Description into the Name box then select the  icon that displays next to the field. 

 

NOTE Sort definition names may be up to 31 characters in length and may contain 
uppercase and lowercase characters, spaces, and punctuation. However, periods (.), 
exclamation points (!), accent graves (`), and brackets ([ ]) may not appear in any 
part of the name. As well, names may not begin with spaces. If a name is entered 
with leading spaces, the name is accepted but the leading spaces are trimmed. 
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 Select the Description field from the Available Fields box, and then click the Add >> button. 

The Description field appears in the Selected Fields box. When a field is moved to the Selected Fields box, its 
initial sort order is Ascending. To change the sort order of a field, right-click on the field to display a context menu 
and select Change Order from the menu. Since we want to sort the field values in ascending order, we’ll leave 
the sort order as it appears. 

 Choose Accept  to accept the sort definition and close the Sort Order Definition window. 

 On the Table ribbon, select the drop-down button of the Active Sort box and then select Product Description. 

The data in the Table view is rearranged according to the Product Description sort order. 

 

Figure 10-2. Table view sorted by the Description field values.  

SORTING ON MULTIPLE FIELDS 

In the previous section, we sorted the table on a single field. Monarch also lets you sort on multiple fields. Let’s sort 
the table again, this time on two fields, Media (in ascending order) and Amount (in descending order). 

Steps: 

 Launch the Sort Definition window once more by selecting Table Design  > Add > Sort.  

 Type Descending Sales by Media in the Name box of the Sort Order Definition window that displays and then 

select the  icon that appears next to this field. 
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 Move the Media and Amount fields to the Selected Fields list. 

Let’s change the sort order of the Amount field to sort the values in descending order (largest values to smallest 
value). 

 Right-click on the Amount field, then select Change Order from the context menu. 

If you don’t provide a name, Monarch will attempt to name the sort definition using the name of the first sort field 
you specified, in this case, Media. If this name is already in use by another sort definition, you will be prompted 
to enter a name. 

 Choose Accept  in the Table Design ribbon to accept the sort definition and close the Sort Order Definition 
window. 

 In Table view, click on the drop-down button of the Active Sort box and then select Descending Sales by 
Media. 

The data in the Table view are sorted, first by Media and then by Amount. The Amount field values for each 
media type are sorted in descending order. 

 

Figure 10-3. Table view sorted by ascending Media and descending Amount.  
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RESTORING THE ORIGINAL TABLE ORDER 

You can turn off sorting and restore the original record order by simply selecting the No Sort option in the Active Sort 
drop-down.  

 

Figure 10-4. The original table order displays when the No Sort is applied to the table.  

DUPLICATING SORTS 

You may want to create a new sort that closely resembles a sort you previously defined. An easy way to do this is by 

using the Duplicate  button. To duplicate a sort, simply select the sort you want to duplicate from the Sort list and 

then select Duplicate  from the Table Design ribbon. The duplicated sort appears on the Sort list; this sort will 
have the name of the sort you duplicated and a number appended to it. Select this sort to display its properties in the 

Sort Definition window and make further revisions to it. Select Accept  when you are finished to accept and save 
your new sort definition. 
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[11] WORKING WITH FILTERS 

In this chapter, you will learn how to use a filter to display a subset of the table data. The lesson topics include: 

❑ A discussion of what a filter is 

❑ Creating a filter expression 

❑ Testing a filter expression 

❑ Using functions 

❑ Restoring the original table data 

❑ Working with value-based filters 

This chapter assumes that you are familiar with opening reports, creating a data extraction template, and working in 
Monarch’s Table view. 

There are several types of filters you can create: 

❑ Value-based filters  

Value-based filters offer simple filters that are typically used to obtain records with only one or two specifications. 
In Classic.prn, for example, you could use a value-based filter to return details for records with descriptions of 
“Mozart” and “Chopin.” Creating a value based filter entails identification of a single field on which your filter will 
be based, and then specifying the exact value(s) of the filter.  

❑ Formula-based filters 

Formula-based filters, in their simplest form, function very much like value-based filters. However, formula-based 
filters offer increased filter-making versatility. Working with Classic.prn again, let’s say you want to filter a table 
for all CD sales amounting to $50.00 and above. Using a value-based filter here is out of the question because 
only one field name can be specified with such filters. The filter you want to create specifies conditions for two 
fields, Media and Amount. Here, a formula-based filter would be more appropriate.  

❑ Compound filters Compound filters function as extensions of formula-based filters, and help you create longer 
filters with two or more component filters.  

To start the lesson, load Monarch, open Classic.prn and Lesson3.dmod, and then launch Table view. 

  

Figure 11-1. Extracted data displayed in Table view.  

The table in Figure 11-1 lists transactions for distributors of classical music recordings. Transactions are included for 
each customer and are broken down by media types, including CDs, LPs, DVDs, SACDs and Blu-ray discs. In all, 
there are 149 records in the table. 
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By applying a filter, you can select only those records that interest you and filter out the rest. Let’s use a filter to view 
only the records for a particular customer, i.e., Big Shanty Music. 

CREATING VALUE-BASED FILTERS 

To filter table data, you create a filter expression via the Filter Definition window. In the following exercise, we will 
create a value-based filter such that only records for the customer “Big Shanty Music” are returned.  

Steps: 

 From the ribbon of Table view, select Table Design  to launch the Table Design interface and then click Add 
> Filter > Value Based Filter.  

The Value-Based Filter Definition window displays. 

 

Figure 11-2. The Value-Based Filter Definition window.  

Let’s take a moment to study the Value-Based Filter Definition window. The panel on the left-hand side of the 
window is a Filter Selector. This panel is particularly useful if you want to modify an existing filter, for example, 
and you have several filters defined. The Value-Based Filter Definition window contains two tabs that help you 
define your filter. At the bottom of the window, the Data Preview button shows you what your table will look like if 
the filter you’ve just defined is applied to it.  

In the Field Values tab of the Filter Definition window, several options display, each of which can help you create 
your filter. 

Let’s say you are creating a filter where only records for Fandangos Records and Musique Royale are to display. 
You would then select Customer from the Field drop-down list and specify values for Fandangos Records and 
Musique Royale. In the Row Selection section, you can specify whether to display all records for either 
Fandangos Records or Musique Royale or display all records that are not by Fandangos Records or Musique 
Royale (i.e., all records except those from Fandangos Records and Musique Royale will display). You can also 
select whether records with blank customer names will display in your table after the filter is applied. 

The Value box displays the type of values you must enter for the selected field. For example, when you select 
the field Quantity, all of the values to be entered into the field must be of the type Numeric. When you select the 
field type Description, all of the values to be entered into the Value field must be of the type Character. If you 
enter a character string into the Value field for a numeric field, the filter will not be created.  

The Import values filtered by… drop-down list allows you to easily select field values for the Value box, 
including values you entered for previous filters. When you click on this box, a list of previously created filters 
displays, including the “No Filter” option. Clicking on any option on the list and then selecting the Add Rows 
button automatically adds all available values for the selected field name. Again, values to be entered must 
match the type of field you selected. When you select the No Filter option and then click Add Rows, all possible 
values for that field display in the Value box. You may delete values added to the box by clicking on the value 
and then selecting the Delete button.  
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In the Advanced tab, you can find options that allow you to either display all rows (records) that fit the filter 
description you specified or limit the display to a certain number of rows.  

 In the Field Values tab, dpublenter Big Shanty Music in the Filter Name box and then select . 

 In the Field drop-list, select Customer.  

 Double-click the first cell in the Value box and then enter Big Shanty Music.  

 Ensure that the radio button for Include rows where the field value matches one of the selected values is 
selected.  

 Click Accept  to save the details of the filter you specified and close the filter definition window.  

 In Table view, select the drop-down button of the Active Filter field and then select Big Shanty Music.  

The table is rebuilt to show only those records from Big Shanty Music. 

 

Figure 11-3. The Table data with a filter applied to it. Only those records for Big Shanty Music display. 

You have successfully created a value-based filter.  

CREATING FORMULA-BASED FILTERS 

To display only transactions amounting to US$100.00 and above, we’ll use the following expression: 

Amount>=100 

To build the expression above, which is a formula-based one, you could type the expression as it appears above, or 
you could build it by inserting components from the list boxes. 

Steps: 

 From the Table Design ribbon, select Add > Filter > Formula-Based Filter.  

 In the Filter Name box, enter Sales >=100 and then select  to accept this name. 

 

NOTE Filter definition names may be up to 31 characters in length and may contain 
uppercase and lowercase characters, spaces, and punctuation marks. However, 
periods (.), exclamation points (!), accent graves (`), and brackets ([ ]) may not 
appear in any part of the name. As well, names may not begin with spaces. If a name 
is entered with leading spaces, the name is accepted but the leading spaces are 
trimmed. 
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 Double-click Amount from the Fields list  

“Amount” displays on the Expression box.  

4. Double-click the greater than or equal to (>=) sign from the Operators list. 

The greater than or equal to sign is added to the expression. 

5. Click on the Expression box right after the operator “>=” and then type in 100. 

6. Select the Accept  icon that displays in the Expression box to accept your formula. 

7. Check the Data Preview panel. 

All of the records that display should have amounts greater than or equal to 100. Note, however, that the Data 
Preview only shows the first 100 records extracted from a report, or first 100 rows imported from a database, so 
depending on the data, you may not see rows affected by the filter in the Data Preview. 

8. Select Accept  in the Filter Definition ribbon to save your new filter and close the Table Design interface. 

9. In Table view, select the drop-down button of the Active Filter box and then choose the filter Sales >=100. 

The table displays only those transactions amounting to US$100.00 or greater (see Figure 11-4). 

  

Figure 11-4. The Table view showing all transactions amounting to or over $100.00.  

CREATING COMPOUND FILTERS 

Compound filters allow you to create longer, more-complicated filters composed of previously created ones. Let’s 
create a compound filter using the value- and formula-based ones we specified earlier.  

If you wanted to create a filter that will return all records from Big Shanty Music AND all records with transaction 
amounts greater than or equal to US$ 100.00, you could create a formula-based filter such as the following: 

Customer=”Big Shanty Music”.AND.Amount>=100 

If you wanted to create a filter that will return all records from Big Shanty Music OR all records with transaction 
amounts greater than or equal to US$ 100.00, you would create the following formula-based filter: 

Customer=”Big Shanty Music”.OR.Amount>=100 

While you can create either of the filters this way, selecting fields, operators, and values, as well as determining the 
correct way to link individual filter expressions may be a tedious task. Here, Monarch allows you to create compound 
filters whose components you can simply select from a list.  

The following steps will show you how to create a compound filter that will return all records that are either by Big 
Shanty Music or have amounts greater than or equal to US$ 100.00. 

Steps: 

 From the Table Design ribbon, select Add > Filter > Compound Filter.  

 In the Filter Name field, enter Big Shanty Music and Sales>=100 then select . 

 Select Big Shanty Music from the Available filters box by clicking on it and then move it to the Component filters 
box by clicking Add>>. 
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 Repeat Step 3 to move the filter Sales>=100 to the Component filters box. 

 In the Select rows that satisfy section, select the radio button for any one of the component filters.  

This selection instructs Monarch to display records that have either Big Shanty Music as the customer or 
transaction amounts greater than or equal to US$100.00.  

If you select all of the component filters, only those records that are by Big Shanty Music and have sales 
amounts greater than or equal to US$100.00 will display in the Table view. Of course, in this case, no records 
will display because none of Big Shanty Music’s sales amount to over US$100.00. 

Note that the component filters, as well as the type of link (AND/OR), display in the Component filter expression 
box. In the present example, the component filter expression should read: [Big Shanty Music] OR 
[Sales>=100]. 

 Click Accept  in the Filter Definition ribbon to accept your new filter definition.  

 From the Active Filter drop-down, select the filter Big Shanty Music and Sales>=100. 

The table is rebuilt and your filter is applied.  

 

Figure 11-5. The resulting compound filter.  

USING FUNCTIONS IN FILTERS 

Monarch provides a host of functions you can use in your filter expressions. For example, to display only shipments 
of symphony recordings, you can use the expression: 

Instr("Symphony",[Description]) 

The Instr() function searches a field for the occurrence of a string. In the above example, the expression returns only 
those records where the word “Symphony” appears anywhere in the Description field. The brackets surrounding the 
Description field name are required, as this field name is longer than 10 characters. 

 

Figure 11-6. Using a filter to display Symphony recordings.  

Monarch supports over 70 functions. The Monarch Help file contains detailed information about each function, 
including examples of their use in filter expressions. Monarch also includes a host of user-defined functions. You can 
create your own functions to provide an easy way to store and use complex expressions, and these functions can be 
shared to other co-workers who use Monarch.  

https://help.altair.com/2024/monarch/help/Introduction__The_Monarch_Application.htm
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RESTORING THE ORIGINAL TABLE ORDER 

You can turn off filtering and re-display all of the table data by selecting the No Filter option in the Filters menu. 

Steps: 

 Select the Active Filter drop-down button and then select No Filter to disable all filters. 

Table view displays all of the original table data extracted by Lesson3.dmod from Classic.prn. 

At this point, you can opt to either save your work or simply close the report and model files you opened for this 
lesson. For the rest of this chapter, we do not need to save our work. 

DUPLICATING FILTERS 

You may want to create a new filter that closely resembles a filter you previously defined. An easy way to do this is by 

using the Duplicate  button. To duplicate a filter, simply select the filter you want to duplicate from the Filters list 

and then select Duplicate  from the Table Design ribbon. The duplicated filter appears on the Filters list; this filter 
will have the name of the filter you duplicated and a number appended to it. Select this filter to display its properties in 
the Filter Definition window and make further revisions to it. Select Accept when you are finished to accept and save 
your new filter definition. 
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[12] WORKING WITH CALCULATED 
FIELDS 

In this chapter, you will learn how to calculate new fields from the data in the Table view. The lesson topics include: 

❑ A discussion of what a calculated field is 

❑ Creating a calculated field 

❑ Making comparisons 

❑ Hiding and deleting calculated fields 

This chapter assumes that you are familiar with opening reports, creating a data extraction template, and working in 
the Monarch’s Table view. 

 

A calculated field is a field whose value is derived from other fields in the same record. Calculated fields can be 
used to perform a variety of tasks, including arithmetical computations, concatenating character fields, and extracting 
information from a field. You can create and save multiple calculated fields. Once a calculated field is created, you 
can use it in filter, sort and summary definitions and copy, print and export it along with other fields. 

You can create several types of calculated fields in Monarch via the Table Design interface. These fields include: 

❑ Formula-based  

To create a formula-based calculated field, you create a calculated field expression. A calculated field expression 
is a formula that returns a value to a calculated field. 

❑ Runtime Parameter  

Runtime parameter calculated fields are very much like formula-based ones. The major difference between them 
is that runtime parameter calculated fields do not contain a formula, just a simple string, number or date value. 
The user is prompted to supply values for each runtime parameter when the model is loaded. 

❑ Lookup  

A lookup calculated field provides a convenient "table lookup" where the value of a designated input field is 
checked against a lookup table. They can be useful in avoiding the long and complicated IF statements that can 
occur in formula-based calculated fields. 

❑ User-edited  

A user-edited calculated field is special in that it allows the user to enter text to annotate rows in the table or 
enter corrections for bad data. 
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To start this lesson, we’ll load Monarch and open Classic.prn and Lesson9.dmod. Switch to Table view when done.  

 

Figure 12-1. Extracted data displayed in the Table view.  

The table in Figure 12-1 lists transactions for distributors of classical music recordings. We’ve extracted the detail 
information for each transaction along with the customer name and account number.  

By creating calculated fields, we can derive new information from the table data. For example, we can create a new 
field that calculates a 20% discount for all transactions. Let’s give this a try.  

CREATING A FORMULA FIELD 

In the previous lesson, we created a filter using a formula expression. We’ll apply the same concept in this lesson to 
add a new column to our table. 

Steps: 

 Select Table Design  to activate the Table Design interface and then click Add > Formula Field  from 
the Table Design ribbon.  

The Formula Fields Definition window displays.  
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Figure 12-2. The Formula Field Definition window.  

 In the General tab of the window, enter Discount in the Name box and then select the  icon to accept this 
name. This name will display as the field name when the results of our calculation definition are shown in Table 
view.  

 

NOTE Field names may be up to 62 characters in length and may contain uppercase and 
lowercase characters, spaces, and punctuation marks. However, periods (.), 
exclamation points (!), accent graves (`), and brackets ([ ]) may not appear in any 
part of the name. As well, names may not begin with spaces or underscores (_). If a 
name is entered with leading spaces, the name is accepted but the leading spaces 
are trimmed. 

 

Since this expression will result in a numeric value, we need to set the appropriate formatting for the field. 

 From the Type drop-down list, select Numeric. 

 Enter 2 in the Decimals box. 

 Select the Formula tab. 

To define a calculated field, you build a calculated field expression that returns a value to the field. The 
calculated field expression appears in the Expression box near the bottom of the Formula tab. Several list boxes 
display the field names from the table, arithmetic and logical operators, and functions that you can use in your 
calculated field expressions. 

To calculate a 20% discount for all transactions, we’ll use the expression, 

Amount*0.2 

To build this expression, you could type the expression as it appears above, or you could build it by inserting 
components from the list boxes. Let’s start by inserting the Amount field. 

 Double-click on the Amount field in the Fields box. 

The Amount field is inserted in the Expression box. Double-clicking an item also inserts it into the box 
automatically. 
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 From the Operators list, double-click the multiplication sign (*) so that it is added to the Expression box. 

 Click on the space beside the * in the Expression box, type 0.2, and then click Apply . 

The Data Preview tab should show a new field containing values obtained from the expression we defined. 

 Choose Accept  in the Formula Field Definition ribbon to accept the calculated field definition and close the 
window. 

A new field name, labeled Discount, is added to the end (far right) of the table.  

 

Figure 12-3. Table view with Discount calculated field.  

CREATING A USER-EDITED FIELD 

Creating User-Edited Fields 

Let’s create a user-edited field and see what it can do to a table. Note that user-defined fields are only saved in 
project files, not model files.  

Steps: 

 Select Table Design  to activate the Table Design interface and then click Add > User Edit Field from the 
Table Design ribbon.  

The User-Edited Field Definition window displays. 
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Figure 12-4. The User-Edited Field Definition window.  

 In the General tab, enter the name Comments and then click the  icon that displays to accept this name. 

 Change the Display Width of the field to 40 and then click Accept  to save your field.  

Table view displays the new field to the far right of the table. 

 

Figure 12-5. The user-edited field displays in Table view.  
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Using User-Edited Fields 

Steps: 

 Double-click on the first cell of the Comments field (Row 1).  

Note that the interface changes and the cell you selected becomes editable. 

 

Figure 12-6. Activating the user-defined field.  

 In the cell, type in “New delivery 12/2018” and then click Apply. 

The table is refreshed and the text you added displays.  

 

Figure 12-7. The results of modifying a user-define field.  
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MAKING COMPARISONS 

In the previous section, we created a calculated field using a simple arithmetical expression. Monarch lets you create 
more complex expressions involving comparisons. Let’s use this feature to calculate a discount only for sales 
amounts of US$75.00 or more. Rather than create a new calculated field, we’ll edit an existing calculated field to 
apply our new discount strategy. 

Steps: 

 Select Table Design  and then click Formula Fields on the ribbon that displays to launch the Formula Field 
window once more.  

 Select Discount from the Formula Field selector and then click on the Formula tab to display its properties. 

To apply the discount only for sales amounts of US$75.00 or more, we’ll use the IF() function in our calculated 
field expression: 

If(Amount>=75,Amount*0.2,0) 

In plain English, this expression reads, “If the Amount field contains a value of 75 or greater, use the first 
expression (Amount*0.2) to calculate a discount, otherwise, use the second expression (0) to show no discount.” 

 Enter the calculated field expression above into the Expression box so that it reads as shown in Figure 12-8 and 

then click the Apply  icon that displays subsequently.  

  

Figure 12-8. The modified Discount calculated field definition.  

 Click Accept  in the Formula Field Definition ribbon to accept the new calculated field definition and close the 
window. 

The field is re-calculated to show a discount only for transactions with an amount of $75.00 or more. 
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Figure 12-9. Updated Discount field.  

Now let’s use another Monarch feature to suppress the zero values so that our discount values will appear more 
prominent. 

 Select the Home tab, and then click Options .  

The Options window displays. 

This window includes several options that control the way data appear in Monarch.  

 Select View to display the View options.  

  

Figure 12-10. The View Options window.  

 Check the Suppress zero values box. 

 Delete any value indicated in the Display null values as box. 

 Click Accept  in the Options ribbon to close the window and apply your settings to the table data. 

The table displays with zero values suppressed. 
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Figure 12-11. Zero values suppressed.  

At this point, you can opt to either save your work or simply close the report and model files you opened for this 
lesson. For now, simply close all open files.  

REDACTION FUNCTIONS 

Monarch supports a set of redaction functions for use in calculated field expressions. These functions appear in the 
Redaction section in the Functions list box of the formula editor, as shown below. See the Help file for more 
information on these functions.  

 

Figure 12-12. Several redaction functions are available in the formula editor.  
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REGEX FUNCTIONS 

Besides redaction functions, Monarch also supports a number of Regex functions. The Monarch Help file contains 
more information on these functions. 

 

Figure 12-13. Regex functions available in the formula editor. 

HIDING AND DELETING CALCULATED FIELDS 

You can temporarily turn off the display of a calculated field by hiding it. Monarch will still re-calculate the hidden field 
while you make other changes to the table. However, if your calculated field expression is computationally intensive, 
this can slow down the display of the table. 

Of course, you can get rid of a calculated field altogether by deleting it altogether. When you delete a calculated field, 
the field is removed from the table and the calculated field definition is deleted. 

To delete a calculated field, launch the Formula Field Definition window, and then select the name of the calculated 
field you wish to delete. Select Delete from the ribbon. Be careful to select the correct field name – Monarch has no 
undo facility for deleted objects. 

DUPLICATING CALCULATED FIELDS 

You may want to create a new calculated field that closely resembles a calculated field you previously defined. An 

easy way to do this is by using the Duplicate  button. To duplicate a calculated field, simply select the calculated 

field you want to duplicate from the Calculated Fields list and then select Duplicate  from the Table Design 
ribbon. The duplicated calculated field appears on the Calculated Fields list; this calculated field will have the name of 
the field you duplicated and a number appended to it. Select this calculated field to display its properties in the 
Calculated Field Definition window and make further revisions to it. Select Accept when you are finished to accept 
and save your new calculated field definition. 

 

https://help.altair.com/2024/monarch/help/Introduction__The_Monarch_Application.htm
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[13] WORKING WITH MULTIPLE 
INSTANCES OF A REPORT 

In the previous chapters, we’ve worked with only one report at a time. In this chapter, you will learn how to open and 
analyze data from multiple reports. The lesson topics include: 

❑ Analyzing data from a series of reports 

❑ Opening multiple instances of a report 

❑ Extracting data 

❑ Working in the Table view 

❑ Creating a summary to analyze data from multiple reports 

 

In most organizations, reports are run on a regular basis -- typically weekly or monthly. Each instance of a report 
contains information about a specific period of time. 

In addition to producing a new report each week or month, some organizations produce a separate report for each 
department, division or region. For example, a retailer might divide its market into four distinct regions: Northeast, 
Central, South and West. A monthly sales report is generated for each region. 

 

Figure 13-1. Each report includes information for a specific region.  

Each instance of the report contains useful sales information for a single region, but it does not tell you how a 
particular product is selling nationally. For that, you will need to analyze data from all four regions. With Monarch, you 
can open all four regional reports and create a summary showing sales of the product within each region with a grand 
total for all four regions. The resulting summary might look like Figure 13-2. 

 

Figure 13-2. Comparing product sales across four regions. 

By analyzing data from all four regional sales reports, you can compare sales results for each region. Since each 
sales report is generated on a monthly basis, our analysis compares sales for only a single month. We can add 
another dimension by opening several monthly sales reports for each region. Figure 13-3 compares sales results by 
region broken down by month for a three-month period.  
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Figure 13-3. Comparing product sales across four regions for a three-month period. 

To create this summary, we opened a total of 12 reports – 3 monthly reports for each of 4 regions (see Figure 13-4). 

 

Figure 13-4. Each report contains information for a specific region and time period.  

As we’ve seen, each report contains only a piece of the overall puzzle. However, taken together, these same reports 
can reveal a wealth of information about your business. 

In the previous chapters, you’ve become familiar with the Classic.prn report. Classic.prn is a periodic report produced 
on a monthly basis. Each report contains shipments of classical music recordings for a single month. For this lesson, 
we’ve provided three instances of the Classic report representing shipments for the months of January, February, and 
March. 

When you load a model file or create a new model, Monarch applies the model parameters to all open reports. Data 
extracted from each report is concatenated in the Table view. 

 

NOTE Although you can open multiple report files at the same time, Monarch allows you to 
open only a single model file. The model file is automatically applied to all open 
reports. Thus, all reports must have the same format. For example, although the 
shipping reports used in this lesson all contain different data, they all share the same 
structure. You cannot extract data from two different types of reports at the same 
time. 

 

Let’s get started by opening ClassJan.prn, ClassFeb.prn, and ClassMar.prn as well as Lesson5.dmod. Go on to 

Table View and select Autosize Columns  to maximize your view all of the fields.  
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WORKING IN TABLE VIEW  

Working with data from multiple reports is virtually the same as working with data from a single report. You can view, 
sort, filter, export and print the data just as though it were extracted from a single report. There are, however, a few 
differences that should be examined. 

Sorting 

Initially, the data are arranged in the order that the report files were opened. Since we opened the January report first, 
the January records appear first in the table followed by February and then March. This initial order has no particular 
relevance. In fact, it may not be desirable at all. By arranging the records this way, Monarch may be violating the 
natural sort order of the reports. For example, each of our shipping reports is sorted by customer and then by ship 
date. By concatenating the records from all three reports, we’ve added a higher sort level. Now the data are sorted by 
period (month) and then, within months, by customer and ship date. Let’s restore the original sort order found in the 
reports. 

Steps: 

 From the Table ribbon, select Table Design  to launch the Table Design interface and then click Add > Sort 

.  

The Sort Order Definition window displays. 

   

Figure 13-5. The Sort Order Definition window.  

 Type Original Sort Order in the Name box and then click the  icon that displays next to this field to accept 
your name.  
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 Select the Customer field from the Available Fields box then click the Add >> button. 

 Select the Ship Date field from the Fields box then click the Add >> button. 

 Select Accept  in the Sort Definition ribbon to accept your changes. 

 Once back in Table view, select Original Sort Order from the Active Sort drop-down list.  

 Select Autosize Columns  from the Table tab to view all the fields properly.  

The table is rebuilt, sorted by customer and then by ship date. 

  

Figure 13-6. Original Sort Order sorts all of the data extracted from all three open reports.  

By using Customer as the first sort field, Monarch groups all the records from each customer together, 
regardless of which report each record was extracted from (note the highlighted ship dates for Betty’s Music 
Store which range from January 10th through March 4th - spanning all three reports). 

Identifying the Source of Each Record 

There are times when you will need to know from which report each record is extracted. You may want to apply a 
filter that excludes some or all of the records from one or more reports or create a summary that generates subtotals 
broken down by period. In either case, Monarch will need to be able to identify the source report for each record. 

Sometimes, this information is available within the reports. In our shipping reports, each page header contains the 
date the report was printed. By extracting this information as a field, you can easily identify the source of each record.  
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Figure 13-7. The report run date is included in the page header.  

For reports that lack a run date or other unique identifying information, Monarch provides a pair of functions - File() 
and ID() - that you can use to identify the source of each record. 

The File() Function 

The File() function returns the path and filename of the report file from which each record was extracted. For 
example, for records extracted from the ClassJan.prn file, the File() function would return the value 
"C:\Reports\ClassJan.prn", assuming that ClassJan.prn is located in the \Reports folder on drive C. 

Let’s create a calculated field using the File() function. 

Steps: 

 From the Table ribbon, select Table Design  to launch the Table Design interface and then click Add > 
Formula Field.  

The Formula Field Definition window displays. 

 In the Name box, type Filename and then click the  icon that displays beside the field to accept your name. 

 From the Type drop-down list, select Character. 

 Enter 60 in the Display Width box and then select the Formula tab. 

 Double-click on the File() function from the Functions list so that it is added to the Expression box.  

 Select the Apply  icon that appears in the Expression box to save the newly defined field and then click 

Accept  in the window’s ribbon to close it. 

 Select Table Design  from the Table ribbon once more.  

 Locate the row for Filename. In the cell for Size, enter the value 65. 

 Select Accept  to apply your changes.  
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The new field is added to the end of the table.  

  

Figure 13-8. The Filename field, including the path.  

For each record, the Filename field returns the entire path and filename of the report from which the record was 
extracted. Let’s use another function to reduce the field values to only the file name. 

Steps: 

 Launch the Formula Field Definition window by selecting Table Design  > Formula Fields.  

 Set the Display Width of the Filename field to 12. 

 Select the Formula tab and then delete the expression File() from the Expression by using your keyboard. 

 Type the following expression into the Expression box instead: 

RSplit(File(),2,"\",1) 

This expression separates the path from the filename and returns the filename by itself. 

 Click Apply  to save your newly defined field and then select Accept  in the window ribbon to close it.  

Now the Filename field displays only the name of each report file. 

 

Figure 13-9. The Filename field, excluding the path.  
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The ID() Function 

The ID function assigns a numeric designation to each report at the time the report is opened. The first report opened 
is assigned 1, the second 2 and so on. If a report is subsequently closed, the list of designations is collapsed to fill 
any gap in the assigned numbers. Let’s create another calculated field using this function. 

Steps: 

 From the Table ribbon, select Table Design to launch the Table Design interface and then click Add > Formula 
Field.  

The Formula Field Definition window displays. 

 In the Name box, type File ID, select , and then select Numeric from the Type drop-down list. 

 Select the Formula tab. 

 Double-click on the ID() function from the Functions list so that it is added to the Expression box. 

 Click Apply  to save your newly defined field and then select Accept  to close the Formula Field 
Definition window. 

The File ID field displays as a new column in the table.  

 

Figure 13-10. The Filename and File ID fields.  

Since ClassJan.prn was the first report we opened, it is assigned 1. ClassFeb.prn was the second report opened, 
so it is assigned 2 and ClassMar.prn is assigned 3. By opening the reports in another order, we could change the 
designations. You can use the ID function to order records in the table or in a summary based on the order in 
which you open the files, rather than alphabetically by file name.  
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[14] EXTRACTING MULTIPLE-LINE 
FIELDS 

In many reports, the majority of fields are single line fields - character, numeric and date fields that occupy space on 
a single line. However, some reports contain large fields that span multiple lines. These multiple line fields are 
variously known as comment fields, description fields, memo fields, text blocks or word wrapped fields. In this 
chapter, you’ll learn how to extract a multiple line field from a report and work with it in Monarch. 

To get started, load Monarch and open the Homes.prn report and Lesson6.dmod model file. 

  

Figure 14-1. The Homes real estate report contains new property listings.  

Homes.prn is a weekly real estate report describing properties that were offered for sale during the previous week. 
For each property, the report includes the address, style, price, listing broker and numerous other points of interest to 
prospective buyers. Chief among these is a description of the property provided by the listing broker. The Remarks 
field is typical of multiple line fields found in many reports. Each instance of the field contains several lines of 
descriptive text - some of the descriptions are only a few lines long and several are as many as nine lines.  

The Lesson6 model contains a detail template that captures several fields from each property listing. The first line of 
the multiple line Remarks field is included in the template, but that field is not yet captured. We’ll capture the Remarks 
field together to illustrate how to capture a multiple line field.  
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CAPTURING A MULTIPLE-LINE FIELD 

To capture a multiple-line field, you need to tell Monarch where the field begins and ends. Typically, locating the 
beginning of a multiple line field is easy - most multiple line fields begin at an absolute offset from the first line of the 
template. Locating the end of a multiple line field is sometimes more difficult. Since the number of lines in the field 
often varies, you can’t tell Monarch how big the field is in absolute terms. Instead, you must describe some 
characteristic that is common to the end of the field. For example, the field may end when a blank line is reached or 
when another field is encountered. Monarch includes these and several more options that you can use to indicate 
where your multiple line field ends. 

Steps: 

 Select Report Design  to switch to the Report Design view. 

The Template Editor displays, showing several lines of the detail template. In this example, the detail template 
contains a total of 16 lines. 

  

Figure 14-2. The Sample Text box displays several sample lines.  

We can scroll the template sample text to view the remaining sample lines. The last line of the template contains 
the beginning of the Remarks field. Let’s scroll down until that line is displayed.  

 Scroll down in the Sample Text box until the Remarks field is visible, as in Figure 14-3.  

  

Figure 14-3. The last template sample line represents the beginning of the Remarks field.  
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Let’s also scroll the report to display the first instance of the Remarks field. Having this field displayed on screen 
will provide valuable feedback during the capture process.  

 Use the vertical scroll bar on the right side of the Template Editor (the lower of the two vertical scroll bars that are 
visible on screen) to scroll down so that the Remarks field is fully visible on screen, as shown in Figure 14-4.  

   

Figure 14-4. Displaying the multiple line Remarks field in the Report view to provide feedback.  

Now we’re ready to capture the multiple-line Remarks field. 

 In the Sample Text line, use the mouse or the keyboard to highlight only the first line of the Remarks field. 
Highlight this entire line, making sure to extend several spaces toward the right to capture all of the data for all of 
the records in the report.  

The field highlight should look like that shown in Figure 14-5. 

   

Figure 14-5. The last template sample line represents the beginning of the Remarks field.  
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Note that the first line of the field in the report is now highlighted. 

    

Figure 14-6. The Sample Text box displays several template sample lines.  

You might be wondering why we highlighted only the first line of the field. Why not highlight the entire field? For a 
multiple line field, we must indicate the horizontal size of the field and the vertical size. The horizontal size is 
indicated by highlighting the first line of the field. However, the vertical size cannot be indicated by highlighting 
multiple lines because the number of lines occupied by each instance of the field varies. What would be correct 
for the first instance of the field may be incorrect for the others. To indicate the vertical size of a multiple line field, 
we must tell Monarch where the field begins and where it ends. To do this, we’ll use the Field Definition window. 

 Select Edit Field  on the Action bar of the Template Editor.  

The Field Definition window appears, showing all of the fields defined for the Detail template. Note that at the 
bottom of the list of fields, the field name eg_Formal, fireplaced dining ro… may be found. This is the field we 
are extracting in the current lesson. 

 Select the field eg_Formal, fireplaced dining ro… to display its properties. Rename this field Remarks and 

then select . 

 Click the Advanced tab.  
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Figure 14-7. The Advanced tab.  

The Advanced tab includes options for indicating the beginning and ending locations of the field. Let’s begin by 
examining each of the Start Field On options. These options tell Monarch how to locate the beginning of a 
multiple line field. The Start Field On options are: 

• Line Number 

The Line Number option indicates that the first line of the field begins at an absolute offset from the top of 
the template. The line number represented by this setting is determined by the position of the field highlight 
in the template sample. Since we painted the first line of the Remarks field at Line Number 16, this option 
displays as Line Number 16. 

 

NOTE The Line Number option is almost always the correct choice for indicating the 
beginning of a multiple line field. The only time the Line Number option would not be 
the correct choice is when the multiple line field begins after another multiple line 
field. In this case, the first multiple line field, if it contains a varying number of lines, 
would cause the beginning position of the second multiple line field to vary (see 
Figure 14-8). Only then would you need to employ one of the other Start Field On 
options. 

 

• String  

The String option indicates that the first line of the field begins on the next line down from (i.e., the line 
below) a line containing a string. This option is particularly useful when trapping HTML data. To use this 
option, enter the string in the adjacent box.  

 

• Preceding String 

The Preceding String option indicates that the first line of the field begins to the right of a string, such as a 
label. To use this option, you simply enter the string in the adjacent box. Figure 14-8 shows a modified 
version of the Homes report where the Remarks field falls after another multiple line field, the Directions 
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field. Here the Line number option would not work because the varying length of the Directions field would 
cause the beginning of the Remarks field to bob up and down. In this case, the preceding string option could 
be used by entering the label "Remarks:" (without the quotation marks). 

 

Figure 14-8. Offset of Remarks field varies due to preceding multiple line Directions field.  

• After Last Defined Field in Template 

The After Last Defined Field option indicates that the first line of the field begins two lines below a previous 
multiple line field. Figure 14-9 is an excerpt from Figure 14-8, except this time there is no identifying label 
next to the Remarks field. In this case, you could use the After Last Defined Field option to indicate that the 
Remarks field begins immediately after the Directions field. To do this, you must also capture the Directions 
field so Monarch will know where it ends. 

 

Figure 14-9. Use After Last Defined Field if no label exists to mark the beginning of the second multiple line field.  
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Since the Remarks field always begins on the same line in the template (Line Number 16), we’ll use the Line 
Number option to indicate where the field starts. Line Number is the default option, so it’s already selected.  

Next, we need to indicate where the multiple line field ends. To do this, we’ll select an End Field On option. 
The End Field On options tell Monarch how to locate the end of a multiple line field. Let’s examine each 
option. 

• Line Count 

The Line Count option terminates a multiple line field after a fixed number of lines. This option should be 
used only when every instance of the field has the same number of lines. This won’t do for our Remarks 
field, as each instance contains a different number of lines. 

• Nonblank Preceding String of 

The Nonblank Preceding String option terminates a multiple line field when any nonblank character appears 
within a specified number of columns to the left of the field. Typically, the character is part of a label that 
appears to the left of a subsequent field. As an example, let’s suppose our fictitious Directions field 
appeared immediately after the Remarks field rather than before (see Figure 14-10). With no blank line to 
separate the fields, it is difficult to determine where the Remarks field ends, but we can find the label 
"Directions:" preceding the first line of the Directions field. We can use this label to terminate the Remarks 
field by selecting the Nonblank Preceding String of option and specifying 3 or more columns.  

Monarch will look for any nonblank character in these columns, terminating the field when it encounters the 
colon (:) in the "Directions:" label. 

 

Figure 14-10. Use Nonblank Preceding String to terminate a field when another field is encountered.  

The Nonblank Preceding String option cannot be used to indicate the end of the Remarks field in the report 
that we are using for this lesson because there is no label in an appropriate position near the end of the 
Remarks field. 

• Blank Field Values  

The Blank Field Values option terminates a multiple line field when Monarch encounters a single blank line 
or a pair of blank lines. Monarch does not require the entire line to be blank, only the column positions 
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immediately under the field. Since our Remarks field is always followed by a blank line, this option is a good 
choice.  

In the case of a large text block containing multiple paragraphs, like the one shown in Figure 14-11, you 
would indicate 2 blank lines - to prevent Monarch from terminating the field when it encounters the blank line 
that falls between the first and second paragraphs.  

Note that using two blank lines to terminate a multiple line field is possible only when the entire text block is 
followed by at least two blank lines, as is the case in our example below. 

 

Figure 14-11. Example of a multi-paragraph text block with a single blank line between paragraphs.  

• End of Left Justification 

This option terminates a multiple line field when Monarch encounters a line with a blank in the first column 
position of the field or any nonblank character in the column immediately preceding the field. Either condition 
indicates that left justification within the field has ended. This option is useful for capturing left aligned text 
blocks. However, if the text block contains a blank line, such as that found between paragraphs, Monarch 
will consider the blank line an end to left justification and will therefore terminate the field. Although this 
option could be used to terminate the Remarks field, the Blank Fields option is preferable as it better 
describes the way that the field is actually terminated. 

• Any Template Hit 

This option terminates a multiple line field only when Monarch encounters another template, including 
another instance of the template in which the multiple line field resides. Monarch will also terminate a 
multiple line field after it extends two pages. The field will be terminated on the second page where the page 
break character (ASCII 12) is encountered. This prevents a field from continuing without end if the selected 
End Field On action is not appropriate to end the field. 

This option should be used only when none of the other End Field On options are suitable. By employing the 
minimum actions, you might capture more data than is actually occupied by the field. 

 

NOTE The minimum actions described above are always enforced by Monarch, even when 
the Any Template Hit option is not selected. Select this option only when none of 
the other options would apply. 

 

From our review of each of the End Field On options, we find that either the Blank Field Values option or the End 
of Left Justification option will properly terminate the field. We recommend using the Blank Field Values option in 
such cases, since it is more descriptive of how the field ends. 
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 Select the Blank Field Values option to indicate to Monarch that the field will end when a blank line is 
encountered. The default value is 1, which tells Monarch that the field should end as soon as 1 blank line is 
found.  

 Select Accept  to accept your changes and close the window. 

Note that Monarch has correctly highlighted the first instance of the Remarks field. 

  

Figure 14-12. Testing the multiple line field definition.  

Let’s double check the field definition by inspecting several more instances of the multiple-line field. 

 Scroll down in the report to the next Remarks field. 

Note that the second instance of the Remarks field is also correctly highlighted. 

  

Figure 14-13. Double checking the multiple line field definition.  

 Select Accept  to accept your changes and close the Template Editor.  
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DISPLAYING A MULTIPLE-LINE FIELD IN TABLE 
VIEW  

Now that we are satisfied that the multiple line field is captured properly, we’ll extract the field and display it in the 
Table view. 

Steps: 

 Select the Table tab to display the extracted data in Table view. 

The table displays, and the Remarks field is found at the far right. 

   

Figure 14-14. Displaying the Remarks field in the Table view.  

The initial field type assigned to the Remarks field is character with a data length of 254 - the maximum data 
length for a character field. The column width is set to the field’s template width, which in this case is 62 
characters.  

These default settings are appropriate for multiple line fields that extract a small amount of data, i.e., when the 
largest field value is less than the 254-character maximum for a character field. For multiple line fields that 
extract large blocks of text, however, such as our Remarks field, the 254-character limit will cause some of the 
field values to be truncated and the display settings don’t let us see very much of each field value on screen. 

MEMO FIELDS 

To accommodate multiple line fields that contain more than 254 characters, Monarch includes support for memo 
fields which can handle up to 65,536 characters (64KB). 

Let’s change the field type of the Remarks field to Memo. 

Steps: 

 Select Table Design to launch the Table Design interface. 

 In the field list that displays, locate the row for Remarks and then change its type to Memo. 

 Select Accept  to accept your changes and return to Table view. 

The Remarks field is redisplayed as a memo field. 
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To view more information for each memo field, you’ll have to adjust the height of each row. Let’s try doing this 
now. 

 In the left hand side of the Table view, click on the border between Rows 1 and 2, then drag down to expand the 
height of the rows to at least six lines.  

Even using a row height of 6 lines, we still may not be able to see all of the text in some of the Remarks fields. 
To view more information, we could increase the width of the field, but this may still not allow us to view the 
entire contents of each cell. Although we could adjust the row height again (Monarch allows a maximum row 
height of 12 lines), let’s try something new instead. Let’s give Monarch’s Show Field Contents feature a try, 
which displays the entire contents of a cell. 

 Select Show Field Contents  from the Table ribbon. 

Monarch opens a small window at the top of the display. This window, called the Field Contents window, displays 
the entire contents of the selected table cell. Initially, the window height is only a few lines, but you can increase 
the height to show more lines and you can scroll within the window to view the entire contents of a cell. 

  

Figure 14-15. The Field Contents window displays the entire contents of the selected cell.  

As you move the cell pointer from cell to cell in Table view, the Field Contents window will display the contents of 
the selected cell. You can try this by using the down arrow key on the keyboard to scroll through the Remarks 
field cells. 

USING MEMO FIELDS 

Monarch does not allow a memo field to be used in a sort or summary definition. If you intend to include the field in a 
sort or summary definition, you must leave the field type set to Character, or on rare occasions, change it to Numeric 
or Date. In addition, there are differences in the way a memo field is exported and printed versus a character, 
numeric or date field. These differences may or may not provide the results you expect or want. We’ll touch on the 
export and print issues later in this lesson. 
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Using Memo Fields in Calculated Field and Filter Expressions 

As stated above, you cannot use a memo field in a sort or summary definition. However, you can use a memo field as 
part of a calculated field expression. By creating a calculated field, you can extract a subset of the memo field that 
you can then use in a sort or summary definition. 

You can also use a memo field in a filter expression. We’ll illustrate this using the Remarks field. Let’s suppose the 
Real Estate agent has a client interested in purchasing a new home and, among the client’s other criteria, she wants 
a home with a fireplace. Some of the property descriptions mention a fireplace and others do not. You could manually 
review all of the Remarks cells in the table to find the ones that mention a fireplace, but this is a tedious process, 
especially if there are hundreds of homes for sale. 

To find out which homes have a fireplace you can create a filter that will search the entire Remarks field and return 
only those records where a fireplace is mentioned. 

Steps: 

 On the Table ribbon, select Template Design  > Add > Filter > Formula based. 

The Filter Definition window displays. 

 Type Homes with a Fireplace in the Filter Name box and then select . 

 Type Instr("fireplace",Remarks)>0 in the Expression box. 

The Instr() function will return the character position of the word "fireplace" in the Remarks field. By setting the 
filter to >0, we are capturing all cases where it appears anywhere in the description text. 

 Choose Apply  to accept your filter and then close the Filter Definition window by clicking Accept . 

Monarch applies the filter, which returns 19 records. That may still be more property descriptions than you want 
to read through, so let’s narrow the choices by adding to the filter definition. While we’re already supposing, let’s 
further suppose that the client refuses to live in any town other than Tewksbury. 

 Select Template Design  > Filters  tool and then click on the Homes with a Fireplace filter from the 
Filter Selector to display its properties. 

 Add .And.Town="Tewksbury" to the filter expression. The entire expression should now read: 

Instr("fireplace",Remarks)>0.And.Town="Tewksbury" 

 

Figure 14-16. Viewing the edited filter expression.  

 Choose Apply  to accept your filter and then close the Filter Definition window by clicking Accept  in the 
window’s ribbon. 

 Select the Homes with a Fireplace filter from the Active Filter drop-down list. 

This time Monarch returns only three records representing homes with fireplaces in the town of Tewksbury. Let’s 
use the Display Source of Record feature to browse the original descriptions in the report. 
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Figure 14-17. Memo fields used in filter expressions.  

 Click on any cell in the first row of the table. 

 Select the Find in Report  button from the Table ribbon.  

Monarch displays the associated property listing in the Report view. 

  

Figure 14-18. Displaying the source of a multiple line field.  

You may repeat Steps 8–9 to view each of the other property listings. In Step 8, click any cell in the second row 
to display the second listing or any cell in the third row to view the third listing. 
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PRINTING MEMO FIELDS 

When you print a memo field, Monarch treats the field as though it were a character field: it prints only that portion of 
the field that is visible in the Table view. This produces a print image that reflects the data you see on screen. To print 
the entire contents of a memo field, you can export the table to a text file, and then use a text editor or a word 
processor to print the file. 

At this point, you can either save your work or simply close the report and model files you opened for this lesson.  
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[15] SUMMARIES 

In this chapter, you will learn how to use the Summary window to analyze data from the table. The lesson topics 
include: 

❑ A discussion of what a summary is 

❑ Creating a summary 

❑ Suppressing duplicate values 

❑ Adding subtotals and blank lines 

❑ Measure calculations 

❑ Adding item fields 

❑ Collapsing and expanding a summary 

❑ Specifying summary design preferences 

❑ Creating a quick summary 

❑ Copying, printing, and exporting summaries 

This chapter assumes that you are familiar with importing and viewing report files, creating data extraction templates 
and working in the Table view. Consider contacting sales@altair.com to obtain a copy of Monarch Complete and gain 
access to these additional functions in Monarch.  

 

A summary tabulates information for selected fields and presents the results in a one- or two-dimensional matrix. For 
example, the summaries shown here show sales totals for a fictional distributor of classical music recordings, first 
broken down by customer, then by media. 

 

Figure 15-1. Sales by customer and media.  

 

Figure 15-2. Sales by media type.  

mailto:sales@altair.com
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The summaries shown above tabulate information about a single key field. In the first summary, the key field is the 
Customer field and in the second summary the key field is the Media field. The field that is tabulated (or summed) is 
called a measure. In both summaries shown above, the Amount field is used as the measure. 

Although only a single key field and a single measure are required, a summary may be quite complex, including 
multiple key fields and measures. Each measure can be used to calculate a variety of information about your data, 
including the sum total, average, percent of total, minimum, maximum, standard deviation, and variance. Monarch 
also provides a count function that can be used as a measure. Rather than performing a calculation on a selected 
measure, the count function counts the number of records for each key. 

For example, the summary in Figure 15-3 includes both the Customer and Media fields as key fields, and the count 
function and Amount field as measures. Separate Amount calculations are used to break down total sales versus 
average sales. 

 

Figure 15-3. Sales broken down by customer and media type. The count column displays the number of transactions and 
the Amount and AVG(Amount) columns display the total sales and average sales (partial summary shown). 

A summary can also include item fields that expand the summary to show individual transactions. Item fields provide 
an advantage over viewing individual transactions in the Table view because you can use the summary to break 
down subtotals. 

The summary in Figure 15-4 includes the Customer and Media fields as key fields and the Quantity and Description 
fields as item fields. This summary displays individual transactions for each media type within each customer. 
Subtotals are generated for each customer. 

 

Figure 15-4. Item fields are used to display individual transactions (partial summary shown). 
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The Summary View Interface 

The Summary View interface is similar to the Report and Table view interfaces; it includes a ribbon, the Summary 
selector, and the Summary window. 

 

Figure 15-5. The Summary view interface 

The Summary View Context Menu 

Right-clicking on the Summary selector displays a context menu that will allow you to perform the following 
operations: 

❑ Perform a quick export - This export operation uses the default file extension and values specified in Export 
Settings and presents the Create Export dialog with all elements prefilled 

❑ Rename a summary 

❑ Edit a summary (via the Summary Design interface) 

❑ Duplicate a summary 

❑ Rebuild a summary (if a specific summary is selected) 

❑ Rebuild all summaries 

❑ Print a summary 

❑ Quick print a summary 

❑ Preview a summary before printing 

❑ Move a summary to the top of the selector 

❑ Move a summary up one position 

❑ Move a summary down one position 

❑ Move a summary to the bottom of the selector 
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Similarly, right-clicking in Summary view displays a context menu that will allow you to: 

❑ Copy text 

❑ Copy with formatting 

❑ Search for a record 

❑ Go to a specific row in the summary 

❑ Go to a specific column in the summary 

❑ Find a specific value in the table 

❑ Autosize columns 

❑ Adjust column widths 

❑ Display field properties 

❑ Set the active measure 

❑ Set a summary filter 

❑ Print the table 

❑ Launch Print Preview 

❑ Export the summary 

❑ Launch the Summary Design interface 

 

To start this lesson, load Monarch and open Classic.prn and Lesson7.dmod. Go on to Table view and select 

Autosize Columns  from the ribbon to maximize your view all the fields. 

 

Figure 15-6. Extracted data displayed in the Table view. 

By creating summaries, we can analyze the data to reveal trends and relationships that would otherwise remain 
buried. Let’s create a simple summary that tabulates sales quantities and totals for each media type (CDs, SACDs, 
DVDs, etc.) within each customer. 
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CREATING A SUMMARY 

To create a summary, you select key fields and measures. 

Key fields are used to define the summary matrix. For example, the summary in Figure 15-1 uses the Customer field 
as the key field. Monarch examines the field and creates a list of all unique values found within the field (e.g., Betty’s 
Music Store, Big Shanty Music, etc.), then uses these values to create the summary matrix. 

Measures are numeric fields that are summed for each unique key field value. For example, in Figure 15-1 the 
Amount field is broken down into separate totals for each customer. Monarch also provides a count function that can 
be used as a measure. Rather than calculating a result for a specific field, the count function simply counts the 
number of records that match each for each key field value (for example, there may be 10 records for Betty’s Music 
Store and 8 for Big Shanty Music, etc.). 

Let’s begin by creating a summary that displays sales broken down by customer and media type. We’ll use the 
Customer and Media fields as the key fields and the Amount field as the measure. 

Steps: 

 Select the Summary tab and then click Summary Design > Add Summary  to activate the Summary 
Design interface.  

 

Figure 15-7. The Summary Definition window.  

The following table summarizes the functions of each of the buttons in the Summary Design ribbon.  

Use this button… To… 

 Accept 
Accept the new template or changes to an 
existing template 

 Cancel 
Cancel the new template or changes to an 
existing template 

 Add summary 
Add a new summary 

 Duplicate summary 
Duplicate a summary 
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Use this button… To… 

 Delete summary 

Delete the selected summary 

 Definition 
Add or modify a summary definition. 

 Add/Remove fields  
Add or remove key, measure, and item fields 

 All fields 
Display the properties of all of the fields 

 Keys 
Display the properties of all key fields 

 Items 
Display the properties of all measure fields 

 Measures 
Display the properties of all item fields 

 Page setup 
Launch the Page Setup window 

 Help 
Launch the Help file 

 

 In the Name field, type in Summary1 and then click the adjacent  icon that appears to accept this name.  

 Select Add/Remove Fields to begin specifying your key, measure, and item fields.   

ADDING KEY FIELDS AND MEASURES 

Let’s get right to adding key fields and measures by clicking on the  Add/Remove Fields button. The 
Add/Remove Fields command displays a list of the fields that are available for use in a summary definition. This list 
includes all the fields available in Table view except for memo fields. To add a field to the summary definition, you 
select the field from the Table Field box, and then click the appropriate button (Key, Item, or Measure) to add the 
field to the corresponding box at the right. Our summary requires the Customer and Media fields as key fields, so let’s 
select those fields.  

Steps: 

 Select Customer from the list of available fields, and then select Add Key.  

Customer displays in the Key Field list.  

 Select Media from the list of available table fields and then select Add Key.  

Now, both Customer and Media display in the Key Field list.   
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Figure 15-8. Specified key fields. 

Several properties are assigned to each field, as you can see from the entries in the corresponding subtabs in 
the Key screen. For now, we’ll accept these default properties. (We’ll explore the properties for Key fields, Item 
fields, and Measures later in this lesson and in the next lesson.) 

The next step is to select the measures that we want to include in our summary definition. Since we want our 
summary to tabulate sales totals, we’ll select the Amount field as a measure. 

 Select Amount from the list, and then click Add Measure.  

Amount displays in the Measure Field list.  

 

Figure 15-9. The specified measure. 

We have just finished specifying our key and measure fields. 

SELECTING FILTERS TO APPLY IN SUMMARIES 

When you create a summary definition, you may assign a filter to limit the records available to the summary. The 
Apply Filter box, which is accessed by selecting the Definition button on the Summary Design ribbon, provides 
several filtering options. 

❑ You may select a filter to apply when building the summary. The filter you select is applied to the data only to 
build the summary. It is not applied to Table view and it does not limit the data available to other summaries. 
When building and displaying the summary, the filter overrides any filter that you may have applied in the Table 
view - it is not applied along with the active table filter. 

❑ You may select No Filter. The No Filter option turns off filtering for the summary. The summary is built using all 
records. This option, like the previous option, overrides any filter that you may have applied in the Table view. 

❑ You may select Default Filter. The Default Filter option applies the filter that is currently applied to the Table 
view. This option uses only the records that are available to the Table view at the time the summary is built. If 
you switch the filter that is applied to the Table view or modify its definition, the summary is recalculated to reflect 
the changes. 
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We want to use all records to build our summary, so we’ll use the default value of No filter to turn off filtering for this 
summary. 

SUPPRESSING DUPLICATE VALUES 

Most report writers include a facility to suppress duplicate values for selected fields. Suppressing duplicate values 
reduces the amount of visual clutter in a report and helps to emphasize details. Monarch also includes this facility, 
allowing you to suppress duplicate values for any key field in a summary (except for the rightmost key field, which 
never contains duplicate values). 

Let’s suppress duplicate values for the Customer key field. 

Steps: 

 Select the Keys button from the Summary Design ribbon.  

A list of specified key fields as well as their corresponding properties displays.  

The Keys screen includes several subtabs that organize key field properties into logical groups. The Layout 
subtab includes key field properties that determine how the key field is displayed, including an option to suppress 
duplicate values. 

 Select the field Customer from the Key Field selector and then click the Layout subtab. 

Locate the drop-down box for Orientation > Down, click the drop-down arrow, and then select Suppress 
duplicates.  

 Click Accept  to accept the changes made to your summary. 

The summary is rebuilt, and duplicate customer names are removed.  

 

Figure 15-10. Duplicate values removed from the Customer column. 
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ADDING SUBTOTALS AND BLANK LINES 

You can add subtotals and blank lines to a summary after each logical group of information. Subtotal lines and blank 
lines are added whenever the value of the selected key field changes. To illustrate this, let’s add subtotals for each 
customer and add blank lines to separate each customer group.  

Steps: 

 Select Summary Design > Keys.  

 Select the Customer key and then click the Layout subtab. 

 Under the “After each key value change” heading, check the Insert subtotal line check box. 

 Select 1 from the “Insert n blank line(s) after each key value change” field drop-down list. 

 Click Accept to accept the changes made to your summary. 

The summary is rebuilt. A subtotal line and a blank line are added directly underneath each customer group. 

 

Figure 15-11. Subtotals are displayed for each customer. Blank lines separate each customer group. 

ADDING MEASURE CALCULATIONS 

Our summary report breaks out sales totals for each media type and each customer. While this is useful, you may 
want to perform other analyses on the data. Monarch supports several calculations you can perform when building a 
summary.  

For each measure you include in your summary definition, you can calculate the total, average, percent of total, 
minimum or maximum value, standard deviation, or variance. To perform multiple calculations, you add multiple 
copies of a measure to the summary definition, one for each calculation you want to perform. In addition to the 
measure calculations, a count function is included that you can use to tabulate the number of records matching each 
set of key field values and a special ratio calculation option that divides subtotals for one field by subtotals for another 
field.  

Let’s edit the summary definition to add the percent of total sales calculation for the Amount measure. 
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Steps: 

 Select Summary Design > Add/Remove Fields.  

 Select Amount from the list of available fields that displays, and then click Add Measure. 

This adds a new Amount field to the Measures screen. 

 Select the Measures button from the Summary Design ribbon. 

 Select this new Amount field (the second one on the list) and then click the Formula subtab.  

 

Figure 15-12. The new Amount subtab showing the Formula options.  

 Delete SUM ([Amount]) from the Expression field, and then enter PCT([Amount]) instead. Click the Apply  
icon that displays in the field when you are finished.  

 

Figure 15-13. Entering a new expression.  
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 Select the General subtab. 

Note that Amount is suggested as the column title. Let’s modify this title to read %Amount. 

 Click on the Use default title check box to deselect this option (the check mark should be removed). 

When the Use Default Title option is unselected, the Title box is activated. 

 Type %Amount in the Title box. 

 Under Display Settings, click on the Custom radio button. 

 Select Percentage from the Format drop-down list.  

 Specify a Decimals setting of 1. 

 Click Accept  in the ribbon to accept your changes and close the Summary Definition window. 

The summary is rebuilt with the new %Amount measure.  

 

Figure 15-14. Summary with a %Amount calculation.  

ADDING ITEM FIELDS 

Item fields are optional fields that you can use to expand a summary to show individual transactions. Item fields 
provide an advantage over viewing individual transactions in Table view because you can use the summary to break 
down subtotals. 

Let’s add the Quantity and Description fields to our summary definition as item fields. 

Steps: 

 Select Summary Design > Add/Remove Fields.  

 Select Quantity from the Table Fields list that displays, and then select Add Item. 

 Select Description from the Table Fields list and then select Add Item.  

 Choose Accept  in the ribbon to accept the modified summary definition. 
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Monarch rebuilds the summary and displays the item fields. 

 

Figure 15-15. A newly constructed summary showing item fields.  

COLLAPSING AND EXPANDING A SUMMARY 

Expanding or collapsing (referred to as drilling down or drilling up) a summary provides a quick way of exploring 
summary data. 

❑ Collapsing (Drilling up)  

Reduces the level of detail in the summary, revealing higher level information. To collapse a summary, Monarch 
removes the rightmost key field from the summary, then re-calculates and re-displays the summary. 

❑ Expanding (Drilling down)  

Restores the previously removed key fields to the summary display. When item fields are included as part of the 
summary definition, you view the item fields by drilling down the itemized level. 

Let’s start by drilling up to hide the item fields we added to our summary definition. 

Steps: 

 From the Summary View ribbon, select Drill Up . 

The item fields are removed, restoring the summary to its initial state. 

 Click Drill Up  once more. 

Monarch further collapses the summary by removing a key field; in this case, the Media field. The collapsed 
version of the summary shows sales broken down by customer. 
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Figure 15-16. After drilling up twice, the summary breaks out totals only by customer.  

 Select Drill Down  from the Summary View ribbon.  

The summary is restored to its original state. Let’s expand the summary even further to once again view the item 
fields we added. 

 Click Drill Down  once more.  

The summary is expanded to display the item fields. At this itemized level, each line in the summary 
corresponds to an individual transaction from the Classic report. 

 

Figure 15-17. Completely expanded, the summary displays individual transactions (partial summary shown).  
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COPYING AND PRINTING SUMMARIES 

You can copy summary data to other applications or print it. You perform these operations in the Summary window 
the same way you perform them in Report view or Table view.  

DUPLICATING SUMMARIES 

You may want to create a new summary that closely resembles a summary you previously defined. An easy way to 

do this is by using the Duplicate  button. To duplicate a summary, simply select the summary you want to 

duplicate from the Summary list and then select Duplicate  from the Summary Design ribbon. The duplicated 
summary appears on the Summary list; this summary will have the name of the summary you duplicated and a 
number appended to it. Select this summary to display its properties in the Summary Definition window and make 
further revisions to it. Select Accept when you are finished to accept and save your new summary definition. 
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[16] ADVANCED SUMMARY 
CAPABILITIES 

In the previous chapter, you learned how to define a summary report using Monarch’s Summary window. In this 
chapter, you’ll continue your tour of the Summary window and learn how to create more advanced summary reports 
to reveal more information about your data. The lesson topics include: 

❑ Displaying key field values across 

❑ Sorting a summary 

❑ Creating a top 10 analysis 

❑ Specifying key field values 

This chapter assumes that you have completed Chapter 15 and are familiar with the process of creating a summary 
definition. 

To start these lessons, we’ll load Monarch and open Classic.prn and Lesson8.dmod. Go on and display Summary 
view.  

SUMMARY DISPLAYS 

Summaries can be configured to show various details. The following sections outline the steps to do so.  

Displaying Key Field Values Across 

When more than one key field is included in a summary report, the values for the first key field are repeated (see the 
values for the Customer field in the preceding illustration). This can sometimes make for a crowded feel and does not 
offer the most efficient method of displaying data. 

While you could suppress duplicate values to provide a cleaner summary display, the summary still requires a large 
number of rows on screen. With only 20 customers represented in our summary, the summary extends 95 rows, or 
about two pages. 

To provide a more compact summary display, Monarch allows you to display the values for the rightmost key field (in 
this case, Media) across the top of the summary, creating a two dimensional matrix. This format, sometimes referred 
to as a crosstab summary, allows for quick comparisons of multiple data groups. 

For summaries like the one we’ve created, this format provides an ideal solution since it displays the entire summary 
matrix on screen at one time. Let’s see how this works. 

Steps: 

 Ensure that the Sales by Media summary is highlighted in the Summary selector. 

 Select Summary Design > Keys and then select Media from the Key Fields selector to display its properties.  

 Select the Layout subtab, select the Across (row) radio button, and then choose Accept  from the ribbon. 

The summary is rebuilt with the Media values spread across the top row.  
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Figure 16-1. Summary with customer values displayed down and media values displayed across.  

Displaying Null Values 

For some media types, such as BLU (Blu-ray discs) and LP (Long Play albums), no sales have been made to certain 
customers. For example, see the “---” strings in the BLU column for the first ten customers. In this case, it would be 
incorrect to display a zero value in the summary report, since zero might suggest that some amount of sales were 
made to this customer.  

For example, consider the case where a customer places an order for several DVDs and in the same period returns 
several previously purchased DVDs. If the total purchase price of the returned media equals the price of the new 
media, the value for this customer would be zero, indicating a net purchase of zero. However, if the customer never 
placed any orders for digital compact cassettes, a zero would not be appropriate. In this case, the value of “---” 
indicates that no sales or returns have been recorded for this media type. 

By default, Monarch displays null values as the string “(null)”, but you can specify another string, or even a blank 
string, to represent null values if you like. You might find the string “(null)” a bit distracting when you’re viewing this 
type of summary report, so let’s change the default string to something else. 

Steps: 

 Select Home and then click the Options  button to launch the Options window. 

 Select the View button from the Options ribbon to display the View options.  

From this screen, you can set several options that affect the way data is displayed on screen in Monarch. 

 Click in the Display null values as edit box, change the “(null)” string to “*”, and then click Accept  in the 
window’s ribbon. 

The Sales by Media summary is redisplayed using the string you specified. 
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Figure 16-2. Null values represented by *.  

 Return the previous null value before moving forward with the lesson.  

Adjusting Column Widths 

Sometimes, you can avoid scrolling altogether by reducing the column widths in a summary so that all of the 
information fits on screen. When Monarch builds a summary, it sets the column widths wide enough to handle large 
numbers, such as 1,000,000.00. If the resulting columns are wider than you need to display your summary data, you 
can adjust them to fit more columns on screen.  

 

NOTE Column Widths for Across Keys 

All of the columns generated from an across key field (in this case the CD, BLU, LP, 
DVD, and SACD) columns are based on the column width of the measure. To set the 
column widths, either use the mouse as described below or double-click on the 
measure (the last column of the summary) and use the Measure window to change 
the width of the measure. All columns related to the key field will snap to the width 
assigned to the measure.   

You can use the mouse to set column widths. Using the mouse is less precise than 
using the window, however, requiring you to estimate the column width. To use the 
mouse to set a column width, position the mouse cursor at the right edge of the 
column title. The mouse cursor changes to a resizing handle. Click down and drag 
left or right until the column title is the desired width. 
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Freezing Panes 

When you spread key values across the top of the summary matrix, the summary often becomes wider than the 
display width, especially if you are using a 640 x 480 display. Scrolling right to view more information often removes 
the most important information from the display, i.e., the highest-level key fields, in this case the Customer field. To 
prevent columns from scrolling off screen, you can use Monarch’s Freeze Panes command. Let’s freeze the 
Customer column and then scroll right to view the rest of the summary columns. 

Steps: 

 Ensure that the Sales by Media summary is highlighted in the Summary selector. 

 Click on the column heading BLU so the entire column is highlighted.  

 Select Freeze Panes  from the Summary view ribbon.  

The Freeze Panes command acts just like the same named command in Microsoft Excel: it locks all rows above 
the cell pointer and all columns to the left of the cell pointer so that they remain on screen when you scroll the 
rest of the summary. This command also works in the Table view, and is retained in Excel file exports. 

 Click on the arrow on the right side of the horizontal scroll bar to scroll right. 

Note that the Customer column remains visible while you scroll. 

 Use the arrow at the left edge of the scroll bar to scroll back to the left. 

 Select the drop-down button of the Freeze Panes tool and then select Unfreeze Panes  to unfreeze the 
Customer column. 

 

Viewing Other Measures 

You may have noticed that our summary displays only a single measure calculation, even though it displayed two 
measures when we started this lesson. 

When you elect to display values for a key field across the top of the summary, Monarch forms a two-dimensional 
matrix that displays a single measure at a time by default. To display results for a different measure, you can select it 
from the Active Measure drop-down list on the Summary window. This list displays the names for all measures 
included in the summary definition. When you select a measure from this list, the summary is redisplayed to show the 
results calculated for that field. 

Steps: 

 Ensure that the Sales by Media summary is highlighted in the Summary selector. 

 On the Summary view ribbon, click the drop-down arrow of the Active Measure list box. This box currently 
displays “Amount.” 

   

Figure 16-3. The Active Measure drop-down list in the Summary tab.  
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 Select %Amount from the list of available measures. 

   

Figure 16-4. Viewing the %Amount measure.  

The summary is re-displayed to show media sales as a percent of total sales. Note that the Summary line at the 
bottom of the summary displays the percentages represented by each media type across all customers and the 
rightmost column represents percentages for by each customer across all media types. 

Displaying Multiple Measures in Across Key Summaries 

Monarch allows you to display multiple measures in across key summaries. Let’s try doing this. 

Steps: 

 Ensure that the Sales by Media summary is selected.  

 Click the drop-down arrow on the Active Measure drop-down list and select All, by Key. 

Monarch displays both of the measures grouped by key.  

 

NOTE Choose a smaller font size and auto-size the column widths in order to display all of 
the data in the summary window. 
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Figure 16-5. Displaying both measures grouped by key.  

You may have to adjust the font size to 10 to reasonably view all the columns.  

We can also choose to view all of the measures grouped by measure.  

 Click the drop-down arrow on the Summary tab’s Active Measure list box and select All, by Measure. 

Monarch displays both measures grouped by measure.  

   

Figure 16-6. Displaying both measures grouped by measure.  

Let’s return to our across key summary with only one measure. 

 Click the drop-down arrow on the Active Measure list box and select %Amount and restore the font size to 12. 
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SORTING A SUMMARY 

When you define a summary, Monarch initially displays the key field values in ascending alphabetical order. You can 
see this in the summary in Figure 16-1. Here, the Customer values are displayed starting with Betty’s Music Store, 
proceeding to The Record Store. The same holds true for the values of the Media field (BLU, CD, DVD, LP, SACD). 

If the initial display order is not what you want, you can modify the order for any key field using the Keys window. 
Let’s change the sort order for the Customer key field to sort the customer field values in descending order. 

Steps: 

 Ensure that the Sales by Media summary is selected. 

 Double-click on the Customer column to display the properties of this field. The Keys screen is focused.  

 Click on the Sorting subtab.  

 Under the Direction heading, select the Descending radio button, and then choose Accept . 

The summary is redisplayed sorted in descending order by customer. 

   

Figure 16-7. Sorting a key field.  

SORTING BY MEASURE VALUES 

Monarch can also sort a summary based on the values of a measure. Let’s use this feature to sort our customers 
from largest to smallest. First, we’ll select the SUM(Amount) measure calculation to show sales totals for each 
customer. 

Steps: 

 Ensure that the Sales by Media summary is selected. 

 Select Amount from the Active Measure drop-down list located on the Summary view ribbon.  
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Now we’ll sort the Customer key field values based on the values of the SUM(Amount) field. This has the effect 
of ranking customers by sales totals. We’ll sort in descending order to rank customer sales from largest to 
smallest. 

 Double-click on the Customer column to display the properties of this field.  

 Click on the Sorting subtab of the Customer field. 

 Under the Sort By heading, select the Measure radio button. 

The SUM(Amount) field is already selected as the measure to sort on. 

 Ensure that the Descending option is selected. 

 Choose Accept . 

The summary is redisplayed with customers sorted in descending order by sales totals. Note that Hope’s Sweet 
Notes appears first because it has the largest total sales amount of any customer (661.97), followed by Musique 
Royale with a sales total of 595.43, and so on. 

  

Figure 16-8. Sorting a key field based on the values of a measure.  

Let’s also sort the Media field values in the same manner. The result should show the media type with the largest 
overall sales first, followed by the second largest in terms of sales, etc. 

 Double click on any cell in the Customer column once more.  

 Select the Media field and then click on the Sorting subtab. 

 Select the Measure radio button under the Sort By heading. 

The SUM(Amount) field is already selected as the measure to sort on, but the sort order is set to Ascending. 
We’ll change this to Descending in order to display the media type with the largest sales first. 

 Select the Descending radio button under the Direction heading, and then choose Accept . 

The summary is redisplayed with customers sorted in descending order by sales totals and Media types also 
sorted in descending order by sales totals. 
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Figure 16-9. Sorting both Customers and Media types by sales totals.  

Note that CD appears first because it has the largest total sales amount across all customers (5403.11), followed 
by DVD with a sales total of 612.01, and so on. The sales totals appear in the Summary row at the bottom of the 
summary report. 

RESTORING THE KEY FIELD DIRECTION 

So far, we’ve shown how to create a crosstab summary that displays the values for a single key field across the top 
row, forming a two-dimensional matrix. This format is useful for displaying a lot of information, but it may not be ideal 
for all summary reports. With Monarch, you can switch between this format and a more traditional report format, 
choosing the appropriate format for your data and viewing requirements. Let’s reset the Media field to display its 
values down rather than across. 

Steps: 

 Ensure that the Sales by Media summary is selected.  

 Double-click anywhere on the Customer column to display the properties of the Key fields.  

 Click on the Media field and then select the Layout subtab. 

 Under the Orientation heading, select the Down radio button. 

Now, let’s suppress duplicate values in the Customer column to give a summary report a nicer look. 

 Select the Customer field and then click on the Layout subtab. 

 From the Key values drop-down box, select Suppress Duplicates and then select Accept . 
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The summary is redisplayed suppressing duplicate customer names. 

  

Figure 16-10. Restoring the summary to a more traditional display format.  

Notice that the summary is still sorted in the same manner, with customer groups sorted in descending order by 
sales amounts (entire summary groups are sorted based on the subtotal values for each group). Within each 
customer, the media types are also sorted in descending order by sales. In this format (with no key field 
displayed across), the summary can display both the SUM(Amount) and %(Amount) measure calculations at the 
same time. 

TOP N ANALYSIS 

Top n analysis, typically referred to as Top 10 Analysis, is a common tool provided by data analysis applications. 
You can create a top n analysis or bottom n analysis of your summary data by first sorting the data in the appropriate 
order and then by selecting the first n values, whether n is 10, 3 or some other number. These values then represent 
either the top n or the bottom n analysis. Let’s see how this works. 

We’ll create a top 3 analysis from our sales summary that shows the top three customers in terms of sales. All other 
customers will be represented using a single summary label, “All Others.” To create our top 3 analysis, we start by 
sorting the customers in descending order by sales totals. This places the top performing customers at the top of the 
summary display. We’ve already applied this sort in our previous discussion on sorting. Next, we need to indicate that 
we want to see only the first three customers (the three customers with the largest sales totals). 

Steps: 

 Ensure that the Sales by Media summary is selected. 

 Double-click on the Customer field to display the properties of the Key fields.   

 Select the Matching subtab for the Customer field. 

 Select the First N Values option and enter 3 in the box (this is the box labeled Count of distinct values as 

sorted). 

 Under the Accumulator for values after the First N heading, ensure that All Others is entered into the Label field.  

 Select the Media field. 
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 In the Layout subtab, select the Across orientation and then click Accept .  

The summary is rebuilt to show only the top three customers. All other customers are grouped together and 
represented by the “All Others” label. 

  

Figure 16-11. A Top 3 analysis showing the top performing customers in terms of total sales.  

You can easily modify this summary to show the bottom 3 customers in terms of sales totals by sorting the customer 
key field in ascending order. Likewise, you can increase or decrease the number of customers that you explicitly 
break down for analysis by increasing or decreasing the value in the Customer field’s First n Values option. 

A top n analysis can be defined at any level in the summary. Within each customer, you can define a top 3 analysis of 
each media type by sorting the media type in descending order and then selecting the First n Values option for the 
Media key field and entering the desired number in its spin box. 

SPECIFYING KEY FIELD VALUES 

While performing a top n analysis is useful when you want to determine which items (customers, salespeople, etc.) 
are the top performers, sometimes you already know which items you want to look at, whether they are the top 
performers or otherwise. For example, suppose you want to focus on just the digital media types (compact discs, 
digital versatile discs, and LPs). You could do this by creating a filter in the Table view with the filter expression: 

Media="CD".Or.Media="DVD".Or.Media="LP" 

You could also write this expression as:  

Media.In.(“CD”, “DVD”, “LP”) 

By applying the filter to the summary definition, the summary would display information about only the digital media 
types. However, Monarch provides an easier and, in some cases, more powerful method of achieving this result. For 
each key field, you can define a list of all values you want to use when building the summary. Further, you can 
accumulate all values not in your list as a single key value (a feature not available if you use a filter). To demonstrate 
how this works, let’s create a list of values to use for the Media field. 

Steps: 

 Ensure that the Sales by Media summary is selected. 

 Double-click on the Customer field to display the properties of the Key fields.  

 Select the Media field and then navigate to the Matching subtab. 



 

Altair Monarch 2024.0 Learning Guide  320 

 

  

Figure 16-12. Displaying the Matching subtab of the Media tab.  

 Check the Values from table option. 

 Click the Add button. 

All unique values found within the Media field (BLU, CD, DVD, LP, and SACD) are displayed. 

  

Figure 16-13. Specifying sorting values. 

 Select CD from the Key Values list, and then click the Add button to add this value to the Specified or Upper 
Limit Values list. 

 Repeat Step 5 to add the DVD and LP values to the Specified or Upper Limit Values list.  

The selected values appear in the subtab’s Click to sort values list. 

 Click the Finish button to close the Key Values list. 

Let’s accumulate the old media types (BLU and SACD) under a separate heading. 

 Ensure that the Display box under the Accumulator for unmapped values heading is selected. 

 Type All Others in the Label box, and then choose Accept . 

Monarch rebuilds the summary using only the selected media types. The two media types not specified (BLU 
and SACD) are combined under the label All Others.  
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Figure 16-14. Using specified values to break down specific digital media types versus all other media types.  

SORTING BY KEY FIELD VALUES 

Once you have specified key field values, you can sort the summary data by either the specified values themselves 
(i.e., their names) or by their order in the Specified or Upper Limit Values list on the Matching subtab. To do so, 
select the Key Field radio button on the Sorting tab, and then choose either the Field Value option (to order the data 
by the field value names) or the Position in values table option (to order the data by their position in the Specified or 
Upper Limit Values list).  

 

NOTE The Position in values table option is not available if the Values from table option on 
the Matching tab has not been chosen. 

 

UPPER LIMIT VALUES 

While the Values from table option lets you select the exact values you want to use in your summary, sometimes you 
want to group values into ranges, such as weekly or monthly periods. This capability is provided via the Upper Limit 
Values option. This option lets you define an upper limit for each range of values. An example of this can be seen in 
the Sales by Ship Date summary. 

Steps: 

 Click on the Sales By Ship Date summary in the Summary Selector. 

 Select Autosize Columns  from the Summary tab to maximize your view of all of the fields. 

The Sales by Ship Date summary displays. This summary breaks out sales for all customers across four weekly 
periods during the month of April 2010. We created this summary by using the dates 04/07/2010, 04/14/2010, 
04/21/2010, and 04/28/2010 to define the ending dates for each weekly period. 
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Figure 16-15. Using upper limit values to break down ship dates into weekly periods.  

SUMMARY LIMIT VALUES 

Another way to analyze summary data is to set a limit against a measure. This feature works somewhat like a filter 
that is applied after the summary is built. For example, the Sales >=400 summary displays only those customers for 
which totals sales exceed 399.00. 

Steps: 

 Click on the Sales >=400 summary in the Summary selector. 

The Sales >= 400 summary displays. This summary breaks out only those customers for which total sales are at 
least 400.00 (There are seven such customers). All other customers are grouped together under an “All Others” 
label. 

To create this summary, simply double-click on the Customer field, and then select the Matching subtab of the 
Customer field. Select the Measure Limit radio button. Choose the SUM(Amount) field, the “>=” operator, and 
enter 400 in the adjacent field.  
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Figure 16-16. Specifying summary limits.  

  

Figure 16-17. Using Summary Limit Values to break down large customers.  

At this point, you can either save your work or simply close the report and model files you opened for this lesson.  
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[17] EXPORTING OPERATIONS 

A key feature of Monarch is that you can export input files, as well as extracted data, into a number of file formats.  

This lesson will discuss how to export: 

❑ Reports 

❑ Tables 

❑ Summaries 

Reports may be exported as .txt and .pdf files, while tables and summaries may be exported to a wider variety of 
formats, including .csv, .xls, .xlsx, .mdb, .dbase, .accdb, .htm, and .xml, among others.  

If your Monarch license is for Monarch Complete, you can export tables and summaries to the Tableau data extract 
(.tde/.csv) and QlikView QVX (.qvx) formats. Tables may also be exported as a SAPExport or SAP Transport files.  

Note that Monarch Classic no longer supports integration with Panopticon Designer. Thus, while the settings of 
exports to this application may display in workspaces created in previous versions of Monarch Classic, these exports 
will fail when run and return the message "Panopticon Designer was deprecated in 2020, please use an alternative 
export format." 

We’ll begin by loading the Classic.prn report file and the Lesson8.dmod model file. 

EXPORTING REPORTS 

Monarch allows you to export data from the Report window specifically into a TXT or PDF file. When exporting to a 
PDF file, if you have configured the Report Index, the tree definition will provide the bookmarks in the PDF file. 

Let’s try exporting the Classic.prn file to a PDF file.  

Steps: 

 Select the Export tab to display Export view. 

  

Figure 17-1. The Export view interface.  
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The Export interface is divided into several panels. To the left of the interface is an Export Selector. The right-
hand side shows to smaller panels arranged one on top of another. The top panel shows the Export Job List. 
Any export selected from the Export Selector and added to this panel becomes a job. The bottom panel shows 
the Export Results. Each time you run an export/job, the results of the export process are added to this panel  

The following table summarizes the functions of each of the buttons in Export view.  

Use this button… To… 

 Export Design 
Launch the Export Design interface 

 Select All Exports 
Select all defined exports 

 Clear Selected Jobs 
Clear all selected jobs 

 Clear Job List 
Clear the job list 

 Create Export 
Create a new export 

 Run Export Run the export 

 

 

 Select Create Export to begin defining your export. The Create Export dialog displays.  

 

Figure 17-2. The Create Export dialog.  

Let’s take a look at this dialog. The File Name field allows you to specify the file name to which the export should 
be saved. Most of the dialog is divided into two panels, the Source View panel and the Export File Type panel. 
The Source View panel allows you to select a view or parts of views (in the case of summaries) to export, and 
the Export File Type panel allows you to select a file type in which to save the export.  

 Enter the file name Export1 in the File Name field. 

  



 

Altair Monarch 2024.0 Learning Guide  326 

 

 From the Source View panel, select Report.  

Note that the entries in the Export File Type panel change to reflect the different file types to which you can save 
the export.  

 

Figure 17-3. The options in the Export File Type panel show the file types to which you can save the report when 
exported.  

 Select Adobe PDF (*.pdf) from the Export File Type panel.  

For this exercise, let’s choose to password-protect the PDF file.  

 Click on the button Edit Advanced Options. 

The dialog closes and the Export Design view displays. A PDF Output panel displays on the right side of the 
view.  

 

Figure 17-4. Advanced options made available when exporting a report to a PDF file.  
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You can add a password to your PDF file by checking the box for Require a password to open the document 
and then clicking the Open Password button.  

If you would like to restrict access to the content of the exported report, you may do so by checking the Restrict 
access to document contents box and then selecting which actions you want to permit. You can even specify a 
password to allow these actions to be executed by clicking the Permissions Password button.  

 We’re not adding any advanced option to our export at this stage so simply select Accept to save the export.  

The Export Design view closes and you are brought to Export view. 

Let’s try running our export now. 

 Double-click on Export1 in the Exports Selector panel so that it is added to the Export Job List. Click on this 
export in the job list panel. 

 Select the Run Exports  button from the Export ribbon.  

The export runs and the results are displayed on the Export Results panel. 

 

Figure 17-5. The Export Results panel shows the results of each export run. This export was successfully completed.  

To view the exported file, click on the export link provided. Doing so copies the path indicated, and you can use 
your mouse to paste this path into your file explorer to navigate to the location of the file.  

The default folder for exported files is specified in the Options window (typically in 
C:\Users\Public\Documents\Altair Monarch\Export).  

Since we opted to password-protect our PDF file, you will be asked to supply the password you specified before 
your file can be opened.  
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Figure 17-6. The PDF file includes all 20 records of Classic.prn.  

Before proceeding with the rest of the lesson, return to Export view and then select Clear Job List. All of the 
jobs added to the job list are run every time you select the Run Exports button. Since we are only interested in 
showing the results of individual exports at this time, we’ll need to clear the Export Job List so that previous jobs 
are not run together with new jobs. 

While it is not required that you do so, you may also clear the Export Results panel by selecting the Clear 
Results button. 

EXPORTING TABLES 

This time, we’ll try exporting the table we extracted using the templates defined in the Lesson8.dmod model file. 

Steps: 

 Select Create Export from the Export ribbon. 

 Enter Export2 in the File Name field of the Create Export dialog that displays. 

  



 

Altair Monarch 2024.0 Learning Guide  329 

 

NOTE The export file name (the name of the file to which you will export data) and the 
export name that displays in the Export Selector have no relation. You can choose to 
export to any file name you wish. The Export Selector will create export names in the 
order in which the export was created beginning from Export1.   

 

 Ensure that Table is selected in the Source View panel and then select Microsoft Excel XLSX (*.xlsx) from the 
Export File Type panel.  

 The Table Name field is activated at the lower right-hand corner of the dialog. Enter the name Table1 here.  

 

NOTE For Excel files, “Table Name” corresponds to a Worksheet name or Named Range, 
and Named Ranges must begin with a letter or underscore, must not be ”C”/“c” or 
“R”/“r”, cannot contain spaces, and must not be the same as a cell reference, e.g., 
R1C1, A1, Z$100, etc., or any other Excel built-in names or objects in the workbook. 

 

 Select the Add to Project button located at the top of the Create Export dialog. 

You are returned to the Export interface. Note that Export2 has been added to the Export Selector.  

Let’s run this export and check our results. 

 Double-click on Export2 from the Export Selector so that it is added to the Export Job List. 

 Select Export2 from the job list and then click the Run Exports button on the Export ribbon.  

 

Figure 17-7. The Export Results panel indicates that the export was successfully run. 

To view the file to which your table was exported, as in the previous lesson, click on the export link provided. Use 
your mouse to paste the copied path into your file explorer to navigate to the location of the file. Select the file to 
open it.  
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Figure 17-8. The exported table. Note that the table is named Table1, as specified in the Create Export dialog. 

As usual, clear the job list before proceeding to the next lesson.  

 

EXPORTING SUMMARIES 

The Lesson8.dmod model includes three summaries. Since we can create more than one summary in a single 
Monarch session, aside from specifying an export name and export file type, we’ll also have to specify which of these 
summaries to export. You can only export one summary at a time. If you wish to export another summary to the same 
file name, you’ll have to add this summary as a new table to the file. Let’s look at how we do this in the following 
example. 

Exporting a Single Summary 

Steps: 

 Select Create Export from the Export ribbon. 

 Enter Export3 in the File Name field of the Create Export dialog that displays. 

 Ensure that the summary Sales by Ship Date is selected in the Source View panel and then select Microsoft 
Excel XLS (*.xls) from the Export File Type panel.  

 The Table Name field is activated at the lower right-hand corner of the dialog. Enter the name SalesbyShipDate 
here. Note that table names cannot contain spaces.   

 Select the Edit Advanced Options button located on the upper right-hand corner of the dialog. 
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The Export Design interface is activated. 

 

Figure 17-9. Advanced Export options for summaries. 

The left-hand panel of the Export Design view provides a host of summary options. You can: 

• Choose another summary to export using the Summary drop-down 

• Specify a drill state (assuming that you had either drilled up or drilled down on the summary) 

• Specify an active measure to apply to the summary prior to export 

• Split the summary into distinct files or tables according to key values 

• Apply a filter to the summary (this option is deactivated if the summary includes no filters) 

• Apply a sort order to the summary (this option is deactivated if the summary includes no sorts) 

Note that the options you choose to apply to your summary may result in more than one exported file, and you 
can choose how these files are to be named (i.e., either by file name or by table name).  

In the present case, for example, choosing the option All measures as separate exports will require you to 
choose whether the measure title should be applied as individual tables or individual file names. In the former 
case, you create one file with two tables named according to the measure title. In the latter case, you create two 
files named according to the measure title.  

The right-hand panel of the Export Design view provides your usual export options, including the folder/filename 
to save your export to, the file format to apply, what tables should be named, etc. 

Note that when specifying a file name in which to export your summary, you must ensure that the file extension 
indicated matches the file type selected in the Export File Type drop-down. 

 For this lesson, let’s use the default summary options as export parameters. 

 In the Export Options section of the Export Design view, ensure that Overwrite file is selected as a When 
output files exist option.  

 Click the Accept button to save the export you’ve just defined. 

You will be returned to the Export interface when you do so. Note that Export3 has been added to the Export 
Selector.  

Let’s run this export and check our results. 
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 Double-click on Export3 from the Export Selector so that it is added to the Export Job List. 

 Select Export3 from the job list and then click the Run Exports button on the Export ribbon.  

When successfully exported, the summary can be viewed as follows. 

 

Figure 17-10. The exported summary. 

Clear the job list before proceeding to the next lesson.  

Adding a Summary to an Export File 

Now we’ll add another summary to the Export3.xls export file.  

Steps: 

 Select Create Export from the Export ribbon. 

 Enter Export3.xls in the File Name field of the Create Export dialog that displays. 

 This time, select Sales >=400 from the Source View panel and then select Microsoft Excel XLS (*.xls) from the 
Export File Type panel.  

 The Table Name field is activated at the lower right-hand corner of the dialog. Enter the name 
SalesOf400Above here. Note that table names cannot contain spaces.  

 In the Export Options section located at the lower left-hand corner of the dialog, expand the When output files 
exist options and then select Add data to file. 

 A drop-down box for When output tables exist options appears. Select Add data to table. 

 Select the Add to Project button located at the top of the dialog.  

You are returned to the Export interface when you do so. Note that the export you’ve just defined displays as 
Export 4 in the Export Selector because it is the fourth export you defined.   
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 Double-click on Export4 from the Export Selector so that it is added to the Export Job List. 

 Select Export4 from the job list and then click the Run Exports button in the Export ribbon.  

 

Figure 17-11. The Export Results panel indicates that the export was successfully run. 

When the exported file is opened, the table SalesByShipDate displays as the first table of the file. A second 
table, SalesOf400Above, is also added to the file. Select this table to view its results. 

 

Figure 17-12. The exported file showing two tables. 
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Figure 17-13. The SalesOf400Above table displays the data in the Sales>=400 summary. 

 

EXPORTING REDACTION ALIAS MAPS 

As Monarch processes a report/model which involves consistent alias replacement redactions, it generates a 
redaction alias map for each such redaction. The map expresses the relation between the un-redacted and the 
redacted values for that particular type of redaction (e.g., “Consistent alias text”), and for that particular build. Since 
the redacted values are generated based (at least partly) on random numbers, the specific aliases recorded in a map 
will change from build to build, even if Monarch is run against the exact same report and model. 

Monarch automatically discards its redaction alias maps when doing a Close All or when exiting. However, in some 
circumstances, it may be desirable to export a redaction alias map so that it may be archived or used by some 
downstream process. Monarch provides for exporting redaction alias maps as simple delimited text files. 

To export a redaction alias map, launch the Create Export dialog and then dialog select Redaction Alias Map under 
Source View. Notice that when this view is selected, the only option under Export File Type is Delimited Text.  
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Figure 17-14. Exporting a redaction alias map.  

Use this dialog to specify your desired output file name and the particular Redaction Map Type you wish to export, as 
shown below. 

 

Figure 17-16. Selecting a redaction map type.  
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The Redaction Map Types listed in the dropdown box correspond directly to the five distinct types of consistent alias 
replacement redactions available. 

When you run this export, the redaction alias map of the selected type is exported to the specified output file as 
delimited text using the delimiter and string quoting mechanism common to all delimited text exports (see the “For 
Delimited Text Files” settings of the Text Files tab under Options > Export). The exported map file consists of just 
two columns: the first contains the un-redacted values, and the second contains the corresponding redacted values.  

For example, the first few lines of an export of a “Consistent alias text” map might look like this: 

"1000-2000-3000-4000","5w7wiwowywkwzwxeg8o" 

"alpha","uuuuu" 

"beta","9999" 

"gamma","uuuuz" 

"delta","uuuuo" 

"epsilon","ooooooo" 

"The Quick Brown Fox Jumps Over The Lazy Dog","0h0h4h0hohvhphnj0amnbueevrjgphdmjm3fts86bgg" 

"7235-5311-6745-2225","zwiwiwswww5wo9kuooz" 

 

EXPORTING TO TABLEAU SERVER 

Tableau Server, by Tableau Software®, is an online solution for sharing, distributing, and collaborating on content 
created in Tableau or exported to Tableau Data Extract form. Monarch offers a simple solution to allow data extracted 
in the application to be exported to Tableau Server quickly and seamlessly.  

Steps: 

 Create an export and select Tableau Data Extracts (.tde) as an export file type. 

 If you created your export via the Create Export dialog, select Edit Advanced Options. If you created your 
export via Export design, you will not need to perform this step. 

 Check the box for Publish to Tableau Server. 

 The information you entered to access Tableau Server in the Security tab of the Options window displays. If you 
did not provide the necessary information in this tab, you can do so now. 

 

Figure 17-17. Specifying Tableau Server connection settings.  
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NOTE You can skip this step if you have specified Tableau Server connection settings in the 
Security tab of the Options window. 

 

 Enter a data source name into the field provided and select a publish type. 

• Overwrite Data Source - This option will erase the existing data source and replace it with a new one 
containing the newly exported data. 

• Replace Data - This option will erase all previous data in the data source and replace it with the newly 
exported data. 

• Append Data - This option will append the newly exported data to the data in the existing data source. 

 Select Accept when you are finished to close Export Design view and add your newly defined export to the 
Export selector in Export view. 

 Run the export as usual. 

DUPLICATING EXPORTS 

You may want to create a new export that closely resembles an export you previously defined. An easy way to do this 

is by using the Duplicate  button. To duplicate an export, simply select the export you want to duplicate from the 

Export list and then select Duplicate  from the Export Design ribbon. The duplicated export appears on the 
Export list; this export will have the name of the export you duplicated and a number appended to it. Select this export 
to display its properties in the Export Definition window and make further revisions to it. Select Accept when you are 
finished to accept and save your new export definition. 
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[18] IMPORTING DATA FROM HTML, 
WEB FILES, AND EXTERNAL 
DATABASES 

This chapter, and the ones that follow, deal with advanced capabilities found in Monarch.  

For most of its history, Monarch has been the leading report mining tool available in the market, allowing access to 
data buried in computer generated reports. Monarch transforms static report data into live data that you can explore, 
analyze, and export to other applications. While its ability to re-deploy data locked inside reports has been the major 
factor distinguishing Monarch technology from other data access technologies, Monarch also includes powerful data 
manipulation, analysis, and transformation tools that potentially make it valuable for use with other data sources. 

Monarch reads report files and data from database files, spreadsheet files, delimited text files, HTML, ODBC 
databases, PDF and XPS files, and provides report extraction, data manipulation, analysis, and transformation 
capabilities. As well, data access from additional sources, including dBase, MS-Excel, and MS-Access files, OLE DB 
and ODBC compatible data sources, such as SQL Server, Oracle, DB2, MySQL, and others, is possible. 

In this chapter, you will learn how to import data from an external data source to begin a Monarch session. You will 
also learn how to import HTML and web files into Monarch. The lesson topics include: 

❑ Accessing database data with Monarch  

❑ Importing data from an external database 

❑ Adjusting fields 

❑ Storing import parameters in a model file 

❑ Storing import parameters in a project file 

❑ Importing data from an HTML file 

❑ Importing data from a Web file 

IMPORTING DATA FROM AN EXTERNAL 
DATABASE 

To illustrate Monarch’s database import capability, we’ll import data from an MS-Access database file called 
Employ.mdb. This file contains information about the employees of a fictitious company. We’ll use Monarch to open 
the file and import data from its Employee Roster database table. 

Steps: 

 Ensure that Monarch is up and running.  

 Select File > Open > Database > Computer.  

The Open Database File dialog displays. This dialog allows you to select the data source, either a data file from 
a local or network drive or an OLE DB/ODBC data source, such as a SQL Server, Oracle, or other OLE 
DB/ODBC compatible database server. 
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Figure 18-1. The Open Database File dialog.  

Monarch can import data from the following local file formats: 

File Format Versions Extension 

MS Access 2003 and earlier MDB 

MS Access 2007, 2010, 2013 ACCDB 

MS Excel 5.0, 8.0 XLS 

MS Excel 2007, 2010, 2013 XLSX, XLSM 

dBASE III, IV, 5.0 DBF 

Delimited text files  CSV, TAB, ASC 

HTML  HTM, HTML, ASP 

PDF files 1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6 PDF 

XPS 1.0 XPS 

 

If you wanted to import from an OLE DB-compatible database (and you have the driver installed), you would 
select the OLE DB option, instead of Computer, and then choose whether to import data via the Data Link 
Wizard or a Data Link File. Note that OLE DB is usually faster than ODBC, so if you have a choice of 
connections to your database, choose OLE DB. If you have existing projects and models that use ODBC, then 
you may want to change the connection method to benefit from enhanced performance. 

If you wanted to import data from an ODBC compatible database you would select the ODBC connection 
option, and then use the Select an ODBC Data Source dialog that displays to select the ODBC data source 
name (DSN) that connects to your ODBC data source. Monarch can import data from ODBC data sources for 
which you have established an ODBC Data Source Name definition (referred to as a DSN). Monarch does not 
create a DSN for you – you must create a DSN using the Windows Control Panel ODBC Data Sources applet or 
a similar utility. 

 Open the Employ.mdb file from the Altair Monarch\Data folder. 

 Click the Open button to open the data source. 

Monarch displays the path to the Employ.mdb file in the dialog’s Data Source box. 

 Click the Select Table button to launch the Select Table dialog. 
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The Select Table dialog displays all of the database tables and queries that are available within the selected 
database. This list does not include system tables or queries, which hold information about the database 
structure.  

  

Figure 18-2. The Select Table dialog.  

Our sample Employ.mdb database file holds only a single database table, called Employee Roster. 

 Check the box for Employee Roster. Expanding the node  beside the table name displays all of the fields 
associated with the selected table.  

 

Figure 18-3. Fields associated with the selected table.  

 Click Select to close the dialog.  
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NOTE If you wanted to apply a filter to the data, you could do so by selecting the Apply 

Filter  button located on the upper right-hand corner of the dialog box to launch 
the Filters menu. 

 

 

The right side of the File screen reflects the selections you have made.  

 

Figure 18-4. Reviewing table(s) to open from a database.  

The Model field allows you to specify a model file to apply to the database. Applying a model to a database is 
similar to applying a model to a report. The model holds parameters that indicate which fields to extract from the 
database, along with field properties for each field and filter, sort, calculated field, and summary definitions, if 
any.  

 Select Import Data to bring your data into Table view.   
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Figure 18-5. An excerpt of the table we opened via an Open Database operation.  

 

 If you want to define how the fields of the table should be displayed in table view, in Step 8, choose Define and 
Import Data instead of Import Data. 

 

Figure 18-6. When you select Define and Import Data, the Edit Table Properties screen displays.  

In the Edit Table Properties screen that displays, two tabs may be observed: one to specify which database 
fields you want to import and another to specify a filter to apply. By default, all of the fields are selected for 
importation. Note also that import fields and filter definitions are only saved in project files. 
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You can manually edit the way import column names will appear in Table view by clicking on the appropriate 
cells under the Table Window Name column in the Import Fields tab.  

You can also add a name prefix to one or more of the import column names. To do so, however, you must enter 
the prefix in the Name Prefix box before selecting any of the columns to import. After specifying the prefix, you 
can then either click the Select All button or select individual columns via their check boxes. The names for the 
columns you chose to import will then be displayed, preceded by the name prefix (e.g., if you specified a Name 
Prefix of “Test”, for example, the import column name for the “Department” source column would be 
“TestDepartment.” 

 Since we want to import all fields, leave the default settings as they are and click Accept . 

Monarch launches Table view and populates it with data imported from the Employ.mdb file’s Employee Roster 

table. Select Autosize Columns  to display the fields properly.  

 

Figure 18-7. Monarch’s Table view is populated with the data imported from Employ.mdb – Employee Roster.  

NOTE The Table view may be initially populated using data extracted from report files or 
using data imported from an external database. You cannot draw data from both 
sources at the same time to populate the table. If you start a Monarch session by 
opening a report file, you will not be allowed to import data from an external database 
in that Monarch session. Conversely, if you start a Monarch session by importing 
data from an external database, you will not be allowed to open any report files in 
that Monarch session. These two means of initially populating Monarch’s Table view 
are mutually exclusive. 
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WORKING WITH THE ALTAIR ODBC DRIVERS 

The Altair ODBC Drivers are very similar to the Altair Data Connectors in that both connector types allow you to 
access data from a number of database types. The Altair ODBC drivers support access to, among others, the 
following database types: 

❑ IBM Cloudant ❑ Splunk 

❑ DB2 ❑ Altair Monarch Report Warehouse 

❑ Hadoop Hive ❑ Sybase IQ 

❑ Informix ❑ MongoDB 

❑ MySQL ❑ Teradata 

❑ Cloudera Impala ❑ dBase 

❑ Oracle ❑ OLEDB 

❑ PostgreSQL ❑ ODBC 

❑ Salesforce ❑ Business Objects Universe 

❑ SQL Server ❑ Greenplum 

❑ Amazon Redshift ❑ OData 

❑ JIRA ❑ Zendesk 

❑ Google Ads ❑ Google Sheets 

❑ Google BigQuery ❑ Google Drive 

❑ Active Directory ❑ Box Cloud Storage 

❑ Cassandra ❑ SugarCRM 

 

Despite their similarities, however, marked differences between these connector types may be observed. The ODBC 
Drivers are configured “outside” of Monarch through the ODBC Data Source Administrator, whereas the Data 
Connectors are configured within Data Prep Studio. Whereas the connection settings for the Data Connectors must 
be specified each time a new database table is to be added to Data Prep Studio, the ODBC drivers are configured 
only once and can be applied any number of times to a Monarch session thereafter.  

Because of these differences, you may want to think about what you aim to achieve when you access an Oracle 
database, for example. For instances where you only require quick and dirty data prep operations, working with the 
Data Connectors in Data Prep Studio may be a good choice. If you wish to establish continuous access to a 
database, however, setting up the ODBC Drivers may be a better strategy.  

Of course, if you have opened a table using a Data Connector in Data Prep Studio and wish to add filters and sorts to 

it, for example, you always can bring this table into Monarch by selecting Application Menu  > Open in Classic 
Mode.  

Setting Up the Altair ODBC Drivers 

The Altair ODBC Drivers are stored in C:\Program Files\Common Files\Altair\Drivers. 

Similar to Data Prep Studio, connecting to any of the database types supported in Monarch requires some 
information, including host name, server name, user ID, password, and database name, among others. Which 
information you need will depend on the database to which you are attempting to connect. If you wish to use any of 
the data connectors, contact your database administrator to obtain the necessary connection details.  

This section describes how to set up the Altair ODBC Drivers. As a typical example, this guide will demonstrate how 
to set up the ODBC Driver for Cloudera Impala.  
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Steps: 

 Select Start > Control Panel > Administrative Tools > Data Sources (ODBC). 

The ODBC Data Source Administrator dialog displays.  

 

Figure 18-8. The ODBC Data Source Administrator dialog. 

 Select Add.  

 From the Create New Data Source dialog that displays, select, for example, Altair Impala Wire Protocol.  

The ODBC Impala Wire Protocol Driver Setup dialog displays. 

 

Figure 18-9. The ODBC Impala Wire Protocol Driver Setup dialog. 
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 Provide a data source name so that you can easily identify this driver from a list. 

 Type in the host name and the database name you wish to gain access to. 

 Select Test Connect to check whether or not you have the credentials necessary to access the database you 
named in Step 4. 

 

Figure 18-10. Testing a Cloudera Impala database connection. 

 Enter your user name and password into the appropriate fields.  

 Click OK. 

A message box displays to inform you of the status of your connection. 

Select OK on the ODBC Impala Wire Protocol Driver Setup dialog if you are satisfied with the test connection 
results.  

 

Figure 18-11. The ODBC driver you have just set up is added to the list of allows user data sources in the ODBC Data 
Source Administrator dialog. 
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Figure 18-12. Setting up a number of the Altair ODBC drivers. 

Connecting to a Database Using the ODBC Drivers 

Assuming that you have set up all of the ODBC drivers you need, you can now begin importing data into Monarch. 

Steps: 

 Select File > Open > Database > ODBC. 

The Select an ODBC Data Source dialog displays.  

 

Figure 18-13. The Select an ODBC Data Source dialog.  

 Select Cloudera Impala from the list of data source names that displays and then enter an appropriate Login ID 
and password to connect to this database type.  
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If connection to the database is successful, the Open Database dialog displays and you can select tables as 
described in Importing Data from an External Database. 

 

Figure 18-14. The Open Database dialog confirms successful Cloudera Impala connection.  

For more information and updates on the Altair ODBC Drivers and Monarch documentation, visit 
docs.datawatch.com.  

Notes on The Salesforce Database Connection 

When setting up the Salesforce driver, the ODBC Salesforce Driver Setup dialog displays. After confirming a 
connection to the database you desire, select the Web Service tab of the setup dialog.  

 

Figure 18-15. Changing the Statement Call Limit of a Salesforce connection.  

The Statement Call Limit field has a default value of 20 – this limit results in a maximum number of 40,000 rows 
returned when the database is accessed. To remove this limit, set the Statement Call Limit value to 0.  

Note also that the number of rows returned is generally limited by the type of Salesforce license you have purchased. 
For more information regarding data limitations, consult your Salesforce sales representative. 

  

https://help.altair.com/2024/monarch/
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WORKING WITH DATABASES 

Once you have imported data into the Table view, you can sort, filter, and export the data, create new calculated 
fields, and use the data in the Summary window where you can create summary reports that perform analyses on the 
data. In short, you can do anything with imported data that you can do with data extracted from a report file. 

Typically, the first thing that you’ll want to do when importing data is to inspect each field to ensure that its column 
width, type and other properties are set correctly. After adjusting the column widths, you should briefly inspect each 
field to ensure that Monarch has established the appropriate field type, whether character, numeric, date, or memo. 
When importing data, Monarch sets the type for each field according to its type in the source database. However, 
only a subset of the field types available in many database applications is supported, so it maps subtypes to the 
corresponding base type. 

For example, MS Access supports several numeric field types, including Byte, Integer, Long Integer, Single, Double, 
etc. Monarch supports only Numeric, with General, Thousands, Currency, Percentage, and Time Span formats that 
determine how a number is represented on screen. When you import a numeric field from an MDB file, Monarch will 
always set the field type to Numeric and will assign to it a format type of General. 

You should inspect each numeric field to ensure that its type and other properties are set appropriately. The Net 
Income field is the only numeric field in our imported data set. Let’s inspect this field’s properties. 

Setting Field Properties 

Steps: 

 Double-click on the Net Income field to display its properties via the Field Properties window. 

  

Figure 18-16. Field properties for the Net Income field.  

Note that the decimal setting of this field is set to 0 (zero) and that its format setting is set to General. Let’s 
change the field format to Thousands and the decimals to 2. While we’re here, let’s change the name of this field 
to something more intuitive. 

 Change the field name to Salary and then click the  button adjacent to this field. 

 Click the drop-down button on the Format list to display the available field formats. 
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Note that Monarch displays only numeric field formats. For fields imported from a database, Monarch does not 
allow you to change the base field type (from Numeric to Character for example). 

 Select Thousands as the new field format. 

 Change the Decimals setting to 2. 

 Click the Accept button to accept the changes to the field properties. 

The Table is updated to reflect the changes. 

 

Figure 18-17. Salary field adjusted.  

Setting Delimited Text Properties 

The following settings may be modified when working with delimited text files imported as databases. 

❑ First row contains column names – Check this box to indicate that the first row of the file contains column 
names 

❑ Delimiter character – Specifies the delimiter (i.e., comma, tab, semicolon, pipe, space, other) used in the file to 
separate values 

❑ Quoted values may contain embedded line breaks – Check this box if values may run beyond one line (i.e., 
the value includes a line break) 

❑ Text qualifier – Specifies what character is used (i.e., double quote, single quote, none) to enclose values. 
When Monarch encounters this qualifier in a line, all of the text following this character and preceding its next 
instance is imported as one value, regardless of the delimiter used (see Note below).  

❑ Character set – Specifies the type of encoding to use when interpreting data 

❑ Lines to skip at start – The number indicated in this box instructs Monarch to skip n lines before beginning data 
import 
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NOTE Delimiter vs. Qualifier Example: If the delimiter is a comma (,) and the text qualifier 
is a double quotation mark ("), "Boston, Massachusetts" is imported into one cell as 
“Boston, Massachusetts.” By contrast, if no character or the single quotation mark (') 
is specified as the text qualifier, "Boston, Massachusetts" is imported into two 
adjacent cells as "Boston" and "Massachusetts." 

 

Storing Import Parameters in Project Files 

After making adjustments to the imported fields, it’s a good idea to save your changes to a Monarch project file. 
Project files store both the input file(s) and the model file, including the original names of each imported field, as well 
as the Monarch field name and properties you assigned. By opening project files, Monarch preserves the work you 
did in this session. Let’s save our work to a project file and then reload the session. 

Steps: 

 Select File and then click on the arrow of the Save As  menu. 

 Select Project, and then type Import in the File name box of the Save Project dialog that displays. Leave the 
Save as type field as is.  

 Click the Save button to save the model file. 

 Select File and then click Exit Monarch to exit the Monarch session.  

Opening Project Files 

Now let’s restart Monarch and import the data along with the model file. 

Steps: 

 Select the Monarch item from the Windows Start menu. 

 Select File > Open > Project. 

 In the Open Project dialog that displays, select Import.dprj. 

Monarch displays the imported data and model files in Table view. Note that the table presents as in Figure 18-
17, which indicates that the field definitions we specified in the saved model have been applied to the open 
database. 

 Select File and then click Close All. Select No when asked if you would like to save changes made to the model 
file.  
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IMPORTING DATA FROM AN HTML FILE 

One of the features that distinguishes Monarch from other is its ability to utilize HTML files. With Monarch, you can 
import an HTML file and then create templates to extract data from it just as you would with a typical report. 

When you import an HTML file, Monarch parses it into a “Monarch-friendly” format and adds markup you may find 
helpful when trapping fields. 

 

NOTE Monarch is best suited to work with dynamically generated HTML pages, such as 
those resulting from database queries. 

 

Let’s explore Monarch’s HTML capabilities. 

Steps: 

 Select File, click on the arrow of the Open menu, and then select Report to display the Open Report dialog. 

 From the Files of type drop-down list, select HTML files (*.htm;*.html;*.asp; *.aspx). 

 Select the Airlines.htm file, and then click the Open button. 

Monarch parses the HTML file and displays it in the Report view. Note the markup that Monarch has added (e.g., 
"<Table–00…"). This markup can be used when trapping fields. 

 

Figure 18-18. Viewing the Airlines.htm file.  

Airlines.htm is a list of flights from Boston, MA to Manchester, England. It contains information such as the price 
of the flights, the airline providing them, and their earliest and latest travel and return dates. 

Let’s scroll down the report and look for an appropriate line with which to create a detail template. Remember, a 
detail template is used for extracting information from the lowest report level. 
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Notice that for each flight listed, the Latest Return information is the last given. This should do for our detail 
template, so let’s begin by trapping the Latest Return information. 

 Select the Report Design  button to launch the Report Design interface. 

 Locate one of the Latest Return lines in the report. In the line selection area to the left of it, click and drag so 
that the Latest Return line and the two lines below it are highlighted. 

 

NOTE You can easily locate the Latest Return information via the Search function of 
Monarch. 

 

 

  

Figure 18-19. Highlighting the Latest Return information.  

 Select New Template > Detail to activate the Template Editor. 

 Rename this template Latest Return. 

 In the Trap line, type Latest Return: directly above its occurrence in the Sample Text box, then highlight the 
latest return information (e.g., "1 months") in the Sample Text box. Extend the highlight by one more character to 
include instances of two-digit months.  

  

Figure 18-20. Specifying trap characters and highlighting a field.  
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 The newly defined field’s properties (i.e., those of eg_1 months) display in the Field Properties panel.  

  

Figure 18-21. The Field Properties panel of the field eg_1 months. 

 Type Latest Return in the Name field of this panel and then click the  button that displays next to this field to 

accept your changes. Click the Accept  icon in the window ribbon to save your changes.  

The Template Editor closes and the Report view displays. Scroll down the report and note that all instances of 
the Latest Return information are now highlighted. 

Now that we’ve defined our detail template, let’s define some append templates to capture additional information 
from the HTML file. 

 Click Report Design  once more.  

 Scroll down the report until you come to one of the price lines (e.g., USD 276.00), and then click in the line 
selection area to highlight it. 

 Select New Templates > Append to activate the Template Editor.  

 Replace Append 1 with Price in the Template Name field of the Template Editor.  

 In the Trap line, type USD directly above its occurrence in the Sample Text box, and then highlight the price in 
the Sample Text box. 

  

Figure 18-22. Trapping the Price field.  

The properties of this newly defined field display in the Field Properties panel. 

 Type Price in the Name field, and then click  to accept your changes. 

 Click Accept . 
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The Template Editor closes and the Report view displays. Scroll down the report and note that all instances of 
the flight price information are highlighted. 

Let’s see how the information we’ve trapped will look in Table view. 

 Select the Table tab and then click Autosize Columns  to view all of the fields properly.  

Monarch displays the two fields we’ve trapped as columns in the Table view.  

 

Figure 18-23. Viewing the fields in the Table view.  

 Return to Report view. 

Using the same techniques that we used to trap the Latest Return and Price fields, try trapping some of the other 
fields in the HTML file (e.g., Earliest Return, Earliest Travel, Latest Travel, etc.).  

When you’ve finished trapping as many fields as you want to, view them in the Table view to see how successful 
you are.  

IMPORTING DATA FROM A WEB FILE 

Importing web files on an FTP site of Amazon S3 is possible in Monarch. To do so, simply select File > Open > 
Report > Web to launch the Open Web File dialog. 

 

Figure 18-24. Opening a web file in Monarch.  
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The Open Web File dialog allows you to select a file protocol (e.g., http://, https://, ftp://, etc.) from a drop-down menu 
and enter the name of the file to open in the adjacent text box. Tooltips are provided for each protocol as a guide. The 
drop-down button located to the right of the filename text box enables you to access recently opened web files.  
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[19] CREATING EXTERNAL 
LOOKUPS 

In this chapter, we’ll discuss external lookups, which allow you to add columns from an external database to the 
Monarch table. The lesson topics include: 

❑ A discussion of what an external lookup is 

❑ Creating an external lookup from a report 

❑ Storing lookup parameters in a model file 

❑ Creating a lookup from two different reports 

❑ Creating a lookup from two external databases 

WHAT IS AN EXTERNAL LOOKUP? 

An external lookup (in technical terms, a left outer join) combines information from two or more tables into a single 
table. External lookups are both powerful and easy to use. In Monarch, a lookup can be used to link two or more 
database sources together or to link a report to one or more database sources.  

As an example, consider the tables on the following page. The first table lists employees in the Marketing department 
of a fictional company. This table includes each employee’s name and the city where he or she lives. The second 
table lists employee compensation. Both tables share a common column, called Emp_ID, designating a unique ID 
assigned to each employee. From the Marketing table, you could create a lookup, based on the Emp_ID column, to 
the Compensation table to find the salary and bonus for each employee in the Marketing department. 

Marketing Table 

Emp_ID Dept Lastname Firstname City 

1597429 Marketing April Anne Worcester 

1607768 Marketing Banning David Burlington 

1593642 Marketing Bartholemew Anne Brookfield 

1605798 Marketing Bradford Eugene Brookline 

1588509 Marketing Carlson Stephen Boston 

 

Compensation Table 

Emp_ID Salary Bonus 

1587390 38,480.00 200.00 

1588509 49,452.00 5,000.00 

1593642 42,640.00 4,000.00 

1596792 38,480.00 200.00 

1597429 55,900.00 5,000.00 

1604375 48,620.00 500.00 

1605798 67,990.00 8,500.00 

1607768 72,150.00 10,000.00 

Figure 19-1. Marketing and Compensation tables with a common Emp_ID column.  
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To link data from two tables, you start by defining a lookup between the tables. A lookup connects the tables based 
on one or more columns that appear in both tables. These columns, referred to as link columns, must include at 
least some values that are common to both tables. In our example, the Emp_ID column would be suitable as a link 
column, as it contains values that are common to both the Marketing and Compensation tables. 

To link these two tables, you would start with the Marketing table, and then create a lookup to the Compensation 
table on the Emp_ID column. Then you select the Salary and Bonus columns to add to the Marketing table. The 
resulting table is shown in Figure 19-2. 

 

Marketing Table 

Emp_ID Dept Lastname Firstname City Salary Bonus 

1597429 Marketing April Anne Worcester 55,900.00 5,000.00 

1607768 Marketing Banning David Burlington 72,150.00 10,000.00 

1593642 Marketing Bartholemew Anne Brookfield 42,640.00 4,000.00 

1605798 Marketing Bradford Eugene Brookline 67,990.00 8,500.00 

1588509 Marketing Carlson Stephen Boston 49,452.00 5,000.00 

Figure 19-2. Marketing Employees table with Salary and Bonus columns linked from Compensation table.  

Note that only those records from the Compensation table that have corresponding Emp_ID values in the Marketing 
table are included in the resulting table. Since the lookup was initiated from the Marketing table, only the records that 
appear in the Marketing table are included. Records in the Compensation table that have no corresponding Emp_ID 
values in the Marketing table are ignored. 

This behavior is unique to a lookup. In other types of joins, records from both tables are combined, with the resulting 
table having at least one record for each record in the contributing tables. Monarch doesn’t support these types of 
joins, so no new records are added when joining data in Monarch. 

To begin this lesson, open the Orders.prn report file and load the Lesson9.dmod model file. Go on and view the 
table of extracted data.  
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CREATING AN EXTERNAL LOOKUP FROM A 
REPORT 

To illustrate Monarch’s database linking capability, we’ll provide a simple example that starts with a slightly modified 
version of our familiar Classic report file; this report is called Orders.prn. We’ll apply a model file to extract data from 
the report into the Table view, and then we’ll create a lookup to an external database to add several columns to the 
table. 

   

Figure 19-3. The Orders.prn report does not include customer address information.  

Orders.prn is a modified version of Classic.prn. Since you’re familiar with Classic.prn, you’ll notice that we’ve 
removed the address information below each customer name. For the sake of this lesson, let’s imagine that the report 
is always produced using only the customer name and that the customer addresses reside in a corporate database. 
After extracting data from the report using a standard Monarch model file, we’ll use a lookup to retrieve the customer 
addresses from the database. 

The Table view includes all of the columns that we’ve extracted from the report, including each customer’s name and 
account number. We’ll use the Account Number column to link to the Customer.mdb database, which holds the 
customer addresses.  

Steps: 

 Select Table Design from the Table ribbon and then click Add > External Lookup . The Open Database 
dialog displays. This dialog is similar to the Open Database dialog we used in Chapter 18. 
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Figure 19-4. The Open Database dialog.  

 Click Computer. 

The Open Database File dialog appears. 

 Select the Customer.mdb file.  

 Click the Open button to select the data source. 

Monarch displays the path to the Customer.mdb file in the Data Source box. 

 Click the Select Table button to display the Select Table dialog box. 

This dialog shows all of the database tables and queries that are available within the selected database. The list 
does not include system tables or queries that hold information about the database structure. 

  

Figure 19-5. The Select Table dialog displays the Customer screen.  

Our sample Customer.mdb database file holds only a single database table, called Customer.  
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 Ensure that the box for Customer is checked. If you wish, you can also expand the  node beside the table 
name to see all of the fields that make up the table. Click Select when you are done to apply your selection and 
close the Select Table dialog.  

 Click the Import Data button on the Open Database dialog. 

The dialog closes and you are transferred to the External Lookup Field Definition window.  

     

Figure 19-6. The Row Definition screen.  

The External Lookup Field Definition window displays a Linking Columns Assignment screen. We’ll use this 
screen to establish an external lookup between the external database and Monarch.  

 Check the Linking Column box for Acct_Num. 

The Acct_Num column in Customer.mdb and Account Number column in your extracted table are actually the 
same column. Each column holds the unique account number assigned to each customer. The column names 
are not required to be the same, but they must be of the same type (character, numeric, or date), and they must 
contain matching values that can be used to create a relationship between the two tables. 

 In the first row of the Table Window Name column, use the drop-down provided to ensure that Account Number 
is selected.  

The Select column allows you to choose with columns from the database to import into Monarch (i.e., the linked 
columns). This screen lists the names of all columns that are available in the selected database table or view. 
Since we want to import the entire address for each customer, we’ll make sure all of the available columns 
selected. 

Default names, taken from the source columns, are assigned to the import columns and are displayed under the 
Table Window Name heading. These are the names that will be assigned to the columns when you import them 
into Monarch. 

If you wish to change the way the name of any of the fields in Customer.mdb displays in Table view, you may do 
so in the Table Window name column. If you want to apply an import filter to the data, you may also do so by 
clicking on the External Lookup Filter tab and then specifying a filter expression in the screen that displays. 

For now, we’ll simply link the appropriate columns in our table and database. 

 Name this lookup Lookup1. 

 Click the Accept  button to close the window. 
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Your table is rebuilt and new address columns are added to it. Monarch links the external database table to the 
Monarch table, adding the selected columns to the Table view as linked columns. 

   

Figure 19-7. The table is rebuilt to include fields from the Customer.mdb database.  

 

NOTE You can manually edit the import column names by double-clicking on them. You can 
also add a name prefix to one or more of the import column names. To do so, 
however, you must enter the prefix in the Name Prefix box of the External Lookup 
Field Definition window before selecting any of the columns to import. After 
specifying the prefix, you can then either click the Select All button or select 
individual columns via their check boxes. The names for the columns you chose to 
import will then be displayed, preceded by the name prefix (e.g., if you specified a 
Name Prefix of “Test”, for example, the import column name for the “Address 1” 
source column would be “TestAddress 1.” 

 

 Scroll right to view the linked columns. 

   

Figure 19-8. The customer address columns are added to each record in the Monarch table. 

You can use linked fields just like any other fields in Monarch. Linked fields can be used in filter, sort, calculated 
field, and summary definitions and can be printed or exported along with fields that you extract from a report. 

Note that in this example, the External Lookup table displays below the Main database table and that Data Prep 
Studio can only open the Main table.  
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STORING LOOKUP PARAMETERS IN A MODEL 
FILE 

Lookup parameters can be saved in a Monarch model file along with other information about your Monarch session. 
When you load the model file, the lookup parameters are used to re-establish the lookup with the external database. 

Storing lookup parameters in a model file is easy. You simply save the model file. That’s all there is to it. The model 
file records the name of the lookup database along with the fields used to establish the lookup and the fields you 
linked to the Monarch table. By applying the model in a future Monarch session, Monarch preserves the work you did 
in this session. Let’s save a model file and then reload the session using the model.  

Steps: 

 Select File > Save As  > Model.  

The Save Model dialog appears. 

 Type Lookup in the File name box of the dialog (the .dmod extension is automatically added) and then click the 
Save button to save the model file. 

 Select File and then click Close All to end the current Monarch session. 

CREATING A LOOKUP FROM TWO DIFFERENT 
REPORTS 

While Monarch’s linking capability is very useful if you happen to have access to a database that includes the 
information you need, what if your data resides in two different reports? You may have already guessed the answer: 
Using Monarch’s export capability, you can create a database file from one report, start a new Monarch session to 
extract data from the second report, and then create a lookup to the exported database file. While this involves a two-
pass approach, it’s relatively easy to do. 

Let’s imagine that we don’t have access to the database of customer address information that we used in the 
previous example. Instead, we have the Orders.prn report and another report called Customer.prn that lists all of our 
customers. Let’s use Monarch to link information from these two reports. 

Using a Report to Create a Lookup File 

We’ll start by opening the Customer report, applying a model to extract the customer address and account number 
fields, and then exporting these fields to a database file. We’ll use this file as a lookup file, which we’ll link to the 
Orders.prn report. 

Steps: 

 Open the Customer.prn report file as well as the Customer.dmod model file.  

 Select the Table tab and then click Autosize Columns  to maximize your view of all of the columns in the 
table.  
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Figure 19-9. Customer address fields extracted from report.  

The Table view includes all of the columns that we’ve extracted from the report, including each customer’s name, 
account number, and address. Now we’ll export the table to a database file. 

 Select the Export tab and then click Create Export  to launch the Create Export dialog. 

 Specify a filename of LookupSource. 

 Ensure that Table is selected in the Source View panel and then select Microsoft Access MDB (*.mdb) as the 
Export File Type.  

 Type CustomerAddresses in the Table Name field and then click the Run this export button located on the 
upper left-hand corner of the dialog. 

A progress dialog displays. Monarch displays the following message box when the export is finished. 

  

Figure 19-10. The message box that displays after successfully completing the export.  

You have just created a lookup file.  
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Linking to the Lookup File 

Now that the first report has been exported to a database file, it’s time to load the second report and link to it. 

Steps: 

 Close all of the open files in Monarch and then open the Orders.prn report and the Lesson9.dmod model file. 
Select No when asked if changes to Customer.dmod or the project should be saved. 

 Select the Table tab and then click Autosize Columns  to maximize your view of the data in the table.  

   

Figure 19-11. Data extracted from the Orders.prn report.  

Now we’re ready to link to the database file we created and pull in the address information for each customer. 

 Select Table Design > Add > External Lookup > Database.  

 Click the Browse button beside the Data Source field and select the Local or network file option to display the 
Open Database File dialog. 

 Select the LookupSource.mdb file from the Altair Monarch\Export folder then click the Open button. 

Monarch displays the path to the LookupSource.mdb file in the Data Source box. 

 Click the Select Table button and check the box for CustomerAddresses from the dialog that displays. Click 
Select when you are done.  

 Select OK to close the Open Database dialog and launch the External Lookup Field Definition window. 

 Name this lookup Lookup2. 

 Check the Linking Column box for Acct_Num.  

 In the first row of the Table Window Name column, ensure that Account Number is selected.  

 Click the Select All button to instruct Monarch to show all lookup fields in the resulting table.  

 Select Accept  to apply your changes and close the window. 

Monarch links the CustomerAddresses table to the Monarch table, adding the address columns to the Table view 
as linked columns. You may need to scroll to the right to view the address columns.  
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Figure 19-12. Customer addresses linked to Orders.prn report data (column widths autosized).  

We started with two disparate reports and ended with data from both reports linked together in the Table view.  

 Select File, and then click Close All to reset the Monarch session. Select No when prompted to save changes to 
the model. 

CREATING A LOOKUP FROM TWO EXTERNAL 
DATABASES 

In the previous sections, we demonstrated how you can link data from an external database to data extracted from a 
report. This is useful when a single report doesn’t include all of the data you need, but you can also use Monarch to 
combine data from two databases, without ever loading a report file. 

To see how this process works, let’s return to the example from the beginning of this lesson. In that example, we 
showed how you could link fields from an employee compensation table to an employee roster table. 

The employee roster table is called Marketing since it stores information only about employees in the Marketing 
department. The employee compensation table is called Compensation. This table stores salary and bonus 
information for all employees for the entire company. 

Importing Database Data 

We’ll start by importing data from the Marketing table. This table resides in the Beantown.mdb file (the name of our 
fictional company is Bean Town Investments). The compensation table resides in a file called Payroll.mdb. We’ll 
create a lookup to this table in order to add the Salary and Bonus field for each employee.  

Steps: 

 Select File, click on the arrow of the Open menu, and then select Database. 

The Open Database dialog displays.  

 Click the Data Source Browse button and select the Local or network file option. 

The Open Database File dialog appears. 
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 Select the Beantown.mdb file from the Altair Monarch\Data folder and then click Open. 

Monarch displays the path to the Beantown.mdb file in the Data Source box. 

 Click the Select Table button and, in the Select Table dialog that displays, choose Marketing. Click Select when 
you are done to close the dialog.  

 Select OK in the Open Database dialog.  

The Import Field Definition window displays. 

 Ensure that all fields are selected (click Select All if not) and then click Accept . 

Monarch opens Table view and populates it with data imported from the Beantown.mdb file’s Marketing table. 

 Select Autosize Columns  to maximize your view of the fields properly. 

 

Figure 19-13. Monarch’s Table view is populated with the data imported from Beantown.mdb, Marketing table.  

Linking Database Data 

Now we’ll link to the Compensation table to add the salary and bonus information for each employee. 

Steps: 

 Select Table Design > Add > External Lookup > Database.  

 In the Open Database dialog, click the Browse button next to the Data Source field and then select the Local or 
Network File option. 

The Open Database File dialog appears. 

 Select the Payroll.mdb file from the Altair Monarch\Data folder, and then click the Open button. 

Monarch displays the path to the Payroll.mdb file in the dialog’s Data Source box. 

 Click the Select Table button. 

The resulting dialog displays all of the database tables and queries that are available within the selected 
database. Check the Compensation table box and then click Select. 

 Click OK to close the Open Database dialog and launch the External Lookup Field Definition window. 

 Name this lookup Lookup3.  
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 In the Linking Columns Assignment screen, check the Linking Column box for Emp_ID.  

 In the first row of the Table Window Name column, ensure that Emp_ID is selected.  

This setting indicates that Emp_ID in the Payroll table should match Emp_ID in the Marketing table.  

 Ensure that both the Salary and Bonus fields are selected in the Select column. 

 Click the Accept  button to apply your settings and close the External Lookup Field Definition window. 

Monarch links the external database table to the Monarch table, adding the selected columns to the Table view 
as linked columns. 

  

Figure 19-14. Salary and Bonus information are added to each record in the Monarch table.  

 Select File, click on the arrow of the Save As  menu, and then select Model.  

 Type Compensation in the File name box of the Save Model As dialog box that displays, and then click the 

Save button to save the model file. 

 Select File and then click Exit Monarch.  

 

NOTE If prompted to save changes to the project file, select No. 

 

The model file stores the lookup parameters along with the import parameters. However, the model file does not 
store the name of the import database. To restore the session, use the Open Database dialog to select the 
Beantown.mdb file and the Compensation model. 

Note that on the Dataset selection screen, you may select any of the three employee roster tables (Accounting, 
Data Processing, or Marketing). The model will work equally well regardless of which table you select. That’s 
why the data source is not stored in the model file -- the model can be used with any compatible data source. 
This is similar to how models store information about a report. The report name is not stored in the model so that 
the model can be used with multiple reports as long as the reports all have a compatible format. 
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[20] USING DIGITAL SIGNATURES 

This chapter introduces a Monarch feature designed to authenticate files, thereby enhancing security. Here, you will 
learn about digital signatures. The chapter assumes you are familiar with exporting Table or Summary data into XLSX 
or XLSM formats.  

Note that this feature is only available in Monarch Classic and Monarch Complete.  

WHAT ARE DIGITAL SIGNATURES? 

Digital signatures are used to authenticate files (i.e., the Excel files that are produced via Monarch Export) by using 
computer cryptography. Digital signatures help to establish the following assurances: 

❑ Authenticity - The digital signature helps to assure that the signer is who he or she claims to be. 

❑ Integrity - The digital signature helps to assure that the content has not been changed or tampered with since it 
was digitally signed. 

❑ Non-repudiation - The digital signature helps to prove to all parties the origin of the signed content. "Repudiation" 
refers to the act of a signer's denying any association with the signed content. 

 

To make these assurances, the content creator must digitally sign the content by using a signature that satisfies the 
following criteria: 

❑ The digital signature is valid.  

❑ The certificate associated with the digital signature is current (not expired). 

❑ The signing person or organization, known as the publisher, is trusted. 

❑ The certificate associated with the digital signature is issued to the signing publisher by a reputable certificate 
authority (CA). 

To start, let’s open the Classic.prn report and Lesson8.dmod model.  

   

Figure 20-1. Loading the Classic.prn report and Lesson8.dmod model. 
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ADDING DIGITAL SIGNATURES TO AN EXCEL 
FILE 

Steps: 

 Select the Table tab.  

The Table view for the report displays. Select Autosize Columns  from the Table tab to view all the data 
properly.  

   

Figure 20-2. The Table view for Classic.prn report and Lesson8.dmod model. 

 Select the Export tab and then click the Create Export button. 

The Create Export dialog displays.  

 In the File name box, enter Digital1. 

 Ensure that Table is selected in the Source View box and then select Microsoft Excel XLSX (*.xlsx) from the 
Export File Type box.  

 Name the table DigiCert in the Table Name box.  

 Click the Edit Advanced Options button to launch the Export Design view. 

 Click the Advanced tab of the Excel Output panel. 

The Excel Advanced Features options of the view display. 
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Figure 20-3. The Excel Advanced features panel in Export Design view.  

 Check the Digital Signature box. 

When you do this, the Certificate drop-down list is activated. This list contains options that allow you to select 
where the digital certificate you are applying is located. Let’s say that your digital certificate is stored in the same 
machine in which Monarch is installed. 

 Select Change to Certificate from File from the Certificate drop-down list. 

 Select the digital certificate you wish to apply to the export, and then click OK. 

Depending on the settings of your digital signature, you may or may not be asked to set a password for the 
certificate. If prompted to do so, simply provide one. 

 Click Accept  when you are finished to close the Export Design view and return to Export view. 

 Run the export you have just defined. Refer to Chapter 17 – Exporting Operations of this Learning Guide if 
necessary.  

 Select File, and then click Exit Monarch. Select No when prompted to save changes to the model and the 
project. 

VIEWING DIGITAL SIGNATURES 

Digital signatures display when you open the spreadsheet containing the certificate. Let’s do this. 

Steps: 

 Launch your spreadsheet. If you don’t have a spreadsheet, just follow along. 

 Select File, and then click Open. 

 Navigate to your Monarch Exports folder (typically in C:\Users\Public\Documents\Altair Monarch\Export), and 
then open the Digital1.xlsx worksheet. 
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The worksheet displays in your screen. 

 

Figure 20-4. The exported table with a digital signature.  

Note the following features of the file that are not present in ordinary worksheets or workbooks: An alert with an 
Edit Anyway button displays on the upper portion of the table to warn you that the workbook has been marked 
final to discourage editing.  

Should you choose to click Edit Anyway to continue editing the workbook, the following dialog displays: 

 

Figure 20-5. Selecting Yes removes any digital signatures applied to the workbook.  

Selecting Yes on the dialog removes any digital signature applied to the workbook. 

As well, on the lower left-hand corner of the workbook, you will find a certificate icon. Hovering on this icon with 
your mouse yields a callout that informs you that a digital signature has been applied to the workbook. 

 

Figure 20-6. The digital signature callout.  
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If you click on this icon, a list of all digital signatures applied to the workbook display on the right-hand side of the 
workbook. You can hover on any of these signatures to display a drop-down button that, upon clicking, will allow 
you to view the properties of that signature.  

 

Figure 20-7. A list of digital signatures displayed on the right-hand side of the workbook.  

 Close the spreadsheet. 



 

Altair Monarch 2024.0 Learning Guide  374 

 

[21] USING PIVOT TABLES 

In the previous chapter, you learned about a special Monarch feature you can use to increase the security and 
authenticity of your report: digital signatures. 

In this chapter, you will learn about another special Monarch feature: pivot tables. Pivot tables are interactive tables 
within Monarch that allow you to further manipulate and view data. They can only be created for XLSX files; they 
cannot be created for XLS files. If you are using a version of Excel earlier than 2007, you can download the Microsoft 
Office Compatibility Pack from Microsoft, which will allow Excel 2000 and higher to open XLSX files.  

The option to create a Pivot Table is not available for a Summary export, since pivot Tables use tabular “raw” data as 
a source, not summarized data. Monarch will export the table data as a worksheet and the pivot table as a separate 
worksheet, which refers to the exported data. 

Let’s again start by loading the Classic.prn report and the Lesson8.dmod model files.  

   

Figure 21-1. Loading the Classic.prn report and Lesson8.dmod model. 

ADDING PIVOT TABLES TO AN EXCEL FILE 

Steps: 

 Select the Table tab.  

The Table view for the report displays. Select Autosize Columns  from the Table tab to view all the data 
properly.  
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Figure 21-2. The Table view for Classic.prn report and Lesson8.dmod model. 

 Select the Export tab and then click the Create Export button. 

The Create Export dialog displays.  

 In the File name box, enter Pivot1. 

 Ensure that Table is selected in the Source View box and then select Microsoft Excel XLSX (*.xlsx) from the 
Export File Type box.  

 Name the table PivoTable in the Table Name box.  

 Click the Edit Advanced Options button to launch the Export Design view. 

 Click the Advanced tab of the Excel Output panel. 

The Excel Advanced Features options of the view display. 

 Check the Include Pivot Table sheet box to activate the pivot table definition options.  
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Figure 21-3. The Excel Advanced features panel in Export Design view.  

 Select Overwrite table from the When sheet with pivot table exists drop-down. 

 Click on the Options tab that displays and then enter PivotTable into the Pivot Table name field. You may leave 
the other settings in this tab as they are for now. Note that pivot table names must conform to the table-naming 
guidelines described earlier in this guide.  

 Click the Fields tab, click on the New drop-down list of the Row Labels field and then select (double-click) 
Customer. 

 In the Column Labels field, select the New drop-down button, and then select (double-click) Media from the list 
that displays.  

 In the Values field, select the New drop-down button, and then select the values Amount and Unit Price from 
the list that displays.  

Note that when you do so, an additional entry (e.g., _VALUES_HEADER_) is added to the Values field. This 
additional entry simply indicates that the separate fields of Amount and Unit Price will have their own headings in 
the resulting worksheet.  

Use the sorting button that displays beside each pivot field or value to specify a display order (i.e., ascending or 
descending).   

 Select Accept  when you are finished to close Export Design view and return to Export view.  

 Run the export you have just defined. Refer to Chapter 17 – Exporting Operations of this Learning Guide if 
necessary.  

 Select File, and then click Exit Monarch. Select No when prompted to save the changes in the model and the 
project. 
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VIEWING A PIVOT TABLE 

Steps: 

 Launch your spreadsheet. If you don’t have a spreadsheet, simply follow along. 

 Select File, and then click Open. 

 Navigate to your Monarch Exports folder (typically in C:\Users\Public\Documents\Altair Monarch\Export) and 
then open the Pivot1.xlsx worksheet. 

The worksheet displays in your screen. 

 

Figure 21-4. The exported Pivot1 worksheet.  

The PivoTable tab shows an Excel file version of the Classic.prn table. 

 Click on the PivotTable1 tab. 

The pivot table displays on your spreadsheet.  
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Figure 21-5. The exported Pivot1 worksheet.  

For more information regarding pivot tables, you may access the Monarch Help file by selecting File, clicking on 

the drop-down button of the Help  menu, and then select Help Topics from the options that display. 

WORKING WITH PIVOT TABLES 

When we selected pivot table fields in the earlier part of this chapter, we were specifying settings similar to those 
used when creating a summary. For example, the Row Labels specify down keys, the Column Labels specify across 
keys, and the Values specify measures.  

Clicking on the drop-down buttons on either the Row Labels or Column Labels fields displays a set of options that 
allow you to sort and filter your data. 
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Figure 21-6. Options for sorting and filtering pivot table data.  

To display the unit prices and amounts for only the media types DVD and BLU, for example, simply click on the drop-
down button of Column Labels, deselect the boxes for CD, LP, and SACD, and then click OK. When you do this, the 
Select All checkbox is automatically deselected.  

A new table is rebuilt and displayed in your spreadsheet. 

 

Figure 21-7. The new pivot table showing only unit prices and amounts for the media types DVD and BLU.  
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[22] WORKING WITH ASIAN (CJK) 
CHARACTER SETS 

Displaying fullwidth characters (e.g., Chinese/Japanese/Korean, or CJK, characters) is more complex than displaying 
standard fixed-width single byte character set (SBCS) characters. This stems from the fact that fullwidth characters 
usually take up nearly twice as much horizontal space in pixels to display. Due to the grid-like nature of Monarch’s 
unique trapping process, Monarch requires that all characters are rendered with the same amount of screen space in 
order for characters to align vertically. This requirement causes issues when SBCS and fullwidth characters are 
present on the same report.  

Notice the indeterminate alignment of these lines: 

 

Now observe the grid-like alignment of these lines: 

 

As you can see in the first example, the characters do not line up in any meaningful way. Thus, it is impossible to 
create a template that traps consistently in this situation. By contrast, in the second example, each character takes up 
the same amount of space, thereby giving us a grid-like 1-to-1 alignment and making it possible to trap data with 
predictable results. This is the fundamental challenge that Fullwidth Character Mode addresses. 

Working with Asian Character sets may be easily accomplished by specifying four settings: 

❑ Fullwidth Character Mode 

❑ Fallback Asian fonts 

❑ Date/Time format 

❑ Ignore Character Width 

SETTING FULLWIDTH CHARACTER MODE 

The Fullwidth Character Mode setting toggles Fullwidth Character Mode on and off. While on, all characters will be 
rendered in the same horizontal space as a Kanji glyph. 

Most fonts do not contain glyphs for every character from every language. This issue is addressed by a fallback 
architecture that renders unknown characters in standard fonts known to contain those characters. The result is text 
that is drawn in multiple fonts as needed on a per-character basis. 
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Figure 22-1. Setting Fullwidth Character Mode on via the Options window.  

To set Fullwidth Character Mode on, simply select Options > Input from the Home screen that displays when 

Monarch is launched. Select Accept  to save your settings when you are finished.  

 

NOTE All other settings for dealing with Japanese input files are applicable only when this 
setting is enabled. 

 

SETTING FALLBACK ASIAN FONTS 

The Fallback Asian Fonts setting allows the user to select which fonts will be used to render unknown characters in 
the event of a fallback. Japanese, Simplified Chinese, and Traditional Chinese options are available. 

 

Figure 22-2. Recommended fallback Asian fonts.  

Language options are also available in the Input tab of the Options window.  
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SETTING THE DATE/TIME FORMAT 

The most commonly used date format in Japan is yyyy/mm/dd, and the Japanese characters for “year,” “month,” and 
“day” are inserted usually between numerals. Thus, in the Japanese format, the date December 21, 2013 is 
presented as: 

 

Users trapping the fields of Japanese input files can compel Monarch to convert dates/times into one of two 
Japanese formats by selecting the appropriate format from the Field Properties panel that displays when a field is 
defined.  

 

Figure 22-3. Specifying the Japanese date format via the Field Properties panel.  

Dates and times may be converted to: 

❑ Japanese date – This setting converts dates/times into the standard Japanese format.  

❑ Japanese Era date – This setting converts dates/times into the standard Japanese format but also inserts the 
current era prior to the actual date.  

SETTING THE IGNORE CHARACTER WIDTH 
OPTION 

Asian reports sometimes use “fullwidth” or “wide” Latin characters. Monarch allows users to ignore the distinction 
between standard (or “narrow”) and wide Latin characters while searching a report, table, or summary. This option in 
enabled via the Ignore Character Width setting.  

When users opt to ignore character widths, the string “ ” would return search hits for both “ ” and “

.” 

Likewise, the string “ ” would return search hits for both “ ” and “ .” 

  



 

Altair Monarch 2024.0 Learning Guide  383 

 

Note that in the above example, “ ” is using the wide characters for t, e, and s. This distinction is made to 
clarify that the text is not simply a string with spaces between characters. 

To set this option, assuming you have an open report in Report View, select the Search  button in the Report 
ribbon and then tick the checkbox for Ignore Character Width that appears on the Search panel that displays.  

 

Figure 22-4. Setting the Ignore Character Width option.  
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CONCLUSION 

Congratulations! You have just completed the lessons in the Monarch Learning Guide. We hope you have found 
them to be a helpful introduction to Monarch’s capabilities.  

For additional information not covered in the Learning Guide, we suggest you thoroughly explore Monarch’s help 

system. To do so, select File, click on the drop-down button of the Help  menu, and then select Help Topics from 

the main menu. You may also click the Help  button on any dialog within Monarch to access context-sensitive 
help.  

Updated documentation is available here.  

Technical assistance is available to registered Monarch owners. Refer to the Appendix C - Contacting Technical 
Support section of the Monarch Help file for more information. 

 

 

https://help.altair.com/2024/monarch/
https://help.altair.com/2024/monarch/help/Product_Support.htm
https://help.altair.com/2024/monarch/help/Product_Support.htm
https://help.altair.com/2024/monarch/help/
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CONTACT US 

GET IN TOUCH 

We’d love to hear from you. Here’s how you can reach us. 

 

SALES CONTACT INFORMATION 

USA: +1 800 445 3311 
International: + 1 978 441 2200 

 

SALES EMAIL 

US: sales@datawatch.com 
Europe: sales_euro@datawatch.com 
Asia Pacific: sales_apac@datawatch.com 

 

SUPPORT CONTACT INFORMATION 

Customer Portal: https://altair.com/customer-support  

 

 

https://www.altair.com/contact-us/
mailto:sales@datawatch.com
mailto:sales_euro@datawatch.com
mailto:sales_apac@datawatch.com
https://altair.com/customer-support
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